Использование функций И и ИЛИ для проверки сочетания условий

Примечание:  Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке) .

Если вам нужно найти данные, которые соответствуют несколько условий, например между апреля и за январь проданных единиц или единиц, проданных Сергей, вы совместное использование функций AND и OR . Вот пример:

Использование функций И и ИЛИ в одной формуле

В этой формуле выполняет вложение функции внутри функции или поиск между 1 апреля 2011 и 1 января 2012 г., проданных единиц или любой единицы проданы Сергей. Вы увидите, что она возвращает значение True , Сергей проданных единиц товара, а также единиц, проданных времен и Сергей во время даты, указанные в формуле.

Ниже приведена формула, которую можно скопировать и вставить. Если вы хотите поэкспериментировать с ней в книге-примере, см. конец статьи.

=ИЛИ(И(C2>ДАТА(30,4,2011),C2<ДАТА(1,1,2012)),B2="Катерина")

Рассмотрим немного глубже в формулу. Функция OR требует набор аргументы (элементам данных), его можно проверить, если они true или false. В этой формуле первый аргумент функции и и Дата его вложены, второй — «Сергей». Формулу можно прочитать следующим образом: проверяйте, если продажу был назначен после 30 апреля 2011 года и до 1 января 2012 г., или был назначен, Сергей.

Кроме того, функция и возвращает True или False. В большинстве случаев, можно использовать и расширение возможностей другую функцию, такие как или и Если. В этом примере используется функция или бы найти даты без функции.

Использование функций И и ИЛИ с функцией ЕСЛИ

Функции И и ИЛИ можно использовать с функцией ЕСЛИ.

Функции И и ИЛИ, вложенные в функцию ЕСЛИ

В этом примере сотрудник не получает премию, если он не продал товаров хотя бы на 125 тыс. рублей или же на 100 тыс. руб, если он работает в южном регионе, где объем рынка меньше.

=ЕСЛИ(ИЛИ(C4>=125000;И(B4="Южный";C4>=100000))=ИСТИНА;C4*0,12;"Премия не положена")

Рассмотрим формулу. Функции ЕСЛИ для правильной работы нужны три элемента данных (аргумента). Первый — логическое выражение, второй — значение, отображаемое, если результатом выражения является ИСТИНА, и третий — значение, отображаемое, если результатом выражения является ЛОЖЬ. В данном примере логическим выражением является функция ИЛИ со всеми вложенными в нее элементами. Формулу можно прочитать следующим образом: "если значение больше или равно 125 000 или же 100 000 при условии, что значение в столбце C — "Южный", умножить значение на процент премии, равный 0,12, в противном случае отобразить слова "Премия не положена".

К началу страницы

Образец данных

Если вы хотите работать с примерами в этой статье, скопируйте приведенную ниже таблицу в ячейку A1 свою таблицу. Не забудьте выделяется вся таблица, включая строки заголовков.


Продавец

Регион

Отдел продаж

Формула и результат

Гладких

Восточный

87925

= Если (или (C2 > = 125000; И (B2 = "Южный"; C2 > = 100000)) = ИСТИНА, C2 * 0.12 «Премия не положена»)

Ильина

Север

100000

= Если (или (C3 > = 125000; И (B3 = "Южный"; C3 > = 100000)) = ИСТИНА, C3 * 0.12 «Премия не положена»)

Песоцкий

Западный

145000

=ЕСЛИ(ИЛИ(C4>=125000;И(B4="Южный";C4>=100000))=ИСТИНА;C4*0,12;"Премия не положена")

Корепин

Юг

200750

= Если (или (C5 > = 125000; И (B5 C5 = "Южный" > = 100000)) = ИСТИНА, C5 * 0.12 «Премия не положена»)

Климов

Юг

178650

= Если (или (C6 > = 125000; И (B6 C6 = "Южный" > = 100000)) = ИСТИНА, C6 * 0.12 «Премия не положена»)

Томас

Север

99555

= Если (или (C7 > = 125000; И (B7 C7 = "Южный" > = 100000)) = ИСТИНА, C7 * 0.12 «Премия не положена»)

Keever

Восточный

147000

= Если (или (C8 > = 125000; И (B8 C8 = "Южный" > = 100000)) = ИСТИНА, C8 * 0.12 «Премия не положена»)

Cassazza

Север

213450

= Если (или (C9 > = 125000; И (B9 C9 = "Южный" > = 100000)) = ИСТИНА, C9 * 0.12 «Премия не положена»)

Brownlee

Юг

122680

= Если (или (C10 > = 125000; И (B10 C10 = "Южный" > = 100000)) = ИСТИНА, C10 * 0.12 «Премия не положена»)

Smithberg

Западный

92500

= Если (или (C11 > = 125000; И (B11 C11 = "Южный" > = 100000)) = ИСТИНА, C11 * 0.12 «Премия не положена»)

Benson

Восточный

88350

= Если (или (C12 > = 125000; И (B12 C12 = "Южный" > = 100000)) = ИСТИНА, C12 * 0.12 «Премия не положена»)

Чтение

Западный

102500

= Если (или (C13 > = 125000; И (B13 C13 = "Южный" > = 100000)) = ИСТИНА, C13 * 0.12 «Премия не положена»)

К началу страницы

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×