Использование функций И и ИЛИ для проверки сочетания условий

Если нужно найти данные, соответствующие нескольким условиям, например товары, проданные с апреля по январь, или объем продаж Катерины, можно использовать функции И и ИЛИ вместе.

В этом примере функция И вложена в функцию ИЛИ для поиска товаров, проданных между 30 апреля 2011 г. и 1 января 2012 г., или любых товаров, проданных Катериной. Она возвращает значение ИСТИНА для товаров, проданных Катериной, а также товаров, проданных Виктором и Андреем за указанный период.

Использование функций И и ИЛИ в одной формуле

Ниже приведена формула, которую можно скопировать и вставить на лист.

=ИЛИ(И(C2>ДАТА(30,4,2011),C2<ДАТА(1,1,2012)),B2="Катерина")

Давайте рассмотрим эту формулу подробнее. Функция ИЛИ принимает набор аргументов и проверяет их истинность. В данной формуле первым аргументом является результат функции И, в которую вложена функция ДАТА. Вторым аргументом является значение "Катерина". Прочитать формулу можно следующим образом: "проверить, продан ли товар после 30 апреля 2011 г. и до 1 января 2012 г. или продан ли товар Катериной".

Как и функция ИЛИ функция И возвращает значение ИСТИНА или ЛОЖЬ. В большинстве случаев ее используют для расширения возможностей других функций, таких как ИЛИ и ЕСЛИ. В данном примере функция ИЛИ не нашла бы правильные даты без функции И.

Использование функций И и ИЛИ с функцией ЕСЛИ

Функции И и ИЛИ можно использовать с функцией ЕСЛИ.

Функции И и ИЛИ, вложенные в функцию ЕСЛИ

В этом примере продавцы не получают премию, если они не продали товаров хотя бы на 125 тысяч рублей или же на 100 тысяч рублей, если они работают в южном регионе, где объем рынка меньше.

=ЕСЛИ(ИЛИ(C4>=125000;И(B4="Южный";C4>=100000))=ИСТИНА;C4*0,12;"Премия не положена")

Рассмотрим формулу. Функции ЕСЛИ нужны три аргумента. Первый — логическое выражение, второй — значение, отображаемое, если результатом выражения является ИСТИНА, а третий — значение, отображаемое, если результатом выражения является ЛОЖЬ. В данном примере логическим выражением является функция ИЛИ со всеми вложенными в нее элементами. Формулу можно прочитать следующим образом: "если значение больше или равно 125 000 или же 100 000 при условии, что значение в столбце C — "Южный", умножить значение на процент премии, равный 0,12, в противном случае отобразить слова "Премия не положена".

Поэкспериментируйте с приведенными выше примерами.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×