Использование функции СУММПРОИЗВ для суммирования произведений соответствующих значений в одном или нескольких массивах

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Функция СУММПРОИЗВ принимает в качестве аргументов (элементы формулы, необходимые ей для работы) диапазоны ячеек (или массивы), перемножает их значения, а затем суммирует произведения.

В приведенном примере используется список товаров: в одном массиве содержатся их цены, а в другом — количество приобретенных товаров.

Значения цен и количеств приобретенных товаров будут перемножены, а их произведения будут суммированы

  1. Чтобы создать формулу, введите =СУММПРОИЗВ(B3:B6,C3:C6) и нажмите клавишу ВВОД.

Каждое значение в столбце B будет умножено на значение в той же строке столбца C, а произведения будут суммированы. Общая стоимость приобретенных товаров составит 21,60 р.

  1. Чтобы написать формулу более, которое дает такой же результат, введите = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 и нажмите клавишу ВВОД.

После нажатия клавиши ВВОД будет выведен такой же результат: 21,60 р. Значение в ячейке B3 будет умножено на значение в ячейке C3, к результату будет добавлено произведение значений в ячейках B4 и C4 и т. д. Как видите, при большом количестве строк функция СУММПРОИЗВ может значительно упростить работу.

Примечания : 

  • Столбцы или строки (массивы) должны быть одинаковой длины.

  • Если ячейка содержит текст, а не число, он считается нулевым значением.

Пример

Если вы хотите поэкспериментировать с функцией СУММПРОИЗВ и массивами, можете воспользоваться предлагаемой книгой Excel Online с данными, использованными в этой статье.

Скопируйте данные примера из приведенной ниже таблицы в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите формулы и нажмите клавишу F2, а затем — ВВОД. При необходимости измените ширину столбцов для отображения всех данных.

А

Б

D

E

3

4

2

7

8

6

6

7

1

9

5

3

Формула

Результат

'=СУММПРОИЗВ(A2:B4,D2:E4)

=СУММПРОИЗВ(A2:B4,D2:E4)

Перемножает все компоненты двух массивов (A2:B4 и D2:E4) и возвращает сумму произведений — т. е. 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

Кроме того, можно открыть эту книгу в Excel. Просто щелкните значок Excel в правом нижнем углу книги  Значок Excel в Excel Web App , сохраните файл в удобном месте на компьютере, а затем откройте его.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×