Использование функции СУММПРОИЗВ для суммирования произведений соответствующих значений в диапазонах ячеек

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

СУММПРОИЗВ принимает в качестве аргументов (элементов формулы, необходимых ей для работы) диапазоны ячеек, перемножает их значения, а затем суммирует произведения.

Чтобы создать формулу для примера ниже, введите =СУММПРОИЗВ(B2:B5;C2:C5) и нажмите клавишу ВВОД. Каждое значение в столбце B будет умножено на значение в той же строке столбца C, а произведения будут суммированы. Общая стоимость приобретенных товаров составит 21,60 р.

Пример списка продуктов, демонстрирующий использование функции СУММПРОИЗВ

Чтобы записать ту же формулу более подробно, введите =B2*C2+B3*C3+B4*C4+B5*C5 и нажмите клавишу ВВОД. Появится такой же результат: 21,60 р. Значение в ячейке B2 будет умножено на значение в ячейке C2, к результату будет добавлено произведение значений в ячейках B3 и C3 и т. д. Как видите, при большом количестве строк функция СУММПРОИЗВ может значительно упростить работу.

Примечания : 

  • Столбцы или строки должны быть одинаковой длины.

  • Если ячейка содержит текст, а не число, он считается нулевым значением.

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×