Использование отчетов для определения эффективности работы узла и его использования

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Пользователю, ответственному за управление узлом, вероятно задают общие вопросы, затрагивающие следующие моменты.

  • Количество посетителей узла

  • Изменение сетевой нагрузки с течением времени

  • Самые частые посетители веб-узла

  • Откуда идут запросы к узлу

  • Наиболее часто посещаемые страницы и ресурсы веб-узла

  • Где находятся документы и ресурсы, используемые в рабочем процессе

В то же время у управляющего веб-узлом пользователя также могут периодически возникать некоторые вопросы, например:

  • Есть ли на узле ресурсы, которые можно удалить, поскольку они устарели или не используются?

  • Как обнаружить проблемы на узле (например несвязанные файлы, медленно загружающиеся страницы, неработающие ссылки), прежде чем они будут замечены пользователями?

Эти вопросы могут показаться неразрешимыми, однако с использованием узла Microsoft Office SharePoint Designer 2007 и Windows SharePoint Services 3.0 или узла Microsoft Office SharePoint Server 2007 на них легко можно ответить, воспользовавшись отчетами Office SharePoint Designer 2007. В этой статье показано применение отчетов для определения эффективности работы узла и его использования.

Важно : Данные для отчетов, созданных с помощью приложения Office SharePoint Designer 2007, хранятся на сервере, на котором расположен узел. Администраторы сервера могут разрешить или запретить доступ к этим отчетам. Если в запрошенных отчетах отсутствуют данные, обратитесь за помощью к администратору сервера. Чтобы выполнить отчеты об использовании, необходимо обладать полномочиями на просмотр данных об использовании, кроме того, администратор сервера должен включить на сервере функцию сбора данных об использовании. По умолчанию функция сбора данных об использовании отключена.

Предполагаемое действие:

Просмотр отчета Сводка по узлу

Просмотр отчетов об файлов

Просмотр отчетов об общего содержимого

Просмотр отчетов о неполадках

Просмотр использование сводный отчет

Просмотр отчетов об использовании

Использование данных результаты диаграммы

Сортировка отчета

Фильтрация отчета

Копирование отчета

Сохранение отчета

Просмотр отчета «Сводка по узлу»

В отчете «Сводка по узлу» представлен самый общий обзор узла, а также ссылки на более подробные отчеты. Например, отчет «Сводка по узлу» можно создать аналогично отчету на следующем рисунке.

Отчет «Сводка по узлу»

Создание отчета «Сводка по узлу»

  1. Откройте узел, для которого нужно выполнить отчет в Office SharePoint Designer 2007.

  2. В меню Узел выберите команду Отчеты, а затем — команду Сводка по узлу.

    Будет создан отчет.

Примечание : Для перехода к более подробным отчетам щелкните гиперссылку в столбце Имя. Например, щелкните Неработающие гиперссылки, чтобы перейти непосредственно к отчету Неработающие гиперссылки.

К началу страницы

Просмотр отчетов о файлах

Можно создать отчеты, отображающие все файлы, последние добавленные файлы, последние измененные файлы и устаревшие файлы. Например, если нужно выделить новое содержимое на домашней странице узла или в информационном бюллетене, продвигающем узел, можно применить отчет «Последние добавленные файлы». Как альтернативу для определения содержимого, которое устарело для просмотра и нуждается в обновлении или удалении, используется отчет «Устаревшие файлы».

Чтобы выполнить отчеты о файлах, сначала следует указать определения для последних и более старых файлов, а также задать количество месяцев, за которые нужно отобразить отчеты.

  1. Откройте веб-узел, для которого нужно выполнить отчет в Office SharePoint Designer 2007.

  2. В меню Сервис выберите команду Параметры приложения.

  3. Перейдите на вкладку Отчеты.

    Диалоговое окно «Параметры приложения» с вкладкой «Отчеты»

  4. В поле Файл считается "новым", если создан менее: введите количество дней, в течение которых страница считается новой.

  5. В поле Файл считается "устаревшим", если создан более: введите количество дней, по истечение которых страница считается устаревшей.

  6. В поле Показывать отчет за последние: введите количество месяцев, за которые нужно отобразить отчеты.

  7. Нажмите кнопку ОК.

    Теперь можно выполнить отчеты.

  8. В меню Узел выберите команду Отчеты, затем — Файлы, а затем — название отчета, который нужно выполнить.

    • Все файлы     Отображение списка всех файлов узла.

    • Последние добавленные файлы     Отображение списка файлов, добавленных на узел в течение дней, указанных в шаге 4.

    • Последние измененные файлы     Отображение списка файлов, измененных на узле в течение дней, указанных в шаге 4.

    • Старые файлы     Отображение списка файлов, считающихся «устаревшими» (определяется количеством дней, указанном в шаге 5).

    • Состояние извлечения     Отображение списка файлов узла, а также текущего состояния извлечения каждого файла. (В этот отчет включены столбцы данных Извлек пользователь, Версия и Заблокирован.)

      В представлении отчетов параметры, определяющие старые и новые файлы, доступны в списке, что позволяет быстро их изменять.

      Представление отчетов с меню фильтра файлов по давности

К началу страницы

Просмотр отчетов об общем содержимом

В состав общего содержимого могут входить главные страницы, настраиваемые и другие страницы, включенные в определение узла, а также связи с таблицами стилей. С помощью приложения Office SharePoint Designer 2007 можно легко выполнять поиск общего содержимого. Например, если нужно изменить эмблему на всех страницах веб-узла и для управления форматированием страниц используются главные страницы, то для поиска всех главных страниц, на которых следует изменить эмблему, можно применить отчет о главных страницах. Для поиска всех таблиц стилей, которые должны быть обновлены для отражения изменений шрифта или форматирования, применяемых ко всему узлу, можно воспользоваться отчетом «Связи с таблицами стилей».

  1. Откройте веб-узел, для которого нужно выполнить отчет в Office SharePoint Designer 2007.

  2. В меню Узел выберите команду Отчеты, затем — Общее содержимое, а затем — название отчета, который нужно выполнить.

    • Динамические веб-шаблоны     Отображение списка всех страниц узла, а также столбца Динамический веб-шаблон, определяющего, присоединена ли каждая страница к динамическому веб-шаблону (и если присоединена, то какая).

    • Главные страницы     Отображение списка всех страниц узла, а также столбца Главная страница, определяющего, присоединена ли каждая страница к главной странице (и если присоединена, то какая).

    • Настраиваемые страницы     Отображение списка всех страниц узла, а также столбца Настроенное, определяющего, настроена ли страница, основанная на определении узла.

    • Связи с таблицами стилей     Отображение списка всех страниц узла, а также столбца Связи с таблицами стилей, определяющего, присоединена ли каждая страница к таблице стилей.

      Примечание : Отображенные связи с таблицами стилей являются статическими (теги <link>). Динамические связи с таблицами стилей, созданные с помощью элементов управления Microsoft ASP.NET (например <SharePoint:CssLink>), в этот отчет не включаются.

К началу страницы

Просмотр отчетов об ошибках

Отчеты Office SharePoint Designer 2007 об ошибках позволяют предупредить пользователя о возможных проблемах и исправить их, прежде чем они коснутся других пользователей. Например, эти отчеты применяются для определения «медленных» страниц, поиска неработающих гиперссылок и поиска файлов для удаления, поскольку они не связаны с другими файлами. Для создания отчета об ошибках сначала нужно выбрать способ определения «медленных» страниц.

  1. Откройте веб-узел, для которого нужно выполнить отчет в Office SharePoint Designer 2007.

  2. В меню Сервис выберите команду Параметры приложения.

  3. Перейдите на вкладку Отчеты.

    Диалоговое окно «Параметры приложения» с вкладкой «Отчеты»

  4. В поле Загрузка "медленных" страниц занимает не менее: введите количество секунд, определяющее время, которое требуется для загрузки «медленной» страницы.

  5. В поле Предполагаемая скорость соединения: введите среднюю скорость подключения (в килобитах в секунду, Кбит/с).

  6. Нажмите кнопку ОК.

    Теперь можно выполнить отчеты.

  7. В меню Узел последовательно выберите команды Отчеты, Ошибки, а затем выберите название отчета, который нужно выполнить.

    • Несвязанные файлы     Отображение списка всех файлов узла, на которые нет ссылок. В этом списке находятся неиспользуемые файлы, которые следует удалить с узла. Обратите внимание, что в этот отчет не входят ссылки, созданные с помощью элементов управления ASP.NET (такие как веб-часть оглавлений на узлах Office SharePoint Server 2007).

    • Медленные страницы     Отображение списка страниц узла, идентифицированных в шаге 3 как медленно загружающиеся при средней скорости соединения, определенной в шаге 4. Обратите внимание, что в этом отчете отражается время, требуемое для загрузки разметки страницы. В отчет не входит динамическое содержимое, созданное с помощью элементов управления ASP.NET.

    • Гиперссылки     Отображение списка всех гиперссылок узла. После создания этого отчета в диалоговом окне будет выведен запрос на проверку гиперссылок на узле. Нажмите кнопку Да, если нужно, чтобы в приложении Office SharePoint Designer 2007 была проверена каждая гиперссылка. Результатом этого процесса является список гиперссылок, где каждая из них обозначена либо как ОК, либо как Неработающая. Чтобы изменить неработающую ссылку, щелкните ее в отчете, а затем на панели инструментов, появившейся в верхнем правом углу окна документа в представлении отчетов, нажмите кнопку Изменить гиперссылку.

      Примечание :  Диалоговое окно «Изменение гиперссылки»

    • Ошибки компонентов     Отображение списка всех компонентов (например интерактивных кнопок или счетчика посещений, известных как «веб-роботы» или «роботы»), которые в текущий момент создают ошибки. Чтобы просмотреть список веб-компонентов, в меню Вставка выберите команду Веб-компонент.  

К началу страницы

Просмотр отчета «Статистика использования»

С помощью отчетов об использовании веб-узлов можно получить ответы на некоторые неотложные вопросы владельцев узлов, например количество посетителей веб-узла, наиболее распространенные ресурсы, кто больше всего использует веб-узел, откуда пользователи обращаются на узел. В отчет «Статистика использования» включена сводка общих посещений, обращений к странице, загруженных байтов и другие сведения.

Отчет «Сводка об использовании»

Чтобы создать отчет «Статистика использования», выполните следующие шаги.

  1. Откройте веб-узел, для которого нужно выполнить отчет в Office SharePoint Designer 2007.

  2. В меню Узел последовательно выберите команды Отчеты, Использование и Статистика использования.

    Будет создан отчет. Для просмотра подробных отчетов щелкните любую из гиперссылок в столбце Имя.

К началу страницы

Просмотр подробных отчетов об использовании

Подробные отчеты об использовании можно создать для ответов на вопросы о способе доступа пользователей к узлу. Например, несмотря на то, что отчет «Статистика использования», созданный в предыдущем разделе, отображает общее количество обращений к странице, в отчете об обращении к страницам за месяц подробно представлены сведения о количестве обращений к каждой странице узла. Далее представлены действия по созданию подробных отчетов об использовании.

  1. Откройте веб-узел, для которого нужно выполнить отчет в Office SharePoint Designer 2007.

  2. В меню Узел выберите команду Отчеты, затем — Использование, а затем выберите название отчета, который нужно выполнить.

    • Ежемесячные итоги     Подсчет количества посещений, обращений, общее число обращений и размер загруженных данных на узле за месяц.

    • Еженедельные итоги     Подсчет количества посещений, обращений, общее число обращений и размер загруженных данных на узле за неделю.

    • Ежедневные итоги     Подсчет количества посещений, обращений, общее число обращений и размер загруженных данных на узле за день.

    • Обращений к странице в месяц     Подсчет количества обращений к каждой странице веб-узла и общее число обращений за месяц.

    • Обращений к странице в неделю     Подсчет количества обращений к каждой странице веб-узла и общее число обращений за неделю.

    • Обращений к странице в день     Подсчет количества обращений к каждой странице веб-узла и общее число обращений за день.

    • Посетители     Подсчет посетителей и их процентное соотношение к общему числу за выбранный месяц.

    • Операционные системы     Подсчет операционных систем посетителей и их процентное соотношение к общему числу за выбранный месяц.

    • Обозреватели     Подсчет обозревателей посетителей и их процентное соотношение к общему числу за выбранный месяц..

    • Домены, из которых производилось обращение     Подсчет количества посещений, выполненных из определенного домена, а также их процентное соотношение к общему числу за выбранный месяц.

    • Адреса URL, с которых производилось обращение     Подсчет количества посещений, выполненных с определенного адреса URL, а также их процентное соотношение к общему числу за выбранный месяц.

    • Строки поиска     Список строк поиска, введенных в окно поиска узла, а также их процентное соотношение к общему числу за выбранный месяц.

К началу страницы

Отображение результатов данных об использовании в виде диаграммы

Можно легко создать диаграмму, отображающую в графическом виде данные об использовании, что облегчает определение тенденций и анализ структуры использования.

  1. В меню Узел выберите команду Отчеты, затем — Использование, а затем выберите название отчета, который нужно выполнить.

  2. На панели инструментов, расположенной в правом верхнем углу окна документа, в списке Диаграмма выберите тип диаграммы, которую нужно создать, например Гистограмма.

    Панель инструментов в представлении отчетов, отображающая список «Диаграммы»

    Отчет будет открыт в новом окне.

    Диаграмма данных по использованию

    Примечание : По умолчанию данные диаграммы создаются вместе с отчетами об использовании. Если при попытке выполнить отчет не удается найти данные в виде диаграммы, в меню Сервис выберите команду Параметры приложения, перейдите на вкладку Отчеты, а затем убедитесь, что установлен флажок Включить диаграмму при сохранении отчета об использовании.

К началу страницы

Сортировка отчета

В представлении отчетов сортировка выполняется щелчком заголовков отчетов.

К началу страницы

Фильтр отчета

Для получения только необходимых сведений можно сократить количество результатов отчета. Отбор можно выполнить только по одному столбцу либо по нескольким столбцам для создания последовательного отбора.

  1. В меню Узел выберите команду Отчеты, а затем выберите название отчета, который нужно выполнить.

  2. Щелкните стрелку рядом с заголовком столбца, по которому нужно выполнить фильтрацию, а затем выберите данные, к которым следует применить фильтр.

    Например, при отборе по типу файла щелкните стрелку рядом с заголовком столбца Тип, а затем выберите bmp для отображения в отчете только файлов рисунков.

    Столбец «Тип», отображающий меню фильтра

  3. Если нужно выполнить фильтрацию по нескольким столбцам, повторите шаг 2 для каждого столбца.

  4. Чтобы создать пользовательский автофильтр для столбца, щелкните стрелку рядом с заголовком столбца, а затем выберите (Другой). Введите условия поиска, а затем нажмите кнопку ОК.

    Например, пользовательский автофильтр можно использовать для отбора всех файлов изображений BMP и GIF на узле.

    Диалоговое окно "Пользовательский автофильтр"

  5. Чтобы удалить фильтр со столбца, щелкните стрелку рядом с заголовком нужного столбца, а затем выберите (Все).

Примечание : Применяемые в данный момент параметры фильтра сохраняются при закрытии узла. Если не удается найти файлы в недавно созданном отчете, возможно, они скрыты в фильтрах, примененные в предыдущем сеансе.

Чтобы удалить все фильтры из отчета, щелкните правой кнопкой мыши заголовок любого столбца, а затем в контекстном меню выберите команду Удалить фильтры.

К началу страницы

Копирование отчета

После создания отчета может понадобиться скопировать и вставить результаты в сообщение электронной почты или в другой документ (например в лист Microsoft Office Excel). Можно скопировать любой отчет, кроме отчета «Сводка по узлу».

  1. Щелкните правой кнопкой мыши любой заголовок столбца в выполненном отчете, а затем в контекстном меню выберите команду Копировать отчет.

    Меню столбца «Имя» с выбранной командой «Копировать отчет»

  2. Вставьте данные в документ или сообщение.

К началу страницы

Сохранение отчета

Отчеты можно сохранить, если для просмотра и анализа результатов или для создания настраиваемых диаграмм и графиков на их основе будет использоваться приложение Microsoft Office Excel 2007.

  1. В меню Узел выберите команду Отчеты, а затем выберите название отчета, который нужно выполнить.

  2. В меню Файл выберите команду Сохранить. Можно также нажать клавиши CTRL+S.

  3. В поле Имя файла введите имя отчета, а затем нажмите кнопку Сохранить. Отчет будет сохранен на узле как файл HTM.

    Отчет, открытый в приложении Excel

  4. Чтобы открыть отчет, дважды щелкните его.

    Отчет будет открыт в приложении Office Excel 2007.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×