Использование нескольких таблиц для создания сводной таблицы

Использование нескольких таблиц для создания сводной таблицы

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Сводные таблицы удобно использовать для анализа данных и создания отчетов с ними. А если это реляционные данные (т. е. такие, которые хранятся в отдельных таблицах, но при этом их можно объединить благодаря общим значениям), вы можете всего за несколько минут создать такую сводную таблицу:

Сводная таблица, содержащая несколько таблиц

Чем примечательна эта сводная таблица? Обратите внимание: в списке полей справа отображается не одна таблица, а целая коллекция таблиц, содержащих поля, которые могут быть объединены в отдельную сводную таблицу для анализа данных в различных представлениях. Нет никакой необходимости в форматировании или подготовке данных вручную. Вы можете создать сводную таблицу, основанную на связанных таблицах, сразу после импорта данных.

Чтобы объединить несколько таблиц в списке полей сводной таблицы:

Ниже приведена процедура импорта нескольких таблиц из базы данных SQL Server.

  1. Убедитесь, что вам известны имя сервера, имя базы данных и учетные данные, необходимые для подключения к SQL Server. Все необходимые сведения можно получить у администратора базы данных.

  2. Щелкните Данные > Получение внешних данных > Из других источников > С сервера SQL Server.

  3. В поле Имя сервера введите сетевое имя компьютера с запущенным сервером SQL Server.

  4. В разделе Учетные данные входа в систему выберите команду Использовать проверку подлинности Windows, если вы подключаетесь с помощью своих учетных данных. В противном случае введите имя пользователя и пароль, предоставленные администратором базы данных.

  5. Нажмите клавишу ВВОД и в разделе Выбор базы данных и таблицы выберите нужную базу данных, а затем щелкните Разрешить выбор нескольких таблиц.

    Флажок "Разрешить выбор нескольких таблиц"

  6. Выберите необходимые для работы таблицы вручную, если вы знаете, какие именно нужны вам. Или же выберите одну или две, а затем щелкните Выбор связанных таблиц для автовыбора таблиц, связанных с уже указанными.

  7. Если установлен флажок Импорт связи между выбранными таблицами, оставьте его, чтобы разрешить Excel воссоздать аналогичные связи таблиц в книге.

  8. Нажмите Готово.

  9. В диалоговом окне Импорт данных выберите элемент Отчет сводной таблицы.

    Диалоговое окно "Параметры импорта"

  10. Нажмите кнопку ОК, чтобы начать импорт и заполнить список полей.

Обратите внимание: список полей содержит несколько таблиц. Это все таблицы, выбранные вами во время импорта. Каждую таблицу можно развернуть и свернуть для просмотра ее полей. Так как таблицы связаны, вы можете создать сводную таблицу, перетянув поля из любой таблицы в область ЗНАЧЕНИЯ, СТРОКИ или СТОЛБЦЫ.

Список полей сводной таблицы

  • Перетащите числовые поля в область ЗНАЧЕНИЯ. Например, если используется образец базы данных Adventure Works, вы можете перетащить поле "ОбъемПродаж" из таблицы "ФактПродажиЧерезИнтернет".

  • Перетащите поля даты или территории в область СТРОКИ или СТОЛБЦЫ, чтобы проанализировать объем продаж по дате или территории сбыта.

  • Иногда нужно создать связь между двумя таблицами, прежде чем использовать их в сводной таблице. Если появится сообщение о необходимости такой связи между таблицами, щелкните Создать, чтобы начать работу с ними.

    Кнопка "Создать", отображаемая при необходимости создать связь

    Работа с другими типами баз данных

    • Для использования других реляционных баз данных, например Oracle, может понадобиться установить дополнительное клиентское программное обеспечение. Обратитесь к администратору базы данных, чтобы уточнить, есть ли такая необходимость.

    • Вы можете импортировать несколько таблиц из приложения Access. Подробнее об этом можно узнать в статье Учебник. Анализ данных сводных таблиц с помощью модели данных в Excel.

Импорт таблиц из других источников

Помимо SQL Server, вы можете импортировать таблицы из ряда других реляционных баз данных.

Реляционные базы данных — это не единственный источник данных, который поддерживает работу с несколькими таблицами в списке полей сводной таблицы. Вы можете использовать таблицы в своей книге или импортировать каналы данных, а затем интегрировать их с другими таблицами данных в книге. Чтобы все эти несвязанные данные работали вместе, нужно каждую таблицу добавить в модель данных, а затем создать связи между ними с помощью соответствующих значений полей.

Использование модели данных для создания новой сводной таблицы

Возможно, вы создали связи между таблицами в модели данных и теперь готовы использовать эти данные для анализа. Ниже описано, как создать новую сводную таблицу или сводную диаграмму с помощью модели данных в книге.

  1. Щелкните любую ячейку на листе.

  2. Выберите Вставка > Сводная таблица.

    Кнопка "Сводная таблица" на вкладке "Вставка"

  3. В диалоговом окне Создание сводной таблицы в разделе Выберите данные для анализа щелкните Использовать внешний источник данных.

    Диалоговое окно "Создание сводной таблицы" с выбором и использованием внешнего источника данных

  4. Нажмите кнопку Выбрать подключение.

  5. На вкладке Таблицы в разделе Модель данных этой книги выберите Таблицы в модели данных книги.
    Таблицы в модели данных

  6. Нажмите кнопку Открыть, а затем — ОК, чтобы отобразить список полей, содержащий все таблицы в модели.

Дополнительные сведения о сводных таблицах и модели данных

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×