Использование вложенных функций в формуле

Примечание:  Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке) .

Использование функции в качестве одного из аргументов формулы, использующей функцию называется вложения, и мы будем воспринимают этой функции в качестве вложенные функции. К примеру, добавив вложенные функции СРЗНАЧ и сумм в аргументов функции Если, следующая формула суммирует набор чисел (G2: G5) только в том случае, если среднее значение другого набора чисел (F2: F5) больше 50. В противном случае возвращает значение 0.

Вложенные функции

Вложенные функции СРЗНАЧ и сумм в функцию Если.

В формулу можно вложить до 64 уровней функций.

  1. Щелкните ячейку, в которую нужно ввести формулу.

  2. Чтобы начать формулу с функции, нажмите в строке формул кнопку Вставить функцию Изображение кнопки Изображение кнопки .

    Знак равенства (=) будет вставлен автоматически.

  3. В поле Категория выберите пункт Все.

    Если вы знакомы с категориями функций, можно также выбрать категорию.

    Если вы не знаете, какую функцию использовать, можно ввести вопрос, описывающий необходимые действия, в поле Поиск функции (например, при вводе "добавить числа" возвращается функция СУММ).

  4. Чтобы ввести другую функцию в качестве аргумента, введите функцию в поле этого аргумента.

    Части формулы, отображенные в диалоговом окне Аргументы функции, отображают функцию, выбранную на предыдущем шаге.

    Если щелкнуть элемент ЕСЛИ, в диалоговом окне Аргументы функции отображаются аргументы для функции ЕСЛИ. Чтобы вложить другую функцию, можно ввести ее в поле аргумента. Например, можно ввести СУММ(G2:G5) в поле Значение_если_истина функции ЕСЛИ.

  5. Введите дополнительные аргументы, необходимые для завершения формулы.

    Вместо того, чтобы вводить ссылки на ячейки, можно также выделить ячейки, на которые нужно сослаться. Нажмите кнопку Изображение кнопки , чтобы свернуть диалоговое окно, выделите ячейки, на которые нужно создать ссылки, и нажмите кнопку Изображение кнопки , чтобы снова развернуть диалоговое окно.

    Совет: Для получения дополнительных сведений о функции и ее аргументах щелкните ссылку Справка по этой функции.

  6. После ввода всех аргументов формулы нажмите кнопку ОК.

  1. Щелкните ячейку, в которую нужно ввести формулу.

  2. Чтобы начать формулу с функции, нажмите в строке формул кнопку Вставить функцию Изображение кнопки Изображение кнопки .

  3. В диалоговом окне Вставить функцию в поле выберите категорию выберите все.

    Если вы знакомы с категориями функций, можно также выбрать категорию.

  4. Чтобы ввести другую функцию в качестве аргумента, введите функцию в поле аргумента в построитель формул или непосредственно в ячейку.

  5. Введите дополнительные аргументы, необходимые для завершения формулы.

  6. Завершив ввод аргументов формулы, нажмите клавишу ВВОД.

Примеры

Ниже приведен пример использования вложенных функций ЕСЛИ для назначения буквенных категорий числовым результатам тестирования.

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД. При необходимости измените ширину столбцов, чтобы видеть все данные.

Оценка

45

90

78

Формула

Описание

Результат

'=ЕСЛИ(A2>89,"A",ЕСЛИ(A2>79,"B", ЕСЛИ(A2>69,"C",ЕСЛИ(A2>59,"D","F"))))

Использует вложенные функции ЕСЛИ для назначения буквенной категории оценке в ячейке A2.

=ЕСЛИ(A2>89;"A";ЕСЛИ(A2>79;"B"; ЕСЛИ(A2>69;"C";ЕСЛИ(A2>59;"D";"F"))))

'=ЕСЛИ(A3>89,"A",ЕСЛИ(A3>79,"B", ЕСЛИ(A3>69,"C",ЕСЛИ(A3>59,"D","F"))))

Использует вложенные функции ЕСЛИ для назначения буквенной категории оценке в ячейке A3.

=ЕСЛИ(A3>89,"A",ЕСЛИ(A3>79,"B",ЕСЛИ(A3>69,"C",ЕСЛИ(A3>59,"D","F"))))

'=ЕСЛИ(A4>89,"A",ЕСЛИ(A4>79,"B", ЕСЛИ(A4>69,"C",ЕСЛИ(A4>59,"D","F"))))

Использует вложенные функции ЕСЛИ для назначения буквенной категории оценке в ячейке A4.

=ЕСЛИ(A4>89,"A",ЕСЛИ(A4>79,"B",ЕСЛИ(A4>69,"C",ЕСЛИ(A4>59,"D","F"))))

Советы: 

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Видео: Вложенные функции Если

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×