Использование аргумента "таблица" в функции подстановки

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

При создании формулы с помощью функции ВПР или ГПР вы вводите аргумент "таблица", который представляет собой диапазон ячеек, например D2:F39. Функция выполняет поиск диапазона данных, которые вам нужно найти.

Аргумент "таблица" всегда используется на втором месте в функциях ВПР или ГПР (первый аргумент — искомое значение), без него они не работают.

Первый аргумент может быть конкретным значением (например, 41 или "шашков") или ссылкой на ячейку (например, F2). Первый аргумент будет выглядеть так:

=ВПР(F2;...

Аргумент "таблица" всегда располагается после искомого значения, например:

=ВПР(F2;B4:D39;...

В диапазоне ячеек, указанном в аргументе "таблица", могут использоваться относительные или абсолютные ссылки на ячейки. Если необходимо скопировать формулу в другие ячейки, используйте абсолютные ссылки на ячейки (обратите внимание на символы $), например:

=ВПР(F2;$B$2:BD$39;...

Если ячейки в аргументе "таблица" расположены на другом листе книги, аргумент должен содержать имя листа с восклицательным знаком. Синтаксис будет выглядеть следующим образом:

=ВПР(F2;Лист2!$C$14:E$42;...

Номер столбца, в котором находятся искомые значения, — третий аргумент, который вы должны ввести. Такие столбцы называют столбцами подстановки. Если искомые значения находятся в столбце D (третьем столбце в таблице), в качестве третьего аргумента нужно ввести 3.

=ВПР(F2;B4:D39;3)

Рекомендуется (но не обязательно) использовать четвертый аргумент ЛОЖЬ или ИСТИНА. Чтобы найти точное соответствие, используйте значение ЛОЖЬ.

=ВПР(F2;B4:D39;3;ЛОЖЬ)

Если вы введете значение ИСТИНА или оставите четвертый аргумент пустым, функция возвратит приблизительные соответствия значению первого аргумента. Итак, если первый аргумент — "Шашков" и вы используете значение ИСТИНА, ВПР вернет "Шашков", "Шашкович" и т. д. Однако если вы используете значение ЛОЖЬ, функция вернет только "Шашков" (точное соответствие). Именно это нужно большинству пользователей.

Дополнительная сложность при использовании значения ИСТИНА состоит в том, что если столбец подстановки (указанный в третьем аргументе) не отсортирован по возрастанию (от А до Я или от меньшего значения к большему), функция может вернуть неверный результат.

Дополнительные сведения о функциях ВПР и ГПР см. в статье Функции подстановки и ссылок (справочник).

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×