Импорт данных из Excel, SQL Server, с сайтов SharePoint и из других внешних источников

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Можно быстро импортировать и отображать данные непосредственно на фигур, Microsoft Office Visio профессиональный 2007. Первый шаг — подключение к источнику данных и импорт данных в документе. Второй шаг — связывание импортируемых данных с фигурами.

Подробнее о том, как добавить данные в фигурах без импорта данных: Добавить данные с фигурами.

В этой статье

Шаг 1: Импорт данных

Шаг 2: Создание связей между строками данных и фигурами документа

Шаг 1: Импорт данных

На этом этапе данные импортируются в окно Внешние данные при помощи мастера отбора данных.

Данные, отображаемые в окне « Внешние данные » — это копия исходных данных во время импорта. Данные можно обновить документа в соответствии с изменениями в исходных данных. Тем не менее не удается обновить источник данных, изменяя данные в документе. Читайте в статье Обновление импортированных данных.

  1. В меню Данные выберите команду Связать данные с фигурами.

  2. На первой странице мастера отбора данных выберите нужный тип источника данных:

    • книга Microsoft Office Excel;

    • база данных Microsoft Office Access;

    • список служб Microsoft Windows SharePoint Services;

    • база данных Microsoft SQL Server;

    • другой источник данных OLEDB или ODBC.

    • Ранее созданное подключение

  3. Выберите остальные параметры мастера.

    Примечание : Если на первой странице мастера выбран вариант, отличный от книги Excel, базы данных Access и списка SharePoint, по ходу выбора остальных параметров мастер отбора данных может быть временно замещен мастером подключения данных.

    Специализированная справка доступна для большинства страниц мастера. Чтобы получить справку, нажмите клавишу F1 или кнопку «Справка».

После нажатия кнопки Готово на последней странице мастера подключения данных с импортированные данные отображаются в сетке откроется окно Внешние данные.

К началу страницы

Шаг 2: Создание связей между строками данных и фигурами документа

Существует три способа связать строки данных с фигурами в документе: можно связывать строки с фигурами по одной, можно связать строки с фигурами в автоматическом режиме, можно создать новые фигуры с данными.

Связывание строк с уже существующими фигурами по одной

Этот способ лучше всего подходит для уже существующих документов с относительно небольшим числом фигур.

  • Перетащите строку данных из окна Внешние данные на фигуру в документе.

    Данные отобразятся в фигуре, а слева от строки данных в окне Внешние данные появится значок связи.

    Перетаскивание строки в фигуру

    Примечания : 

    • Одну и ту же строку можно связать с несколькими фигурами, но связать несколько строк с одной фигурой нельзя.

    • Изменение или улучшить внешний вид фигуры и данных, читайте в статье для улучшения представления данных с помощью графических данных.

    • Чтобы отобразить окно Внешние данные, выберите в меню Вид команду Окно внешних данных.

Связывание строк с уже существующими фигурами в автоматическом режиме

Этот способ лучше всего подходит для уже существующих документов с большим числом фигур. Этот способ применим только в том случае, если в фигурах уже имеются данные, которые можно сопоставить с импортированными данными.

  1. В меню Данные выберите команду Связать автоматически.

  2. Следуйте указаниям мастера автоматического связывания.

    Данные будут отображаться в фигурах. Изменение или улучшить внешний вид фигуры и данных, читайте в статье для улучшения представления данных с помощью графических данных.

Специализированная справка доступна для большинства страниц мастера. Чтобы получить справку, нажмите клавишу F1 или щелкните значок «Справка».

Создание новых фигур с данными

Этот способ лучше всего подходит для документов, еще не имеющих фигур, при условии, что не требуется использовать фигуры определенного типа.

  1. Выберите фигуру, щелкнув ее в окне Фигуры.

  2. Перетащите одну строку данных или набор строк из окна Внешние данные на свободное пространство в документе.

    Для каждой такой строки появится свой экземпляр фигуры, которую вы щелкнете.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×