Изменение, удаление или вставка данных в представлении данных

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

После создания представления данных, источником данных которого является список или библиотека SharePoint, база данных SQL или XML-файл, можно легко добавлять ссылки для редактирования, удаления или вставки записей в источник данных с помощью обозревателя.

Например, Northwind Traders, компания по продаже деликатесов, отслеживает складские запасы в XML-файле. Если уровень запасов низкий, участник команды звонит поставщику определенного продукта и размещает заказ. Вы можете предложить добавить ссылки для редактирования представления данных, чтобы участник команды, который размещает заказ, мог немедленно обновить запись для определенного продукта. Можно также добавить ссылки вставки и удаления в представление данных, чтобы участник команды мог добавлять или удалять продукты. Таким образом, компания Northwind Traders всегда будет обеспечена последними данными о текущем состоянии складских запасов.

В этой статье описывается добавление, изменение, удаление и вставка ссылки на существующее представление данных. Создание образцы данных и представление данных, которые используются в примере или для получения дополнительных сведений о представлениях данных, читайте в статье Создание представления данных.

В этой статье

Перед началом работы

Добавление ссылки на изменение, удаление или Вставка данных в представлении данных

Изменение, удаление или Вставка записи через браузер

Настройка шаблонов редактирования и вставки

Подготовка

Microsoft Office SharePoint Designer 2007 содержит две отдельные функции, позволяющие пользователям изменять данные в представлении данных с помощью обозревателя.

  • Добавление ссылок в существующее представление данных.     Можно добавлять ссылки в существующее представление данных, чтобы пользователи могли изменять, удалять или вставлять записи в источник данных. Пользователю необходимо щелкнуть ссылку Изменить для записи, чтобы перевести элемент в режим редактирования. Если ссылки добавляются в представление данных, которое было вставлено как форма, ссылки заменяют кнопки формы. Кроме того, если добавляются ссылки в представление данных, которое было вставлено как форма, поля формы не будут отображаться в представлении данных по умолчанию, по умолчанию будут отображаться только данные.

  • Вставка представления данных в виде формы     При создании представления данных, вы можете вставить как форма отдельного элемента или несколькими элементами. Форма всегда находится в режиме редактирования и будет отображен записи одного или нескольких записей. Пользователи могут изменять существующие записи через браузер, но их невозможно вставить или удалить записи. Может потребоваться выбрать форму несколькими элементами, если пользователи, вероятно, чтобы быстро изменить данные в нескольких записей одновременно. Для получения дополнительных сведений обратитесь к статье Вставка представления данных в виде формы.

Форматы данных

В этом примере в качестве источника данных используется XML-файл. Так как XML-файл — это обычный текстовый файл, невозможно указать типы значений, которые должны содержаться в отдельных полях. Например, ничто не помешает ввести и сохранить текст в поле, которое должно содержать числа, например «Единицы_на_заказ».

Однако, если источник данных является базой данный, списком или библиотекой SharePoint, при создании базы данных, списка или библиотеки можно указать типы значений, которые могут содержать отдельные поля. В таком случае, если использовать форму, чтобы ввести текст в поле, в котором необходимы числа, а затем нажать кнопку Сохранить, система создаст сообщение об ошибке, уведомляющее пользователя о том, что элементу управления источника данных не удалось выполнить команду обновления. Причиной этого является ввод значения, которое не может быть принято полем в источнике данных. Если будет получено такое сообщение об ошибке, нажмите кнопку Назад обозревателя. Затем щелкните Отмена в форме, чтобы отменить изменения, либо введите значение, которое может быть принято источником данных.

При создании формы пользователь может захотеть включить примечание в заголовок каждого столбца, чтобы указать, какой тип данных следует ввести в каждое поле.

К началу страницы

Добавление ссылок для изменения, удаления или вставки записей в представление данных

Эти ссылки могут быть добавлены в любое представление данных, вне зависимости от того, было оно вставлено как представление или как форма. Однако, если эти ссылки добавляются в представление, которое было вставлено как форма, вставленные ссылки заменяют кнопки формы. Кроме того, если добавляются ссылки в представление данных, которое было вставлено как форма, поля формы не будут отображаться в представлении данных по умолчанию, по умолчанию будут отображаться только данные. С помощью этих возможностей нельзя создать представление данных, содержащее одновременно кнопки и ссылки.

  1. Откройте страницу, содержащую представление данных, в которое необходимо добавить ссылки.

    Выполните в этом примере с помощью представления данных, созданного в списке Создать представление данных.

    Отображение файла products.xml в представлении данных

  2. Нажмите кнопку представление данных, нажмите кнопку со стрелкой Изображение кнопки в правом верхнем углу, чтобы отобразить список Общих задач представления данных и нажмите кнопку Свойства представления данных. Щелкните стрелку еще раз, чтобы скрыть список.

    Совет : Также можно правой кнопкой мыши щелкнуть представление данных, а затем щелкнуть Показать общие задачи управления в контекстном меню.

  3. В диалоговом окне Свойства представления данных щелкните вкладку Правка.

  4. На вкладке Правка в группе Ссылки включения режимов выполните одно из следующих действий.

    • Чтобы добавить ссылку для редактирования записи, установите флажок Отображать ссылки для изменения элементов.

    • Чтобы добавить ссылку для удаления записи, установите флажок Отображать ссылки для удаления элементов.

    • Чтобы добавить ссылку для удаления новой записи, установите флажокОтображать ссылки для вставки элементов.

      В этом примере установите флажки Отображать ссылки для изменения элементов, Отображать ссылки для удаления элементов и Отображать ссылки для удаления элементов.

      Вкладка Правка диалогового окна Свойства представления данных

      Примечание : Предыдущий пример относится в XML-файлам. При работе с базами данных SQL вкладка Правка диалогового окна Свойства представления данных содержит параметр Автоматическая синхронизация команд. Если выбран этот параметр, команды обновления, удаления и вставки из источника данных SQL синхронизируются с элементами управления изменения, удаления и вставки в представлении данных.

  5. Нажмите кнопку ОК.

    Каждой записи в представлении данных предшествуют ссылки Изменить и Удалить. В левом нижнем углу представления данных находится ссылка Вставка.

    Представление данных с несколькими элементами с ссылками вставки, изменения и удаления

  6. В меню Файл выберите команду Сохранить как.

  7. В диалоговом окне Сохранить как в поле Имя файла введите имя файла, а затем щелкните Сохранить.

К началу страницы

Изменение, удаление или вставка записи с помощью обозревателя

После сохранения страницы, содержащей форму, ее можно просмотреть в обозревателе и изменить данные в форме.

Просмотр представления данных в обозревателе

  • В приложении Office SharePoint Designer 2007 в меню Файл щелкните Просмотр в обозревателе, а затем щелкните тип обозревателя и размер, которые необходимо использовать.

    Сочетание клавиш выберите страницу, которую требуется просмотреть в списке папок и нажмите клавишу F12.

    Представление данных со ссылками отобразится в обозревателе.

    Отображение представления данных со ссылками в обозревателе

Изменение записи

  1. Щелкните ссылку Изменить для записи, которую необходимо изменить.

    Для подписки в примере, щелкните ссылку Изменитьчай. Представление данных, включая формы данных для отображается чай запись.

    Отдельная запись в представлении данных в режиме редактирования

    Примечания : 

    • При работе со списками и библиотеками SharePoint элементами управления редактированием являются не текстовые поля, а элементы управления полями формы SharePoint.

    • При работе с полями, предназначенными только для чтения, например полем «Код» в списке SharePoint или базе данных SQL, поле отображается только как текст, а не как редактируемое поле.

    Теперь можно редактировать любые сведения, которые отображаются в чай записи.

  2. Измените данные для этой записи, а затем либо щелкните Сохранить, чтобы сохранить изменения, либо щелкните Отмена, чтобы отменить изменения и вернуться в представление данных.

    Чтобы отслеживать пример, введите в поле в столбце значения , 40и нажмите кнопку Сохранить слева от чай записи.

    Отобразится представление данных с обновленными данным.

    Запись со значением «Заказано_единиц»

Удаление записи

  • Щелкните ссылку Удалить слева от записи, которую необходимо удалить.

    Важно : При удалении записи через обозреватель не создается окно с запросом, в котором уточняется, действительно ли пользователь намерен осуществить действие, и не существует способа отменить удаленную запись.

    Чтобы отслеживать в примере, щелкните ссылку Удалить слева от изменений в списке ProductName . Откроется представление данных, содержащую только четыре записи.

    В представлении данных отображается только четыре записи

Вставка записи

  1. Щелкните ссылку Вставить в нижнем левом углу представления данных.

    Отобразится запись с пустыми полями формы.

    При щелчке на ссылку вставки отобразится запись с пустыми полями формы

    Теперь можно вставить новую запись.

  2. Введите данные для этой записи, а затем щелкните Сохранить, чтобы сохранить изменения, или щелкните Отмена, чтобы отменить изменения и вернуться в представление данных.

    Для выбора в примере, в поле в столбце ProductName введите Разворота Ежевичный бабушка элемента. В диалоговом окне товары столбца введите 120. В диалоговом окне в столбце значения введите значение 0. В диалоговом окне в столбце МинимальныйЗапас введите 25. Нажмите кнопку Сохранить. Откроется представление данных с новой записи.

    В представлении данных отображается новая вставленная запись

К началу страницы

Использование шаблонов изменения или вставки

Использование представления данных для вставки или изменения записей несколько отличается от использования, к примеру, таких форм списков как NewForm.aspx или EditForm.aspx для добавления и изменения элементов в списке SharePoint. Список или библиотека отображают разные страницы для пользователей при добавлении или изменении элементов, но представление данных отображается в другом режиме. Однако для каждого режима существует шаблон, который может настраиваться в полном объеме. Например, при настройке шаблона «Изменить» настройки будут отображаться только, если пользователь щелкнет ссылку изменения для перевода представления данных в режим редактирования.

Может возникнуть необходимость настроить каждый шаблон, если, например нужно предоставить пользователям определенные инструкции при вставке или редактировании записей. Можно легко вставить новую строку под заголовком столбца, а затем использовать эту строку для ввода текста, указывающего, какой тип данных необходимо ввести в каждый столбец, а также формат вводимых данных (текст, числа и т.д.).

  1. Нажмите кнопку представление данных и нажмите кнопку со стрелкой Изображение кнопки в правом верхнем углу, чтобы отобразить список Общих задач представления данных.

    Совет : Также можно правой кнопкой мыши щелкнуть представление данных, а затем щелкнуть Показать общие задачи управления в контекстном меню.

  2. В списке Обзор представления данных щелкните Шаблон изменения илиШаблон вставки.

    В представлении данных отобразится шаблон для этого режима. Можно настроить внешний вид и возможности шаблона, изменив шрифт, форматирование или макет формы.

  3. Чтобы сохранить внесенные изменения, в меню Файл выберите команду Сохранить.

  4. Чтобы просмотреть шаблон в обозревателе, в меню Файл выберите пункт Просмотр в обозревателе, а затем выберите тип обозревателя и размер, которые следует использовать.

    Сочетание клавиш выберите страницу, которую требуется просмотреть в списке папок и нажмите клавишу F12.

Открыв представление данных в обозревателе, а затем щелкнув Изменить или Вставить, можно отобразить настроенный созданный шаблон.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×