Изменение отчетов

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

В этом разделе описываются методы, которые можно использовать для изменения существующего отчета. Microsoft Office Access 2007 имеется два представления, которые можно использовать для внесения изменений в отчет: режим макета и конструкторе. Выбор из какой режим использовать зависит от каких конкретной задаче вы попытались выполнить. Вы можете получить с помощью оба представления и внесите нужные изменения.

Предполагаемое действие:

Режим макета

Режим конструктора

Переключение между режимами

Изменение отчета в режиме макета

Изменение отчета в режиме конструктора

Режим макета

Режим макета — наиболее наглядный из режимов, применяемых для изменения отчетов. Им можно пользоваться, чтобы вносить практически любые изменения в данные отчетов Office Access 2007. В режиме макета отчет выполняется фактически, поэтому пользователь получает возможность просматривать данные почти в том же виде, в каком они отобразятся после вывода на печать. В этом режиме можно также изменять структуру отчета. Поскольку при внесении изменений пользователь имеет возможность просматривать данные, в этом режиме очень удобно задавать ширину столбцов, добавлять уровни группировки и выполнять другие задачи, связанные с внешним видом и удобочитаемостью отчетов. На следующем рисунке изображен отчет в режиме макета, созданный на основе телефонной книги клиентов.

Отчет в режиме макета

Однако в режиме макета отчет отображается не совсем в том виде, в каком он будет напечатан. Например, в этом режиме не отображаются разрывы страниц. Не отображаются также столбцы, если для форматирования отчета в несколько столбцов использовалось диалоговое окно «Параметры страницы». Тем не менее, в этом режиме внешний вид отчета максимально приближен к печатной версии. Если требуется просмотреть, в каком виде отчет будет выведен на печать, следует воспользоваться режимом предварительного просмотра.

Некоторые задачи в режиме макета выполнить невозможно, поэтому иногда требуется переключиться в режим конструктора. В определенных случаях в Access отображается сообщение о том, что для внесения изменений следует переключиться в режим конструктора.

К началу страницы

Режим конструктора

Режим конструктора позволяет более подробно изучить структуру отчета. Пользователь может просматривать заголовки и примечания для отчета, определенной страницы и групп. В этом режиме отчет не выполняется, поэтому во время работы невозможно просматривать базовые данные. Однако некоторые задачи удобнее выполнять в режиме конструктора, а не макета, например.

  • К отчету можно добавлять различные элементы управления, такие как надписи, рисунки, линии и прямоугольники.

  • Можно изменять источник элемента управления «поле» непосредственно в самом поле, без использования окна свойств.

  • Можно также изменять определенные свойства, недоступные в режиме макета.

На следующем рисунке изображен отчет в режиме конструктора, созданный на основе телефонной книги клиентов.

Отчет в режиме конструктора

К началу страницы

Переключение между режимами

В Access есть несколько способов переключения между режимами. Если отчет уже открыт, переключиться в другой режим можно следующим образом.

  • Щелкните правой кнопкой мыши отчет в области переходов, затем выберите в контекстном меню нужный режим.

  • Щелкните правой кнопкой мыши вкладку документа отчета или окно с его заголовком, затем выберите в контекстном меню нужный режим.

  • На вкладке Главная в группе Просмотр нажмите кнопку Просмотр для переключения между доступные представления. Кроме того можно щелкните стрелку в разделе Просмотр и выберите один из доступных представлений в меню. Предварительный просмотр не поддерживается в этом меню.

    Изображение ленты Access

  • Щелкните правой кнопкой мыши пустую область в отчете и выберите нужный режим. Если отчет открыт в режиме конструктора, нужно щелкнуть правой кнопкой мыши вне области бланка отчета.

  • Щелкните один из небольших значков представлений в строке состояния Access.

Если отчет не открыт, дважды щелкните отчет в области переходов, чтобы открыть его в режиме конструктора. Чтобы открыть отчет в другом режиме, щелкните правой кнопкой мыши отчет в области переходов и выберите нужный режим в контекстном меню.

Примечание : При изменении отчета, в котором для создания нескольких столбцов использовалось диалоговое окно «Параметры страницы» (например отчет для почтовых наклеек), увидеть несколько столбцов можно только в режиме предварительного просмотра. При просмотре отчета в режиме макета Access отображает данные в одном столбце.

К началу страницы

Изменение отчета в режиме макета

В этом разделе описываются некоторые простые изменения, которые можно внести в отчет в режиме макета.

Изменение ширины столбца или поля

Изменение высоты строки или поля

Добавление поля

Макеты элементов управления

Удаление поля или столбца

Изменение параметров страницы

Изменение форматирования поля

Привязка текстового поля к другому полю (изменение источника элемента управления)

Изменение источника записей для отчета

Перенос текста в поле

Добавление линий сетки

Добавление или изменение эмблемы или другого рисунка

Добавление или изменение заголовка отчета

Добавление номеров страниц, текущих даты и времени

Изменение ширины столбца или поля

  1. Щелкните элемент в столбце, который нужно изменить.

    Граница вокруг элемента указывает на то, что поле выделено.

  2. Чтобы изменить ширину столбца, перетащите правый или левый край границы.

К началу страницы

Изменение высоты строки или поля

  1. Щелкните элемент строки, который требуется изменить.

    Граница вокруг элемента указывает на то, что поле выделено.

  2. Чтобы изменить высоту строки, перетащите верхний или нижний край границы.

К началу страницы

Добавление поля

  • На вкладке Формат в группе элементы управления нажмите кнопку Добавить существующие поля. Изображение кнопки

    Будет отображен список доступных полей. При наличии доступных полей в других таблицах они будут отображены в списке Доступные поля в другой таблице:.

  • Перетащите поле из области Список полей в отчет. При перетаскивании поля выделенная область покажет, куда оно будет помещено, если отпустить кнопку мыши.

    Примечание : Чтобы добавить сразу несколько полей, следует выбрать нужные поля в области Список полей, удерживая нажатой клавишу CTRL. После этого отпустите клавишу CTRL и перетащите поля в отчет. Все они будут размещены рядом друг с другом.

К началу страницы

Макеты элементов управления

Макеты элементов управления — это направляющие для горизонтального и вертикального выравнивания элементов управления, придающие отчетам схожий внешний вид. Макет элементов управления можно считать таблицей, в которой каждая ячейка содержит элемент управления. В следующих процедурах показано, как добавлять, удалять и упорядочивать элементы управления в макетах.

Существует два основных вида макетов элементов управления: табличные и в столбик.

  • В табличных макетах элементы управления выровнены по строкам и столбцам — наподобие электронных таблиц с подписями, расположенными в верхней части. Табличные макеты всегда занимают два раздела отчета; в каком бы разделе ни находились элементы управления, подписи всегда будут располагаться над ними. На следующем рисунке показан простой табличный макет элементов управления.

    Базовый макет таблицы для элементов управления

  • На макетах в столбик элементы управления выравниваются вертикально, как на бумажной форме, а подписи располагаются слева от каждого элемента управления. Макеты в столбик всегда состоят из одного раздела отчета. На следующем рисунке показан простой макет в столбик.

    Основной макет элемента управления в столбик

В отчете может быть несколько макетов элементов управления любого типа. Например, можно создать табличный макет со строкой данных для каждой записи, а ниже — один или несколько макетов в столбик, содержащих дополнительные данные из каждой записи.

Создание нового макета элементов управления

Access автоматически создает макеты элементов управления в виде столбцов при следующих условиях.

  • Новый отчет создается по нажатию кнопки Отчет Изображение кнопки в группе Отчеты на вкладке Создание.

  • Новый отчет создается по нажатию кнопки Пустой отчет Изображение кнопки в группе Отчеты на вкладке Создание, затем поля из области Список полей перетаскиваются в отчет.

Если отчет уже существует, новый макет элементов управления можно создать, выполнив следующие действия.

  1. Выберите элемент управления, который нужно добавить в макет.

  2. Если в тот же макет нужно добавить другие элементы управления, удерживайте клавишу SHIFT и выберите эти элементы.

  3. Выполните одно из следующих действий.

    • На вкладке Упорядочить в группе Макет элементов управления выберите вариант Табличный Изображение кнопки или В столбик Изображение кнопки .

    • Щелкните правой кнопкой мыши выбранные элементы управления, выберите команду Макет и нажмите кнопку Табличный Изображение кнопки или В столбик Изображение кнопки .

Приложение Access создаст макет элементов управления и добавит в него выбранные элементы.

Переключение табличного вида макета элементов управления к виду в столбик и наоборот

Чтобы переключить тип макета, выполните следующие действия.

  • Выберите макет элементов управления, щелкнув в оранжевой области выделения макета в его левом верхнем углу.

    Все ячейки макета окажутся выбранными.

  • Выполните одно из следующих действий.

    • На вкладке Упорядочить в группе Макет элементов управления выберите нужный тип макета (Табличный Изображение кнопки или В столбик Изображение кнопки ).

    • Щелкните правой кнопкой мыши макет элементов управления, выберите команду Макет и выберите нужный тип макета.

Access упорядочит элементы управления в соответствии с выбранным типом макета.

Разбиение одного макета элементов управления на два макета

Разбить один макет элементов управления на два можно с помощью следующих действий.

  1. Удерживая клавишу SHIFT, щелкните каждый из элементов управления, который нужно переместить в новый макет.

  2. Выполните одно из следующих действий.

    • На вкладке Упорядочить в группе Макет элементов управления выберите тип нового макета (Табличный Изображение кнопки или В столбик Изображение кнопки ).

    • Щелкните правой кнопкой мыши выбранные элементы управления, выберите команду Макет и затем выберите тип нового макета.

Access создаст новый макет элементов управления и добавит в него выбранные элементы.

Изменение расположения элементов управления в макете

  • Поместить элемент управления в макет можно, перетащив элемент из нужного расположения. При перетаскивании поля горизонтальная или вертикальная полоса указывает на расположение элемента после того, как будет отпущена кнопка мыши.

  • Элементы управления можно перетаскивать из одного макета управления в другой такого же типа. Например, можно перетащить элемент управления из одного табличного макета в другой табличный, но не в макет в столбик.

Добавление элементов управления в макет

Добавление нового поля из области Список полей в существующий макет элементов управления    

  • Перетащите поле из области Список полей в макет. При перетаскивании горизонтальная или вертикальная полоса указывает на расположение поля после того, как будет отпущена кнопка мыши.

Добавление существующих элементов управления в существующий макет   

  1. Выберите первый элемент управления, который нужно добавить в макет.

  2. Если в тот же макет нужно добавить другие элементы управления, удерживайте клавишу SHIFT и выберите эти элементы. Можно также выбрать элементы управления из других макетов.

  3. Выполните одно из следующих действий.

    • Если отчет открыт в режиме конструктора, перетащите выбранные поля в макет. Синяя горизонтальная полоса указывает на расположение поля после того, как будет отпущена кнопка мыши.

    • Если отчет уже открыт в режиме макета.

      1. На вкладке Упорядочить в группе Макет элементов управления выберите тип макета, в который нужно добавить элементы. При добавлении в табличный макет нажмите кнопку Табличный. При добавлении в макет с элементами, упорядоченными в столбик, нажмите кнопку В столбик.

        Access создаст новый макет и добавит в него выбранные элементы управления.

      2. Перетащите новый макет в существующий макет. Горизонтальная или вертикальная полоса указывает на расположение элемента после того, как будет отпущена кнопка мыши.

Удаление элементов управления из макета

Удаление элемента управления из макета позволяет помещать элемент в любое место отчета, не влияя на расположение других элементов.

  • Выделите элемент управления, чтобы удалить его из макета. Чтобы выделить несколько элементов управления, удерживайте клавишу SHIFT и щелкните каждый элемент, который нужно удалить. Чтобы выбрать все элементы управления в макете, щелкните окно выбора макета в его левом верхнем углу.

  • Выполните одно из следующих действий.

    • На вкладке Упорядочить в группе Макет элементов управления нажмите кнопку Удалить Изображение кнопки .

    • Щелкните правой кнопкой мыши один из выбранных элементов управления, выберите команду Макет и нажмите кнопку Удалить.

      Access удалит выбранные элементы управления из отчета.

Совет : Чтобы запретить, вставляемых в макет элемента управления при перемещении элемента управления, нажмите и удерживайте клавишу CTRL и перетащите элемент управления в нужное место.

К началу страницы

Удаление поля или столбца

  1. Щелкните поле в столбце, которое нужно удалить, его подпись или заголовок столбца.

    Access отобразит границы вокруг элемента, обозначающие, что он выбран.

  2. Нажмите клавишу DEL.

К началу страницы

Изменение параметров страницы

Чтобы изменить параметры страницы (размер, ориентацию, поля и т. д.), используйте группу Разметка страницы на вкладке Параметры страницы.

  1. Щелкните вкладку Параметры страницы.

  2. В группе Разметка страницы нажмите кнопку Размер Изображение кнопки , чтобы выбрать другой размер страницы.

  3. Нажмите кнопку Книжная Изображение кнопки или кнопку Альбомная Изображение кнопки , чтобы изменить ориентацию страницы.

  4. Нажмите кнопку Поля Изображение кнопки для настройки полей отчета.

К началу страницы

Изменение форматирования поля

  1. Выберите поле для форматирования.

  2. На вкладке " Формат " в группе « Шрифт » для применить форматирование, которое вы хотите используйте средства.

    Изображение ленты Access

К началу страницы

Привязка текстового поля к другому полю (изменение источника элемента управления)

  1. Щелкните внутри поля или столбца, для которого нужно изменить источник элементов управления.

    Граница вокруг поля указывает на то, что оно выделено.

  2. Если окно свойств не открыто, нажмите клавишу F4.

  3. На вкладке Данные окна свойств в свойстве Данные (ControlSource) задайте новое поле. Можно также выбрать поле из раскрывающегося списка или ввести выражение в поле. Дополнительные сведения о выражениях см. в разделе См. также в этой статье.

К началу страницы

Изменение источника записей для отчета

  1. Если окно свойств не открыто, нажмите клавишу F4.

  2. В раскрывающемся списке в верхней части окна свойств щелкните Отчет.

  3. В окне свойств перейдите на вкладку Данные.

  4. В раскрывающемся списке Источник записей выберите таблицу или запрос, который нужно использовать в качестве источника записей, либо нажмите кнопку Кнопка "Построитель" , чтобы отобразить построитель запросов.

    Примечание : Если отчет основан на таблице, в Access будет отображено сообщение с вопросом, нужно ли создать запрос, основанный на таблице. Нажмите кнопку Да, чтобы открыть область построителя запросов и создать запрос, или кнопку Нет, чтобы отменить операцию. Если выбрано создание запроса, новый запрос станет источником записей для отчета. Созданный запрос будет «внедренным» (т. е. будет храниться в свойстве отчета Источник записей (RecordSource), а не в виде отдельного объекта запроса).

К началу страницы

Перенос текста в поле

  1. Если окно свойств не отображается, щелкните правой кнопкой мыши поле, к которому требуется применить перенос текста, и выберите пункт Свойства. В противном случае просто щелкните поле, чтобы выделить его.

  2. На вкладке Формат окна свойств укажите значение Да для свойства Расширение (CanGrow).

К началу страницы

Добавление линий сетки

Если элементы управления содержатся в макете, можно добавить сетку для обеспечения более наглядного разделения элементов управления. Дополнительные сведения о макетах элементов управления см. в разделе Работа с макетами элементов управления.

  1. Щелкните любое поле в макете элементов управления.

    Граница вокруг поля указывает на то, что оно выделено.

  2. На вкладке Формат в группе Сетка установите флажок Сетка.

    Изображение ленты Access

  3. Выберите нужный стиль линий сетки.

Примечание : Чтобы добавить линии сетки, можно также щелкнуть правой кнопкой мыши любое поле в макете, выделить пункт Макет, затем — пункт Сетка и выбрать нужный тип линий.

К началу страницы

Добавление или изменение эмблемы или другого рисунка

В следующих процедурах показано, как добавить в отчет эмблему с помощью инструмента «Эмблема» и как изменить размеры рамки изображения или изображения внутри рамки.

Добавление эмблемы

  • На вкладке Формат в группе элементы управления нажмите кнопку логотип. Изображение кнопки

    Откроется диалоговое окно Вставка рисунка.

  • Найдите папку, в которой хранится файл эмблемы, и дважды щелкните этот файл.

    Эмблема будет добавлена в левый верхний угол отчета.

Изменение размеров элемента управления, содержащего эмблему или другой рисунок

  1. Щелкните элемент управления, который содержит рисунок.

    Граница вокруг элемента указывает на то, что он выделен.

  2. Поместите указатель мыши на границу. Когда указатель примет вид двунаправленной стрелки, его можно перетащить в указанных стрелками направлениях, чтобы увеличить или уменьшить элемент управления «рисунок».

Обратите внимание, что по умолчанию свойство рисунка Установка размеров (Size Mode) имеет значение Обрезать, благодаря чему размер рисунка не меняется при изменении размера элемента управления. Если требуется, чтобы размер рисунка изменялся при изменении размера элемента управления, выполните следующие действия.

Изменение размера эмблемы или рисунка внутри элемента управления

  1. Выберите рисунок.

  2. Если окно свойств не открыто, нажмите клавишу F4.

  3. На вкладке Формат окна свойств задайте нужное значение для свойства Установка размеров.

Значение

Описание

Обрезать

Размер рисунка не изменяется при изменении размера элемента управления. Если размер элемента управления меньше размера рисунка, рисунок обрезается.

Растянуть

Рисунок растягивается по вертикали и по горизонтали в соответствии с размером элемента управления. Исходное соотношение длины и ширины не сохраняется, поэтому рисунок может выглядеть искаженным, если высота и ширина элемента управления были заданы неправильно.

Масштаб

При изменении размеров элемента управления размер рисунка максимально увеличивается, но сам рисунок не искажается.

К началу страницы

Добавление или изменение заголовка отчета

В следующих процедурах описано, как добавить или изменить подпись, содержащую заголовок отчета.

Добавление заголовка отчета

  • На вкладке Формат в группе элементы управления щелкните заголовок. Изображение кнопки

    В заголовок отчета будет добавлена новая надпись. В качестве заголовка отчета будет указано его имя.

  • При создании надписи текст в ней автоматически выделяется, чтобы можно было при необходимости сразу ввести нужный заголовок, просто начав вводить текст.

  • После ввода заголовка нажмите клавишу ВВОД.

Изменение заголовка отчета

  1. Дважды щелкните надпись с заголовком отчета, чтобы поместить в нее курсор.

  2. Введите нужный текст заголовка отчета и нажмите клавишу ВВОД.

К началу страницы

Добавление номеров страниц, текущих даты и времени

В следующих процедурах показано, как добавить в отчет номера страниц, а также текущие дату и время.

Добавление номеров страниц

  • На вкладке Формат в группе элементы управления нажмите кнопку Номера страниц. Изображение кнопки

    Откроется диалоговое окно Номера страниц.

  • Выберите формат, расположение и выравнивание номеров страниц.

  • Если номер на первой странице не требуется, снимите флажок Показывать номер первой страницы.

  • Нажмите кнопку ОК.

    В отчет будут добавлены номера страниц. Перейдите в режим предварительного просмотра, чтобы увидеть, как будут выглядеть номера страниц при выводе на печать.

Добавление даты и времени

  • На вкладке Формат в группе элементы управления нажмите кнопку даты и времени. Изображение кнопки

    Откроется диалоговое окно Дата и время.

  • Если не требуется добавлять дату, снимите флажок Формат даты.

  • Если требуется добавить дату, выберите нужный формат.

  • Если не требуется добавлять время, снимите флажок Формат времени.

  • Если требуется добавить время, выберите нужный формат времени.

    Пример выбранных форматов даты и времени отображается в области Образец диалогового окна.

  • Нажмите кнопку ОК.

К началу страницы

Изменение отчета в режиме конструктора

Не все изменения можно внести в отчет в режиме макета, поэтому воспользуйтесь режимом конструктора.

Добавление номеров строк

  1. На вкладке Конструктор в группе Элементы управления нажмите кнопку Поле Изображение кнопки .

  2. Щелкните на пустом месте раздела место отображения номеров строки. В большинстве случаев это будет раздел подробностей. Будет выполнено перемещение текстового поля в конечном расположении более поздней версии.

    При щелчке отчета Access создаст новый, свободные текстового поля.

  3. Щелкните подпись (она находится слева от поля) и нажмите клавишу DELETE.

  4. Щелкните поле один раз, чтобы выделить его, затем щелкните второй раз, чтобы поместить курсор в поле.

  5. Введите = 1 и нажмите клавишу ВВОД.

  6. Если окно свойств не открыто, нажмите клавишу F4.

  7. На вкладке Данные окна свойств задайте для свойства Сумма с накоплением значение Для всего.

    Примечание : Если отчет содержит группы и в каждой группе нумерация должна начинаться с 1, задайте для этого свойства значение Для группы.

  8. Уменьшите ширину поля. Для этого поместите указатель на маркер изменения размера на правой границе поля и перетащите ее влево. Размер поля должен быть достаточным для того, чтобы в нем помещался наибольший из номеров строк в отчете.

  9. При необходимости освободить место для текстового поля на левом краю раздела «Область данных». Для этого следует перетащить существующие элементы управления вправо или изменить размер крайнего левого элемента управления в разделе.

  10. Перетащите поле в нужное место, требуется в отчете.

  11. Чтобы увидеть номера строк, переключитесь в режим отчета, предварительного просмотра или макета.

Отображение заголовка группы вверху каждой страницы

Для групп, которые занимают несколько страниц, удобно поместить заголовок вверху каждой страницы, чтобы не искать его в начале группы. Можно выделить заголовок группы в режиме макета, но в режиме конструктора сделать это легче.

  1. Дважды щелкните маркер выделения заголовка группы (горизонтальную полосу над заголовком группы).

  2. На вкладке Формат окна свойств задайте для свойства Повторение раздела (Repeat Section) значение Да.

Открытие подчиненного отчета в его собственном окне в режиме конструктора

При открытии отчета в режиме конструктора все подчиненные отчеты, содержащиеся в отчете, также открываются в режиме конструктора. Тем не менее, каждый подчиненный отчет отображается внутри собственного элемента управления, а не в отдельном окне. Поскольку размер элемента управления подчиненного отчета часто оказывается слишком мал для комфортной работы, открывать подчиненный отчет для редактирования лучше в отдельном окне. Чтобы открыть подчиненный отчет в новом окне, выполните следующие действия.

  • Выберите подчиненный отчет и на вкладке Конструктор в группе Инструменты нажмите кнопку Подчиненный отчет в новом окне Изображение кнопки .

  • Щелкните один раз вне элемента управления подчиненного отчета, чтобы убедиться, что он не выбран, затем щелкните правой кнопкой мыши внутри элемента управления подчиненного отчета и выберите команду Подчиненный отчет в новом окне.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×