Изменение новой базы данных

Примечание:  Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке) .

Каждый шаблон, который входит в состав Microsoft Office Access 2007 — это приложение полный отслеживания, содержащий стандартные таблицы, формы, отчеты, запросы, макросы и связи. Эти шаблоны предназначены для быть немедленно полезным для готовых, таким образом, можно создать новую базу данных на основе шаблона и получите и быстро. Тем не менее, может быть иногда возникает необходимость изменение новой базы данных — например, чтобы добавить или переименовать поле или изменить отчет.

В этой статье объясняется, как выполнять наиболее распространенные изменения, которые можно применить к базе данных, который был создан на основе шаблона. Просмотрите ссылки на статьи для более подробная информация об определенных областей.

В этой статье

Основные сведения о таблиц и полей

Добавление поля в таблицу

Удаление поля из таблицы

Переименование таблицы или поля

Добавление поля в форму или отчет

Добавление поля, в которой хранятся документы, файлы или изображения

Изменение способа отображения поля

Основные сведения о таблиц и полей

При создании базы данных, хранения данных в таблицах — списки на основе темы строк и столбцов. Содержат элементы сведений, которые вы хотите отслеживать в полях (также называемые столбцы). Например в таблице контактов, может создавать поля для фамилии, имени, номер телефона и адрес. Для создания таблицы Товары можно создать поля для имени продукта, код товара и цена.

Важно тщательно Выбор полей. Например обычно это рекомендуется создать поле для хранения вычисленное значение. В большинстве случаев может иметь Office Access 2007 вычисления значения при необходимости. При выборе поля попробуйте для хранения сведений в его наименьшего полезные части. К примеру вместо полного имени в одном поле, рассмотрите возможность сохранения имени и фамилии отдельно. Как правило если вам нужно отчета, сортировка, поиск или производить вычисления для определенного элемента сведения, разместите его в поле отдельно.

Дополнительные сведения о проектировании базы данных и выборе полей см. в статье Основные сведения о проектировании баз данных.

Поле содержит некоторые определяющие характеристики. Например все поля, имеет имя, которое однозначно определяет поля в таблице. Поля, также имеет тип данных, который выбран в соответствии с будет храниться информация. Тип данных определяет значения, которые могут храниться и операции, которые можно выполнять на эти значения также как объем дискового пространства для отложить для каждого значения. Все поля, также имеет связанный группа параметров свойства, определяющие внешний вид и поведение характеристики поле под названием. Например, свойство Формат определяет поля формата вывода, то есть, как она должна отображаться при отображении.

К началу страницы

Добавление поля в таблицу

Можно легко добавить поле в таблицу в режиме таблицы. Тем не менее можно добавить поле в таблицу в режиме конструктора. В режиме таблицы добавьте поле, введя некоторые данные в ячейку под заголовком столбца Добавить новое поле.

Таблица со столбцом "Добавить поле" в Access

1. новое пустое поле.

Добавление поля в режиме таблицы

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Открыть.

  2. В диалоговом окне Открытие файла базы данных выберите и откройте базу данных.

  3. В области навигации дважды щелкните таблицу, в которой вы хотите добавить новое поле.

    При открытии таблицы в режиме таблицы.

  4. Введите данные в ячейку под заголовком столбца Добавить новое поле.

    Если таблица накопилось много полей, может потребоваться прокрутка вправо, чтобы появился столбец, который содержит заголовок столбца Добавить новое поле.

При вводе данных в новом столбце Office Access 2007 использует эти сведения, введенные распознавать соответствующего типа данных для поля. Например при вводе даты в столбце, например 1/1/2007 Office Access 2007 распознает сведения, которые вы ввели как даты и наборы тип данных для поля даты и времени. Если Access не достаточно информации из ввода для определения типа данных, тип данных имеет значение в текст.

Если вы хотите явно делает набор данных введите и отформатируйте переопределяет выбор в полях, Office Access 2007, это можно сделать с помощью команд в группе Форматирование и тип данных на вкладки " Таблица ".

Явное задание типа данных

  • На вкладке таблицы в группе Форматирование и тип данных щелкните стрелку раскрывающегося списка рядом с полем Тип данных и выберите тип данных. Изображение группы "Тип данных и форматирование" на ленте Access

  • Выберите необходимый тип данных.

Явное задание формата

  1. На вкладке таблицы в группе Форматирование и тип данных щелкните стрелку раскрывающегося списка рядом с полем Формат и затем выберите нужный формат. Изображение группы "Тип данных и форматирование" на ленте Access

  2. Выберите требуемый формат.

При добавлении поля, введя данные в ячейку под заголовком Добавить новое полеOffice Access 2007 автоматически назначает имя поля. Недопустимые имена начинаются с поле1 для первого поля, поле2 второго поля и так далее. Рекомендуется использовать более описательные имена полей. Можно переименовать поле, щелкнув его заголовок и выбрав в контекстном меню команду Переименовать столбец.

Кроме добавления поля в режиме таблицы, можно добавить поля в режиме конструктора. Так как в режиме таблицы позволяет задать наиболее распространенные свойства поля, возможно, вам нужно задать свойство, которое не поддерживается в режиме таблицы с помощью конструктора.

Добавление поля в режиме конструктора

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Открыть.

  2. В диалоговом окне Открытие файла базы данных выберите и откройте базу данных.

  3. В области навигации щелкните правой кнопкой мыши таблицу, в которой вы хотите добавить новое поле и выберите в контекстном меню команду Конструктор.

    При открытии таблицы в режиме конструктора.

  4. В столбце Имя поля щелкните первую пустую строку и введите имя нового поля.

  5. Нажмите кнопку смежной ячейки в столбце Тип данных и выберите тип данных из списка.

  6. Для сохранения изменений нажмите кнопку Сохранить на панели быстрого доступа.

Дополнительные сведения о том, как добавить новое поле, читайте в статье Вставка нажмите Добавить, или создайте новое поле в таблице.

Примечание: При добавлении нового поля в таблицу, это поле не добавляется автоматически существующих форм и отчетов. Необходимо вручную добавить поле в эти формы и отчеты в противном случае он должен отображаться в их.

К началу страницы

Удаление поля из таблицы

Если это возможно, следует не удаляйте поля из базы данных, который был создан из одного из встроенных шаблонов, весьма вероятно, что поле работает в других объектов базы данных, например форм и отчетов. Таким образом, удаление этого поля будет создавать последствия при попытке использовать другие объекты базы данных, использующих поле — объекты базы данных не будет работать должным образом. Потребуется удалить все ссылки в поле из всех объектов, которые используют в противном случае эти объекты для правильной работы.

Когда вы решите, что необходимо удалить поле из базы данных, который был создан на основе шаблона, это можно сделать в режиме таблицы или в режиме конструктора. Помните, что если поле удаленных ссылаются на другие объекты базы данных, необходимо изменить эти объекты, чтобы удалить ссылку. Например если отчет содержит элемент управления, привязанный к полю удаленных и запустить отчет, появляется сообщение об ошибке, так как Access не удается найти данные для поля.

При удалении поля окончательно удалить все данные, хранящиеся в этом поле. По этой причине при удалении поля следует соблюдать осторожность и перед удалением поля следует создать резервную копию базы данных.

Прежде чем удалить поле, необходимо убедиться, что он не участвует в все связи между таблицами. Если вы пытаетесь удалить поле, для которого существуют связи, Access предупредит вас, необходимо сначала удалить связи. Пошаговые инструкции по удалению отношения между таблицами в разделе Удаление отношения между таблицами.

Удаление поля в режиме таблицы

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Открыть.

  2. В диалоговом окне Открытие файла базы данных выберите и откройте базу данных.

  3. В области навигации дважды щелкните таблицу, из которой вы хотите удалить поле.

    При открытии таблицы в режиме таблицы.

  4. Выберите поле (столбце), который нужно удалить.

    Совет: Чтобы выбрать поле (столбце), щелкните область выделения поля (заголовок столбца).

  5. Нажмите клавишу DELETE.

    Или:

    На вкладке таблицы в группе поля и столбцы нажмите кнопку Удалить.

Примечание: Нельзя удалить поле, которое является частью первичного ключа таблицы в режиме таблицы. Чтобы удалить поле первичного ключа, необходимо использовать конструктор.

Дополнительные сведения о первичных ключей читайте в статье Добавление, установка, изменение и удаление первичного ключа.

Удаление поля в режиме конструктора

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Открыть.

  2. В диалоговом окне Открытие файла базы данных выберите и откройте базу данных.

  3. В области навигации щелкните правой кнопкой мыши таблицу, из которой вы хотите удалить поле и выберите в контекстном меню команду Конструктор.

    При открытии таблицы в режиме конструктора.

  4. Выделите поле (строку), которое требуется удалить.

    Совет: Чтобы выделить строку, щелкните область выделения.

  5. Нажмите клавишу DELETE.

    Или:

    На вкладке " Конструктор " в группе Сервис выберите команду Удалить строки.

  6. Для сохранения изменений нажмите кнопку Сохранить на панели быстрого доступа.

Прежде чем удалить поле, необходимо убедиться, что он не участвует в все связи между таблицами. Если вы пытаетесь удалить поле, для которого существуют связи, Access предупредит вас, необходимо сначала удалить связи. Удаление отношения между таблицами, выполните следующие действия.

Удаление связи между таблицами

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Открыть.

  2. В диалоговом окне Открытие файла базы данных выберите и откройте базу данных.

  3. Закройте таблицы, участвующие в связи, если они открыты. Связь между открытыми таблицами удалить нельзя.

  4. На вкладке Работа с базами данных в группе Показать или скрыть выберите элемент Схема данных.

  5. Если не отображаются таблицы, участвующие в межтабличной связи, сделайте следующее:

    1. На вкладке Конструктор в группе Показать или скрыть нажмите кнопку Имена таблиц.

    2. В диалоговом окне Добавление таблицы выберите таблицы, которые нужно добавить, нажмите кнопку Добавить и нажмите кнопку Закрыть.

  6. Щелкните линию связи между таблицами, который вы хотите удалить (линия отображается полужирным шрифтом при выборе), а затем нажмите клавишу DELETE.

К началу страницы

Переименование таблицы или поля

Если это возможно, не следует Переименование поля или таблицы в базе данных, который был создан из одного из встроенных шаблонов, вероятно, других объектов базы данных, таких как формы и отчеты применять поля или таблицы. Таким образом Переименование поля или таблицы можно создать последствия при попытке использовать другие объекты базы данных, использующих поля или таблицы. Другие объекты не может работать неправильно, если они по-прежнему ссылаться старому имени. Для других объектов для правильной работы необходимо изменить имя старого новое имя. Если в категории « Текущая база данных » диалогового окна «Параметры Access» установлен флажок выполнять автозамену имен, большую часть этих действий будет сделана за вас автоматически.

Может потребоваться изменить текст, отображаемый в заголовке столбца в режиме таблицы. Это можно сделать без необходимости присвойте полю. Если вы хотите изменить только текст в заголовке столбца, и вы не хотите переименовать поле, в разделе Изменить текст, который отображается в заголовке столбца.

При необходимости можно переименовать таблицу в области навигации или переименование поля в режиме таблицы или в режиме конструктора. Прежде чем это делать необходимо рассмотреть Включение параметра Автозамену имен, если она является не включен.

Включите параметр автозамены имен

При переименовании объекта базы данных, таких как поля, таблицы, формы или отчета, обычно вы хотите изменить имя распространяться по всей базы данных. В противном случае — объекты, которые ссылаются старому имени не будет работать должным образом. Office Access 2007 предоставляет автозамену имен, которая помогает распространить изменения имени. По умолчанию для всех новых баз данных в Office Access 2007Автозамену имен включен. Тем не менее если отключено, вы выполните следующие действия, чтобы включить ее.

Включите параметр автозамены имен

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Параметры Access.

  2. В диалоговом окне «Параметры Access» в области слева выберите пункт Текущая база данных.

  3. В разделе Параметры автозамены имен установите флажок отслеживать автозамену имен и установите флажок выполнять автозамену имен.

  4. Если вы хотите сохранить таблицу, журналы каждого изменения, выполняемых автозамены имен, установите флажок журнал изменений автозамены имен.

  5. Нажмите кнопку ОК.

  6. Для сохранения изменений нажмите кнопку Сохранить на панели быстрого доступа.

Примечание: Автозамена имен не так же, как функция автозамены. Автозамена имен исправляет связи между объектами. Автозамена исправляет часто неправильно написанное слово или фразу.

Переименование поля в режиме таблицы

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Открыть.

  2. В диалоговом окне Открытие файла базы данных выберите и откройте базу данных.

  3. В области навигации дважды щелкните таблицу, в которой вы хотите переименовать поле.

    При открытии таблицы в режиме таблицы.

  4. Щелкните правой кнопкой мыши заголовок столбца для поля, которое вы хотите переименовать и выберите в контекстном меню Переименовать столбец.

  5. Введите имя нового поля и нажмите клавишу ВВОД.

Переименование поля в режиме конструктора

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Открыть.

  2. В диалоговом окне Открытие файла базы данных выберите и откройте базу данных.

  3. В области навигации щелкните правой кнопкой мыши таблицу, в которой вы хотите переименовать поле и выберите в контекстном меню команду Конструктор.

    При открытии таблицы в режиме конструктора.

  4. Щелкните ячейку в столбце Имя поля для поля, которое вы хотите переименовать.

    Совет: Чтобы выбрать имя поля целиком, поместите указатель превратится в стрелку слева от первого знака в поле имя и нажмите кнопку.

  5. Редактирование текста, чтобы переименовать поле.

  6. Для сохранения изменений нажмите кнопку Сохранить на панели быстрого доступа.

Переименование таблицы

Таблицы и большинство объектов базы данных непосредственно из области навигации можно переименовать.

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Открыть.

  2. В диалоговом окне Открытие файла базы данных выберите и откройте базу данных.

  3. В области навигации щелкните правой кнопкой мыши таблицу, которую требуется переименовать и выберите в контекстном меню выберите команду Переименовать.

    Примечание: Необходимо закрыть все открытые объекты, которые ссылаются на таблицу, прежде чем можно переименовать.

  4. Введите новое имя и нажмите клавишу ВВОД.

  5. Для сохранения изменений нажмите кнопку Сохранить на панели быстрого доступа.

Изменить текст, отображаемый в заголовке столбца

Название — заголовок или заголовок, вы можете назначать поля с помощью свойства поля заголовка . Заголовок независимо от имени поля — каждое поле имеет имя поля и также могут содержать подписи. Например вы можете название поля для состоять из одного слова без пробелы. Затем можно использовать свойства Caption для создания более описательное имя, которое содержит пробелы. Access отображает заголовок вместо имени поля в режиме таблицы и подписи данных и заголовки в запросов, форм и отчетов.

Если не указать текст для свойство заголовок , имя поля используется по умолчанию.

Если вы хотите изменить имя, которое отображается в заголовке столбца в режиме таблицы, можно сделать без изменения имени поля с помощью свойства поля заголовка . Чтобы изменить Название поля, сделайте следующее:

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Открыть.

  2. В диалоговом окне Открытие файла базы данных выберите и откройте базу данных.

  3. В области навигации щелкните правой кнопкой мыши таблицу, в которой вы хотите изменить подпись и выберите в контекстном меню команду Конструктор.

    При открытии таблицы в режиме конструктора.

  4. Щелкните ячейку в столбце Имя поля, для которого нужно задать свойство заголовок поля.

  5. В нижней части в разделе Свойства поля на вкладке Общие нажмите кнопку подписи.

  6. Введите новое название поля.

  7. Для сохранения изменений нажмите кнопку Сохранить на панели быстрого доступа.

При следующем открытии таблицы в режиме таблицы, название вместо имени поля будет отображаться в заголовке столбца.

К началу страницы

Добавление поля в форму или отчет

При создании базы данных, основанного на шаблоне базы данных будет содержать количество встроенных, готовой форм и отчетов, работа с немедленно. Возможно, вам, однако вы хотите добавить дополнительные поля в форму или отчет. При добавлении поля в форму или отчет о создании называемое элемента управления.

Знакомство с элементами управления

Элементы управления, объекты отображения данных, выполните действия, которые позволяют просматривать и работать с информацией, расширяющая возможности создания пользовательского интерфейса, например подписи и изображения. Элементы управления могут присоединенные, свободные и вычисляемые.

  • Присоединенный элемент управления    Это элемент управления, чьи источника данных — это поле в таблицу или запрос. Связанный элемент управления используется для отображения значений из полей в базе данных. Значения могут быть текста, дат, чисел, значениями Да/Нет, рисунки или диаграмм. Текстовое поле является наиболее распространенный тип присоединенный элемент управления. Например текстовое поле в форме, отображающий Фамилия сотрудника может появиться эту информацию из поля Фамилия в таблице «Сотрудники».

  • Элемент управления Unbound    Этот тип элемента управления нет источника данных (поле или выражение). Используйте свободные элементы управления для отображения информации, линии, прямоугольники и рисунки. Например метка, отображающая заголовок формы является свободный элемент управления.

  • Вычисляемый элемент управления    Это элемент управления, чьи источник данных — выражение вместо поля. Значение, которое вы хотите задать в элементе управления, определив выражение в качестве источника данных для элемента управления. Выражение — это сочетание операторов (таких как = и + ), управлять имена, имена полей, функции, возвращающие одно значение, констант и. Например следующее выражение вычисляет цены товара со скидкой 25%, умножая значение в поле «Цена» постоянную величину (0,75).

= [Цена за единицу] * 0,75

Выражения могут использовать данные из поля в базовой таблице или запросе формы или данные из элемента управления в форме. Дополнительные сведения о выражениях воспользуйтесь ссылками в разделе См.

Текстовое поле может быть связанные элементы управления, свободный элемент управления или вычисляемом элементе управления. Когда вы создаете форму, которая использует связанные, свободные и вычисляемые элементы управления, это, вероятно, наиболее эффективно для добавления и упорядочение связанных элементов управления во-первых, особенно, если они составляют большинство элементов управления в форме. Затем можно добавить необходимые свободные и вычисляемые элементы управления завершения разработки с помощью средств в группе элементы управления на вкладке " Конструктор " в режиме конструктора.

Элемент управления текстового поля привязать к полю, определяя поля, из которого элемент управления получает данные. Можно создать элемент управления, который связан с выделенным полем, перетащив поле из области Список полей в форму. В области Список полей отображаются поля из базовой таблицы или запроса формы. Чтобы отобразить область Список полей на вкладке " Конструктор " в группе " Сервис ", нажмите кнопку Добавить существующие поля. По умолчанию при перетаскивании поля из области Список полей в сетку шаблона формы, приложение Access вставляет текстового поля.

Кроме того можно связать поля к элементу управления, указав имя поля в самом элементе управления или в поле для Управления исходное значение свойств элемента управления. Окно свойств определяет характеристики элемента управления, например его имени, источника данных и его формат.

Использование области Список полей — лучший способ создать связанные надписи по двум причинам:

  • Связанные надписи имеет вложенных подпись и подпись совпадает с именем поля (или заголовок, определенные для данного поля в базовой таблице или запросе) как его заголовка по умолчанию, так что вам не нужно самостоятельно введите подпись.

  • Связанные надписи наследует многие те же параметры поля в базовой таблице или запросе (например, для свойства Формат, число десятичных знакови Маска ввода ). Таким образом можно убедиться, что эти свойства поля не изменяются при создании текстового поля, привязанный к этому полю.

Если вы уже создали свободный элемент управления и нужно связать с полем, элемент управления ControlSource свойству присвойте имя поля.

Добавление поля в форму или отчет в режиме макета

После создания формы или отчета, можно легко настройте его структуру при работе в режиме макета. С помощью как руководству фактические данные реального времени, можно Настройка ширины полей и изменить порядок полей. Можно поместить новые поля на форме или отчете и задание свойств для формы или отчета и их элементов управления.

Чтобы перейти в режим разметки, в области навигации щелкните правой кнопкой мыши форму или отчет и выберите в контекстном меню пункт Режим макета. Кроме того можно нажмите кнопку Режим макета в строке состояния Access или можно щелкните правой кнопкой мыши вкладку документа для формы или отчета и выберите в контекстном меню пункт Режим макета.

Перейти в режим разметки

  • В области навигации щелкните правой кнопкой мыши форму или отчет и выберите в контекстном меню пункт Режим макета.

    -Или-

    В строке состояния Access нажмите кнопку Режим макета.

    -Или-

    Щелкните правой кнопкой мыши вкладку документа для формы или отчета и выберите в контекстном меню пункт Режим макета.

В форме или отчете откроется в режиме макета.

Открыть окно свойств

  • На вкладке Упорядочить в группе Сервис выберите элемент Страница свойств.

    Сочетание клавиш нажмите клавишу F4.

С помощью области Список полей для добавления полей из базовой таблицы или запроса в настройте оформление. Чтобы отобразить область Список полей на вкладке Формат в группе элементы управления нажмите кнопку Добавить существующие поля. Можно затем перетащить поля непосредственно из области Список полей структуры.

Отображение области списка полей

  • На вкладке Формат в группе Элементы управления нажмите кнопку Добавить поля.

Добавление поля из области «Список полей»

  • Чтобы добавить одно поле, перетащите поле из области Список полей в раздел место его отображения в форме или отчете.

  • Чтобы добавить сразу несколько полей, удерживайте нажатой клавишу CTRL и щелкните поля, которые требуется. Перетащите выделенные поля в форму или отчет.

При перетаскивании поля на раздел Access создаст управления присоединенного текстового поля для каждого поля и автоматически добавит элемент управления метки рядом с полями.

Дополнительные сведения о формах и отчетах читайте в статьях Создание формы с помощью средства "форма" и Создание простого отчета.

К началу страницы

Добавление поля, в которой хранятся документы, файлы или изображения

Office Access 2007 можно использовать для добавления поля с типом данных вложения для хранения один или несколько документов, файлы или изображения. Поле вложения можно использовать для хранения несколько файлов в одном поле. В этом поле можно даже хранить более одного типа файла. Например в базе данных кандидата занятости одного или нескольких резюме, кроме фотографии, можно прикрепить к запись для каждого контакта.

Добавление поля вложения в таблицу

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Открыть.

  2. В диалоговом окне Открытие файла базы данных выберите и откройте базу данных.

  3. В области навигации щелкните правой кнопкой мыши таблицу, в которую нужно добавить поле и выберите в контекстном меню команду Конструктор.

    При открытии таблицы в режиме конструктора.

  4. В столбце Имя поля щелкните первую пустую строку и введите имя нового поля.

  5. Нажмите кнопку смежной ячейки в столбце Тип данных и выберите вложение в списке.

  6. Для сохранения изменений нажмите кнопку Сохранить на панели быстрого доступа.

    Access может отображаться сообщение о том, что не удается отменить изменения после сохранения таблицы. Это означает, что невозможно преобразовать поля в другой тип данных, но вы можете удалить поле, если вы считаете, что вы создали возникает ошибка.

  7. Нажмите Да, чтобы подтвердить преобразование.

Добавив поле вложения в таблицу, чтобы добавить документы, файлы или изображения в запись можно использовать диалоговое окно вложения.

Добавление вложений к полю

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Открыть.

  2. В диалоговом окне Открытие файла базы данных выберите и откройте базу данных.

  3. В области навигации дважды щелкните таблицу, к которому вы хотите добавить вложение.

    При открытии таблицы в режиме таблицы.

  4. В таблице дважды щелкните поле вложения.

    Откроется диалоговое окно Вложения.

  5. Нажмите кнопку Добавить.

    Откроется диалоговое окно Выберите файл.

  6. С помощью списка Папка перейдите к файлу или файлы, которые вы хотите добавить к записи, выберите файлы и нажмите кнопку Открыть.

    Обратите внимание, что можно выбрать несколько файлов, поддерживаемые данных любого типа.

  7. Чтобы добавить файлы в таблицу, в диалоговом окне Вложения нажмите кнопку ОК.

    Access добавит в файлы в поле и увеличивает число, указывающее вложения, соответственно.

  8. Чтобы добавить файлы в текущее поле или другие поля таблицы, повторите эти шаги.

Дополнительные сведения о поля вложений читайте в статье Присоединение файлов и изображений в записи базы данных.

К началу страницы

Изменение способа отображения поля

Вы можете настроить как поле появляется, когда она появится. Например можно настроить форматы отображения использовать во всей базы данных, таких как в формах и отчетах, а также при открытии таблицы в режиме таблицы. Чтобы задать формат отображения, задайте свойство '' Формат '' поля. Свойство '' Формат '' поля автоматически нажмите наследуются новых форм и отчетов, можно создать.

Настройка формата отображения в режиме базы данных

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Открыть.

  2. В диалоговом окне Открытие файла базы данных выберите и откройте базу данных.

  3. В области навигации дважды щелкните таблицу, содержащую поле, формат которого требуется задать.
    Открытии таблицы в режиме таблицы.

  4. Щелкните поле, формат отображения которого требуется настроить.

  5. На вкладке таблицы в группе Форматирование и тип данных щелкните стрелку раскрывающегося списка рядом с полем Формат и затем выберите нужный формат. Изображение группы "Тип данных и форматирование" на ленте Access

    Поле отображается с отображаться в новом формате.

Настройка формата отображения в режиме конструктора

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Открыть.

  2. В диалоговом окне Открытие файла базы данных выберите и откройте базу данных.

  3. В области навигации щелкните правой кнопкой мыши таблицу, содержащую поле отображения, формат которого требуется изменить и выберите в контекстном меню команду Конструктор.

    При открытии таблицы в режиме конструктора.

  4. Щелкните поле, формат отображения которого требуется настроить.

  5. В разделе Свойства поля на вкладке Общие щелкните поле " Формат ".

  6. Нажмите кнопку раскрывающегося списка и выберите формат отображения.

  7. Для сохранения изменений нажмите кнопку Сохранить на панели быстрого доступа.

Дополнительные сведения о том, как изменить внешний вид поля читайте в статье Форматирование данных в строках и столбцах.

К началу страницы

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×