Извлечение файла из библиотеки SharePoint и его возвращение

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

При извлечении файла из библиотеки узла Microsoft Windows SharePoint Services, убедитесь, что другие пользователи не смогут вносить в него изменения, пока он редактируется. Пока файл извлечен, его можно редактировать, закрывать, открывать его снова, а также работать с ним на жестком диске. Другие пользователи не смогут менять файл и видеть вносимые изменения до его возвращения.

В этой статье

Общие сведения

Извлечение файла из библиотеки SharePoint

Возврат файла в библиотеке SharePoint

Изменить расположение, где можно работать с файлами извлечен

Обзор

Извлечение файлов перед началом работы с ними помогает избежать возникновения конфликтов и путаницы, когда несколько пользователей работает над одними и теми же файлами. Когда файл извлечен на компьютер пользователя, только он может вносить в него изменения. На узле SharePoint можно извлечь любой файл, на который имеется разрешение, также файлы можно извлекать непосредственно из следующих программ выпуска выпуск 2007 системы Microsoft Office: Word, Excel, PowerPoint и Visio.

При возвращении файла можно вставить комментарии о внесенных в него изменениях. Это облегчает понимание того, что изменилось в файле при переходе на новую версию. Это особенно полезно, если файл редактируется несколькими людьми или должен пройти несколько проверок. Если в библиотеке отслеживаются версии файлов, комментарии становятся частью истории версий файла, что может быть полезно для пользователей, просматривающих или восстанавливающих предыдущие версии файла.

В организации может быть необходимо извлечь файл перед его редактированием. Если нужно извлечение, то при создании или загрузке файла в библиотеку его нужно вернуть.

Если файл извлечен, вносимые в него изменения не будут видны остальным пользователям до тех пор, пока он не будет возвращен. Может возникнуть ситуация, когда нужно вернуть файл, чтобы другие пользователи могли увидеть изменения, а, с другой стороны, необходимо оставить его извлеченным, чтобы продолжать работу над ним. При возвращении файла можно выбрать возможность продолжения работы над ним, если библиотека не отслеживает обе версии: основную и вспомогательную. В основную версию обычно вносятся значительные по сравнению с предыдущей версией изменения, в то время как вспомогательная изменяется незначительно. Например, в основную версию может быть внесен большой объем информации, а во вспомогательной могли быть исправлены орфографические ошибки.

Когда для извлечения файла с узла Windows SharePoint Services 3.0 используется программа Office, он будет по умолчанию сохранен на жестком диске компьютера в папке черновиков, которая находится в папке Мои документы. Место хранения можно поменять на любой другое, находящееся на жестком диске или в сети, или же можно указать, что извлеченные файлы во время работы над ними будут храниться на веб-сервере. В зависимости от нужд организации администратор может установить особое место хранения или запретить смену текущего.

Если файл извлекается с узла Microsoft Windows SharePoint Services 2.0, во время работы он будет храниться на сервере, но его все равно нужно будет вернуть, чтобы другие пользователи смогли увидеть изменения. В большинстве случаев при извлечении файла с узла Windows SharePoint Services 3.0 пользователь получит сообщение, в котором будет указано место хранения. При извлечении файла с узла Windows SharePoint Services 2.0 такое сообщение отображено не будет.

Когда документ извлечен, на панели задач Управление документами в программе Office отображается команда, позволяющая вернуть файл.

Если отслеживаются и основная и вспомогательная версии файлов, может быть запрошено, какую версию необходимо вернуть.

К началу страницы

Извлечение файла из библиотеки SharePoint

Эта процедура используется для извлечения уже открытого в программе Office файла. Также можно извлечь файл из библиотеки на узле SharePoint.

Выполните в этих программах выпуска 2007 Office (выпуск) следующие действия.

Word, Excel или PowerPoint

  1. Нажмите Кнопку Microsoft Office Изображение кнопки Office сервер и выберите команду Извлечь.

    Документы Word часто по умолчанию открываются в полноэкранном режиме чтения. В этом случае может понадобиться нажать Разметка страницы, чтобы переключиться в режим разметки страницы, прежде чем можно будет выполнить этот шаг.

  2. Если было отображено сообщение, содержащее сведения о месте хранения извлеченного файла, нажмите .

    В большинстве случаев данное сообщение отображается, когда файл извлекается с узла Windows SharePoint Services 3.0.

    Совет : В сообщении, содержащем сведения о месте хранения извлеченного файла, можно изменить параметры работы с извлеченными файлами.

Visio

  1. В меню Файл выберите пункт Извлечь.

  2. Если было отображено сообщение, содержащее сведения о месте хранения извлеченного файла, нажмите .

    В большинстве случаев данное сообщение отображается, когда файл извлекается с узла Windows SharePoint Services 3.0.

    Совет : В сообщении, содержащем сведения о месте хранения извлеченного файла, можно изменить параметры работы с извлеченными файлами.

К началу страницы

Возвращение файла в библиотеку SharePoint

Эта процедура используется для возвращения открытого в программе Office файла. Также можно вернуть файл из библиотеки на узле SharePoint.

Выполните в этих программах выпуска 2007 Office (выпуск) следующие действия.

Word, Excel или PowerPoint

  1. Нажмите Кнопку Microsoft Office Изображение кнопки Office сервер и выберите команду Вернуть.

    Документы Word часто по умолчанию открываются в полноэкранном режиме чтения. В этом случае может понадобиться нажать Разметка страницы, чтобы переключиться в режим разметки страницы, прежде чем можно будет выполнить этот шаг.

  2. Если нужно выбрать, какую (основную или вспомогательную) версию необходимо вернуть, щелкните Вспомогательная версия, если сделаны незначительные изменения или Основная версия, если изменения значительные.

  3. В поле Примечания к версии введите любые комментарии к внесенным изменениям.

    Эти заметки отображаются как часть истории версий для файла в библиотеке SharePoint. Это может быть полезно, если кому-то еще понадобится просмотреть сведения о предыдущих версиях.

  4. Если флажок Оставить документы извлеченными после возврата этой версии доступен, его можно установить, если планируется продолжать работу над файлом.

    Этот параметр доступен, если библиотека не отслеживает версии, если она отслеживает все версии одним способами или в случае возвращения вспомогательной версии. Этот параметр не будет доступен, если возвращается основная версия или публикуется файл.

Visio

  1. В меню Файл выберите пункт Вернуть.

  2. Если требуется выбрать, какую (основную или вспомогательную) версию необходимо вернуть, щелкните Вспомогательная версия, если сделаны незначительные изменения или Основная версия, если изменения значительные.

  3. В поле Примечания к версии введите любые комментарии к внесенным изменениям.

    Эти заметки отображаются как часть истории версий для файла в библиотеке SharePoint. Это может быть полезно, если кому-то еще понадобится просмотреть сведения о предыдущих версиях.

  4. Если флажок Оставить документы извлеченными после возврата этой версии доступен, его можно установить, если планируется продолжать работу над файлом.

    Этот параметр доступен, если библиотека не отслеживает версии, если она отслеживает все версии одним способами или в случае возвращения вспомогательной версии. Этот параметр не будет доступен, если возвращается основная версия или публикуется файл.

К началу страницы

Изменение места хранения извлеченных файлов

Этот параметр изменяет расположение, где будет производиться работа над следующим извлеченным файлом. Если на текущий момент производится работа над извлеченным файлом, эта процедура не изменит его расположения.

Выполните в этих программах выпуска 2007 Office (выпуск) следующие действия.

Word, Excel или PowerPoint

  1. Нажмите Кнопку Microsoft Office Изображение кнопки Office и нажмите кнопку Параметры для конкретной программы: Параметры Word, Excel параметры и Параметры PowerPoint.

  2. В появившемся диалоговом окне нажмите кнопку Сохранение.

  3. В разделе Параметры автономного редактирования для файлов на сервере управления документами выполните одно из следующих действий.

    • Для работы с извлеченными фалами на жестком диске или сетевом ресурсе используйте следующую процедуру.

      1. Под надписью Сохранять извлеченные файлы в щелкните переключатель в расположении серверных черновиков на данном компьютере.

      2. В поле Расположение серверных черновиков введите расположение на жестком диске, где нужно работать с извлеченными файлами, или нажмите кнопку Обзор, чтобы найти расположение.

    • Чтобы работать с извлеченными файлами на веб-сервере, под надписью Сохранить извлеченные файлы в щелкните переключатель на веб-сервере.

      При выборе данного параметра работа с извлеченными файлами будет производиться на веб-сервере или узле, где они хранятся. Настроить расположение будет нельзя.

  4. Нажмите кнопку ОК.

Visio

  1. В меню Сервис выберите пункт Параметры.

  2. В диалоговом окне Параметры перейдите на вкладку Общие, а затем щелкните кнопку Параметры служб.

  3. В появившемся диалоговом окне выберите пункт Параметры автономного редактирования.

  4. В разделе Параметры автономного редактирования для файлов на сервере управления документами выполните одно из следующих действий.

    • Для работы с извлеченными файлами на жестком диске или сетевом ресурсе используйте следующую процедуру.

      1. Чтобы работать над извлеченными файлами на жестком диске, под надписью Сохранять извлеченные файлы в щелкните переключатель в расположении серверных черновиков на данном компьютере.

      2. Под надписью Расположение серверных черновиков укажите расположение на жестком диске, где необходимо работать с извлеченными файлами или щелкните Обзор, чтобы найти расположение.

    • Чтобы работать над извлеченными файлами на жестком диске, под Сохранить извлеченные файлы в щелкните на веб-сервере.

      При выборе данного параметра работа с извлеченными файлами будет производиться на веб-сервере или узле, где они хранятся. Настроить расположение будет нельзя.

  5. Нажмите кнопку ОК.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×