ИНДЕКС (функция ИНДЕКС)

Функция ИНДЕКС возвращает значение или ссылку на значение из таблицы или диапазона.

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Функцию ИНДЕКС можно использовать двумя способами:

  • Если вы хотите возвращать значение указанной ячейки или массива ячеек, см. раздел Форма массива.

  • Если требуется возвращать ссылку на указанные ячейки, см. раздел Ссылочная форма.

Форма массива

Описание

Возвращает значение элемента таблицы или массив, заданного номером строки и номером столбца.

Если первый аргумент функции ИНДЕКС является константной массива, используйте форму массива.

Синтаксис

ИНДЕКС(массив; номер_строки; [номер_столбца])

Аргументы функции ИНДЕКС описаны ниже.

  • Массив    — обязательный аргумент. Диапазон ячеек или константа массива.

    • Если массив содержит только одну строку или один столбец, соответствующий аргумент "номер_строки" или "номер_столбца" не является обязательным.

    • Если массив содержит больше одной строки и одного столбца, а из аргументов "номер_строки" и "номер_столбца" задан только один, функция ИНДЕКС возвращает массив, состоящий из целой строки или целого столбца аргумента "массив".

  • Номер_строки     — обязательный аргумент. Выбирает строку в массиве, из которой требуется возвратить значение. Если аргумент "номер_строки" опущен, аргумент "номер_столбца" является обязательным.

  • Номер_столбца     — необязательный аргумент. Выбирает столбец в массиве, из которого требуется возвратить значение. Если аргумент "номер_столбца" опущен, аргумент "номер_строки" является обязательным.

Замечания

  • Если используются оба аргумента — и "номер_строки", и "номер_столбца", — функция ИНДЕКС возвращает значение ячейки на пересечении указанных строки и столбца.

  • Если указать в качестве аргумента "номер_строки" или "номер_столбца" значение 0 (ноль), функция ИНДЕКС возвратит массив значений для целого столбца или целой строки соответственно. Чтобы использовать значения, возвращенные как массив, введите функцию ИНДЕКС как формула массива в горизонтальный диапазон ячеек для строки и в вертикальный — для столбца. Чтобы ввести формулу массива, нажмите сочетание клавиш CTRL+SHIFT+ВВОД.

    Примечание :  В Excel Web App невозможно создавать формулы массива.

  • Аргументы "номер_строки" и "номер_столбца" должны указывать на ячейку внутри заданного массива; в противном случае функция ИНДЕКС возвратит значение ошибки #ССЫЛКА!.

Примеры

Пример 1

В этих примерах функция ИНДЕКС используется для поиска значения ячейки, находящейся на пересечении заданных строки и столбца.

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД. При необходимости измените ширину столбцов, чтобы видеть все данные.

Данные

Данные

Яблоки

Лимоны

Бананы

Груши

Формула

Описание

Результат

=ИНДЕКС(A2:B3;2;2)

Значение ячейки на пересечении второй строки и второго столбца в диапазоне A2:B3.

Груши

=ИНДЕКС(A2:B3;2;1)

Значение ячейки на пересечении второй строки и первого столбца в диапазоне A2:B3.

Бананы

Пример 2

В этом примере функция ИНДЕКС используется в формуле массива для поиска значений двух заданных ячеек в массиве с диапазоном 2 x 2.

В этом случае нужно выбрать любые две ячейки по вертикали, например A1:A2, вставить в первую ячейку формулу =ИНДЕКС({1;2:3;4};0;2) и нажать клавиши CTRL+SHIFT+ВВОД. Если ввести формулу как формулу массива, Excel автоматически вставит ее во вторую ячейку.

Формула

Описание

Результат

=ИНДЕКС({1;2:3;4};0;2)

Значение ячейки на пересечении первой строки и второго столбца в массиве. Массив содержит значения 1 и 2 в первой строке и значения 3 и 4 во второй строке.

2

Значение ячейки на пересечении второй строки и второго столбца в массиве, указанном выше.

4

Примечание : Это формула массива, которую нужно вводить с помощью клавиш CTRL+SHIFT+ВВОД. Excel автоматически заключит формулу в фигурные скобки {}. Если вы попытаетесь ввести их вручную, Excel отобразит формулу как текст. Если при вводе формулы не нажать клавиши CTRL+SHIFT+ВВОД, она возвратит ошибку #ЗНАЧ!

К началу страницы

Ссылочная форма

Описание

Возвращает ссылку на ячейку, расположенную на пересечении указанной строки и указанного столбца. Если ссылка составлена из несмежных выделенных диапазонов, можно указать, какой из них требуется использовать.

Синтаксис

ИНДЕКС(ссылка; номер_строки; [номер_столбца]; [номер_области])

Аргументы функции ИНДЕКС описаны ниже.

  • Ссылка    — обязательный аргумент. Ссылка на один или несколько диапазонов ячеек.

    • Если в качестве аргумента "ссылка" используется несмежный диапазон, его необходимо заключить в скобки

    • Если каждая область в ссылке содержит только одну строку или один столбец, аргумент "номер_строки" или "номер_столбца" соответственно является необязательным. Например, для ссылки на единственную строку нужно использовать формулу ИНДЕКС(ссылка,,номер_столбца).

  • Номер_строки    — обязательный аргумент. Номер строки в диапазоне, заданном аргументом "ссылка", из которого требуется возвратить ссылку.

  • Номер_столбца    — необязательный аргумент. Номер столбца в диапазоне, заданном аргументом "ссылка", из которого требуется возвратить ссылку.

  • Номер_области    — необязательный аргумент. Диапазон в аргументе "ссылка", из которого требуется возвратить значение ячейки на пересечении строки и столбца, заданных аргументами "номер_строки" и "номер_столбца". Первая введенная или выделенная область имеет номер 1, вторая — 2 и т. д. Если аргумент "номер_области" опущен, в функции ИНДЕКС используется область 1.  Все указанные здесь области должны находиться на одном листе.  Если указать области, находящиеся на разных листах, произойдет ошибка #ЗНАЧ!  Если необходимо использовать диапазоны, находящиеся на разных листах, рекомендуется применить функцию ИНДЕКС в форме массива и использовать другую функцию для вычисления диапазона, составляющего массив.  Например, определить используемый диапазон можно с помощью функции ВЫБОР.

Например, если аргумент "ссылка" определяет ячейки (A1:B4,D1:E4,G1:H4), номер области 1 соответствует диапазону A1:B4, номер области 2 — диапазону D1:E4, а номер области 3 — диапазону G1:H4.

Замечания

  • После того как с помощью аргументов "ссылка" и "номер_области" выбран диапазон, с помощью аргументов "номер_строки" и "номер_столбца" выбирается конкретная ячейка: номер строки 1 соответствует первой строке диапазона, номер столбца 1 — его первому столбцу и т. д. Ссылка, возвращаемая функцией ИНДЕКС, указывает на пересечение строки "номер_строки" и столбца "номер_столбца".

  • Если указать в качестве аргумента "номер_строки" или "номер_столбца" значение 0 (ноль), функция ИНДЕКС возвратит ссылку на целый столбец или целую строку соответственно.

  • Аргументы "номер_строки", "номер_столбца" и "номер_области" должны указывать на ячейку внутри аргумента "ссылка"; в противном случае функция ИНДЕКС возвращает значение ошибки #ССЫЛКА!. Если аргументы "номер_строки" и "номер_столбца" опущены, функция ИНДЕКС возвращает область в аргументе "ссылка", заданную аргументом "номер_области".

  • Результатом вычисления функции ИНДЕКС является ссылка, которая интерпретируется в качестве таковой другими функциями. В зависимости от формулы значение, возвращаемое функцией ИНДЕКС, может использоваться как ссылка или как значение. Например, формула ЯЧЕЙКА("ширина";ИНДЕКС(A1:B2;1;2)) эквивалентна формуле ЯЧЕЙКА("ширина";B1). Функция ЯЧЕЙКА использует значение, возвращаемое функцией ИНДЕКС, как ссылку. С другой стороны, такая формула, как 2*ИНДЕКС(A1:B2;1;2), преобразует значение, возвращаемое функцией ИНДЕКС, в число в ячейке B1.

Примечание :  Функция ЯЧЕЙКА недоступна в Excel Web App.

Примеры

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД. При необходимости измените ширину столбцов, чтобы видеть все данные.

Фрукты

Цена

Количество

Яблоки

0,69 ₽

40

Бананы

0,34 ₽

38

Лимоны

0,55 ₽

15

Апельсины

0,25 ₽

25

Груши

0,59 ₽

40

Миндаль

2,80 ₽

10

Кешью

3,55 ₽

16

Арахис

1,25 ₽

20

Грецкие орехи

1,75 ₽

12

Формула

Описание

Результат

=ИНДЕКС(A2:C6;2;3)

Пересечение второй строки и третьего столбца в диапазоне A2:C6, т. е. содержимое ячейки C3.

38

=ИНДЕКС((A1:C6;A8:C11);2;2;2)

Пересечение второй строки и второго столбца во второй области (A8:C11), т. е. содержимое ячейки B9.

1,25

=СУММ(ИНДЕКС(A1:C11;0;3;1))

Сумма третьего столбца в первой области диапазона (A1:C11) является суммой диапазона C1:C11.

216

=СУММ(B2:ИНДЕКС(A2:C6;5;2))

Сумма значений из диапазона, начинающегося с ячейки B2 и заканчивающегося пересечением пятой строки и второго столбца диапазона A2:A6, т. е. сумма значений из диапазона B2:B6.

2,42

К началу страницы

См. также

Функция ВПР

Функция ПОИСКПОЗ

Функция ДВССЫЛ

Рекомендации и примеры по использованию формул массива

Функции ссылки и поиска (справка)

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×