Перейти к основному контенту
Office

ИНДЕКС (функция ИНДЕКС)

Функция ИНДЕКС возвращает значение или ссылку на значение из таблицы или диапазона.

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Функцию ИНДЕКС можно использовать двумя способами:

  • Если вы хотите возвращать значение указанной ячейки или массива ячеек, см. раздел Форма массива.

  • Если требуется возвращать ссылку на указанные ячейки, см. раздел Ссылочная форма.

Форма массива

Описание

Возвращает значение элемента в таблице или массиве, выбранном с помощью индексов строк и столбцов.

Если первый аргумент функции ИНДЕКС является константной массива, используйте форму массива.

Синтаксис

ИНДЕКС(массив; номер_строки; [номер_столбца])

Форма массива функции индекс имеет следующие аргументы:

  • IsArray    — обязательный аргумент. Диапазон ячеек или константа массива.

    • Если массив содержит только одну строку или один столбец, соответствующий аргумент "номер_строки" или "номер_столбца" является необязательным.

    • Если массив содержит более одной строки и несколько столбцов и используется только аргумент "номер_строки" или "номер_столбца", функция индекс возвращает массив всей строки или столбца в массиве.

  • Номер_строки    — обязательный аргумент. Выбирает строку в массиве, из которой требуется возвратить значение. Если аргумент "номер_строки" опущен, требуется номер_столбца.

  • Номер_столбца    — необязательный аргумент. Выбирает столбец в массиве, из которого требуется возвратить значение. Если аргумент номер_столбца опущен, то требуется номер_строки.

Замечания

  • Если используются оба аргумента "номер_строки" и "номер_столбца", функция индекс возвращает значение в ячейке на пересечении номер_строки и номер_столбца.

  • аргумент "номер_строки" и "номер_столбца" должен указывать на ячейку в массиве; в противном случае функция индекс возвращает значение #REF! ошибка #ЧИСЛО!.

  • Если для аргумента "номер_строки" или "номер_столбца" установлено значение 0 (ноль), функция индекс возвращает массив значений для всего столбца или строки соответственно. Чтобы использовать значения, возвращаемые в виде массива, введите в качестве формулы массива функцию индекс.

    Примечание: Если у вас установлена текущая версия Office 365, вы можете ввести формулу в левую верхнюю ячейку диапазона вывода, а затем нажмите клавишу Ввод , чтобы подтвердить формулу как формулу динамических массивов. В противном случае необходимо ввести формулу в качестве устаревшей формулы массива, сначала выделив диапазон вывода, введите формулу в верхнюю левую ячейку выходного диапазона, а затем нажмите клавиши CTRL + SHIFT + ВВОД , чтобы подтвердить его. Excel автоматически вставляет фигурные скобки в начале и конце формулы. Дополнительные сведения о формулах массива см. в статье Использование формул массива: рекомендации и примеры.

Примеры

Пример 1

В этих примерах функция ИНДЕКС используется для поиска значения ячейки, находящейся на пересечении заданных строки и столбца.

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — ВВОД.

Данные

Данные

Яблоки

Лимоны

Бананы

Груши

Формула

Описание

Результат

=ИНДЕКС(A2:B3;2;2)

Значение ячейки на пересечении второй строки и второго столбца в диапазоне A2:B3.

Груши

=ИНДЕКС(A2:B3;2;1)

Значение ячейки на пересечении второй строки и первого столбца в диапазоне A2:B3.

Бананы

Пример 2

В этом примере функция ИНДЕКС используется в формуле массива для поиска значений двух заданных ячеек в массиве с диапазоном 2 x 2.  

Примечание: Если у вас установлена текущая версия Office 365, вы можете ввести формулу в левую верхнюю ячейку диапазона вывода, а затем нажмите клавишу Ввод , чтобы подтвердить формулу как формулу динамических массивов. В противном случае формула должна быть введена как устаревшая формула массива, если сначала выбрать две пустые ячейки, ввести формулу в верхнюю левую ячейку выходного диапазона, а затем нажать клавиши CTRL + SHIFT + ВВОД , чтобы подтвердить его. Excel автоматически вставляет фигурные скобки в начале и конце формулы. Дополнительные сведения о формулах массива см. в статье Использование формул массива: рекомендации и примеры.

Формула

Описание

Результат

=ИНДЕКС({1;2:3;4};0;2)

Значение ячейки на пересечении первой строки и второго столбца в массиве. Массив содержит значения 1 и 2 в первой строке и значения 3 и 4 во второй строке.

2

Значение ячейки на пересечении второй строки и второго столбца в массиве, указанном выше.

4

К началу страницы


Справочная форма

Описание

Возвращает ссылку на ячейку, расположенную на пересечении указанной строки и указанного столбца. Если ссылка состоит из несмежных диапазонов, вы можете выбрать вариант поиска.

Синтаксис

ИНДЕКС(ссылка; номер_строки; [номер_столбца]; [номер_области])

Ссылочная форма функции индекс имеет следующие аргументы:

  • справки    Обязательный. Ссылка на один или несколько диапазонов ячеек.

    • Если вы вводите несмежный диапазон для ссылки, заключите его в круглые скобки.

    • Если каждая область в ссылке содержит только одну строку или один столбец, аргумент "номер_строки" или "номер_столбца" соответственно является обязательным. Например, для ссылки на единственную строку нужно использовать формулу ИНДЕКС(ссылка,,номер_столбца).

  • Номер_строки    — обязательный аргумент. Номер строки в диапазоне, заданном аргументом "ссылка", из которого требуется возвратить ссылку.

  • Номер_столбца    — необязательный аргумент. Номер столбца в диапазоне, заданном аргументом "ссылка", из которого требуется возвратить ссылку.

  • номер_области    — необязательный аргумент. Выделяет диапазон в ссылке, из которого нужно вернуть пересечение номер_строки и номер_столбца. Первая выделенная или введенная область имеет номер 1, второй — 2 и т. д. Если аргумент номер_области опущен, то функция индекс использует область 1.  Все перечисленные здесь области должны располагаться на одном листе.  Если вы указали области, которые не находятся на одном листе, это вызовет #VALUE! ошибка #ЧИСЛО!.  Если необходимо использовать диапазоны, расположенные на разных листах, рекомендуется использовать форму массива функции индекс и использовать другую функцию для вычисления диапазона, который составляет массив.  Например, чтобы вычислить диапазон, который будет использоваться, можно использовать функцию выбор.

Например, если в ссылке описаны ячейки (a1: B4, D1: E4, G1: H4), то функция номер_области 1 — это диапазон a1: B4, номер_области 2 — диапазон D1: E4, а номер_области 3 — диапазон G1: H4.

Замечания

  • После того, как ссылка и номер_области выделены определенный диапазон, выбери ячейку и номер_столбца, выделив одну из них: номер_строки 1 — это первая строка диапазона, номер_столбца 1 — первый столбец, и т. д. Ссылка, возвращаемая функцией индекс, — это пересечение с номер_строки и номер_столбца.

  • Если для аргумента "номер_строки" или "номер_столбца" установлено значение 0 (ноль), функция индекс возвращает ссылку на весь столбец или строку соответственно.

  • номер_строки, номер_столбца и номер_области должны указывать на ячейку в ссылке. в противном случае функция индекс возвращает значение #REF! ошибка #ЧИСЛО!. Если аргумент "номер_строки" и "номер_столбца" опущен, функция индекс возвращает область в ссылке, указанную с помощью номер_области.

  • Результатом вычисления функции ИНДЕКС является ссылка, которая интерпретируется в качестве таковой другими функциями. В зависимости от формулы значение, возвращаемое функцией ИНДЕКС, может использоваться как ссылка или как значение. Например, формула ЯЧЕЙКА("ширина";ИНДЕКС(A1:B2;1;2)) эквивалентна формуле ЯЧЕЙКА("ширина";B1). Функция ЯЧЕЙКА использует значение, возвращаемое функцией ИНДЕКС, как ссылку. С другой стороны, такая формула, как 2*ИНДЕКС(A1:B2;1;2), преобразует значение, возвращаемое функцией ИНДЕКС, в число в ячейке B1.

Примеры

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД.

Фрукты

Цена

Количество

Яблоки

0,69 ₽

40

Бананы

0,34 ₽

38

Лимоны

0,55 ₽

15

Апельсины

0,25 ₽

24

Груши

0,59 ₽

40

Миндаль

2,80 ₽

10

Кешью

3,55 ₽

шестнадцат

Арахис

1,25 ₽

20

Грецкие орехи

1,75 ₽

12

Формула

Описание

Результат

=ИНДЕКС(A2:C6;2;3)

Пересечение второй строки и третьего столбца в диапазоне A2:C6, т. е. содержимое ячейки C3.

38

=ИНДЕКС((A1:C6;A8:C11);2;2;2)

Пересечение второй строки и второго столбца во второй области (A8:C11), т. е. содержимое ячейки B9.

1,25

=СУММ(ИНДЕКС(A1:C11;0;3;1))

Сумма третьего столбца в первой области диапазона (A1:C11) является суммой диапазона C1:C11.

216

=СУММ(B2:ИНДЕКС(A2:C6;5;2))

Сумма значений из диапазона, начинающегося с ячейки B2 и заканчивающегося пересечением пятой строки и второго столбца диапазона A2:A6, т. е. сумма значений из диапазона B2:B6.

2,42

К началу страницы

См. также

Функция ВПР

ПОИСКПОЗ (функция ПОИСКПОЗ)

ДВССЫЛ (функция ДВССЫЛ)

Использование формул массива: рекомендации и примеры

Функции ссылки и поиска (справка)

Примечание:  Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Была ли информация полезной? Для удобства также приводим ссылку на оригинал (на английском языке).

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×