Запись макросов в Visio

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Создайте макрос для автоматизации шагов или процессы, которые можно выполнить несколько раз. Команды для записи макросов, на вкладке "Разработчик".

Примечание : Макросы могут активировать оповещения системы безопасности, так как могут создаваться и использоваться в вредоносных целях. Дополнительные сведения о риске, связанном с макросами, а также о том, что делать с оповещениями безопасности, см. в статье Включение и отключение макросов в файлах Office.

  1. На вкладке Разработчик щелкните Запись макроса. (Если вы не видите вкладки "Разработчик", см. раздел "Отображение вкладки «Разработчик»" ниже.)

    Команды макросов

  2. В поле Имя макроса введите имя макроса.

  3. В поле Сочетание клавиш укажите клавиши, которые можно использовать с клавишей CONTROL для запуска макроса.

  4. В поле Сохранить в щелкните документ, в котором вы хотите сохранить макрос.

  5. В поле Описание введите описание макроса.

  6. Нажмите ОК, чтобы начать запись макроса.

  7. Выполните действия, которые вы хотите включить в макрос. На вкладке Разработчик при необходимости нажмите кнопку Пауза.

    При записи макроса вы можете щелкать мышью команды и параметры, а также работать с формами и объектами в рисунках.

  8. Чтобы остановить запись макроса, щелкните Остановить запись на вкладке Разработчик.

Вы также можете приостановить или возобновить запись макроса при помощи панели инструментов Запись.

Чтобы просмотреть получившийся код, в меню Инструменты наведите указатель мыши на пункт Макросы, нажмите кнопку Макросы, затем имя макроса, после чего выберите команду Изменить.

Отображение вкладки "Разработчик"

  1. На вкладке Файл выберите раздел Параметры.

  2. Выберите пункт Настройка ленты.

  3. В разделе Настройка ленты в списке Основные вкладки установите флажок Разработчик.

    Вкладка Разработчик появится в конце ленты напротив вкладки Файл.

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×