Запись макроса

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

При необходимости многократного выполнения одной и той же задачи в Microsoft Office Project эту задачу можно автоматизировать с помощью макроса. Макрос представляет собой набор макрокоманд и функций, которые сохраняются в модуль и которые можно запустить, чтобы выполнить ту или иную задачу.

  1. На вкладке Вид нажмите кнопку макросы и нажмите кнопку Запись макроса.

    (В Project 2007, в меню Сервис выберите пункт макрос и нажмите кнопку Запись макроса.)

  2. В поле Имя макроса введите имя для макрос.

    Имя макроса должно начинаться с буквы и может включать в себя буквы, цифры и знаки подчеркивания. Пробелы в имени макроса использовать нельзя, в качестве разделителя слов следует использовать знак подчеркивания.

  3. Чтобы можно было запускать макрос с помощью сочетание клавиш, введите букву или сочетание клавиш в поле Сочетание клавиш.

    Можно использовать комбинацию CTRL+буква (для строчных букв) или CTRL+SHIFT+буква (для прописных букв), где буква — любая клавиша на клавиатуре, соответствующая букве, но не цифре или специальному знаку. Нельзя использовать сочетание клавиш, которое уже используется в Microsoft Office Project.

  4. В списке Сохранить макрос в выберите расположение, где будет храниться макрос:

    • Чтобы макрос можно было запустить в любом проекте Project, выберите пункт глобальном файле.

    • Чтобы макрос можно было запустить только в текущем проекте, выберите пункт данном проекте.

  5. Чтобы добавить описание для макроса, введите описание в поле Описание.

  6. Если при записи макроса были выделены ячейки, макрос будет выделять тот же самый столбец (поле) каждый раз при запуске независимо от того, какая ячейка была выделена вначале, поскольку он использует абсолютные ссылки на столбцы. Если необходимо, чтобы макрос при запуске выделял столбцы независимо от расположения активной ячейки, установите переключатель Ссылки на столбцы в положение Относительные.

    При выделении строк макрос, напротив, будет при запуске выделять строки независимо от расположения активной ячейки, поскольку он использует относительные ссылки на строки. Если необходимо, чтобы макрос всегда выделял одну и ту же строку независимо от того, какая ячейка была выделена вначале, установите переключатель Ссылки на строки в положение Абсолютные (идентификаторы).

    Примечание: Эти параметры будут использоваться при записи макроса, пока они не будут изменены или работа программы Project не будет завершена.

  7. Нажмите кнопку ОК, а затем выполните все действия, которые необходимо записать.

  8. После завершения всех действий, которые нужно записать на вкладке " Вид " нажмите кнопку макросы и нажмите кнопку Остановить запись.

    (В Project 2007, в меню Сервис выберите пункт макрос и нажмите кнопку Остановить запись.)

Примечание по безопасности: Так как макросы могут содержать вирусы, соблюдайте осторожность при их запуске. Используйте следующие меры предосторожности: обновляйте антивирусную программу; задайте для макросов высокий уровень безопасности; снимите флажок Доверять всем установленным надстройкам и шаблонам; используйте цифровые подписи; ведите список надежных издателей.

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×