Добавление и удаление элементов раскрывающегося списка в Excel 2016 для Mac

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

После создания раскрывающегося списка вам может понадобиться добавить дополнительные элементы или удалить имеющиеся. Как вы это сделаете, зависит от способа создания списка. При создании раскрывающегося списка вы подключаете его к списку записей, которые используются для заполнения списка. Во время прикрепления этих записей к раскрывающемуся списку можно сослаться на имя, присвоенное списку ("именованный диапазон"), или ячейки, содержащие ваш список записей ("диапазон ячеек").

Изменение раскрывающегося списка, основанного на именованном диапазоне

  1. Откройте лист, содержащий именованный диапазон для раскрывающегося списка.

    Совет : Чтобы определить именованный диапазон, выделите его и найдите его имя в поле Имя.

    Поле "Имя" с именованным диапазоном

  2. Выполните одно из указанных ниже действий.

    • Чтобы добавить элемент, перейдите в конец списка и введите новый элемент.

    • Чтобы удалить элемент, удерживая нажатой клавишу CONTROL, щелкните нужную ячейку. Нажмите кнопку Удалить, а затем кнопку ОК, чтобы сдвинуть ячейки вверх.

  3. На вкладку Формулы щелкните Присвоить имя.

    Откройте вкладку "Формулы" и выберите команду "Присвоить имя"

  4. В окне Имя щелкните именованный диапазон, который нужно обновить.

  5. Справа от поля Выберите диапазон ячеек нажмите кнопку Изображение кнопки "Свернуть диалоговое окно" , чтобы свернуть диалоговое окно, а затем на своем листе выделите все ячейки, содержащие записи для вашего раскрывающегося списка.

    Кнопка "Свернуть диалоговое окно" в окне "Имя"

  6. Нажмите кнопку Кнопка "Развернуть" , чтобы развернуть диалоговое окно.

    Кнопка "Развернуть диалоговое окно" в окне "Имя"

  7. Нажмите кнопку ОК.

Изменение раскрывающегося списка, основанного на диапазоне ячеек

  1. Откройте лист, содержащий данные для раскрывающегося списка.

  2. Выполните любое из описанных ниже действий.

    • Чтобы добавить элемент, перейдите в конец списка и введите новый элемент.

    • Чтобы удалить элемент, удерживая нажатой клавишу CONTROL, щелкните нужную ячейку. Нажмите кнопку Удалить, а затем кнопку ОК, чтобы сдвинуть ячейки вверх.

  3. На листе с раскрывающимся списком выделите содержащую список ячейку.

  4. На вкладке Данные щелкните Проверка данных.

    Элемент "Проверка данных" на вкладке "Данные"

  5. На вкладке Настройки справа от поля Источник нажмите кнопку Изображение кнопки "Свернуть диалоговое окно" , чтобы свернуть диалоговое окно, а затем на листе с записями для раскрывающегося списка выберите все ячейки, содержащие эти записи.

    Кнопка "Свернуть диалоговое окно" в окне "Проверка данных"

  6. Нажмите кнопку Кнопка "Развернуть" , чтобы развернуть диалоговое окно.

    Кнопка "Развернуть диалоговое окно" в поле "Проверка данных"

  7. Чтобы обновить все ячейки, к которым применен один и тот же раскрывающийся список, установите флажок Распространить изменения на другие ячейки с тем же условием.

Работа с раскрывающимся списком

После обновления раскрывающегося списка убедитесь, что он работает так, как нужно. Например, проверьте, достаточно ли ширины ячеек для отображения ваших обновленных записей.

Если список записей для раскрывающегося списка находится на другом листе и вы хотите запретить пользователям его просмотр и изменение, скройте и защитите этот лист. Подробнее о защите листов читайте в статье Блокировка ячеек.

Если вам нужно удалить раскрывающийся список, см. эту статью.

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×