Добавление данных в фигуры

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Документ Microsoft Office Visio может быть гораздо более сложным, чем просто изображение ― он может быть хорошим способом систематизации данных и извлечения их в отчет.

В этой статье рассматриваются лучшие способы добавления данных вручную в выделенные фигуры, создание многократно используемого набора данных, который можно применить к нескольким фигурам документа, и добавление данных в образец фигуры.

Примечание : Следующие процедуры применяются как к Microsoft Office Visio профессиональный 2007, так и к Microsoft Office Visio стандартный 2007. При наличии установленной версии Visio Профессиональный можно автоматически импортировать данные, добавлять данные в фигуры и отображать данные в фигурах с помощью рисунков, связанных с данными. Для выяснения того, в какой версии Visio ведется работа, выберите пункт О средстве просмотра Microsoft Office Visio в меню Справка.

В этой статье

Добавление данных в выбранные фигуры

Создание многократно используемого набора полей данных

Добавление полей данных в образец фигуры

Добавление данных в выбранные фигуры

Для добавления данных в фигуры, уже находящиеся в документе, сначала добавьте в них поля данных, а затем — значения.

Совет : Следующая процедура является самым простым способом добавления данных в фигуры. Однако если требуется добавить одни и те же данные в несколько фигур, можно выбрать один из альтернативных вариантов, описанных в других разделах статьи.

Различие между полем данных и значением

  • Поле данных представляет собой подписанную ячейку, в которой могут храниться значения.

  • Значения — это текст или числа, находящиеся в ячейках таблицы базы данных, листа или, в данном случае, в фигуре.

Ниже приведен пример, показывающий окно Данные фигуры с полями и значениями для фигуры Решение из набора элементов Простая блок-схема. В этом случае полями являются «Почасовая ставка», «Необходимость сетевого доступа» и «Срок контракта», а значениями — «49,00р.», «Да» и «3 недели».

В окне "Данные фигуры" показаны поля и значения.

Добавление полей данных в выбранные фигуры

  1. Выделите фигуру или фигуры, в которые требуется добавить данные.

  2. Щелкните правой кнопкой мыши выделение, выберите в контекстном меню команду Данные, а затем — команду Данные фигуры.

  3. При выводе сообщения с вопросом об определении данных нажмите кнопку Да.

    Примечание : Если фигура уже содержит поля данных, сообщение будет выведено.

  4. В диалоговом окне Определение данных фигуры введите подпись для поля.

  5. Для создания другого поля нажмите кнопку Создать и повторите шаг 4.

  6. После определения всех полей данных нажмите кнопку ОК.

    Откроется диалоговое окно Данные фигуры, в котором будут отображены все поля.

Добавление значений в поля данных

  1. В меню Вид выберите команду Окно данных фигуры.

  2. Выделите фигуры, щелкая их по одной, и введите значения в поля данных в окне Данные фигуры.

    Примечание : В окне Окно данных фигуры будут отображены данные только для выделенной фигуры.

К началу страницы

Создание многократно используемого набора полей данных

Можно создать набор полей данных, применяемый к фигурам, которые уже находятся в документе или будут размещены там позднее.

  1. В меню Вид выберите команду Окно данных фигуры.

  2. Щелкните правой кнопкой мыши любую область окна Данные фигуры, а затем в контекстном меню выберите Наборы данных фигур.

  3. В окне Наборы данных фигур нажмите кнопку Добавить.

  4. В диалоговом окне Добавление набора данных фигуры введите имя для набора данных.

  5. Выберите Создать новый набор, а затем нажмите кнопку ОК.

    Набор данных появится в столбце Имя окна Наборы данных фигур.

    Примечание : Если требуется изменить существующий набор данных, можно выбрать другой параметр.

  6. В списке Имя выберите новый набор данных, а затем нажмите кнопку Определить.

  7. В диалоговом окне Определение данных фигуры введите подпись для поля.

  8. Для создания нового поля нажмите кнопку Создать и повторите шаг 7.

  9. После определения всех полей данных нажмите кнопку ОК.

  10. Для применения набора данных к выделенным фигурам документа выберите необходимый набор в окне Наборы данных фигур, а затем нажмите кнопку Применить.

    Совет : Для просмотра новых полей, примененных к одной из фигур, выделите эту фигуру, а затем посмотрите в окно Данные фигуры.

К началу страницы

Добавление полей данных в образец фигуры

Если при каждом использовании конкретной фигуры в нее требуется добавлять одинаковый набор данных, можно сэкономить время, добавив поля данных в копию образца этой фигуры. Например, в образец фигуры человека можно добавить такие поля данных, как имя и номер сотрудника.

  1. Щелкните правой кнопкой мыши образец, в который требуется добавить данные фигуры, выберите в контекстном меню команду Добавить к моим фигурам, а затем — команду Добавить в новый набор элементов.

    Примечание : Если пользовательский набор элементов уже создан, можно добавить в него образец вместо создания нового набора.

  2. В диалоговом окне Сохранить как введите имя для нового набора элементов, а затем нажмите кнопку Сохранить.

  3. В меню Файл выберите команду Фигуры, затем — команду Мои фигуры, а затем выберите набор элементов, содержащий скопированный образец.

  4. Щелкните правой кнопкой мыши заголовок нового набора элементов, а затем выберите в контекстном меню команду Изменить набор элементов.

  5. Щелкните правой кнопкой мыши фигуру, только что добавленную в набор элементов, выберите команду Изменить образец, а затем — команду Изменить фигуру образца.

  6. В окне редактирования фигуры щелкните правой кнопкой мыши фигуру, выберите в контекстном меню команду Данные, а затем — команду Данные фигуры.

  7. При выводе сообщения с вопросом об определении данных нажмите кнопку Да.

    Примечание : Если фигура уже содержит поля данных, сообщение не будет выведено, но необходимо будет продолжить выполнение оставшихся действий.

  8. В диалоговом окне Определение данных фигуры введите имя для поля и другие необходимые сведения. Например, может потребоваться изменить тип данных или добавить сообщение фигуры.

  9. Для создания другого поля нажмите кнопку Создать и повторите шаг 8.

  10. Закончив определение полей данных, нажмите кнопку ОК.

    Появится диалоговое окно Данные фигуры, в котором будут отображены поля.

    Примечание : Если в поля нужно внести изменения, нажмите кнопку Определить и повторите шаг 8.

  11. Для закрытия окна редактирования фигуры выберите команду Закрыть в меню Файл.

  12. При выводе сообщения с вопросом об обновлении фигуры нажмите кнопку Да.

  13. При выводе другого сообщения с вопросом о сохранении изменений в наборе элементов нажмите кнопку Да.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×