Добавление данных в фигуры

Документ Microsoft Visio 2010 может быть гораздо сложнее простого изображения. Его можно также использовать для организации и извлечения данных в отчете. Можно вручную добавлять в выбранные фигуры данные, создавать повторно используемые наборы данных, применяемые к нескольким фигурам в документе, и добавлять данные в образцы фигур.

Примечания : 

  • Описанные ниже процедуры применимы к Microsoft Visio стандартный 2010, Visio профессиональный 2010 и Microsoft Visio премиум 2010. Если на компьютере установлено приложение Visio профессиональный 2010 или Visio премиум 2010, вы можете автоматически импортировать данные из различных источников, добавлять их в фигуры и графически представлять свои данные. Чтобы узнать, какая версия приложения Visio установлена на компьютере, выберите на вкладке Файл пункт Справка и изучите раздел Активация продукта.

  • Дополнительные сведения об импорте данных из внешнего источника в приложение Visio профессиональный 2010 или Visio премиум 2010 см. в статье Импорт данных из Excel, SQL Server, с сайтов SharePoint и из других внешних источников.

  • Дополнительные сведения о применении рисунков, связанных с данными, к фигурам в приложении Visio профессиональный 2010 или Visio премиум 2010 см. в статье Использование рисунков, связанных с данными, для улучшения представления данных.

В этой статье

Добавление данных в выбранные фигуры

Добавление полей данных в выбранные фигуры

Добавление значений в поля данных

Создание повторно используемого набора полей данных

Добавление полей данных в образец фигуры

Удаление поля данных

Добавление данных в выбранные фигуры

Для добавления данных в фигуры, уже находящиеся в документе, сначала добавьте в них поля данных, а затем — значения.

Совет : Ниже описан самый простой способ добавления данных в фигуры. Тем не менее если вы хотите добавить те же данные к нескольким фигурам, рекомендуется Создание повторно используемого набора полей данных или Добавление полей данных в образец фигуры.

В чем разница между полем данных и значением?

Поле данных представляет собой подписанную ячейку, в которой могут храниться значения.

Значения — это текст или числа, находящиеся в ячейках таблицы базы данных, листа или, в данном случае, в фигуре.

Ниже приведен пример с окном Данные фигуры с полями и значениями для фигуры Решение из набора элементов Простая блок-схема. В этом случае полями являются "Почасовая ставка", "Необходимость сетевого доступа" и "Срок контракта", а значениями — "49,00 ₽", "ИСТИНА" и "3 недели".

Фигура решения с тремя полями и соответствующими значениями

Добавление полей данных в выбранные фигуры

  1. На вкладке Вид в группе Показать нажмите кнопку Области задач и выберите пункт Данные фигуры.
    Откроется область Данные фигуры.

  2. Выделите фигуру или фигуры, в которые требуется добавить данные.

  3. Щелкните правой кнопкой мыши выделенные фигуры и выберите в контекстном меню пункт Данные, а затем — Определить данные фигуры.

  4. Выберите в диалоговом окне Определение данных фигуры команду "Создать", а затем выполните одно из указанных ниже действий.

    • В поле Подпись введите имя нового поля.

    • В списке Тип выберите тип данных для нового поля.

    • В списке Формат выберите формат отображения данных.

    • Если вы хотите указать текст сообщения для пользователя, добавляющего данные в поле, введите его в поле Сообщение.

  5. Нажмите кнопку ОК.

К началу страницы

Добавление значений в поля данных

  1. На вкладке Вид в группе Показать нажмите кнопку Области задач и выберите пункт Данные фигуры.
    Откроется область Данные фигуры.

  2. Выделите фигуры, щелкая их по одной, и введите значения в поля данных в области Данные фигуры.

Примечание :  В области Данные фигуры отображаются данные только для выделенной фигуры.

К началу страницы

Создание повторно используемого набора полей данных

Можно создать набор полей данных для применения к фигурам, которые уже находятся в документе или будут размещены там позднее.

  1. На вкладке Вид в группе Показать нажмите кнопку Области задач и выберите пункт Данные фигуры.
    Откроется область Данные фигуры.

  2. Щелкните правой кнопкой мыши область Данные фигуры, а затем в контекстном меню выберите Наборы данных фигур.

  3. В области Наборы данных фигур нажмите Добавить.

  4. В диалоговом окне Добавление набора данных фигуры введите имя набора данных.

  5. Выберите команду Создать новый набор и нажмите кнопку ОК.
    Набор данных появится в области Наборы данных фигур в столбце Имя.

  6. В списке Имя выберите новый набор данных, а затем нажмите кнопку Определить.

  7. В диалоговом окне Определение данных фигуры укажите поля для набора данных фигуры. Дополнительные сведения об определении полей данных см. в статье Добавление полей данных в выбранные фигуры.

  8. Чтобы создать новое поле, нажмите кнопку Создать и повторите предыдущее действие.

  9. После определения всех полей данных нажмите кнопку ОК.

  10. Чтобы применить набор данных к выделенным фигурам документа, выберите нужный набор в области Наборы данных фигур и нажмите кнопку Применить.

Примечание :  Чтобы просмотреть новые поля, примененные к одной из фигур, выделите ее и откройте область Данные фигуры.

К началу страницы

Добавление полей данных в образец фигуры

Если при каждом использовании конкретной фигуры в нее требуется добавлять одинаковый набор данных, можно сэкономить время, добавив поля данных в копию образец фигуры. Например, в образец фигуры, представляющей человека, можно добавить такие поля данных, как имя и номер сотрудника.

  1. На вкладке Вид в группе Показать нажмите кнопку Области задач и выберите пункт Данные фигуры.
    Откроется область Данные фигуры.

  2. Щелкните правой кнопкой мыши образец фигуры, в который нужно добавить данные, выберите в контекстном меню пункт Добавить к моим фигурам и выполните одно из указанных ниже действий.

    • Чтобы добавить образец фигуры в новый набор элементов, выберите пункт Добавить в новый набор элементов.

    • Чтобы добавить образец фигуры в существующий пользовательский набор элементов, выберите пункт Добавить в существующий набор элементов.

  3. В диалоговом окне Сохранить как введите имя нового набора элементов, а затем нажмите кнопку Сохранить.

  4. В окне Фигуры наведите указатель мыши на элемент Дополнительные фигуры и выберите пункт Мои фигуры, а затем — набор элементов, содержащий скопированный образец фигуры.

  5. Щелкните правой кнопкой мыши заголовок нового набора элементов и выберите в контекстном меню пункт Изменить набор элементов.

  6. Щелкните правой кнопкой мыши фигуру, добавленную в набор элементов, и выберите пункт Изменить образец, а затем — Изменить фигуру образца.

  7. В окне редактирования фигуры щелкните правой кнопкой мыши фигуру и выберите в контекстном меню пункт Данные, а затем — Определить данные фигуры.

  8. В диалоговом окне Определение данных фигуры введите имя для поля и другие необходимые сведения. Например, может потребоваться изменить тип данных или добавить сообщение фигуры.

  9. Чтобы создать новое поле, нажмите кнопку Создать и повторите предыдущее действие.

  10. Завершив определение полей данных, нажмите кнопку ОК.

  11. Чтобы закрыть окно редактирования образца фигуры, на вкладке Вид в группе Окно выберите пункт Каскад, выделите окно образца фигуры и нажмите кнопку Закрыть.

  12. В ответ на запрос подтверждения обновления фигуры нажмите кнопку Да.

  13. В окне Фигуры щелкните набор элементов правой кнопкой мыши и выберите команду Сохранить.

К началу страницы

Удаление поля данных

  1. На вкладке Вид в группе Показать нажмите кнопку Области задач и выберите пункт Данные фигуры.
    Откроется область Данные фигуры.

  2. Выделите фигуру с полем данных, которое нужно удалить.

  3. Щелкните правой кнопкой мыши в области Данные фигуры и выберите в контекстном меню пункт Определить данные фигуры.

  4. В диалоговом окне Определение данных фигуры в разделе Свойства выберите поле данных, которое нужно удалить, и нажмите кнопку Удалить.

К началу страницы

Примечания : 

  • Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

  • Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала. Вместе с другими участниками сообщества Майкрософт вы можете улучшить эту статью с помощью Community Translation Framework (CTF). Просто наведите указатель мыши на предложение в статье и выберите команду "УЛУЧШИТЬ ПЕРЕВОД" в мини-приложении CTF. Для получения дополнительных сведений о CTF щелкните здесь. Используя CTF, вы соглашаетесь с нашими условиями предоставления услуг.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×