В некоторых ячейках вместо содержимого отображается значение #ПУСТО!

Причина Формула содержит недопустимый оператор диапазона.

Решение    Чтобы задать диапазон соседних ячеек, введите двоеточие (:) между ссылкой на первую и последнюю ячейки диапазона.

Например, формула =СУММ(A1:A10) ссылается на диапазон ячеек с A1 по A10.

Решение    Чтобы задать два непересекающихся диапазона, используйте оператор объединения — запятую (,).

Так, если формула суммирует два диапазона, убедитесь, что их разделяет запятая, например: =СУММ(A1:A10,C1:C10).

Причина Формула содержит ссылки на именованные диапазоны, которые не пересекаются.

Решение    Измените ссылки на диапазоны, чтобы они пересекались.

  1. На вкладке Формулыв разделе Функция выберите пункт Построитель формул.

    Вкладка "Формулы", группа "Функция"

  2. В разделе Аргументы построителя формул щелкните любой аргумент. Все ячейки и диапазоны ячеек, на которые ссылается формула, будут выделены в Excel другим цветом.

    Цветовые коды показывают, что формула в ячейке D9 ссылается на ячейки B9 и C9

    Ячейки, содержащие выделенные цветом ссылки на диапазоны

  3. Выполните одно из указанных ниже действий.

Чтобы

Выполните указанные ниже действия

Перетаскивание ссылки на ячейку или диапазон в другую ячейку или диапазон

Перетащите обозначенную цветом границу ячейки или диапазона на новую ячейку или диапазон.

Увеличение и уменьшение числа ячеек в ссылке

Для изменения диапазона используйте маркер перетаскивания в нижнем правом углу границы.

Ввод новой ссылки

В конструкторе формул выделите аргумент, содержащий ссылку, и введите новую ссылку.

  1. Нажмите клавишу ВВОД .

Причина Формула содержит ссылки на диапазоны без имени, которые не пересекаются.

Решение    Измените ссылки на диапазоны, чтобы они пересекались.

  1. На вкладке Формулыв разделе Функция выберите пункт Построитель формул.

    Вкладка "Формулы", группа "Функция"

  2. В разделе Аргументы построителя формул щелкните любой аргумент. Все ячейки и диапазоны ячеек, на которые ссылается формула, будут выделены в Excel другим цветом.

    Цветовые коды показывают, что формула в ячейке D9 ссылается на ячейки B9 и C9

    Ячейки, содержащие выделенные цветом ссылки на диапазоны

  3. Выполните одно из указанных ниже действий.

Чтобы

Выполните указанные ниже действия

Замена ссылок именами

Выделите диапазон ячеек, содержащих формулы, в которых нужно выполнить замену.

Увеличение и уменьшение числа ячеек в ссылке

Для изменения диапазона используйте маркер перетаскивания в нижнем правом углу границы.

Изменение ссылок на имена во всех формулах на листе

Выделите на листе любую ячейку.

  1. Выберите в меню Вставка пункт Имя и нажмите кнопку Применить.

  2. В поле Применить имена выберите одно или несколько имен.

См. также

Скрытие значений и индикаторов ошибок

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×