В некоторых ячейках вместо содержимого отображается значение #ИМЯ!

Причина В формуле используется пользовательская функция, которая недоступна.

Решение    Убедитесь, что книга, содержащая пользовательскую функцию, открыта и что эта функция работает правильно.

  1. Выделите ячейку.

  2. На вкладке Формулыв разделе Функция выберите пункт Построитель формул.

    Вкладка "Формулы", группа "Функция"

  3. Измените формулу в разделе Аргументы окна "Построитель формул".

    Примечание : Некоторые встроенные функции Excel для Windows недоступны в Excel для Mac. Дополнительные сведения см. в статье Моя функция не работает

Причина Формула содержит ссылку на именованную ячейку или диапазон, которые не определены.

Решение    Убедитесь, что именованная ячейка или диапазон определены.

  1. Выберите в меню Вставка пункт Имя и нажмите кнопку Определить.

  2. Если именованная ячейка или диапазон отсутствуют в списке, добавьте ее с помощью кнопки Определить.

Причина Формула содержит неправильное имя функции, именованную ячейку или именованный диапазон.

Решение    Исправьте имя в формуле.

  1. Выделите ячейку.

  2. На вкладке Формулыв разделе Функция выберите пункт Построитель формул.

    Вкладка "Формулы", группа "Функция"

  3. Измените формулу в разделе Аргументы окна "Построитель формул".

    Примечание : Некоторые встроенные функции Excel для Windows недоступны в Excel для Mac. Дополнительные сведения см. в статье Моя функция не работает

Причина Формула содержит неправильно введенный текст.

Решение    Заключите текст в формуле в двойные кавычки ("").

  1. Выделите ячейку.

  2. На вкладке Формулыв разделе Функция выберите пункт Построитель формул.

    Вкладка "Формулы", группа "Функция"

  3. Измените формулу в разделе Аргументы окна "Построитель формул".

Причина В ссылке на диапазон отсутствует двоеточие (:).

Решение    Убедитесь, что в формуле во всех ссылках на диапазоны есть двоеточия.

Например, =СУММ(A1:C10).

Причина Формула содержит ссылку на другую книгу или лист с именем, содержащим пробел или символ не из алфавита, но ссылка не заключена в одинарные кавычки (').

Решение    Заключите имя книги или листа в формуле в одинарные кавычки (').

  1. Выделите ячейку.

  2. На вкладке Формулыв разделе Функция выберите пункт Построитель формул.

    Вкладка "Формулы", группа "Функция"

  3. Измените формулу в разделе Аргументы окна "Построитель формул".

Причина Формула содержит ссылку на заголовок (подпись) строки или столбца, которые не поддерживается в Excel 2008 для Mac и Excel 2007 для Windows.

Решение    Разрешите приложению Excel заменить ссылки на подписи стандартными ссылками на ячейки.

При открытии книги, содержащей формулу с подписями, приложение Excel предлагает заменить ссылки на подписи стандартными ссылками на ячейки. Например, если книга содержит столбец данных с заголовком "Продажи", включающий ячейки с A2 по A10, и в книге есть формула =СУММ(Продажи), Excel заменит ссылку на ячейку "Продажи" стандартной ссылкой на ячейки "A2:A10", а затем пересчитает формулу. Если разрешить приложению Excel внести эти изменения, после сохранения книги их нельзя будет отменить.

При создании формул можно также использовать более понятные имена. Дополнительные сведения о создании имен и формул с именами см. в разделе Использование имен в формулах.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×