Выполнение слияния

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Слияние используется тогда, когда необходимо создать много почти одинаковых документов, содержащих небольшой объем уникальной информации. Например, слияние можно использовать при создании публикаций, включающих личные данные пользователей. Можно также при помощи слияния создать объявление о новом товаре, чтобы разослать его ста основным клиентам. Текст публикации везде будет одинаковым, а имена и адреса клиентов — разными.

Для выполнения пошаговой процедуры слияния воспользуйтесь областью задач Слияние. Чтобы открыть область задач Слияние в новой или существующей публикации, в меню Сервис выберите пункт Почтовые сообщения и каталоги, а затем — Слияние.

В этой статье:

Создание или подключение к списку получателей

Подготовка публикации

Создание объединенной публикации

Отмена слияния

Создание списка получателей и подключение к нему

Чтобы выполнить слияние, необходимо открыть новую или существующую публикацию, а затем подключиться к источнику данных — файлу с уникальными сведениями, которые требуется включить в публикацию. Файл может содержать список имен и адресов, сведения о товаре или изображения. Файлы данных могут иметь различный формат, например:

  • Список контактов Microsoft Office Outlook

  • листы Microsoft Office Excel

  • таблицы Microsoft Office Word

  • Таблицы баз данных Microsoft Office Access

  • Текстовые файлы, в которых столбцы разделяются знаками табуляции или запятыми, а строки — знаками абзаца.

Можно подключиться к существующему списку или источнику данных, а также создать новый список. Если требуется использовать определенные элементы списка, можно задать условие для фильтрации списка. Можно также отсортировать элементы списка в алфавитном порядке.

Примечание : Если вы хотите добавить изображения на страницы публикации с помощью слияния, источник данных должен содержать имена их файлов и пути к ним. Не включайте сами рисунки или изображения в источник данных.

Использование существующего списка

  1. В группе Создание списка получателей выберите параметр Существующий список, а затем щелкните ссылку Далее. Создание или выбор списка получателей.

    По умолчанию источники данных Microsoft Publisher хранятся в папке Мои источники данных. Возможно, потребуется открыть другое расположение источника данных.

  2. В диалоговом окне Выбор источника данных укажите источник данных.

  3. Нажмите кнопку Открыть.

    В зависимости от типа выбранного источника данных могут появиться другие диалоговые окна, в которых потребуется ввести дополнительные сведения.

    Например, если источником данных является книга Microsoft Office Excel, содержащая несколько листов с данными, необходимо выбрать нужный лист и нажать кнопку ОК.

Выбор из контактов Outlook

  1. В группе Создание списка получателей выберите параметр Выбрать из контактов Outlook, а затем щелкните ссылку Далее. Создание или выбор списка получателей.

  2. Если появится сообщение о необходимости выбрать профиль электронной почты, выберите нужный профиль, а затем нажмите кнопку ОК.

  3. В диалоговом окне Выбор контактов выберите нужный список контактов, а затем нажмите кнопку ОК.

    Все контакты папки отображаются в диалоговом окне Получатели слияния; список получателей можно отфильтровать и отсортировать для включения в слияние.

Создание нового списка адресов

Если список получателей отсутствует, можно создать новый список получателей.

  1. В группе Создание списка получателей выберите параметр Ввести список, а затем щелкните ссылку Далее. Создание или выбор списка получателей.

  2. В диалоговом окне Новый список адресов введите данные для первой записи в соответствующие поля. Заполнять все поля необязательно.

  3. Когда будут введены все данные, относящиеся к первой записи списка, нажмите кнопку Создать запись.

  4. Добавьте другие необходимые записи, повторяя шаги 2 и 3, а затем нажмите кнопку ОК.

  5. В диалоговом окне Сохранение списка адресов введите название списка адресатов в поле Имя файла и выберите папку, в которой требуется сохранить список.

    По умолчанию Microsoft Publisher сохраняет список адресов в папке Мои источники данных. Список адресов рекомендуется хранить в этой папке, поскольку именно в ней Publisher по умолчанию выполняет поиск источников данных.

    Все контакты нового списка отображаются в диалоговом окне Получатели слияния; список получателей можно отфильтровать и отсортировать для включения в слияние.

Выбор получателей

В диалоговом окне Получатели слияния установите флажки для получателей, которых требуется включить в список, и снимите флажки для получателей, которых не требуется включать.

Если требуется использовать не все имеющиеся в списке записи, а только некоторые, можно отфильтровать список по заданному полю или по условию. После выполнения фильтрации можно добавить или исключить записи при помощи флажков.

Фильтрация элементов в списке

  1. Щелкните стрелку рядом с заголовком столбца необходимого элемента, по которому будет выполняться сортировка.

  2. Выберите одно их следующих действий:

    • (Пустые) — отображение всех записей с соответствующим пустым полем.

    • (Непустые) — отображение всех записей с соответствующим непустым полем.

    • Выберите пункт (Дополнительно), чтобы открыть диалоговое окно Фильтр и сортировка, в котором можно выполнить фильтрацию по нескольким условиям. В диалоговом окне Получатели слияния можно также щелкнуть ссылку Фильтр в группе Уточнить список получателей, чтобы открыть диалоговое окно Фильтр и сортировка.

      Совет : Если источник данных содержит записи с одинаковыми сведениями, а столбец содержит не более десяти уникальных значений, можно выполнить отбор по конкретным сведениям. Например, при наличии нескольких адресов, в которых в качестве страны или региона указана Австралия, можно выполнить отбор по слову Австралия.

      В диалоговом окне Получатели слияния отображаются только отмеченные записи. Чтобы снова вывести все записи, выберите команду (Все).

Чтобы отобразить элементы в алфавитном порядке, можно выполнить сортировку списка.

Сортировка элементов в списке

  • В диалоговом окне Получатели слияния щелкните заголовок того элемента, по которому требуется выполнить сортировку.

    Например, чтобы отсортировать список по фамилии, щелкните заголовок столбца Фамилия.

  • Чтобы быстро выбрать или отменить все элементы, установите или снимите флажок заголовка столбца.

  • Чтобы отсортировать список по нескольким условиям, в диалоговом окне щелкните Получатели слияния в группе Уточнить список получателей ссылку Сортировка. В диалоговом окне Фильтр и сортировка выберите условия сортировки.

Нажмите кнопку ОК, чтобы вернуться в область задач Слияние.

К началу страницы

Подготовка публикации

С помощью слияния можно составить документ, содержащий сведения, общие для всех копий, а также несколько местозаполнителей для сведений, уникальных для каждой копии. После создания публикации вставьте в нее текст, который должен присутствовать во всех версиях публикации слияния (приветствие или местозаполнители для уникальных сведений, например, для адреса).

Если это не сделано ранее, вставьте текстовое поле и введите текст, который должен отображаться во всех версиях публикации слияния и добавьте местозаполнители для уникальных данных.

Добавление текстового поля

  1. На панели инструментов объекты щелкните Текстовое поле Изображение кнопки .

  2. В публикации установите указатель в то место, где должен находиться один из углов текстовой рамки, и перетаскивайте его по диагонали, пока не получится рамка нужного размера.

Ввод текста, общего для всех версий публикации слияния

  • Щелкните текстовую рамку и введите текст, который будет отображаться в каждой версии публикации слияния.

Вставка полей данных в публикацию

  1. В публикации слияния щелкните внутри текстового поля, в которое следует вставить поле данных.

  2. Вставьте один из следующих вариантов.

    Блок адресов с именем, почтовым адресом и прочими сведениями

    1. В области задач Слияние (Этап 2. Подготовка публикации) в группе Другие элементы выберите пункт Блок адреса.

    2. В диалоговом окне Вставка блока адреса выберите нужные элементы адреса и нажмите кнопку ОК.

      Примечание : Если имена поле данных в источнике данных не совпадают с именами полей адреса, используемыми в Microsoft Publisher, нажмите в диалоговом окне Вставить блок адреса кнопку Подбор полей. В раскрывающихся списках диалогового окна Подбор полей выберите поля из источника данных, соответствующие полям Microsoft Publisher.

    Строка приветствия

    1. В области задач Слияние (Шаг 2. Подготовка публикации) в группе Другие элементы щелкните ссылку Строка приветствия.

    2. В диалоговом окне Строка приветствия выберите формат строки приветствия, включающий обращение, формат имени и последующую пунктуацию.

    3. Выберите текст, который будет отображаться в тех случаях, когда Microsoft Publisher не удается правильно определить имя получателя (например, если в источнике данных не указано ни имя ни фамилия получателя, а содержится только название организации).

    4. Нажмите кнопку ОК.

      Примечание : Если названия полей данных в источнике данных не совпадают с названиями полей строки приветствия, используемых в Microsoft Publisher, в диалоговом окне Строка приветствия нажмите кнопку Подбор полей. В диалоговом окне Подбор полей в раскрывающемся списке выберите поля из источника данных, соответствующие полям в Microsoft Publisher.

    Поля адреса

    1. В области задач Слияние (Шаг 2. Подготовка публикации) в группе Другие элементы щелкните ссылку Поля адреса.

    2. В диалоговом окне Вставка поля адреса щелкните каждый элемент адреса, который требуется включить.

      Примечание : Если имена полей в источниках данных не совпадают с именами полей адреса в Microsoft Publisher, нажмите в диалоговом окне Вставка поля адреса кнопку Подбор полей. В раскрывающихся списках диалогового окна Подбор полей выберите поля источников данных, соответствующие полям Microsoft Publisher.

    Другие поля данных

    В области задач Слияние (Шаг 2. Подготовка публикации) перетащите поле из группы Подготовка публикации в текстовое поле, созданное в публикации.

Форматирование полей данных

Поля данных, а также любой другой добавленный текст (например, приветствие Привет! или обращение Уважаемый) можно отформатировать, чтобы изменить внешний вид объединенных данных. Для форматирования объединенных данных необходимо отформатировать поля данных в публикации слияния.

  1. В публикации слияния выберите поле, содержащее данные, которые требуется добавить.

  2. В меню Формат выберите команду Шрифт и установите требуемые параметры.

Предварительный просмотр данных получателя в полях данных публикации

Теперь можно посмотреть, как будут выглядеть в публикации объединенные поля с реальными данными.

  1. Чтобы просмотреть публикацию, выполните одно из следующих действий:

    • Чтобы просмотреть элементы в порядке, нажмите кнопку Кнопка ''Вперед'' кнопок навигации Кнопка «Назад» чтобы увидеть, как будет выглядеть каждая запись в объединенной публикации.

      Поля слияния заполняются данными из первой записи источника данных. Записи источника данных невозможно редактировать на страницах публикации, но можно форматировать, перемещать и удалять поля данных.

    • Чтобы найти и просмотреть определенную запись в источнике данных, щелкните ссылку Найти получателя и введите параметры поиска в диалоговое окно Поиск элемента.

  2. При необходимости внесите изменения в список получателей. Выполните одно из следующих действий:

    • Для исключения определенного получателя из списка рассылки выберите команду Исключить получателя.

    • Чтобы изменить список получателей, щелкните ссылку Изменить список и внесите изменения в диалоговом окне Получатели слияния.

  3. После завершения работы с публикацией и вставки всех объединенных полей выберите в меню Файл команду Сохранить как. В поле Имя файла введите имя публикации и нажмите кнопку Сохранить.

  4. Щелкните ссылку Далее. Создание объединенных публикаций.

К началу страницы

Создание объединенной публикации

В области задач Слияние в группе Создание объединенных публикаций можно выполнить следующие действия:

  • Напечатать публикацию слияния (например, для отправки по почте).

  • Просмотреть публикацию слияния (чтобы до вывода на печать всех версий увидеть, как будет выглядеть публикация и решить потенциальные проблемы).

  • Сохранить публикацию слияния для дальнейшего использования.

  • Добавить страницы слияния в другую публикацию.

Предварительный просмотр публикации слияния

  • Щелкните ссылку Предварительный просмотр.

Печать публикации слияния

  1. Щелкните ссылку Печать.

  2. В диалоговом окне Печать выберите нужные параметры и нажмите кнопку ОК.

    Важно : Чтобы напечатать разные наборы данных слияния (например, разные имена и адреса) на каждом листе бумаги, выберите в разделе Параметры печати параметр Несколько страниц на листе. Если выбран параметр Несколько копий на листе, на каждом листе бумаги будут напечатаны несколько копий одних и тех же данных.

    Диалоговое окно печати с параметром "Несколько страниц на листе"

Сохранение публикации слияния для дальнейшего использования

Если вы хотите изменить объединенные страницы, сохранить их для дальнейшего использования или распечатать их позже, можно собрать и сохранить все объединенные страницы в виде одной объединенной публикации, содержащей фактические данные, например имена и адреса — вместо полей слияния.

  1. Щелкните ссылку Слияние в новую публикацию.

    С помощью объединенных страниц будет создана новая публикация.

  2. В новой публикации в области задач Слияние щелкните ссылку Сохранение публикации. Введите имя новой публикации в поле Имя файла, а затем нажмите кнопку Сохранить.

Добавление объединенных страниц к существующей публикации

Если планируется добавить объединенные страницы в конец существующей публикации, публикация слияния должна соответствовать существующей публикации по следующим параметрам:

  • размеры страницы (высота и ширина);

  • режим отображения страниц (одна или две страницы);

  • тип публикации (для Интернета или для печати);

  • порядок страниц (слева направо или справа налево).

В Microsoft Publisher можно добавить объединенные страницы к новой или существующей публикации, но не к открытой публикации. Публикацию, к которой требуется добавить страницы, необходимо сохранить и закрыть перед завершением слияния.

  1. Щелкните ссылку Добавить в публикацию.

  2. В диалоговом окне Открыть публикацию укажите публикацию, к которой требуется добавить объединенные страницы, и нажмите кнопку Открыть.

    Publisher добавит объединенные страницы к этой публикации.

  3. В существующей публикации в области задач Слияние щелкните ссылку Сохранение публикации, чтобы сохранить обновления.

Сохранение публикации слияния

Чтобы сохранить также публикацию, содержащую поля слияния, можно вернуться назад, изменить поля слияния и создать новую объединенную публикацию, содержащую новые поля слияния или обновленный список получателей. Чтобы сохранить публикацию слияния, необходимо выполнить следующие действия.

  1. Откройте публикацию слияния.

  2. В меню Файл выберите команду Сохранить.

  3. Присвойте публикации имя и нажмите кнопку Сохранить.

К началу страницы

Отмена слияния

Можно отменить слияние, отключив публикацию слияния или шаблон объединения в каталог от соответствующего источник данных.

  1. В меню Сервис выберите пункт Почтовые сообщения и каталоги, а затем — команду Отменить слияние.

  2. В появившемся запросе на подтверждение отмены слияния нажмите кнопку Да.

Публикация будет отсоединена от источника данных.

Примечание : При отмене слияния все поля, кроме полей адреса, полей адреса, строк приветствий и блоков адресов, преобразуются в обычный текст.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×