Вставка таблицы в форму

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Таблица — это простой режим отображения данных, упорядоченных в виде строк и столбцов. Если дважды щелкнуть таблицу базы данных в области переходов, приложение Microsoft Office Access 2007 отобразит эту таблицу в режиме таблицы. Благодаря компактному представлению данных таблицы удобно использовать в качестве подчиненных форм для отображения данных со стороны «многие» отношение "один-ко-многим". В данной статье описано, как в программе Office Access 2007 можно к формам добавлять таблицы.

Предполагаемое действие:

Просмотрите пример таблицы в форме

Установить связи между таблицами

Создание формы, содержащей таблицы данных с помощью средства "форма"

Создание формы, содержащей таблицы, используя режим макета

Вставка таблицы в существующую форму с помощью режим макета

Вставка таблицы в существующую форму в режиме конструктора

О различиях между разделенной формы и формы, содержащей таблицы данных

Пример таблицы в форме

Предположим, требуется создать форму, отображающую данные о типах товаров, а также перечень самих товаров по каждому типу. Данные в таблице «Типы» представляют сторону «один» этого отношения, а данные в таблице «Товары» — сторону «многие». К каждому типу может принадлежать несколько товаров.

Форма, содержащая подчиненную форму

1. В главной форме отображаются данные на стороне отношения «один».

2. В таблице отображаются данные на стороне отношения «многие».

К началу страницы

Создание связей между таблицами

Прежде чем начинать разрабатывать форму, содержащую таблицу, следует проверить связи между таблицами и добавить недостающие связи. Это позволит приложению Access автоматически создать связи между таблицами и главными формами. Для просмотра, добавления или изменения связей между таблицами в базе данных, на вкладке Дополнительные инструменты в группе Анализ нажмите кнопку Связи. Для получения дополнительных сведений о создании связей воспользуйтесь ссылками в разделе См. также этой статьи.

К началу страницы

Создание формы, содержащей таблицу, при помощи инструмента «Простая форма»

При использовании инструмента «Простая форма» для создания формы на основе таблицы, являющейся стороной «один» отношения «один-ко-многим», автоматически вставляется таблица.

Например, при соблюдении всех перечисленных ниже условий будет вставлена таблица, отображающая все заказы для каждого клиента:

  • Создана простая форма на основе таблицы «Клиенты».

  • Задано отношение «один-ко-многим» для таблицы «Заказы», определяющее одну запись в таблице «Клиенты», которая может быть связана с несколькими записями в таблице «Заказы».

  • Таблица «Клиенты» не является стороной «один» никакого другого отношения «один-ко-многим».

  • В области переходов щелкните таблицу, участвующую в отношении «один-ко-многим» на стороне «один».

  • На вкладке Создание в группе формы нажмите кнопку форма. Изображение кнопки

Будет создана форма с таблицей, расположенной в нижней части формы. Если таблица не создана, значит, либо данная таблица не является частью ни одного отношения «один-ко-многим», либо она является частью нескольких отношений «один-ко-многим».

Примечания : 

  • Помимо создания главной формы, этот процесс не создает никаких других объектов формы. Эта таблица является непосредственным представлением таблицы данных.

  • Скрытие столбца в таблице    Щелкните правой кнопкой мыши столбец и выберите команду Скрыть столбец. Этот параметр сохраняется; если сохранить и закрыть форму, а затем вновь открыть ее, столбец останется скрытым.

  • Восстановление скрытого столбца таблицы    Щелкните правой кнопкой мыши любой заголовок столбца в таблице и выберите команду Отобразить столбцы. Установите флажок рядом с каждым столбцом, который требуется восстановить, и нажмите кнопку Закрыть.

К началу страницы

Создание формы, содержащей таблицу, в режиме макета

Если отношения между таблицами в базе данных уже заданы, можно быстро создать форму, содержащую таблицу, воспользовавшись режимом макета. При добавлении поля из стороны «многие» в форму, основанную на стороне «один», автоматически создается новая таблица, в которой будут отображаться связанные записи.

  1. На вкладке Создание в группе формы нажмите кнопку Пустая форма. Изображение кнопки

    Будет открыта пустая форма в режиме макета, и слева от формы будет отображаться область Список полей.

    Примечание : Если вы случайно закрыли область Список полей, ее можно открыть заново, выполнив одно из следующих действий:

    • Нажмите клавиши ALT+F8.

      -или-

      На вкладке Формат в группе элементы управления нажмите кнопку Добавить существующие поля. Изображение кнопки

  2. Щелкните знак плюс (+) рядом с таблицей на стороне «один» отношения «один ко многим», а затем перетащите первое нужное поле в форму.

    После того как поле будет помещено в форму, обратите внимание, что в области Список полей таблицы отражены по разделам: Поля, доступные в данном представлении и ниже Доступные поля в связанной таблице. В нижней части области Список полей в разделе Доступные поля в другой таблице перечислены все остальные таблицы, не связанные напрямую с главной таблицей.

  3. Перетащите из раздела Поля, доступные в данном представлении другие требуемые поля в главную форму.

  4. Перетащите из раздела Доступные поля в связанной таблице в форму первое поле, которое нужно вставить в таблицу. Будет создана таблица с добавленным в нее полем.

  5. Чтобы добавить дополнительные поля в новую таблицу, нужно сначала выбрать таблицу щелчком. Заметьте, что в Access область Список полей перестраивается таким образом, что доступные для добавления в таблицу поля находятся сверху. Перетащите из раздела Поля, доступные в данном представлении на таблицу любые другие поля, которые нужно добавить в таблицу. При перемещении каждого поля в таблицу отображается линия вставки, указывающая место, куда будет вставлено поле после отпускания кнопки мыши.

  6. Продолжайте добавлять поля в главную форму или таблицу: сначала выбирайте щелчком главную форму или таблицу, а затем перетаскивайте поле из области Список полей.

В разделе Доступные поля в других таблицах из области Список полей есть таблицы, которые непосредственно не связаны с таблицу или запрос, основанный на выбранной формы или таблицы. Если в окне схемы данных определены все связи допустимой таблицы, поля в разделе Доступные поля в других таблицах не являются скорее всего, будут недоступны для формы, которая выполняется построение. При перетаскивании поля из этого раздела в форме Access отображается диалоговое окно Выбор связи. Необходимо ввести одно или несколько полей, которые связаны друг с другом двух таблиц, перед началом работы. После этого области Список полей утратит Отсортированная разделы согласно предопределенных связей. Это может быть наиболее удобно нажмите кнопку Отмена в этом диалоговом окне и вместо повторную проверку межтабличных связей. Дополнительные сведения о связях читайте в статье Создание, изменение или удаление связи.

К началу страницы

Вставка таблицы в существующую форму с использованием режима макета

Если отношения между таблицами в базе данных уже заданы, можно быстро добавить таблицу в существующую форму, воспользовавшись режимом макета. При добавлении поля из стороны «многие» в форму, основанную на стороне «один», автоматически создается таблица, в которой будут отображаться связанные записи.

  1. Откройте существующую форму в режиме макета: щелкните ее правой кнопкой мыши в области переходов и выберите команду Режим макета в контекстном меню.

    Если область Список полей не отображается:

    • Нажмите клавиши ALT+F8.

      -или-

      На вкладке Формат в группе элементы управления нажмите кнопку Добавить существующие поля. Изображение кнопки

      Обратите внимание, что в области Список полей таблицы отражены по разделам: Поля, доступные в данном представлении и ниже Доступные поля в связанной таблице. В нижней части области Список полей в разделе Доступные поля в другой таблице перечислены все остальные таблицы, не связанные напрямую с главной таблицей.

  2. В разделе Доступные поля в связанной таблице разверните таблицу, содержащую первое поле, которое нужно вставить в новую таблицу, а затем перетащите поле в форму. Будет создана новая таблица с добавленным к ней полем.

  3. Чтобы добавить дополнительные поля в новую таблицу, сначала нужно выбрать таблицу щелчком. Заметьте, что в Access область Список полей перестраивается таким образом, что доступные для добавления в таблицу поля находятся сверху. Перетащите из раздела Поля, доступные в данном представлении на таблицу любые другие поля, которые нужно добавить в таблицу. При перемещении каждого поля в таблицу отображается линия вставки, указывающая место, куда будет вставлено поле после отпускания кнопки мыши.

  4. Продолжайте добавлять поля в главную форму или таблицу: сначала выбирайте щелчком главную форму или таблицу, а затем перетаскивайте поле из области Список полей.

В разделе Доступные поля в других таблицах из области Список полей есть таблицы, которые не связаны непосредственно в таблицу или запрос, на основе выбранной формы. Если в окне схемы данных определены все связи допустимой таблицы, поля в разделе Доступные поля в других таблицах не являются скорее всего, будут недоступны для формы, которая выполняется построение. При перетаскивании поля из этого раздела в форме Access отображается диалоговое окно Выбор связи. Необходимо ввести одно или несколько полей, которые связаны друг с другом двух таблиц, перед началом работы. После этого области Список полей больше не будут отсортированы по разделам согласно предопределенных связей. Это может быть наиболее удобно нажмите кнопку Отмена в этом диалоговом окне и вместо повторную проверку межтабличных связей. Дополнительные сведения о связях читайте в статье Создание, изменение или удаление связи.

К началу страницы

Вставка таблицы в существующую форму с использованием режима конструктора

Используйте эту процедуру для добавления таблицы, основанной непосредственно на таблице или запросе, в существующую форму в режиме конструктора.

  1. Откройте форму в режиме конструктора: щелкните правой кнопкой мыши форму в области переходов и выберите команду Режим конструктора.

  2. Если на вкладке Конструктор в группе Элементы выделена кнопка Использовать мастер, нажмите ее, чтобы снять выделение.

    Изображение кнопки

    Причина

    Если этого не сделать, мастер элементов управления подчиненной формы создаст отдельный объект формы и использует его как основу элемента управления подчиненной формы. В данной процедуре, напротив, создается таблица, основанная непосредственно на таблице или запросе, а не на форме.

  3. На вкладке " Конструктор " в группе элементы управления нажмите кнопку Изображение кнопки Подчиненная форма/отчет. Изображение кнопки

  4. В сетке конструктора формы щелкните место, куда требуется вставить таблицу.

  5. Измените положение и размеры элемента управления подчиненной формы, перетаскивая маркеры на сторонах и углах элемента управления.

  6. Измените присоединенную к элементу управления подпись: щелкните ее, затем дважды щелкните ее для выделения в ней текста, после чего введите новую подпись. Если требуется удалить подпись, щелкните ее один раз и нажмите клавишу DELETE.

  7. Если окно свойств не отображается, нажмите клавишу F4, чтобы отобразить.

  8. Если элемент управления подчиненной формы не выделен, щелкните его один раз, чтобы выделить.

  9. На вкладке Данные окна свойств щелкните раскрывающийся список Объект-источник и выберите таблицу или запрос, который должен отображаться в табличном представлении. Например, если требуется отображать данные из таблицы «Заказы», выберите значение Таблица.Заказы.

  10. Если до выполнения этой процедуры все связи заданы правильно, для свойств Подчиненные поля и Основные поля автоматически задаются правильные значения, которые будут связывать главную форму с подчиненной формой.

    Мои свойства "Подчиненные поля" и "Основные поля" пусты

    Если приложение Access не сможет определить, как связать подчиненную форму с главной, значит, свойства Подчиненные поля и Основные поля элемента управления подчиненной формы оставлены пустыми, и необходимо задать эти свойства вручную следующим образом.

    1. Откройте главную форму в режиме конструктора.

    2. Щелкните элемент управления подчиненной формы один раз, чтобы выделить его.

    3. Если окно свойств не отображается, нажмите клавишу F4.

    4. На вкладке Данные окна свойств нажмите кнопку ... рядом с ячейкой свойства Подчиненные поля.

      Будет открыто диалоговое окно Связь с полями подчиненной формы.

    5. В раскрывающихся списках Основные поля и Подчиненные поля выберите поля, которыми нужно связать формы. В случае неуверенности в том, какие поля использовать, нажмите кнопку Предложить, чтобы приложение Access определило связывающие поля. Затем нажмите кнопку ОК.

      Если поле, которое требуется использовать для связывания форм, не отображается, может потребоваться отредактировать источник записи главной или подчиненной формы, чтобы в нем присутствовало данное поле. Например, если форма основана на запросе, следует убедиться, что связывающее поле присутствует в результатах запроса.

    6. Сохраните главную форму и перейдите в режим формы, чтобы проверить правильность работы созданной формы.

  11. Сохраните форму, нажав кнопку Сохранить Изображение кнопки на панели Быстрого доступа или, нажав клавиши CTRL + S.

  12. Переключитесь в представление формы и проверьте правильность работы таблицы.

К началу страницы

Различия между разделенной формой и формой, содержащей таблицу

Форма, содержащая таблицу, отображает данные из различных (но, как правило, связанных) источников. Например, в форме может отображаться список сотрудников, и у нее может быть таблица, в которой отображаются все задачи, назначенные каждому сотруднику. Таблица и содержащая ее форма имеют разные источники данных. Напротив, разделенная форма состоит из двух разделов (форма и таблица), в которых отображаются одни и те же данные. Оба раздела работают синхронно и дают возможность одновременно просматривать данные в двух разных режимах.

Дополнительные сведения о создании разделенной формы и работе с ней см. в статье Создание разделенной формы.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×