Вставка объекта в электронной таблице Excel

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Чтобы включить содержимое из других программ, например Word или Excel можно использовать объект связывание и внедрение (OLE).

Интерфейс OLE поддерживается множеством различных программ и используется для помещения содержимого, созданного в одной программе, в другую программу. Например, можно вставить документ Office Word в книгу Office Excel. Чтобы посмотреть, содержимое какого типа можно вставить, на вкладке Вставка в группе Текст выберите элемент Объект. В поле Тип объекта отображаются только объекты программ, установленных на данном компьютере и поддерживающих интерфейс OLE.

Данные, которые копируются в Excel из другой программы, поддерживающей интерфейс OLE (например, Word), можно вставить как связанный объект или внедренный объект. Основные различия между внедренными и связанными объектами заключаются в том, где хранятся данные и как обновляется объект после вставки в конечный файл. Внедренные объекты хранятся в той книге, в которую вставлены, и не обновляются. Связанные объекты остаются в отдельных файлах и могут обновляться.

Связанные и внедренные объекты в документе

Связанные и внедренные объекты в документе Office для Windows

1. У внедренного объекта нет связи с исходным файлом.

2. Связанный объект связан с исходных файлом.

3. При обновлении исходного файла обновляется связанный объект.

Когда следует использовать связанные объекты

Используйте связанные объекты, если нужно, чтобы данные в конечном файле обновлялась при изменении данных в исходном файле.

При использовании связанного объекта исходные данные хранятся в исходном файле. В конечном файле отображается представление связанных данных, однако хранится в нем только информация о местоположении исходных данных (и размере, если объект является диаграммой Microsoft Excel). Для поддержания связи с исходными данными файл, в котором они хранятся, должен быть доступен на локальном диске или в сети.

Связанные данные могут обновляться автоматически при изменении данных в исходном файле. Например, если в документе Word выделяется абзац, который затем вставляется в качестве связанного объекта в книгу Excel, то при изменении данных в документе Word данные в книге Excel также будут изменены.

Когда следует использовать внедренные объекты

Используйте внедренный объект, если не требуется, чтобы скопированные данные изменялись при их изменении в исходном файле. Версия исходных данных полностью внедряется в книгу. При копировании данных в качестве внедренного объекта конечный файл занимает больше дискового пространства, чем при связывании данных.

При открытии файла на другом компьютере можно просмотреть внедренный объект, не имея доступа к исходным данным. Поскольку внедренный объект не связан с исходным файлом, он не обновляется при изменении исходных данных. Чтобы изменить внедренный объект, дважды щелкните его для открытия и редактирования в исходной программе. Исходная программа (или другая программа, позволяющая редактировать объект) должна быть установлена на компьютере.

Изменение способа отображения объекта OLE

В книге связанный объект или внедренный объект может отображаться либо в том же виде, что и в исходной программе, либо в виде значка. Если книга будет просматриваться через Интернет и ее не придется печатать, можно выбрать отображение этого объекта в виде значка. Это уменьшает площадь, занимаемую объектом на экране. Для просмотра этого объекта в исходном виде необходимо дважды щелкнуть его значок.

Внедрение объекта на лист

  1. Щелкните ячейку листа, в которую вы хотите вставить объект.

  2. На вкладке Вставка в группе текст нажмите кнопку объект Значок "объект" на ленте .
    Вставить объект

  3. В диалоговом окне объект щелкните вкладку Создание из файла.

  4. Нажмите кнопку Обзор и выберите файл, который вы хотите вставить.

  5. Если вы хотите вставить значка в электронную таблицу вместо Показать содержимое файла, установите флажок отобразить в виде значка . Если вы не выбрали все флажки Excel отображает первую страницу файла. В обоих случаях полный файл откроется между столбцами. Нажмите кнопку ОК.

    Примечание : После добавления значок или файл можно перетащить и вставьте его на листе. Также можно изменить значок или файл с помощью маркеров изменения размера. Чтобы найти маркеров, щелкните файл или значок один раз.

Вставка ссылки на файл

Можно просто добавить ссылку на объект, а не ее внедрения полностью. Можно сделать, если книгу и объект, который вы хотите добавить хранятся на сайте SharePoint, общем сетевом диске или же расположении и расположение файлов не изменится. Это удобно, если связанный объект изменяется, так как ссылка всегда открывается последнюю версию документа.

Примечание : Если связанный файл переместить, ссылка не будет работать.

  1. Щелкните ячейку листа, в которую вы хотите вставить объект.

  2. На вкладке Вставка в группе текст нажмите кнопку объект Значок "объект" на ленте .
    Вставить объект

  3. Откройте вкладку Создание из файла .

  4. Нажмите кнопку Обзор и выберите файл, который должна указывать ссылка.

  5. Установите флажок Связь с файлом, а затем нажмите кнопку ОК.

Создание объекта в Excel

Можно создать новую объекта на основании другая программа не выходя из книги. Например если вы хотите добавить более подробное описание диаграммы или таблицы, можно создать внедренный документ, например файл Word или PowerPoint в Excel. Вы можете установить для отображения объекта вправо на листе или добавить значок, который открывает файл.

Внедренный объект является документом Word.
  1. Щелкните ячейку листа, в которую вы хотите вставить объект.

  2. На вкладке Вставка в группе текст нажмите кнопку объект Значок "объект" на ленте .
    Вставить объект

  3. На вкладке Новый выберите в списке тип объекта, который вы хотите вставить. Если вы хотите вставить в электронную таблицу значок, а не сам объект, установите флажок В виде значка.

  4. Нажмите кнопку ОК. В зависимости от типа вставляемого файла откроется новое окно программы или появится окно редактирования.

  5. Создайте объект, который вы хотите вставить.

    Если Excel открыл новое окно программы для создания объекта, вы можете работать непосредственно в нем.

    Вы можете редактировать внедренный документ Word прямо в Excel.

    Когда закончите свою работу в окне без сохранения внедренный объект может выполнять другие задачи. При закрытии книги будут автоматически сохранены на новых объектов.

    Примечание : После добавления объекта вы можете перетащить его в любое место на листе Excel или изменить его размер с помощью маркеров изменения размера. Чтобы отобразить эти маркеры, щелкните объект один раз.

Внедрение объекта на лист

  1. Щелкните ячейку листа, в которую вы хотите вставить объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект.

    Элемент "Объект" находится на вкладке "Вставка".
  3. Откройте вкладку Из файла.

    Вкладка "Создать из файла" в диалоговом окне "Объект"
  4. Нажмите кнопку Обзор и выберите файл, который вы хотите вставить.

  5. Если вы хотите вставить значка в электронную таблицу вместо Показать содержимое файла, установите флажок отобразить в виде значка . Если вы не выбрали все флажки Excel отображает первую страницу файла. В обоих случаях полный файл откроется между столбцами. Нажмите кнопку ОК.

    Примечание : После добавления значок или файл можно перетащить и вставьте его на листе. Также можно изменить значок или файл с помощью маркеров изменения размера. Чтобы найти маркеров, щелкните файл или значок один раз.

Вставка ссылки на файл

Можно просто добавить ссылку на объект, а не ее внедрения полностью. Можно сделать, если книгу и объект, который вы хотите добавить хранятся на сайте SharePoint, общем сетевом диске или же расположении и расположение файлов не изменится. Это удобно, если связанный объект изменяется, так как ссылка всегда открывается последнюю версию документа.

Примечание : Если связанный файл переместить, ссылка не будет работать.

  1. Щелкните ячейку листа, в которую вы хотите вставить объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект.

    Элемент "Объект" находится на вкладке "Вставка".
  3. Откройте вкладку Создание из файла .

  4. Нажмите кнопку Обзор и выберите файл, который должна указывать ссылка.

  5. Установите флажок Связь с файлом, а затем нажмите кнопку ОК.

    На вкладке "Создать из файла" установите флажок "Связать с файлом".

Создание объекта в Excel

Можно создать новую объекта на основании другая программа не выходя из книги. Например если вы хотите добавить более подробное описание диаграммы или таблицы, можно создать внедренный документ, например файл Word или PowerPoint в Excel. Вы можете установить для отображения объекта вправо на листе или добавить значок, который открывает файл.

Внедренный объект является документом Word.
  1. Щелкните ячейку листа, в которую вы хотите вставить объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект.

    Элемент "Объект" находится на вкладке "Вставка".
  3. На вкладке Новый выберите в списке тип объекта, который вы хотите вставить. Если вы хотите вставить в электронную таблицу значок, а не сам объект, установите флажок В виде значка.

    Вкладка "Создать" в диалоговом окне "Объект"
  4. Нажмите кнопку ОК. В зависимости от типа вставляемого файла откроется новое окно программы или появится окно редактирования.

  5. Создайте объект, который вы хотите вставить.

    Если Excel открыл новое окно программы для создания объекта, вы можете работать непосредственно в нем.

    Вы можете редактировать внедренный документ Word прямо в Excel.

    Когда закончите свою работу в окне без сохранения внедренный объект может выполнять другие задачи. При закрытии книги будут автоматически сохранены на новых объектов.

    Примечание : После добавления объекта вы можете перетащить его в любое место на листе Excel или изменить его размер с помощью маркеров изменения размера. Чтобы отобразить эти маркеры, щелкните объект один раз.

Связывание или внедрение содержимого из другой программы с помощью OLE

Можно связать или внедрить содержимое (целиком или частично) из другой программы.

Создать ссылку на контент из другой программы

  1. Щелкните лист, на который необходимо поместить связанный объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект.

    Изображение ленты Excel

  3. Откройте вкладку Из файла.

  4. В поле Имя файла введите имя файла или нажмите кнопку Обзор для выбора файла из списка.

  5. Установите флажок Связь с файлом.

  6. Выполните одно из следующих действий.

    • Чтобы отобразить содержимое объекта, снимите флажок В виде значка.

    • Чтобы отобразить значок, установите флажок отобразить в виде значка. При необходимости Чтобы изменить изображение по умолчанию значка или метки, щелкните Значок "Изменить", нажмите и нажмите кнопку значок, который вы хотите из списка значок в поле заголовок введите метку.

    Примечание : Команду Объект нельзя использовать для вставки графики и файлов определенных типов. Чтобы вставить графическое изображение или файл, на вкладке Вставка в группе Иллюстрации нажмите кнопку Рисунок.

Внедрение содержимого из другой программы

  1. Щелкните лист, на который необходимо поместить внедренный объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект.

    Изображение ленты Excel

  3. Если документ еще не существует, откройте вкладку Новый. В списке Тип объекта выберите необходимый тип.

    Если этот документ уже существует, откройте вкладку Из файла. В поле Имя файла введите имя файла или нажмите кнопку Обзор для выбора файла из списка.

  4. Снимите флажок Связь с файлом.

  5. Выполните одно из следующих действий.

    • Чтобы отобразить содержимое объекта, снимите флажок В виде значка.

    • Чтобы отобразить значок, установите флажок отобразить в виде значка. Чтобы изменить изображение по умолчанию значка или метки, нажмите Значок "Изменить" и щелкните значок, который вы хотите из списка значок или введите подпись в поле заголовок.

Связывание или внедрение Частичное содержимое из другой программы

  1. В используемой программе (не в Excel) выделите данные, которые требуется скопировать как связанный или внедренный объект.

  2. На вкладке Главная в группе Буфер обмена нажмите кнопку Копировать.

    Изображение ленты Excel

  3. Перейдите к листу, на который нужно поместить данные, и щелкните в том месте, где требуется их расположить.

  4. На вкладке Главная в группе Буфер обмена щелкните стрелку под кнопкой Вставить и выберите команду Специальная вставка.

  5. Выполните одно из следующих действий.

    • Для вставки данных в качестве связанного объекта выберите команду Связать.

    • Чтобы вставить данные в качестве внедренного объекта, выберите команду Вставить. В поле Как выберите элемент, в названии которого есть слово "объект". Например, если данные копируются из документа Word, выберите элемент Объект документа Microsoft Word.

Изменение способа отображения объекта OLE

  1. Щелкните правой кнопкой мыши значок или объект, наведите указатель на элемент Объект тип объекта (например, Объект Документ) и выберите команду Преобразовать.

  2. Выполните одно из следующих действий.

    • Чтобы отобразить содержимое объекта, снимите флажок В виде значка.

    • Чтобы отобразить значок, установите флажок отобразить в виде значка. При необходимости можно изменить по умолчанию значок или подпись. Чтобы сделать это, щелкните Значок изменения и щелкните значок, который вы хотите из списка значок или в поле заголовок введите метку.

Управление обновлением в связанных объектах

При установлении связей с другими программами обновление может выполняться одним из следующих способов: автоматически при открытии конечного файла, вручную, если нужно посмотреть предыдущие данные перед их обновлением из исходного файла, или с помощью запроса обновления, независимо от включенного способа обновления (автоматически или вручную).

Установка обновления вручную связи с другой программой

  1. На вкладке Данные в группе Подключения нажмите кнопку Изменить связи.

    Изображение ленты Excel

    Примечание : Отсутствие команды Изменить связи означает, что файл не содержит связей с другими файлами.

  2. В списке Источник выберите связанный объект, который необходимо обновить. Буква A в столбце Обновить означает автоматическое обновление связи, а буква M в столбце Обновить — обновление Вручную.

    Совет : Для выделения нескольких связанных объектов щелкните каждый из них, удерживая нажатой клавишу CTRL. Чтобы выделить все связанные объекты, нажмите клавиши CTRL+A.

  3. Если изменения связанных объектов необходимо производить при выборе команды Обновить значения, нажмите Вручную.

Установка автоматического обновления связи с другой программой

  1. На вкладке Данные в группе Подключения нажмите кнопку Изменить связи.

    Изображение ленты Excel

    Примечание : Отсутствие команды Изменить связи означает, что файл не содержит связей с другими файлами.

  2. В списке Источник выберите связанный объект, который необходимо обновить. Буква A в столбце Обновить означает автоматическое обновление связи, а буква M в столбце Обновить — обновление вручную.

    Совет : Для выделения нескольких связанных объектов щелкните каждый из них, удерживая нажатой клавишу CTRL. Чтобы выделить все связанные объекты, нажмите клавиши CTRL+A.

  3. Нажмите кнопку ОК.

Проблема: не удается обновить автоматические связи на листе

Параметр Автоматически в Excel переопределяется параметром Обновить ссылки на другие документы.

Чтобы обеспечить автоматическое обновление автоматических связей с объектами OLE, сделайте следующее:

  1. Нажмите Кнопку Microsoft Office Изображение кнопки Office , выберите пункт Параметры Excel и выберите категорию Дополнительно.

  2. В разделе При пересчете этой книги убедитесь, что установлен флажок Обновить ссылки на другие документы.

Немедленное обновление связи с программой

  1. На вкладке Данные в группе Подключения нажмите кнопку Изменить связи.

    Изображение ленты Excel

    Примечание : Отсутствие команды Изменить связи означает, что файл не содержит связанных данных.

  2. Из списка Источник выберите связанный объект, который необходимо изменить.

    Совет : Для выделения нескольких связанных объектов щелкните каждый из них, удерживая нажатой клавишу CTRL. Чтобы выделить все связанные объекты, нажмите клавиши CTRL+A.

  3. Нажмите Обновить значения.

Изменение содержимого из программы OLE

В приложении Excel можно изменить содержимое, связанное или внедренное из другой программы.

Редактирование связанного объекта в исходной программе

  1. На вкладке Данные в группе Подключения нажмите кнопку Изменить связи.

    Изображение ленты Excel

    Примечание : Отсутствие команды Изменить связи означает, что файл не содержит связанных данных.

  2. В списке Исходный файл выберите источник связанного объекта, а затем нажмите кнопку Открыть.

  3. Внесите нужные изменения в связанный объект.

  4. Выйдите из исходной программы, чтобы вернуться в конечный файл.

Редактирование внедренного объекта в исходной программе

  1. Дважды щелкните внедренный объект, чтобы его открыть.

  2. Внесите необходимые изменения.

  3. Если изменение объекта происходит прямо в окне открытой программы, щелкните за пределами объекта, чтобы вернуться в конечный файл.

    Если изменение объекта выполняется в исходной программе, открытой в отдельном окне, для возврата в конечный файл выйдите из исходной программы.

Примечание :  Если дважды щелкнуть некоторые внедренные объекты, такие как видео- и звуковые клипы, начнется их воспроизведение, а не открытие. Чтобы изменить такой внедренный объект, щелкните правой кнопкой мыши значок или объект, наведите указатель на элемент Объект тип объекта (например, Объект Клип мультимедиа), а затем выберите команду Изменить.

Редактирование внедренного объекта в программе, отличной от источника

  1. Выделите внедренный объект, который необходимо изменить.

  2. Щелкните правой кнопкой мыши значок или объект, наведите указатель на элемент Объект тип объекта (например, Объект Документ) и выберите команду Преобразовать.

  3. Выполните одно из следующих действий.

    • Чтобы преобразовать внедренный объект в тип, выбранный в списке, установите флажок преобразовать в.

    • Чтобы открыть внедренный объект в формате, выбранном в списке, без изменения типа внедренного объекта, установите флажок активизировать как.

Выделение объекта OLE с помощью клавиатуры

  1. Нажмите клавиши CTRL+G для отображения диалогового окна Переход.

  2. Нажмите кнопку Выделить, выберите вариант объекты и нажмите кнопку ОК.

  3. Несколько раз нажмите клавишу TAB, пока не будет выделен требуемый объект.

  4. Нажмите клавиши SHIFT+F10.

  5. Наведите указатель на элемент Объект или Объект Диаграмма и выберите команду Изменить.

Проблема: при двойном щелчке по связанному или внедренному объекту появляется сообщение "Нельзя изменить"

Это сообщение появляется, если невозможно открыть исходный файл или программу-источник.

Убедитесь, что исходная программа доступна.    Если исходная программа не установлена на компьютере, преобразуйте объект в формат файла той программы, которая есть на компьютере.

Убедитесь, что имеется достаточно памяти.    Убедитесь, что на компьютере имеется достаточно памяти для запуска исходной программы. В случае необходимости для освобождения памяти закройте другие программы.

Закройте все диалоговые окна.    Если исходная программа запущена, убедитесь, что в ней нет открытых диалоговых окон. Переключитесь в исходную программу и закройте все открытые диалоговые окна.

Закройте исходный файл.    Если исходный файл является связанным объектом, убедитесь, что он не открыт другим пользователем.

Убедитесь, что имя исходного файла не изменилось.    Если исходный файл, который требуется изменить, является связанным объектом, убедитесь, что он имеет то же имя, что и при создании связи, а также что он не был перемещен. Чтобы узнать имя исходного файла, выделите связанный объект, а затем на вкладке Данные в группе Подключения выберите команду Изменить связи. Если исходный файл был переименован или перемещен, воспользуйтесь кнопкой Смена источника в диалоговом окне Изменение связей, чтобы найти исходный файл и восстановить связь.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×