Вставка дат в юлианском представлении

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Выражение «Юлианское представление дат» иногда используется для обозначения формата даты, в котором после текущего года стоит номер дня с начала года. Например, дате 1 января 2007 г. соответствует значение 2007001, а 31 декабря 2007 г. — значение 2007365. Следует помнить, что этот формат не основан на юлианском календаре.

Юлианское представление дат также обычно используется в астрономии, где даты отсчитываются с 1 января 4713 года до н. э.

Существует несколько способов вставки дат в юлианском представлении.

Предполагаемое действие:

Введите в качестве в юлианское сегодня

Сведения о функции

Преобразование даты в юлианское

Сведения о функции

Преобразование даты в юлианское, используемом в астрономии

Ввод текущей даты в юлианском представлении

Для выполнения этой задачи используются функции ТЕКСТ, СЕГОДНЯ и ДАТАЗНАЧ.

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

Копирование примера

  1. Создайте пустую книгу или лист.

  2. Выделите пример в разделе справки.

    Примечание : Не выделяйте заголовки строк и столбцов.

    Выделение примера из справки

    Выделение примера из справки

  3. Нажмите клавиши CTRL+C

  4. На листе выделите ячейку A1 и нажмите клавиши CTRL+V.

  5. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите клавиши CTRL+` (апостроф) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показать формулы.

1

2

3

A

B

Формула

Описание (результат)

=ТЕКСТ(СЕГОДНЯ();"гг")&ТЕКСТ((СЕГОДНЯ()-ДАТАЗНАЧ("1.1."&ТЕКСТ(СЕГОДНЯ();"гг"))+1);"000")

Текущий день в юлианском представлении с двузначным обозначением года (значение может быть разным)

=ТЕКСТ(СЕГОДНЯ();"гггг")&ТЕКСТ((СЕГОДНЯ()-ДАТАЗНАЧ("1.1."&ТЕКСТ(СЕГОДНЯ();"гг"))+1);"000")

Текущий день в юлианском представлении с четырехзначным обозначением года (значение может быть разным)

Примечание : 

  • Текущее значение даты определяется по системным часам компьютера.

  • В приведенных выше формулах год начинается с 1 января (1.1). Чтобы преобразовать формулу для использования другой начальной даты, укажите вместо «1.1» нужную дату.

Описание функций

ФУНКЦИЯ ДАТАЗНАЧ

ТЕКСТ

СЕГОДНЯ

К началу страницы

Преобразование даты в юлианское представление

Для выполнения этой задачи используются функции ТЕКСТ и ДАТАЗНАЧ.

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

Копирование примера

  1. Создайте пустую книгу или лист.

  2. Выделите пример в разделе справки.

    Примечание : Не выделяйте заголовки строк и столбцов.

    Выделение примера из справки

    Выделение примера из справки

  3. Нажмите клавиши CTRL+C

  4. На листе выделите ячейку A1 и нажмите клавиши CTRL+V.

  5. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите клавиши CTRL+` (апостроф) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показать формулы.

1

2

A

Дата

23.06.2007

Формула

Описание (результат)

=ТЕКСТ(A2;"гг")&ТЕКСТ((A2-ДАТАЗНАЧ("1.1."&ТЕКСТ(A2;"гг"))+1);"000")

Приведенная выше дата в юлианском представлении с двузначным обозначением года (07174)

=ТЕКСТ(A2;"гггг")&ТЕКСТ((A2-ДАТАЗНАЧ("1.1."&ТЕКСТ(A2;"гг"))+1);"000")

Приведенная выше дата в юлианском представлении с четырехзначным обозначением года (2007174)

Примечание : В приведенных выше формулах год начинается с 1 января (1.1). Чтобы преобразовать формулу для использования другой начальной даты, укажите вместо «1.1» нужную дату.

Описание функций

ФУНКЦИЯ ДАТАЗНАЧ

ТЕКСТ

К началу страницы

Преобразование даты в юлианское представление, используемое в астрономии

Эта формула работает только с датами после 01.03.1901 и в книгах, использующих систему отсчета дат с 1900 года.

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

Копирование примера

  1. Создайте пустую книгу или лист.

  2. Выделите пример в разделе справки.

    Примечание : Не выделяйте заголовки строк и столбцов.

    Выделение примера из справки

    Выделение примера из справки

  3. Нажмите клавиши CTRL+C

  4. На листе выделите ячейку A1 и нажмите клавиши CTRL+V.

  5. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите клавиши CTRL+` (апостроф) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показать формулы.

1

2

A

Дата

23.06.2007

Формула

Описание (результат)

=A2+2415018,50

Первая приведенная выше дата в юлианском представлении используется в астрономии (28.07.8619)

Примечание : Даты можно представить в числовом формате. Выделите ячейку, на вкладке Главная в группе Число щелкните стрелку и выберите вариант Числовой.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×