Воспроизведение в презентации анимации Adobe Macromedia Flash

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Если у вас есть анимированный рисунок, который был создан с помощью программы Adobe Macromedia Flash и сохранена как файл с расширением .swf Shockwave, вы можете воспроизвести файла в презентацию PowerPoint.

Добавление файла формата Flash в презентацию в PowerPoint 2010 и более поздних версий, выполнив внедрение или связывание файла на слайде.

Примечания : 

  • При использовании формата Flash в PowerPoint, включая к невозможности сжать эти файлы для упростить совместное использование и распространение с помощью специальных эффектов (таких как тени, отражения, свечение, сглаживание, рельеф и поворот объемной фигуры), исчезания и СЖПРОБЕЛЫ возможности и возможности могут быть некоторые ограничения.

  • В PowerPoint 2010 64-разрядной версии несовместим с 32-разрядных версиях QuickTime или Flash. Вы должны установить 64-разрядной версии QuickTime или Flash или 32-разрядной версии PowerPoint 2010.

Внедрение флэш-файла

  1. В обычном режиме выберите слайд, в который необходимо внедрить видео.

  2. На вкладке Вставка в группе мультимедиа щелкните стрелку под кнопкой видео и выберите пункт видео на Компьютере или видео из файла.

  3. В диалоговом окне Вставка видеозаписи найдите и щелкните видео, которое вы хотите внедрить и нажмите кнопку Вставить.

  4. Для предварительного просмотра анимации флэш-памяти, на вкладке " Работа с видео | формат " нажмите кнопку Воспроизведение.

Ссылка на файл Flash

  1. На вкладке Слайды в обычном режиме щелкните слайд, на который вы хотите добавить видео или анимационный GIF-файл.

  2. На вкладке Вставка в группе Клип мультимедиа щелкните стрелку под надписью Видео.

  3. Выберите видео на Компьютере или видео из файла, найдите и щелкните файл, который должна указывать ссылка.

  4. На кнопке Вставить щелкните стрелку вниз и выберите пункт Связь с файлом.

    Важно : Чтобы избежать возможных проблем с неработающими ссылками, рекомендуется скопировать видеофайлы в ту же папку, где находится презентация, и связать их с презентацией из этого места.

  5. Для предварительного просмотра анимации флэш-памяти, на вкладке " Работа с видео | формат " нажмите кнопку Воспроизведение.

Добавление файла .swf в PowerPoint 2007, используйте элемент управления ActiveX под названием объект Shockwave Flash и Adobe Macromedia Flash Player. Для воспроизведения флэш-файла, добавить элемент управления ActiveX на слайд и создать ссылку на их основе флэш-файла.

Параметры безопасности элемента ActiveX доступны в центре управления безопасностью, где можно настраивать параметры безопасности и конфиденциальности для приложений выпуск 2007 системы Microsoft Office. Чтобы разрешить выполнение элементов Active X, вам, возможно, понадобится настроить параметры безопасности. Параметры ActiveX в центре управления безопасностью применяются ко всем продуктам 2007 Office (выпуск). Например, если изменить определенный параметр в приложении PowerPoint, он изменится во всех остальных приложениях Office, которые используют центр управления безопасностью. Дополнительные сведения об элементах Active X и изменении параметров см. в разделе Включение и отключение элементов ActiveX в документах Office.

Важно : 

  • Для воспроизведения в презентации файла формата Flash на компьютере должен быть зарегистрирован объект Shockwave Flash. Чтобы просмотреть ли зарегистрирован объект Shockwave Flash, на вкладке Разработчик в группе элементы управления нажмите кнопку Другие элементы управления Изображение кнопки . Если объект Shockwave Flash зарегистрирован на вашем компьютере, он отобразится в списке элементов управления. Если он не зарегистрировано, Загрузите последнюю версию Flash Player Adobe веб-страниц сайта зарегистрировать объект Shockwave Flash на вашем компьютере.

  • Чтобы обеспечить правильное воспроизведение сложной анимации, установите последнюю версию Flash Player, даже если на вашем компьютере зарегистрирован объект Shockwave Flash более ранней версии.

Добавление файла формата Flash в презентацию

  1. Установите на компьютере проигрыватель Flash Player.

  2. В PowerPoint откройте в обычном режиме слайд, на котором требуется воспроизвести анимацию.

  3. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Параметры PowerPoint.

  4. Выберите категорию Популярные, а затем в разделе Основные параметры работы с PowerPoint установите флажок Показывать вкладку "Разработчик" на ленте и нажмите кнопку ОК.

  5. На вкладке Разработчик в группе Элементы управления выберите пункт Другие элементы Изображение кнопки .

  6. В списке элементов управления щелкните Объект Shockwave Flash, нажмите кнопку ОК, а затем перетащите на слайде указатель мыши, чтобы нарисовать элемент управления.

    Измените размер элемента управления, перетащив маркеры изменения размера.

  7. Щелкните правой кнопкой мыши объект Shockwave Flash и нажмите кнопку Свойства.

  8. На вкладке По алфавиту выберите свойство Фильм.

  9. В столбце значения (пустая ячейка рядом с параметром Фильм) укажите полный путь к диску, включая имя файла (например, C\:MyFile.swf), или введите URL-адрес файла формата Flash, который требуется воспроизвести.

  10. Чтобы настроить параметры для воспроизведения анимации, выполните указанные ниже действия, а затем закройте диалоговое окно Свойства.

    • Чтобы автоматически воспроизводить файл при отображении слайда, для свойства Воспроизведение установите значение Истина. Если файл формата Flash содержит встроенный элемент "Воспроизведение/Перемотка", для свойства Воспроизведения можно задать значение Ложь.

    • Если не требуется непрерывно воспроизводить анимацию, установите для свойства Циклическое воспроизведение значение Ложь.

Предварительный просмотр анимации в режиме слайд-шоу

  • На вкладке Вид в группе Режимы просмотра презентации выберите пункт Слайд-шоу или нажмите клавишу F5.

    Для выхода из режима слайд-шоу и возврата в обычный режим нажмите клавишу ESC.

Примечания : 

  • В отличие от изображения или рисунки флэш-файлы всегда связан с презентацией в PowerPoint 2007, а не встроен в его. При вставке связанный файл PowerPoint создается ссылка на текущее расположение файла. Если файл позже переместить в другое место, PowerPoint не удается найти при необходимости воспроизведения файла. Рекомендуется скопировать флэш-памяти файлы в ту же папку, где находится презентация, прежде чем вставлять флэш-файлы. PowerPoint создает ссылку на файл Flash и флэш-файл можно найти при условии, что оставить ее в папке презентации, даже если переместить или скопировать папки на другом компьютере. Другой способ быть уверены в том, что связанные файлы в той же папке, где находится презентация — пакет для компакт-диска. Эта функция копирует все файлы местоположение (компакт-ДИСК или папку), где находится презентация и автоматически обновляет все ссылки для файлов. Если презентация содержит связанные файлы, если вы планируете презентации на другом компьютере или отправить его по электронной почте необходимо скопировать связанные файлы, а также презентации.

  • Продукты сторонних разработчиков, рассмотренные в этой статье, выпущены производителями, независимыми от корпорации Майкрософт. Корпорация Майкрософт не гарантирует надлежащую работоспособность и надежность этих продуктов.

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×