Office

Воспроизведение анимации Adobe Macromedia Flash в презентации

PowerPoint для Office 365, PowerPoint 2019, PowerPoint 2016, PowerPoint 2013, PowerPoint 2010

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Если у вас есть анимированный рисунок, созданный с помощью Adobe Macromedia Flash и сохраненный в виде файла Shockwave с расширением. SWF, вы можете воспроизвести его в презентации PowerPoint.

Вы добавляете файл флэш-памяти в презентацию в PowerPoint 2010 и более поздних версиях, добавляя или связывая файл на слайде.

Примечания: 

  • При использовании Flash в PowerPoint могут возникнуть некоторые ограничения, в том числе невозможность применять специальные эффекты (такие как тени, отражения, эффекты свечения, размытые края, багетные рамки и поворот объемной фигуры), возможности затухания и монтажа, а также возможность их сжатия. файлы для упрощения совместного использования и распространения.

  • Версия 64-bit PowerPoint 2010 несовместима с 32-разрядными версиями QuickTime или Flash. Вы должны либо установить 64-разрядную версию QuickTime или Flash либо 32-разрядную версию PowerPoint 2010.

Внедрение файла Flash

  1. В обычном режиме щелкните слайд, в который вы хотите внедрить видео.

  2. На вкладке Вставка в группе мультимедиа щелкните стрелку под кнопкой видеои выберите пункт видео на компьютере или видео из файла.

  3. В диалоговом окне Вставка видеозаписи найдите и выберите видеофайл, который необходимо внедрить, и нажмите кнопку Вставить.  

    Чтобы убедиться в том, что в диалоговом окне указаны SWF-файлы, измените фильтр файлов (над кнопкой " Вставить ") на все файлы.

    В диалоговом окне "Вставка видео" в фильтре "тип файла" есть параметр "все файлы".
  4. Чтобы просмотреть анимацию Flash, нажмите кнопку воспроизвести на вкладке Работа с видео "формат ".

Создание ссылки на файл в формате флэш-памяти

  1. На вкладке Слайды в обычном режиме щелкните слайд, на который вы хотите добавить видео или анимационный GIF-файл.

  2. На вкладке Вставка в группе Клип мультимедиа щелкните стрелку под надписью Видео.

  3. Нажмите кнопку видео на компьютере или видео из файла, найдите и выберите файл, на который должна указывать ссылка.

    Чтобы убедиться в том, что в диалоговом окне указаны SWF-файлы, измените фильтр файлов (над кнопкой " Вставить ") на все файлы.

    В диалоговом окне "Вставка видео" в фильтре "тип файла" есть параметр "все файлы".
  4. На кнопке Вставить щелкните стрелку вниз и выберите пункт Связь с файлом.

    Важно: Чтобы предотвратить возможные проблемы с неработающими ссылками, рекомендуется скопировать видеофайлы в ту же папку, где находится презентация, и добавить в нее ссылки.

  5. Чтобы просмотреть анимацию Flash, нажмите кнопку воспроизвести на вкладке Работа с видео "формат ".

Видеоролики Adobe Macromedia Director

Вы не можете вставить в презентацию PowerPoint файл видео Adobe Macromedia Director.

Чтобы добавить SWF-файл в PowerPoint 2007, используйте элемент ActiveX, который называется объект Shockwave Flash и Adobe Macromedia Flash Player. Чтобы воспроизвести файл в формате флэш-памяти, добавьте на слайд элемент ActiveX и создайте в нем ссылку на него.

Параметры безопасности элемента ActiveX доступны в центре управления безопасностью, где можно настраивать параметры безопасности и конфиденциальности для приложений выпуск 2007 системы Microsoft Office. Чтобы разрешить выполнение элементов Active X, вам, возможно, понадобится настроить параметры безопасности. Параметры ActiveX в центре управления безопасностью применяются ко всем продуктам 2007 Office (выпуск). Например, если изменить определенный параметр в приложении PowerPoint, он изменится во всех остальных приложениях Office, которые используют центр управления безопасностью. Дополнительные сведения об элементах управления ActiveX и изменении параметров можно найти в разделе Включение и отключение параметров наэкране.

Важно: 

  • Для воспроизведения в презентации файла формата Flash на компьютере должен быть зарегистрирован объект Shockwave Flash. Чтобы узнать, зарегистрирован ли объект Shockwave Flash, на вкладке разработчик в группе элементы управления нажмите кнопку другие элементы управления Изображение кнопки . Если объект Shockwave Flash зарегистрирован на вашем компьютере, он отобразится в списке элементов управления. Если он не зарегистрирован, скачайте последнюю версию проигрывателя Flash Player с веб-сайта Adobe, чтобы зарегистрировать объект Shockwave Flash на вашем компьютере.

  • Чтобы обеспечить правильное воспроизведение сложной анимации, установите последнюю версию Flash Player, даже если на вашем компьютере зарегистрирован объект Shockwave Flash более ранней версии.

Добавление файла формата Flash в презентацию

  1. Установите на компьютере проигрыватель Flash Player.

  2. В PowerPoint откройте в обычном режиме слайд, на котором требуется воспроизвести анимацию.

  3. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Параметры PowerPoint.

  4. Выберите категорию Популярные, а затем в разделе Основные параметры работы с PowerPoint установите флажок Показывать вкладку "Разработчик" на ленте и нажмите кнопку ОК.

  5. На вкладке разработчик в группе элементы управления нажмите кнопку другие элементы управления Изображение кнопки .

  6. В списке элементов управления щелкните Объект Shockwave Flash, нажмите кнопку ОК, а затем перетащите на слайде указатель мыши, чтобы нарисовать элемент управления.

    Измените размер элемента управления, перетащив маркеры изменения размера.

  7. Щелкните правой кнопкой мыши объект Shockwave Flash и нажмите кнопку Свойства.

  8. На вкладке По алфавиту выберите свойство Фильм.

  9. В столбце значения (пустая ячейка рядом с параметром Фильм) укажите полный путь к диску, включая имя файла (например, C\:MyFile.swf), или введите URL-адрес файла формата Flash, который требуется воспроизвести.

  10. Чтобы настроить параметры для воспроизведения анимации, выполните указанные ниже действия, а затем закройте диалоговое окно Свойства.

    • Чтобы автоматически воспроизводить файл при отображении слайда, для свойства Воспроизведение установите значение Истина. Если файл формата Flash содержит встроенный элемент "Воспроизведение/Перемотка", для свойства Воспроизведения можно задать значение Ложь.

    • Если не требуется непрерывно воспроизводить анимацию, установите для свойства Циклическое воспроизведение значение Ложь.

Предварительный просмотр анимации в режиме слайд-шоу

  • На вкладке Вид в группе Режимы просмотра презентации выберите пункт Слайд-шоу или нажмите клавишу F5.

    Для выхода из режима слайд-шоу и возврата в обычный режим нажмите клавишу ESC.

Примечания: 

  • В отличие от рисунков и рисунков, Flash-файлы всегда связаны с презентацией в PowerPoint 2007, а не внедрены в нее. При вставке связанного файла в PowerPoint создается ссылка на текущее расположение файла. Если позже вы переместит файл в другое место, PowerPoint не сможет найти его, когда вы хотите воспроизвести файл. Перед вставкой файлов Flash рекомендуется скопировать их в ту же папку, где находится презентация. PowerPoint создаст ссылку на файл Flash и сможет найти его, пока он не будет храниться в папке презентации, даже если переместить или скопировать ее на другой компьютер. Кроме того, вы можете убедиться, что ваши связанные файлы находятся в той же папке, что и презентация, и использовать функцию упаковка для компакт-диска. Эта функция копирует все файлы в одну папку (на компакт-диск или в папку) и автоматически обновляет все ссылки на файлы. Если в презентации есть связанные файлы, необходимо скопировать связанные файлы, а также презентацию, если вы планируете присвоить презентацию на другом компьютере или отправить ее другим пользователям по электронной почте.

  • Продукты сторонних разработчиков, рассмотренные в этой статье, выпущены производителями, независимыми от корпорации Майкрософт. Корпорация Майкрософт не гарантирует надлежащую работоспособность и надежность этих продуктов.

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×