Анимация отдельных ячеек, строк или столбцов в таблице

Анимация отдельных ячеек, строк или столбцов в таблице

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Выполните следующие действия для имитации эффект анимации частей таблицы. Процесс включает в себя изменения в таблице с набором графических объектов, которые можно «разгруппировать» и анимация отдельно.

Важно : Эта процедура преобразует таблиц в графические объекты и удаляются любые эффекты, такие как отражение, Рельефная ячейка, тень или заливка (градиентная, изображения и текстуры), которые применяются к таблице.

  1. Дублирование слайдов, содержащую таблицу, которую нужно анимировать. Первый экземпляр слайда оставьте без изменений. Сейчас вы резервной копии на случай, если у вас возникают проблемы с этот процесс или в случае, если вы хотите использовать в таблице ниже в этой презентации или в другую. Чтобы создать копию слайда, выберите эскиз слайда в левом поле в обычном режиме. На вкладке " Главная " на ленте щелкните стрелку рядом с кнопкой копирования и выберите команду Дублировать.

  2. Один дубликат слайда, созданные вами, установите курсор на границе таблицы и нажмите кнопку, чтобы выделить таблицу целиком.

  3. На вкладке Главная на ленте в группе буфер обмена нажмите кнопку Копировать.

  4. В группе Буфер обмена нажмите стрелку под командой Вставить и выберите команду Специальная вставка.

  5. Щелкните рисунок (расширенный метафайл) и нажмите кнопку ОК. (Формат расширенного метафайла позволяет предотвратить таблицы изображений вставленной таблице снижения.)

  6. В разделе Работа с рисунками на вкладке Формат в группе Упорядочить нажмите кнопку Группа Изображение кнопки и нажмите кнопку Разгруппировать Изображение кнопки .

    Команда «Разгруппировать» на вкладке "Формат" на ленте PowerPoint, в разделе Работа с рисунками.

    В ответ на предложение преобразовать рисунок в графический объект Microsoft Office нажмите кнопку Да. Для получения дополнительных сведений о процессе преобразования нажмите кнопку Показать справку.

  7. Повторите команда «Разгруппировать» еще раз. Появятся маркеры выделения на отдельные ячейки в таблице. Щелкните за пределами таблицы, чтобы очистить эти параметры.

  8. Нажмите и удерживайте клавишу Ctrl при выделении части таблицы, которую нужно анимировать.

  9. На вкладке Анимация в группе Расширенная анимация нажмите кнопку Добавить анимацию, чтобы открыть меню параметров анимации:

    • Чтобы появление фигур сопровождалось эффектом, укажите пункт Вход и выберите эффект.

    • Чтобы добавить эффект к фигурам (например эффект вращения), укажите пункт Выделение и выберите эффект.

    • Чтобы добавить эффект исчезновения фигур из слайда в какой-то момент, укажите пункт Выход и выберите эффект.

    • Чтобы добавить эффект перемещения фигуры по указанному образцу, укажите пункт Пути перемещения и выберите путь.

  10. На вкладке время нажмите кнопку Дополнительные параметры, которые вы хотите использовать, например длительность или задержки.

  11. Повторите действия 8 до 10 для других элементов таблицы, в которую нужно анимировать отдельно.

    Удалите исходную таблицу с дубликат слайда, чтобы дубликат слайда с новой версией расширенный метафайл таблицы содержит только на нем.

Совет : Если нежелательно преобразовывать таблицу в рисунок для добавления анимации, можно создать отдельные таблицы для каждой части, которую требуется анимировать. Например, если нужно, чтобы данные появлялись отдельно от строки заголовков таблицы, первая таблица должна включать сведения строки заголовков, а вторая таблица – данные. Выровняйте обе таблицы по левому краю, совместив нижнюю часть первой таблицы (строки заголовков) с верхней частью второй таблицы (данных) таким образом, чтобы они выглядели как одна таблица. Затем для достижения желаемого эффекта примените анимацию отдельно к каждой таблице.

Изображение двух таблиц, которые выглядят как одна

1: два отдельных таблицах не выровнен

2: двух таблиц, выровненный по отображаются в виде одной

Важно : Эта процедура преобразует таблиц в графические объекты и удаляются любые эффекты, такие как отражение, Рельефная ячейка, тень или заливка (градиентная, изображения и текстуры), которые применяются к таблице. Если вы хотите использовать в таблице ниже в этой презентации или другой презентации, следует Создать копию слайда .

  1. Щелкните правой кнопкой мыши таблицу и нажмите кнопку Выбрать таблицу.

  2. На вкладке Главная в группе Буфер обмена нажмите кнопку Буфер обмена.

  3. В группе Буфер обмена нажмите стрелку под командой Вставить и выберите команду Специальная вставка.

  4. Выберите пункт Рисунок (расширенный метафайл) и нажмите кнопку ОК.

    При использовании формата расширенного метафайла предотвращается ухудшение качества изображения вставляемой таблицы.

  5. В разделе Работа с рисунками на вкладке Формат в группе Упорядочить нажмите кнопку Группа Изображение кнопки и нажмите кнопку Разгруппировать Изображение кнопки .

    Вкладка «Работа с рисунками»

    В ответ на предложение преобразовать рисунок в графический объект Microsoft Office нажмите кнопку Да. Для получения дополнительных сведений о процессе преобразования нажмите кнопку Показать справку.

  6. В разделе Средства рисования на вкладке Формат в группе Упорядочить нажмите кнопку Группа Изображение кнопки и нажмите кнопку Разгруппировать Изображение кнопки .

    Изображение вкладки "Формат" окна "Средства рисования"

  7. Удерживая клавишу CTRL выберите элементы таблицы, который вы хотите добавить анимацию и в группе Упорядочить нажмите кнопку Группа Изображение кнопки и нажмите кнопку Группа Изображение кнопки в раскрывающемся списке.

  8. На вкладке Анимация в группе Анимация выберите пункт Настройка анимации.

  9. В области задач Настройка анимации нажмите кнопку Добавить эффект и выполните одно или несколько действий, перечисленных ниже.

    • Чтобы появление фигур сопровождалось эффектом, укажите пункт Вход и выберите эффект.

    • Чтобы добавить эффект к фигурам (например эффект вращения), укажите пункт Выделение и выберите эффект.

    • Чтобы добавить эффект исчезновения фигур из слайда в какой-то момент, укажите пункт Выход и выберите эффект.

    • Чтобы добавить эффект перемещения фигуры по указанному образцу, укажите пункт Пути перемещения и выберите путь.

  10. Чтобы задать способ применения эффекта к фигуре, щелкните правой кнопкой мыши настраиваемый эффект анимации в списке Настройка анимации и выберите команду Параметры эффектов.

  11. На вкладках Эффект и Время выберите нужные параметры.

Совет : Если нежелательно преобразовывать таблицу в рисунок для добавления анимации, можно создать отдельные таблицы для каждой части, которую требуется анимировать. Например, если нужно, чтобы данные появлялись отдельно от строки заголовков таблицы, первая таблица должна включать сведения строки заголовков, а вторая таблица – данные. Выровняйте обе таблицы по левому краю, совместив нижнюю часть первой таблицы (строки заголовков) с верхней частью второй таблицы (данных) таким образом, чтобы они выглядели как одна таблица. Затем для достижения желаемого эффекта примените анимацию отдельно к каждой таблице.

Изображение двух таблиц, которые выглядят как одна

1. Две отдельных таблицы без выравнивания

2. Две таблицы, которые в результате выравнивания выглядят как одна

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

См. также

Форум сообщества: как анимировать таблицы...?

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×