Utilizar funções e funções aninhadas em fórmulas do Excel

As funções são fórmulas predefinidas que efetuam cálculos através de valores específicos denominados argumentos, com uma determinada ordem ou estrutura. As funções podem ser utilizadas para efetuar cálculos simples ou complexos. Pode encontrar todas as funções do Excel no separador Fórmulas no Friso:

O separador Fórmulas do Excel no Friso
  • Sintaxe de funções do Excel

    O exemplo seguinte de uma função ARRED a arredondar um número na célula A10 ilustra a sintaxe de uma função.

    Estrutura de uma função

    1. Estrutura. A estrutura de uma função começa com um sinal de igual (=), seguido do nome da função, um parêntese de abertura, os argumentos da função separados por vírgulas e um parêntese de fecho.

    2. Nome da função. Para obter uma lista de funções disponíveis, clique numa célula e prima Shift+F3 de formar a abrir a caixa de diálogo Inserir Função.

    Fórmulas do Excel – caixa de diálogo Inserir Função

    3. Argumentos. Os argumentos podem ser números, texto, valores lógicos como VERDADEIRO ou FALSO, matrizes, valores de erro do tipo #N/D ou referências de célula. O argumento que indicar deve produzir um valor válido para esse argumento. Os argumentos também podem ser constantes, fórmulas ou outras funções.

    4. Descrição do argumento. É apresentada uma descrição com a sintaxe e os argumentos à medida que for escrevendo a função. Por exemplo, escreva =ARRED( para que a descrição seja apresentada. As descrições só são apresentadas para funções incorporadas.

    Nota: Não precisa de escrever as funções em maiúsculas, como =ARRED, uma vez que o Excel irá alterar automaticamente o nome da função para maiúsculas ao premir a tecla Enter. Se escrever incorretamente o nome de uma função, por exemplo =SUMA(A1:A10) em vez de =SOMA(A1:A10), o Excel irá devolver o erro #NOME?

  • Introduzir funções do Excel

    Quando cria uma fórmula que contém uma função, pode utilizar a caixa de diálogo Inserir Função para ajudá-lo a introduzir funções de folha de cálculo. Após selecionar uma função na caixa de diálogo Inserir Função, o Excel irá iniciar o assistente de funções, que apresenta o nome da função, cada um dos respetivos argumentos, uma descrição da função e de cada argumento, o resultado atual da função e o resultado atual de toda a fórmula.

    Assistente de Funções do Excel

    Para facilitar a criação e edição de fórmulas e reduzir a quantidade de erros de escrita e de sintaxe, utilize a Conclusão Automática de Fórmulas. Depois de escrever um = (sinal de igual) e as primeiras letras de uma função, o Excel apresenta uma lista pendente dinâmica de funções, argumentos e nomes válidos que correspondem a essas letras. Em seguida, pode selecionar uma das opções na lista pendente e o Excel irá introduzi-la automaticamente.

    Conclusão Automática de Fórmulas do Excel

  • Aninhar funções do Excel

    Em certos casos, poderá ter de utilizar uma função como um dos argumentos de outra função. Por exemplo, a fórmula que se segue utiliza uma função MÉDIA aninhada e compara o resultado com o valor 50.

    Funções aninhadas

    1. As funções MÉDIA e SOMA estão aninhadas na função SE.

    Devoluções válidas    Quando uma função aninhada é utilizada como um argumento, a função aninhada tem de devolver o mesmo tipo de valor utilizado pelo argumento. Por exemplo, se o argumento devolver um valor do tipo VERDADEIRO ou FALSO, a função aninhada terá de devolver um valor VERDADEIRO ou FALSO. Se a função não o fizer, o Excel apresentará um valor de erro #VALOR!.

    Aninhamento dos limites dos níveis    Uma fórmula pode conter até sete níveis de funções aninhadas. Quando uma função (que iremos designar por Função B) é utilizada como um argumento noutra função (a que iremos chamar Função A), a Função B atua como uma função de segundo nível. Por exemplo, a função MÉDIA e a função SOMA são ambas funções de segundo nível se forem utilizadas como argumentos da função SE. Uma função aninhada dentro da função MÉDIA aninhada seria uma função de terceiro nível e assim sucessivamente.

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×