Utilizar funções aninhadas numa fórmula

Nota:  Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Utilizar uma função, tal como um dos argumentos numa fórmula que utiliza uma função chama-aninhamento e podemos irá referir-se a essa função como uma função aninhada. Por exemplo, ao aninhar a função média e soma nos argumentos da função se, a fórmula seguinte soma um conjunto de números (G2: G5) apenas se a média de outro conjunto de números (F2: F5) for maior que 50. Caso contrário, devolve 0.

Funções aninhadas

As funções média e soma estão aninhadas a função se.

Pode aninhar até 64 níveis de funções numa fórmula.

  1. Clique na célula na qual pretende introduzir a fórmula.

  2. Para iniciar a fórmula com a função, clique em Inserir função imagem de botão na fórmula imagem de botão da barra.

    O Excel insere o sinal de igual (=) automaticamente.

  3. Na caixa Ou selecione uma categoria, selecione Todas.

    Se estiver familiarizado com as categorias de função, também pode selecionar uma categoria.

    Se não tiver a certeza sobre que função utilizar, escreva uma pergunta que descreva o que quer fazer na caixa Procurar uma função (por exemplo, "somar números" devolve a função SOMA).

  4. Para introduzir outra função como argumento, introduza a função na caixa de argumento pretendida.

    As partes da fórmula apresentadas na caixa de diálogo Argumentos de Função refletem a função selecionada no passo anterior.

    Se clicou em SE, a caixa de diálogo Argumentos da função apresenta os argumentos da função SE. Para aninhar outra função, pode introduzi-la na caixa de argumento. Por exemplo, pode introduzir SOMA(G2:G5) na caixa Valor_se_verdadeiro da funçãoSE.

  5. Introduza os argumentos adicionais necessários para preencher a sua fórmula.

    Em vez de introduzir referências de célula, pode selecionar as células que quer referenciar. Clique em imagem de botão para minimizar a caixa de diálogo, selecione as células que pretende referenciar e, em seguida, clique em Imagem de botão para voltar a expandir a caixa de diálogo.

    Sugestão: Para saber mais sobre a função e o seus argumentos, clique em Ajuda sobre esta função.

  6. Depois de completar os argumentos para a fórmula, clique em OK.

  1. Clique na célula na qual pretende introduzir a fórmula.

  2. Para iniciar a fórmula com a função, clique em Inserir função imagem de botão na fórmula imagem de botão da barra.

  3. Na caixa de diálogo Inserir função, na caixa Escolha uma categoria, selecione Tudo.

    Se estiver familiarizado com as categorias de função, também pode selecionar uma categoria.

  4. Para introduzir outra função como um argumento, introduza a função na caixa de argumento no construtor de fórmulas ou diretamente na célula.

  5. Introduza os argumentos adicionais necessários para preencher a sua fórmula.

  6. Depois de concluir os argumentos para a fórmula, prima ENTER.

Exemplos

A imagem seguinte mostra um exemplo de utilização de se funções para atribuir uma classificação por letra à um valor numérico testar pontuação aninhadas.

Copie os dados de exemplo que se encontram na seguinte tabela e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem os resultados, selecione-as, prima F2 e, em seguida, prima Enter. Caso seja necessário, pode ajustar a largura das colunas para ver todos os dados.

Pontuação

45

90

78

Fórmula

Descrição

Resultado

'=SE(A2>89,"A",SE(A2>79,"B", SE(A2>69,"C",SE(A2>59,"D","F"))))

Utiliza condições aninhadas SE para atribuir uma nota (letra) à pontuação na célula A2.

=SE(A2>89,"A",SE(A2>79,"B",SE(A2>69,"C",SE(A2>59,"D","F"))))

'=SE(A3>89,"A",SE(A3>79,"B", SE(A3>69,"C",SE(A3>59,"D","F"))))

Utiliza condições aninhadas SE para atribuir uma nota (letra) à pontuação na célula A3.

=SE(A3>89,"A",SE(A3>79,"B",SE(A3>69,"C",SE(A3>59,"D","F"))))

'=SE(A4>89,"A",SE(A4>79,"B", SE(A4>69,"C",SE(A4>59,"D","F"))))

Utiliza condições aninhadas SE para atribuir uma nota (letra) à pontuação na célula A4.

=SE(A4>89,"A",SE(A4>79,"B",SE(A4>69,"C",SE(A4>59,"D","F"))))

Sugestões: 

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no User Voice do Excel.

Consulte Também

Vídeo: Funções funções se aninhadas

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×