TIPO.ERRO (função TIPO.ERRO)

Este artigo descreve a sintaxe da fórmula e a utilização da função TIPO.ERRO no Microsoft Excel.

Descrição

Devolve um número que corresponde a um dos valores de erro do Microsoft Excel ou devolve o valor de erro #N/D se não existir um erro. Pode utilizar TIPO.ERRO numa função SE para testar um valor de erro e devolver uma cadeia de texto, como uma mensagem, em vez do valor de erro.

Sintaxe

TIPO.ERRO(val_erro)

A sintaxe da função TIPO.ERRO tem os seguintes argumentos:

  • Val_erro    obrigatório. O valor de erro cujo número de identificação deseja localizar. Apesar de val_erro poder ser o valor de erro real, ele é normalmente uma referência a uma célula que contém uma fórmula que deseja testar.

Se val_erro for

TIPO.ERRO devolve

#NULO!

1

#DIV/0!

2

#VALOR!

3

#REF!

4

#NOME?

5

#NÚM!

6

#N/D

7

#OBTER_DADOS

8

Outros

#N/D

Exemplo

Copie os dados de exemplo na tabela seguinte e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem resultados, selecione-as, prima F2 e, em seguida, prima ENTER. Se pretender, pode ajustar as larguras das colunas para ver todos os dados.

Dados

#NULO!

#DIV/0!

Fórmula

Descrição

Resultado

=TIPO.ERRO(A2)

Número do Erro #NULO! (1).

1

=SE(TIPO.ERRO(A3)<3;SELECIONAR(TIPO.ERRO(A3);"Os intervalos não se intercetam";"O divisor é zero"))

Verifica a célula A3 para observar se a célula tem o valor de erro #NULO! ou o valor de erro #DIV/0!. Se for esse o caso, o número para o valor de erro é utilizado na função SELECIONAR da folha de cálculo, para apresentar uma de duas mensagens; caso contrário, o valor de erro #N/D é devolvido.

O divisor é zero

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×