SOMARPRODUTO (função SOMARPRODUTO)

Este artigo descreve a sintaxe da fórmula e a utilização da função SOMARPRODUTO no Microsoft Excel.

Descrição

Multiplica os componentes correspondentes nas matrizes fornecidas e devolve a soma destes produtos.

Sintaxe

SOMARPRODUTO(matriz1; [matriz2]; [matriz3]; ...)

A sintaxe da função SOMARPRODUTO tem os seguintes argumentos:

  • Matriz1     Obrigatório. O primeiro argumento de matriz cujos componentes pretende multiplicar e, em seguida, adicionar.

  • Matriz2; Matriz3; ...     Opcional. São 2 a 255 argumentos de matriz cujos componentes pretende multiplicar e, em seguida, adicionar.

Comentários

  • Os argumentos de matriz têm de ter a mesma dimensão. Se não tiverem, SOMARPRODUTO devolve o valor de erro #VALOR!.

  • SOMARPRODUTO trata as entradas da matriz não numéricas como se fossem zeros.

Exemplo

Copie os dados de exemplo na tabela seguinte e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem resultados, selecione-as, prima F2 e, em seguida, prima ENTER. Se pretender, pode ajustar as larguras das colunas para ver todos os dados.

Matriz 1

Matriz 2

3

4

2

7

8

6

6

7

1

9

5

3

Fórmula

Descrição

Resultado

=SOMARPRODUTO(A2:B4; D2:E4)

Multiplica todos os componentes das duas matrizes e, depois, adiciona os produtos, ou seja, 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156)

156

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×