Somar números

Nota:  Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Imaginemos que pretende calcular um preço total para o inventário de uma loja ou as margens de lucro brutas totais de todos os departamentos que estão abaixo do orçamento anual. Existem várias formas de adicionar números. Para uma forma mais rápida de adicionar números em células, utilize + (sinal de adição) numa fórmula.

Por exemplo, se escrever =5+10, a célula apresenta 15 como o resultado.

Adicionar todos os números numa linha ou coluna

Se tiver um intervalo de números adjacentes (ou seja, não existem sem células em branco), pode utilizar a Soma automática imagem de botão .

  1. Clique numa célula abaixo da coluna de números ou à direita da linha de números.

  2. Clique em Base > Soma Automática e, em seguida, prima ENTER.

Adicionar números não adjacentes

Se tiver um intervalo de números que inclui células em branco ou células que têm texto em vez de números, utilize a função soma numa fórmula. Apesar de eles poderão ser incluídos no intervalo que é utilizado na fórmula, quaisquer células em branco e as células que têm texto são ignoradas.

Exemplo

Este livro apresenta exemplos desta função. Inspecione-os, altere as fórmulas existentes ou introduza as suas próprias fórmulas para saber como trabalhar com a função.

Nota: A função SOMA pode incluir qualquer combinação até 30 referências de célula ou intervalo. Por exemplo, a fórmula =SOMA(B2:B3;B5) contém uma referência de intervalo (B2:B3) e uma célula (B5).

Adicionar números com base numa condição

Pode utilizar a função SOMA.se para criar um valor total para um intervalo com base num valor noutro intervalo. No exemplo seguinte, que pretende criar um total apenas para os valores na coluna B (fatura) que correspondem aos valores na coluna A (vendedor) para o vendedor Ferreira com o nome.

Exemplo

Este livro apresenta exemplos da função SOMA.SE. Inspecione-os, altere as fórmulas existentes ou introduza as suas próprias fórmulas para saber como a função funciona.

Adicionar números com base em várias condições

Para executar esta tarefa, utilize a função SOMA.se.S.

Exemplo

Este livro apresenta exemplos desta função. Inspecione-os, altere as fórmulas existentes ou introduza as suas próprias fórmulas para saber como trabalhar com a função.

Como são utilizadas as funções no exemplo SOMA.SE.S

=SOMA.SE.S(D2:D11;A2:A11;"Sul";C2:C11;"Carne")

A função SOMA.SE.S é utilizada na primeira fórmula para localizar linhas nas quais "Sul" esteja na coluna A e "Carne" esteja na coluna C. Existem três casos desta situação; nas linhas 7, 8 e 11. A função verifica primeiro a coluna A, que contém as regiões, para localizar uma correspondência para "Sul". Em seguida, verifica a coluna C, que contém o tipo de alimentos, para localizar uma correspondência para "Carne". Finalmente, a função verifica o intervalo que contém os valores a adicionar, D2:D11 e soma apenas os valores nessa coluna que satisfazem essas duas condições.

=SOMA(SE((A2:A11="Sul")+(A2:A11="Este");D2:D11))

A segunda fórmula, que utiliza as funções SOMA e SE, é introduzida como uma fórmula de matriz (para alterar as matrizes, clique em Abrir no Excel) para localizar linhas nas quais "Sul" e/ou "Este" se encontrem na coluna A. Existem sete casos desta situação; nas linhas 2, 4, 6, 7, 8, 9 e 11. Uma vez que esta fórmula é uma fórmula de matriz, o operador + não é utilizado para adicionar valores; é utilizado para verificar duas ou mais condições, em que pelo menos uma tem de ser satisfeita. Em seguida, a função SOMA é utilizada para adicionar os valores que satisfazem esses critérios.

Adicionar apenas valores exclusivos

Para executar esta tarefa, utilize uma combinação da Soma, see frequência funções.

O exemplo seguinte utiliza a:

  • Função FREQUÊNCIA para identificar os valores exclusivos num intervalo. Na primeira ocorrência de um valor específico, esta função devolve um número igual ao número de ocorrências desse valor. Para cada ocorrência desse mesmo valor depois da primeira ocorrência, esta função devolve um 0 (zero).

  • Função SE para atribuir um valor de 1 a cada condição verdadeira.

  • Função SOMA para somar os valores exclusivos.

Exemplo

Este livro mostra exemplos destas funções. Inspecione-os, altere as fórmulas existentes ou introduza as suas próprias fórmulas para saber como as funções funcionam.

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×