Fórmulas e funções

Função SOMA

SOMA (função SOMA)

A função soma adiciona valores. Pode adicionar valores individuais, referências de células, intervalos ou uma combinação dos três.

Por exemplo:

  • =SOMA(A2:A10) Soma os valores nas células a2:10.

  • =SOMA(A2:A10; C2:C10) Soma os valores nas células a2:10, bem como nas células C2: C10.

O seu browser não suporta vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

SOMA(número1,[número2],...)

Nome do argumento

Descrição

número1   

Obrigatório

O primeiro número que pretende somar. O número pode ser 4, uma referência da célula como B6 ou um intervalo de células como B2:B8.

número2-255   

Opcional

Este é o segundo número que quer adicionar. Pode especificar até 255 números desta forma.

Esta secção irá debater algumas das melhores práticas para trabalhar com a função SOMA. Muitas destas práticas também se podem aplicar quando trabalha com outras funções.

O Método =1+2 ou =A+B – apesar de poder introduzir =1+2+3 ou =A1+B1+C2 e obter resultados corretos, estes métodos são propensos a erros por diversas razões:

  1. Erros de digitação – imagine tentar introduzir mais valores e/ou valores muito maiores, como estes:

    • =14598,93+65437,90+78496,23

    E, em seguida, tentar confirmar que as suas entradas estão corretas. É muito mais fácil colocar estes valores em células individuais e utilizar a fórmula SOMA. Além disso, pode formatar os valores quando estes se encontram em células, tornando-os muito mais legíveis quando estes se encontrarem numa fórmula.

    Utilize a função SOMA em vez de incluir os valores nas fórmulas.  A fórmula na célula D5 é =SOMA(D2:D4)
  2. Obtém o erro #VALOR! devido a referências de texto em vez de números

    Se utilizar uma fórmula como:

    • =A1+B1+C1 ou =A1+A2+A3

    Exemplo de uma construção de fórmula incorreta.  A fórmula da célula D2 é =A2+B2+C2

    A sua fórmula poderá não funcionar se existirem valores não numéricos (de texto) nas células referenciadas, o que irá devolver um erro #VALOR! . A função SOMA irá ignorar os valores de texto e devolver-lhe apenas a soma dos valores numéricos.

    Construção adequada de fórmulas.  Em vez de =A2+B2+C2, a fórmula da célula D2 é =SOMA(A2:C2)
  3. Obtém o erro #REF! ao eliminar linhas ou colunas

    Erro #REF! causado pela eliminação de uma coluna.  A fórmula mudou para =A2+#REF!+B2

    Se eliminar uma linha ou coluna, a fórmula não será atualizada de forma a excluir a linha eliminada e irá devolver um erro #REF!, ao passo que uma função SOMA faz automaticamente a atualização.

    A função SOMA ajusta-se automaticamente a linhas e colunas inseridas ou eliminadas
  4. As fórmulas não atualizam as referências quando introduz linhas ou colunas

    Se adicionar linhas, as fórmulas =A+B+C não serão atualizadas

    Se inserir uma linha ou coluna, a fórmula não será atualizada de forma a incluir a linha adicionada, ao passo que a função SOMA é automaticamente atualizada (desde que não se encontre fora do intervalo referenciado na fórmula). Isto é especialmente importante se esperar que a fórmula seja atualizada e esta não o for, pois pode ter consequências como resultados incompletos dos quais poderá não se aperceber.

    O exemplo retrata uma fórmula SOMA que se expande automaticamente de =SOMA(A2:C2) a =SOMA(A2:D2) quando uma coluna é inserida
  5. SOMA com Referências de Célula individuais vs. Intervalos

    Utilizar uma fórmula como:

    • =SOMA(A1;A2;A3;B1;B2;B3)

    É igualmente suscetível de erro ao inserir ou eliminar linhas no intervalo referenciado pelas mesmas razões. É muito mais simples utilizar intervalos individuais, como:

    • =SOMA(A1:A3;B1:B3)

    Que serão atualizados quando adicionar ou eliminar linhas.

  1. Quero apenas Adicionar/Subtrair/Multiplicar/Dividir números Veja esta série de vídeos sobre Matemática Básica no Excel ou Utilizar o Excel como a sua calculadora.

  2. Como posso mostrar mais/menos casas decimais? Pode alterar o formato de número. Selecione a célula ou intervalo em questão e utilize Ctrl+1 para apresentar a caixa de diálogo Formatar Células e, em seguida, clique no separador Número e selecione o formato pretendido, garantindo que indica o número de casas decimais que pretende.

  3. Como posso somar ou subtrair horas? Pode somar e subtrair horas de formas diferentes. Por exemplo, para obter a diferença entre 8:00 – 12:00 para efeitos de folha de pagamentos deveria utilizar: =("12:00"–"8:00")*24, a hora de fim menos a hora de início. Tenha em atenção que o Excel calcula as horas como uma fração de um dia, pelo que precisa de multiplicar por 24 para obter as horas totais. No primeiro exemplo estamos a utilizar =((B2-A2)+(D2-C2))*24 para obter a soma das horas do início ao fim, menos uma hora de almoço (total de 8,50 horas).

    Se estiver a adicionar horas e minutos e quiser apresentar dessa forma, pode somar e não precisa de multiplicar por 24, pelo que no segundo exemplo estamos a utilizar =SOMA(A6:C6) uma vez que só precisamos do número total de horas e minutos para as tarefas atribuídas (5:36 ou 5 horas, 36 minutos).

    Calcular horas

    Para obter mais informações, consulte: Somar ou subtrair horas

  4. Como posso obter a diferença entre datas? Tal como acontece com as horas, pode adicionar e subtrair datas. Eis um exemplo muito comum de como contar o número de dias entre duas datas. É tão simples como =B2-A2. O segredo para trabalhar com Datas e Horas é que começa com a Data/Hora de Fim e subtrai a Data/Hora de Início.

    Calcular diferenças entre as datas

    Para ver mais formas de trabalhar com datas, consulte: Calcular a diferença entre duas datas.

  5. Como posso somar apenas células visíveis? Por vezes, ao ocultar manualmente linhas ou utilizar o Filtro Automático para apresentar apenas determinados dados também só pretende somar as células visíveis. Pode utilizar a função SUBTOTAL. Se estiver a utilizar uma linha total numa tabela do Excel, qualquer função que selecione a partir da lista pendente Total será introduzida automaticamente como um subtotal. Consulte mais informações sobre como Calcular o total dos dados numa tabela do Excel.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no User Voice do Excel.

Consulte Também

Saiba mais sobre a função SOMA

A função SOMA.SE soma apenas os valores que correspondem a um único critério

A função SOMA.SE.S soma apenas os valores que correspondem a múltiplos critérios

A função CONTAR.SE conta apenas os valores que correspondem a um único critério

A função CONTAR.SE.S conta apenas os valores que correspondem a múltiplos critérios

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Localizar e corrigir erros em fórmulas

Problemas comuns de fórmulas e como corrigi-los

Funções de Matemática e Trigonometria

Funções do Excel (por ordem alfabética)

Funções do Excel (por Categoria)

Nota:  Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode indicar-nos se estas informações foram úteis? Eis o artigo em inglês para sua referência.​

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×