Fórmulas e funções

Função SOMA

SOMA (função SOMA)

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

A função Soma , uma das funções matemáticas e trigonométricas, adiciona os valores. Pode adicionar valores individuais, referências de células ou intervalos ou uma mistura de todos os três.

Por exemplo:

  • =SOMA(A2:A10)

  • =SOMA(A2:A10; C2:C10)

O seu browser não suporta vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

SOMA(número1,[número2],...)

Nome do argumento

Descrição

número1   . (Obrigatório)

O primeiro número que pretende somar. O número pode ser 4, uma referência da célula como B6 ou um intervalo de células como B2:B8.

número2-255    (Opcional)

Este é o segundo número que quer adicionar. Pode especificar até 255 números desta forma.

Esta secção vai abordar algumas das melhores práticas para trabalhar com a função SOMA. Muitas disto podem ser aplicada a trabalhar com outras funções também.

O Método =1+2 ou =A+B – apesar de poder introduzir =1+2+3 ou =A1+B1+C2 e obter resultados corretos, estes métodos são propensos a erros por diversas razões:

  1. Erros de digitação – imagine tentar introduzir mais valores e/ou valores muito maiores, como estes:

    • =14598,93+65437,90+78496,23

    Em seguida, tente validar se as entradas estão corretas. É muito mais fácil colocar estes valores em células individuais e utilizar uma fórmula de soma. Além disso, pode formatar os valores quando estiverem nas células, tornando-as muito mais legível, em seguida, quando se encontram uma fórmula.

    Utilize a função SOMA em vez de incluir os valores nas fórmulas.  A fórmula na célula D5 é =SOMA(D2:D4)
  2. Obtém o erro #VALOR! devido a referências de texto em vez de números

    Se utilizar uma fórmula como:

    • =A1+B1+C1 ou =A1+A2+A3

    Exemplo de uma construção de fórmula incorreta.  A fórmula da célula D2 é =A2+B2+C2

    Pode interromper a sua fórmula se não existirem quaisquer valores não numéricos (texto) nas células referenciadas, irão devolvem uma #VALUE! Ocorreu um erro. Soma irá ignorar valores de texto e dar-lhe a soma dos valores numéricos.

    Construção adequada de fórmulas.  Em vez de =A2+B2+C2, a fórmula da célula D2 é =SOMA(A2:C2)
  3. Obtém o erro #REF! ao eliminar linhas ou colunas

    Erro #REF! causado pela eliminação de uma coluna.  A fórmula mudou para =A2+#REF!+B2

    Se eliminar uma linha ou coluna, a fórmula não será atualizada de forma a excluir a linha eliminada e irá devolver um erro #REF!, ao passo que uma função SOMA faz automaticamente a atualização.

    A função SOMA ajusta-se automaticamente a linhas e colunas inseridas ou eliminadas
  4. As fórmulas não atualizam as referências quando introduz linhas ou colunas

    Se adicionar linhas, as fórmulas =A+B+C não serão atualizadas

    Se inserir uma linha ou coluna, a fórmula não irão atualizar para incluir a linha adicionada, onde uma função de soma irá atualizar automaticamente (desde que não estiver fora do intervalo de referenciados na fórmula). Este é particularmente importante se espera que a fórmula para atualizar e não tiver, tal como-irão deixá-lo com resultados incompletos que não poderá detectar.

    O exemplo retrata uma fórmula SOMA que se expande automaticamente de =SOMA(A2:C2) a =SOMA(A2:D2) quando uma coluna é inserida
  5. SOMA com Referências de Célula individuais vs. Intervalos

    Utilizar uma fórmula como:

    • =SOMA(A1;A2;A3;B1;B2;B3)

    É igualmente erro sujeito ao inserir ou eliminar linhas dentro do intervalo referenciada pelas mesmas razões. É muito melhor utilizar intervalos individuais, como:

    • =SOMA(A1:A3;B1:B3)

    Que serão atualizados quando adicionar ou eliminar linhas.

Problema

O que correu mal

A minha função SOMA mostra ##### em vez do resultado.

Verifique a sua largura da coluna. # # # normalmente significa que a coluna é demasiado estreita para apresentar o resultado da fórmula.

A minha função SOMA mostra a própria fórmula como texto, não o resultado.

Verifique que a célula não estiver formatada como texto. Selecione a célula ou intervalo em questão e utilize Ctrl + 1 para apresentar a caixa de diálogo Formatar células , em seguida, clique em separador do número e selecione o formato que pretende. Se a célula foi formatada como texto e não altera depois de alterar o formato, poderá ter de utilizar F2 > Enter para forçar o formato para alterar.

A minha função SOMA não é atualizada.

Certifique-se de que o cálculo está definido para Automático. No separador fórmula , aceda a Opções de cálculo. Também pode utilizar F9 para forçar a folha de cálculo para calcular.

Certifique-se de que o cálculo está definido para Automático.  No separador Fórmula, aceda a Opções de Cálculo.

Alguns valores não foram adicionados.

Apenas os valores numéricos no intervalo ou referência da função podem ser adicionados. As células vazias, os valores lógicos como VERDADEIRO ou o texto são ignorados.

O erro #NOME? é apresentado em vez do resultado esperado.

Geralmente, isto significa que a fórmula está mal escrita, como por exemplo =some(A1:A10) em vez de =SOMA(A1:A10).

A minha função SOMA mostra um número inteiro, mas devia mostrar números decimais

Verifique a formatação da célula para garantir que está a apresentar números decimais. Selecione a célula ou intervalo em questão e utilize Ctrl+1 para apresentar a caixa de diálogo Formatar Células e, em seguida, clique no separador Número e selecione o formato pretendido, garantindo que indica o número de casas decimais que pretende.

  1. Quero apenas Adicionar/Subtrair/Multiplicar/Dividir números Veja esta série de vídeos sobre Matemática Básica no Excel ou Utilizar o Excel como a sua calculadora.

  2. Como mostrar mais/menos casas decimais? Pode alterar o formato do número. Selecione a célula ou intervalo em questão e utilize Ctrl + 1 para apresentar a caixa de diálogo Formatar células , em seguida, clique no separador número e selecione o formato que pretende, certificando-se indicar o número de casas decimais que pretende.

  3. Como posso somar ou subtrair horas? Pode somar e subtrair horas de formas diferentes. Por exemplo, para obter a diferença entre 8:00 – 12:00 para efeitos de folha de pagamentos deveria utilizar: =("12:00"–"8:00")*24, a hora de fim menos a hora de início. Tenha em atenção que o Excel calcula as horas como uma fração de um dia, pelo que precisa de multiplicar por 24 para obter as horas totais. No primeiro exemplo estamos a utilizar =((B2-A2)+(D2-C2))*24 para obter a soma das horas do início ao fim, menos uma hora de almoço (total de 8,50 horas).

    Se estiver a adicionar horas e minutos e quiser apresentar dessa forma, pode somar e não precisa de multiplicar por 24, pelo que no segundo exemplo estamos a utilizar =SUM(A6:C6) uma vez que só precisamos do número total de horas e minutos para as tarefas atribuídas (5:36 ou 5 horas, 36 minutos).

    Calcular horas

    Para obter mais informações, consulte: Somar ou subtrair horas

  4. Como obter a diferença entre datas? Tal como acontece com horas, pode adicionar e subtrair datas. Eis um exemplo muito comuns de contagem do número de dias entre duas datas. É tão simple como = B2 A2. A chave para trabalhar com datas e horas é que começa com a data/hora de fim e subtrair a começar a data/hora.

    Calcular diferenças entre as datas

    Para ver mais formas de trabalhar com datas, consulte: Calcular o número de dias entre duas datas.

  5. Como posso somar apenas células visíveis? Por vezes, ao ocultar manualmente linhas ou utilizar o Filtro Automático para apresentar apenas determinados dados também só pretende somar as células visíveis. Pode utilizar a função SUBTOTAL. Se estiver a utilizar uma linha total numa tabela do Excel, qualquer função que selecione a partir da lista pendente Total será introduzida automaticamente como um subtotal. Consulte mais informações sobre como Calcular o total dos dados numa tabela do Excel.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no User Voice do Excel.

Consulte Também

Saber mais sobre soma

A função SOMA.se soma apenas os valores que correspondam a um único critério

Função SOMA.se.S a soma apenas os valores que correspondam a vários critérios

Função contar.Se a conta apenas os valores que correspondam a um único critério

Função contar.se.S a conta apenas os valores que correspondam a vários critérios

Descrição geral das fórmulas no Excel

Como evitar fórmulas quebradas

Localizar e corrigir erros em fórmulas

Atalhos de teclado no Excel para Windows

Atalhos de teclado no Excel para Mac

Matemática e trigonometria funções

Funções do Excel (por ordem alfabética)

Funções do Excel (por categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×