SELECCIONAR (função SELECCIONAR)

SELECCIONAR (função SELECCIONAR)

Este artigo descreve a sintaxe da fórmula e a utilização da função SELECIONAR no Microsoft Excel.

Descrição

Utilize núm_índice para devolver um valor da lista de argumentos de valor. Utilize SELECIONAR para SELECIONAR um valor de entre 254 valores que se baseiem no número de índice. Por exemplo, se valor1 até valor7 forem os dias da semana, SELECIONAR devolve um dos dias quando um número entre 1 e 7 é utilizado como núm_índice.

Sintaxe

SELECIONAR(núm_índice, valor1, [valor2], ...)

A sintaxe da função SELECIONAR tem os seguintes argumentos:

  • Núm_índice    Obrigatório. Especifica qual o argumento de valor selecionado. Núm_índice tem de ser um número entre 1 e 254 ou uma fórmula ou referência a uma célula que contenha um número entre 1 e 254.

    • Se núm_índice for 1, SELECIONAR devolve valor1; se for 2, SELECIONAR devolve valor2; e assim sucessivamente.

    • Se núm_índice for menor que 1 ou maior que o número do último valor na lista, SELECIONAR devolve o valor de erro #VALOR!

    • Se núm_índice for uma fração, é truncado para o menor inteiro antes de ser utilizada.

  • Valor1; valor2; ...     Valor 1 é obrigatório, os valores posteriores são opcionais. 1 a 254 argumentos de valores a partir dos quais SELECIONAR seleciona um valor ou uma ação que será executada com base no núm_índice. Os argumentos podem ser números, referências de célula, nomes definidos, fórmulas, funções ou texto.

Observações

  • Se núm_índice for uma matriz, cada valor é avaliado quando SELECIONAR for avaliada.

  • Os argumentos de valor para SELECIONAR podem ser referências de intervalo, bem como valores únicos.

    Por exemplo, a fórmula:

=SOMA(SELECIONAR(2,A1:A10,B1:B10,C1:C10))

avaliada para:

=SOMA(B1:B10)

que depois devolve um valor baseado nos valores do intervalo B1:B10.

A função SELECIONAR é a primeira a ser avaliada, devolvendo a referência B1:B10. A função SOMA é avaliada em seguida, utilizando B1:B10, o resultado da função SELECIONAR, como argumento.

Exemplos

Copie os dados de exemplo que se encontram na seguinte tabela e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem resultados, selecione-as, prima F2 e, em seguida, prima ENTER. Se pretender, pode ajustar as larguras das colunas para ver todos os dados.

Dados

 

1.º

Pregos

2.º

Roscas

3.º

Porcas

Terminado

Parafusos

Fórmula

Descrição

Resultado

=SELECIONAR(2;A2;A3;A4;A5)

Valor do segundo argumento da lista (valor da célula A3)

2.º

=SELECIONAR(4;B2;B3;B4;B5)

Valor do quarto argumento da lista (valor da célula B5)

Parafusos

=SELECIONAR (3;"Wide";115;"world";8)

Valor do terceiro argumento da lista

mundo

Exemplo 2

Dados

23

45

12

10

Fórmula

Descrição (Resultado)

Resultado

=SOMA(A2:SELECIONAR(2,A3,A4,A5))

Calcula a soma do intervalo A2:A4. A função SELECIONAR devolve A4 como a segunda parte do intervalo para a função SOMA.

80

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×