Fórmulas e funções

Função SE

SE (função SE)

A função SE é uma das funções mais populares no Excel e permite-lhe fazer comparações lógicas entre um valor e o que está à espera.

Assim, uma instrução SE pode ter dois resultados. O primeiro resultado é se a sua comparação for considerada Verdadeiro, o segundo se a sua comparação for considerada Falso.

Por exemplo, =SE(C2="Sim";1;2) significa SE(C2 = Sim, então devolver um 1, caso contrário, devolver um 2).

O seu browser não suporta vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Utilize a função SE, uma das funções lógicas, para devolver um valor se uma condição for verdadeira e outro valor se for falsa.

SE(teste_lógico; valor_se_verdadeiro; [valor_se_falso])

Por exemplo:

  • =SE(A2>B2;"Ultrapassou o Orçamento";"OK")

  • =SE(A2=B2;B4-A4;"")

Nome do argumento

Descrição

teste_lógico    (obrigatório)

A condição que pretende testar.

valor_se_verdadeiro    (obrigatório)

O valor que pretende que seja devolvido se o resultado do teste_lógico for VERDADEIRO.

valor_se_falso    (opcional)

O valor que pretende que seja devolvido se o resultado do teste_lógico for FALSO.

Exemplos SE fáceis

A célula D2 contém uma fórmula =SE(C2="Sim";1;2)
  • =SE(C2="Sim";1;2)

No exemplo acima, a célula D2 diz: SE(C2 = Sim, então devolver um 1, caso contrário, devolver um 2)

A célula D2 contém a fórmula =SE(C2=1;"SIM";"NÃO")
  • =SE(C2=1;"Sim";"Não")

Neste exemplo, a fórmula na célula D2 significa: SE(C2 = 1, então devolver Sim, caso contrário, devolver Não)Como pode ver, a função SE pode ser utilizada para avaliar texto e valores. Também pode ser utilizada para avaliar erros. Não está limitado a verificar apenas se uma coisa é igual a outra e devolver um único resultado, também pode utilizar operadores matemáticos e efetuar cálculos adicionais, consoante os seus critérios. Também pode aninhar múltiplas funções SE de forma a efetuar múltiplas comparações.

A fórmula na célula D2 é =SE(C2>B2;"Ultrapassou o Orçamento";"Dentro do Orçamento")
  • =SE(C2>B2;"Ultrapassou o Orçamento";"Dentro do Orçamento")

No exemplo acima, a função SE na célula D2 está a dizer que SE(C2 for Maior do que B2, então devolver "Ultrapassou o Orçamento", caso contrário, devolver "Dentro do Orçamento")

A fórmula na célula E2 é =SE(C2>B2;C2-B2;"")
  • =SE(C2>B2;C2-B2;0)

Na ilustração acima, em vez de devolver um resultado de texto, irá devolver um cálculo matemático. Então, a fórmula na célula E2 está a dizer SE(Real for Maior do que o que está Orçamentado, então Subtrair o montante Orçamentado do montante Real, caso contrário, não devolver nada).

A fórmula na Célula F7 é SE(E7="Sim";F5*0,0825;0)
  • =SE(E7="Sim";F5*0,0825;0)

Neste exemplo, a fórmula na célula F7 está a dizer SE(E7 = "Sim", então calcular o Montante Total em F5 * 8,25%, caso contrário, nenhum Imposto sobre Vendas está em atraso e devolver 0)

Nota: Se utilizar texto nas fórmulas, tem de colocar o texto entre aspas (por exemplo, "Texto"). A única exceção a esta regra é se utilizar VERDADEIRO ou FALSO, que o Excel entenderá automaticamente.

Problemas comuns

Problema

O que correu mal

0 (zero) numa célula

Não existe um argumento para os argumentos valor_se_verdadeiro ou valor_se_falso Para ver o valor correto devolvido, adicione o argumento de texto aos dois argumentos ou adicione VERDADEIRO ou FALSO ao argumento.

#NOME? na célula

Normalmente, isto significa que essa fórmula está mal escrita.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no UserVoice do Excel.

Consulte Também

Operadores de cálculo e ordem de precedência

Utilizar funções aninhadas numa fórmula

Utilizar a função SE para verificar se uma célula está em branco

Utilizar a função SE para verificar se uma célula está em branco

Vídeo: Funções avançadas da função SE

Função SE.S (Office 365, Excel 2016 e posterior)

Funções avançadas da função SE – trabalhar com fórmulas aninhadas e evitar falhas

Vídeos de formação: funções avançadas da função SE

A função CONTAR.SE conta valores com base num único critério

A função CONTAR.SE.S conta valores com base em múltiplos critérios

A função SOMA.SE soma valores com base num único critério

A função SOMA.SE.S soma valores com base em múltiplos critérios

Função E

Função OU

Função PROCV

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detetar erros em fórmulas

Funções lógicas

Funções do Excel (por ordem alfabética)

Funções do Excel (por categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×