SE.ERRO (função SE.ERRO)

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Este artigo descreve a sintaxe da fórmula e a utilização da função SE.ERRO no Microsoft Excel.

Descrição

Devolve um valor definido pelo utilizador se ocorrer um erro na fórmula, e devolve o resultado da fórmula se não ocorrer nenhum erro. Pode utilizar a função SE.ERRO para detetar e tratar erros em fórmula.

Sintaxe

SE.ERRO(valor, valor_se_erro)

A sintaxe da função SE.ERRO tem os seguintes argumentos:

  • Valor    Obrigatório. É o argumento no qual pode ser detetado um erro.

  • valor_se_erro    Obrigatório. É o valor devolvido se ocorrer um erro na fórmula. São detetáveis os seguintes tipos de erro: #N/D, #VALOR!, #REF!, #DIV/0!, #NÚM!, #NOME?, ou #NULO!.

Observações

  • Se os parâmetros Valor ou Valor_se_erro forem uma célula vazia, a função SE.ERRO trata-os como uma cadeia de texto vazia ("").

  • Se o parâmetro Valor for uma fórmula de matriz, a função SE.ERRO devolve uma matriz de resultados para cada célula do intervalo passado nesse parâmetro. Ver segundo exemplo em baixo.

Exemplos

Copie os dados de exemplo que se encontram na seguinte tabela e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem resultados, selecione-as, prima F2 e, em seguida, prima ENTER. Caso seja necessário, pode ajustar a largura das colunas para ver todos os dados.

Quota

Unidades Vendidas

210

35

55

0

23

Fórmula

Descrição

Resultado

=SE.ERRO(A2/B2; "Erro no cálculo")

Verifica se ocorre um erro na fórmula, no primeiro argumento (que divide 210 por 35); não ocorre nenhum erro, portanto devolve o resultado da fórmula

6

=SE.ERRO(A3/B3; "Erro no cálculo")

Verifica se ocorre um erro na fórmula, no primeiro argumento (que divide 55 por 0); deteta o erro de divisão por 0, portanto devolve o valor especificado no parâmetro valor_se_erro

Erro no cálculo

=SE.ERRO(A4/B4; "Erro no cálculo")

Verifica se ocorre um erro na fórmula, no primeiro argumento (que divide "" por 23); não ocorre nenhum erro, portanto devolve o resultado da fórmula.

0

Exemplo 2

Quota

Unidades Vendidas

Razão

210

35

6

55

0

Erro no cálculo

23

0

Fórmula

Descrição

Resultado

=C2

Verifica se ocorre um erro na fórmula, no primeiro argumento, no primeiro elemento da matriz (A2/B2, que divide 210 por 35); não ocorre nenhum erro, portanto devolve o resultado da fórmula

6

=C3

Verifica se ocorre um erro na fórmula, no primeiro argumento, no segundo elemento da matriz (A3/B3, que divide 55 por 0); deteta o erro de divisão por 0, portanto devolve o valor especificado no parâmetro valor_se_erro

Erro no cálculo

=C4

Verifica se ocorre um erro na fórmula, no primeiro argumento, no terceiro elemento da matriz (A4/B4, que divide "" por 23); não ocorre nenhum erro, portanto devolve o resultado da fórmula

0

Nota: a fórmula do exemplo tem de ser introduzida como uma fórmula de matriz. Depois de copiar o exemplo para uma folha de cálculo vazia, selecione o intervalo C2:C4, prima F2 e prima CTRL+SHIFT+ENTER.

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×