Procurar valores com o PROCV, ÍNDICE ou CORRESP

Para localizar um valor numa lista grande, pode utilizar a função de pesquisa. A função PROCV é frequentemente utilizada, mas a função PROCH e a utilização conjunta das funções ÍNDICE e CORRESP também poderá funcionar perfeitamente para si.

Aqui estão as informações da função PROCV e o argumento que utiliza:

=PROCV(<valor de pesquisa>;<intervalo de pesquisa>;<coluna>;<Correspondência aproximada>)

Por exemplo;=PROCV(21500;C2:E7;3;FALSO)

  • O primeiro argumento - um fragmento do qual a função necessita para funcionar - é o valor que pretende procurar. Pode ser uma referência de célula, tal como B2 ou um valor como "botas" ou 21500.

  • O segundo argumento é o intervalo de células que pensa que contém o valor que pretende localizar.

    Importante: Com a função PROCV, a coluna que contém o valor ou referência de célula que procura tem de ser a coluna mais à esquerda no intervalo.

  • O terceiro argumento corresponde à coluna nesse intervalo de pesquisa de células que contém o valor que pretende ver.

Apesar de o quarto argumento ser opcional, a maioria das pessoas introduz FALSO (ou 0). Porquê? Porque, desta forma, força a função a localizar uma correspondência exata na pesquisa. Poderá não introduzir um argumento ou VERDADEIRO. No entanto, se não for encontrada uma correspondência exata, a função devolve a correspondênciaaproximada mais próxima e, normalmente, a maioria das pessoas não pretende uma correspondência aproximada.

Para mostrar como uma correspondência aproximada pode ser um problema sério, imagine que está à procura do preço de uma peça com o ID 2345768, mas troca dois dos números e engana-se a escrevê-los na fórmula desta forma: =PROCV(2345678;A1:E7,5). A fórmula devolve o preço da peça errada porque a função PROCV encontrou o número mais próximo, menor ou igual ao número que especificou (2345678). Pode acabar por faturar um cliente incorretamente devido a este erro.

Se especificar FALSO ou 0 para o argumento Correspondência Aproximada e não existir nenhuma correspondência exata, a fórmula devolve #N/D na célula em vez do valor errado – um cenário muito melhor. Neste caso, #N/D não significa que introduziu a fórmula errada (exceto o número introduzido incorretamente). Significa que 2345678 não foi encontrado – pretendia o número 2345768.

Este exemplo mostra-lhe como funciona a função. Ao introduzir um valor na célula B2 (o primeiro argumento), a função PROCV procura no intervalo de células C2:E7 (o segundo argumento) e devolve a correspondência aproximada mais próxima da terceira coluna do intervalo, a coluna E (o terceiro argumento).

Uma utilização típica da função PROCV

Neste exemplo, o quarto argumento foi deixado em branco, por isso a função devolve uma correspondência aproximada.

Utilizar a função PROCH

Quando estiver à vontade com a função PROCV, a função PROCH não será difícil de utilizar. O utilizador introduz os mesmos argumentos, mas a função PROCH localiza valores em linhas em vez de colunas.

Utilizar as funções ÍNDICE e CORRESP em conjunto

Quando não quiser estar restrito a procurar na coluna mais à esquerda, pode utilizar uma combinação das funções ÍNDICE e CORRESP. Uma fórmula que utiliza estas duas funções em conjunto é um pouco mais complexa do que uma fórmula com a função PROCV, mas pode ser mais avançada – e algumas pessoas preferem vivamente a combinação ÍNDICE/CORRESP em vez da função PROCV.

Este exemplo apresenta uma pequena lista onde o valor que pretendemos procurar, Carcavelos, não se encontra na coluna mais à esquerda. Por isso, não podemos utilizar a função PROCV. Em vez disso, iremos utilizar a função CORRESP para localizar Carcavelos no intervalo B1:B11. Pode ser encontrado na linha 4. Em seguida, a função ÍNDICE utiliza esse valor como o argumento de pesquisa e localiza a população de Carcavelos na coluna 4 (coluna D). A fórmula utilizada é apresentada na célula A14.

Utilizar as funções ÍNDICE e CORRESP para procurar um valor

Mais acerca das funções de procura

Início da Página

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×