Preparar a origem de dados do Excel para uma impressão em série do Word

Criámos uma lista de contactos e outros dados que pretende utilizar numa impressão em série do Word. Se a origem de dados for uma folha de cálculo do Excel existente, apenas tem de preparar os dados para uma impressão em série. No entanto, se a origem de dados for um ficheiro separado por tabulações (.txt) ou por vírgulas (.csv), primeiro tem de importar os dados para o Excel e, em seguida, prepará-los para uma impressão em série.

Passo 1: Configurar a origem de dados no Excel

Se estiver a utilizar uma folha de cálculo do Excel como origem de dados para uma impressão em série no Word, ignore este passo. Se a origem de dados for um ficheiro .txt ou um ficheiro .csv, utilize o Assistente de Importações de Texto para configurar os dados no Excel.

Depois de importar um ficheiro .txt ou .csv com êxito, vá para o Passo 2.

  1. Abra o Excel.

  2. Aceda a Dados > A Partir de Texto/CSV.

    Selecionar Texto/CSV a partir do separador Dados

  3. Selecione o ficheiro .txt ou .csv que pretende e, em seguida, selecione Importar.

  4. Na janela pré-visualizar, selecione Transformar Dados.

  5. Selecione o Código Postal ou outra coluna para formatar.

  6. Aceda a Transformar > Tipo de Dados: e selecione Texto.

    Janela do Power Query com Texto selecionado

  7. Selecione Substituir atual.

  8. Repita os passos 5 a 7, conforme necessário.

  9. Selecione Fechar e Carregar.

  10. Aceda a Ficheiro > Guardar como e, em seguida, guardar como com um nome diferente.

  1. Abra o Excel.

  2. Excel 2016    Aceda a Dados > Obter Dados Externos > A Partir do Texto .

    A opção A Partir de um Ficheiro de Texto está realçada no separador Dados.

  3. Selecione o ficheiro .txt ou .csv que pretende e, em seguida, selecione Importar.

  4. No Assistente de Importações de Texto, no painel Tipo de dados original, escolha Delimitado.

    Excel: Obter Dados Externos do Texto, Assistente de Importações de Texto, Passo 1 de 3

  5. Selecione Os meus dados têm cabeçalhos acima do painel Pré-visualizar se o ficheiro tiver cabeçalhos e, em seguida, selecione Seguinte.

  6. No painel Delimitadores, selecione a caixa de verificação que corresponde ao delimitador (por exemplo, uma Tabulação ou Vírgula) utilizado pelos dados e, em seguida, selecione Seguinte.

    As opções de Delimitadores estão realçadas no Assistente de Importação de Texto.

  7. Em Pré-visualização de dados, escolha a coluna que contém códigos postais e, em Formato dos dados da coluna, escolha Texto.

    A opção Texto da Formatação de dados da Coluna está realçada no Assistente de Importação de Texto.

    Nota: Sempre que aplicar um formato de dados, Geral, Texto ou Data, a uma coluna, o nome do formato é apresentado no cabeçalho da tabela dessa coluna.

  8. Repita o passo 7 conforme necessário, ao selecionar a coluna que pretende alterar e o formato de dados que pretende aplicar.

  9. Selecione Concluir.

  10. Na caixa de diálogo Importar Dados, aceite as predefinições da Folha de cálculo existente e o endereço da célula e, em seguida, escolha OK.

    Na caixa de diálogo Importar Dados, opte por colocar os dados numa folha de cálculo existente, a predefinição, ou numa nova folha de cálculo

    Atenção: O endereço da célula na caixa de diálogo Importar Dados mostra a célula atualmente selecionada. Os dados são importados a partir do endereço da célula com nome.

  11. Guarde a folha de cálculo com um novo nome de ficheiro.

Passo 2: Preparar a origem de dados

Na origem de dados do Excel que irá utilizar para criar uma lista de correio numa impressão em série do Word, certifique-se de que formata as colunas de dados numéricos corretamente. Formate uma coluna com números, por exemplo, para corresponder a uma categoria específica, como moeda.

Se escolher percentagem como categoria, tenha em atenção que o formato de percentagem irá multiplicar o valor da célula por 100. Formate uma coluna de percentagens como texto se pretender evitar esse fator de multiplicação.

Os códigos postais têm de ser formatados como texto para preservar os dados durante uma impressão em série. Se não tiver sido feito quando foi importado, formate-o agora. Os zeros à esquerda, por exemplo, 00399, nos códigos desaparecem durante uma impressão em série se não estiverem formatados como texto.

  1. Selecione a coluna que contém os códigos postais ou outros dados a serem formatados.

  2. Aceda a Base e, no grupo Número, selecione a seta para baixo da caixa Formato do Número e, em seguida, selecione uma opção na lista (tal como Texto).

    No Excel, no separador Base, no grupo Número, escolha a seta para baixo da caixa Geral e, em seguida, escolha o formato de número a utilizar.

Certifique-se de que adiciona o símbolo adequado antes ou depois de um campo de impressão em série. Por exemplo, veja o aspeto dos valores de moeda e percentagem se omitir os símbolos.

O documento de impressão em série que indica "o seu contributo de 50,00" e "oferecem-lhe um desconto de 20".

Se incluir os símbolos, os números fazem mais sentido.

O documento de resultados da impressão em série indica "o seu contributo de $50,00" e "oferecem-lhe um desconto de 20%".

No documento de impressão em série, adicione os símbolos antes ou depois dos campos de impressão em série da seguinte forma:

Documento de impressão em série de exemplo onde um campo denominado Doação é precedido por um cifrão e um campo denominado Percentagem é seguido de um sinal de percentagem.

Consulte também

Um passo essencial num processo de impressão em série do Word é configurar e preparar uma origem de dados. Pode utilizar uma origem de dados existente do Excel ou criar uma nova ao importar um ficheiro de valores delimitados por tabulações (.txt) ou separados por vírgulas (.csv). Após configurar e preparar a sua origem de dados, pode efetuar uma impressão em série ao utilizar o DDE (Dynamic Data Exchange) com o Assistente de Impressão em Série Passo a Passo ou através de um método de impressão em série manual.

Se não estiver a utilizar uma origem de dados existente do Excelpara a sua impressão em série, pode utilizar uma lista de contactos ou um livro de endereços num ficheiro .txt ou num ficheiro .csv. O Assistente de Importação de Texto guia-o ao longo dos passos para obter dados contidos num ficheiro .txt ou .csv para o Excel.

  1. Abra o Excel.

  2. No separador Dados, selecione A Partir do Texto/CSV.

  3. Escolha o ficheiro .txt ou .csv que pretende e, em seguida, selecione Importar.

  4. No Assistente de Importações de Texto, no painel Tipo de dados original, selecione Delimitado.

    Excel: Obter Dados Externos do Texto, Assistente de Importações de Texto, Passo 1 de 3

  5. Selecione a caixa de verificação Os meus dados têm cabeçalhos acima do painel Pré-visualizar se o ficheiro que estiver a importar tiver cabeçalhos e, em seguida, escolha Seguinte.

  6. No painel Delimitadores, selecione a caixa de verificação que corresponde ao delimitador (por exemplo, uma Tabulação ou Vírgula) utilizado pelos dados e, em seguida, escolha Seguinte.

    As opções de Delimitadores estão realçadas no Assistente de Importação de Texto.

    Sugestão: O painel Pré-visualização de dados mostra qual será o aspeto dos resultados num formato de tabela.

  7. Em Pré-visualização de dados, escolha a coluna que contém códigos postais e, em Formato dos dados da coluna, escolha Texto.

    A opção Texto da Formatação de dados da Coluna está realçada no Assistente de Importação de Texto.

    Notas: 

    • Os formatos disponíveis são Geral, Texto e Data. Sempre que aplicar um formato de dados a uma coluna, o nome do formato é apresentado no cabeçalho da tabela dessa coluna.

    • Uma coluna que contém dados numéricos, como uma percentagem ou um valor monetário, por exemplo, só pode ser formatada depois de o ficheiro ser importado. Consulte a subsecção "Formatar dados numéricos no Excel" que se segue para obter mais informações.

  8. Repita o passo 7 conforme necessário, ao selecionar a coluna que pretende alterar e o formato de dados que pretende aplicar.

  9. Selecione Concluir.

  10. Na caixa de diálogo Importar Dados, aceite as predefinições da Folha de cálculo existente e o endereço da célula e, em seguida, escolha OK.

    Na caixa de diálogo Importar Dados, opte por colocar os dados numa folha de cálculo existente, a predefinição, ou numa nova folha de cálculo

    Atenção: O endereço da célula na caixa de diálogo Importar Dados mostra a célula atualmente selecionada. Os dados são importados a partir do endereço da célula com nome.

  11. Quando terminar, guarde a sua origem de dados com um novo nome de ficheiro.

Formatar dados numéricos no Excel

Formate quaisquer dados numéricos como percentagens ou valores monetários em qualquer origem de dados nova ou existente no Excel que pretende utilizar numa impressão em série do Word. Para preservar os dados numéricos que formatou como percentagem ou como moeda durante uma impressão em série, siga as instruções na seção "Passo 2: Utilizar DDE (Dynamic Data Exchange) para uma impressão em série”.

Na origem de dados do Excel que irá utilizar para criar uma lista de correio numa impressão em série do Word, certifique-se de que formata as colunas de dados numéricos corretamente. Formate uma coluna com números, por exemplo, para corresponder a uma categoria específica, como moeda.

  1. Abra a sua origem de dados do Excel.

  2. Selecione a coluna que pretende formatar.

  3. No separador BaseNúmero, escolha a seta para baixo da caixa Formato do Número (Geral) e, em seguida, escolha uma opção na lista.

    No Excel, no separador Base, no grupo Número, escolha a seta para baixo da caixa Geral e, em seguida, escolha o formato de número a utilizar.

  4. Repita os passos 2 e 3 conforme necessário.

  5. Quando terminar, selecione Guardar.

Se tiver uma origem de dados do Excel que contenha números formatados, como percentagens e valores monetários, alguns dos dados numéricos poderão não manter a formatação durante uma impressão em série. Obterá os resultados da impressão em série que quiser e pode preservar o formato dos seus dados numéricos no Excel através de DDE.

Formato de dados do Excel em comparação com o Campo de Impressão em série de Trabalho ao utilizar ou não o Dynamic Data Exchange

Nota: Se optar por não utilizar DDE, siga as orientações em Utilizar a impressão em série para enviar mensagens de e-mail em massa.

  1. Abra o Word, selecione Ficheiro > Opções > Avançadas.

  2. Em Geral, selecione a caixa de verificação Confirmar a conversão do formato de ficheiro ao abrir.

    Opção Confirmar a conversão do formato de ficheiro ao abrir

  3. Selecione OK.

  4. No separador Mailings, selecione Iniciar Impressão em Série > Assistente de Impressão em Série Passo a Passo.

    No Word, no separador Mailings, clique em Iniciar Impressão em Série e, em seguida, selecione Assistente de Impressão em Série Passo a Passo

  5. No painel Impressão em Série, em Selecionar destinatários, selecione Utilizar uma lista existente.

    No Word, o painel de tarefas Impressão em Série que é aberto quando seleciona o Assistente de Impressão em Série Passo a Passo no grupo Impressão em Série

  6. Em Utilizar uma lista existente, selecione Procurar e, em seguida, abra a sua folha de cálculo formatada.

  7. Na caixa de diálogo Confirmar Origem de Dados, selecione a caixa de verificação Mostrar tudo e selecione Folhas de cálculo MS Excel via DDE (*.xls) > OK.

    Caixa de diálogo Confirmar Origem de Dados

  8. Na caixa de diálogo Microsoft Excel, selecione Folha de Cálculo Inteira > OK.

    Caixa de diálogo Microsoft Excel no Word

  9. Quando a caixa de diálogo Destinatários da Impressão em Série abrir, selecione OK.

    Caixa de diálogo Destinatários da Impressão em Série que mostra os conteúdos de uma folha de cálculo do Excel utilizada como uma origem de dados para uma lista de correio

  10. Continue com a sua impressão em série de umacarta, mensagem de e-mail, etiqueta ou envelope.

Sugestão: Pode impedir que lhe seja pedido pelo Word de cada vez que abrir um ficheiro de dados. Depois de se ligar à sua lista de correio, aceda a Ficheiro > Opções > Avançadas. Em Geral, desmarque a caixa de verificação Confirmar a conversão do formato de ficheiro ao abrir.

Se tiver criado uma lista de contactos numa folha de cálculo do Excel, é importante formatar os códigos postais como texto para evitar a perda de dados. Se estiver a importar para uma nova folha de cálculo todos os contactos de um ficheiro de texto (.txt) ou de um ficheiro de valores separados por vírgulas (.csv), o Assistente de Importações de Texto poderá ajudá-lo a importar e a formatar os seus dados.

Passo 1: Configurar a origem de dados no Excel

Se já estiver a utilizar uma folha de cálculo do Excel como origem de dados para uma impressão em série no Word, aceda ao Passo 2 deste tópico. Se a origem de dados for um ficheiro .txt ou .csv com contactos do Gmail, por exemplo, utilize o Assistente de Importações de Texto para configurar os dados no Excel.

  1. Abra o Excel e, no separador Dados, selecione Do Texto.

    No separador Dados, selecione Do Texto

  2. Escolha o ficheiro .csv ou .txt pretendido e, em seguida, selecione Obter Dados.

  3. No Assistente de Importações de Texto, selecione Seguinte.

  4. Em Delimitadores, selecione a caixa que corresponde ao delimitador que separa cada elemento dos seus dados (por exemplo, uma tabulação ou vírgula). Em seguida, selecione Seguinte.

    Sugestão: O painel Pré-visualização dos dados selecionados mostra-lhe o aspeto que os resultados terão em formato de tabela.


    Passo 2 do Assistente de Importações de Texto
     

  5. Em Pré-visualização dos dados selecionados, selecione a coluna que contém os códigos postais. Em seguida, em Formato dos dados da coluna, selecione Texto.

    Assistente de Importações de Texto Passo 3
     

  6. Repita o passo 5 conforme necessário, escolhendo a coluna que pretende alterar e o formato de dados que pretende aplicar.

    Nota: Sempre que aplicar um formato de dados a uma coluna, o nome do formato é apresentado no cabeçalho da tabela dessa coluna.

  7. Clique em Concluir.

  8. Na caixa de diálogo Importar Dados, selecione onde pretende que o Excel introduza os seus dados e, em seguida, clique em OK.

    Nota: Guarde a folha de cálculo com um novo nome de ficheiro.

Passo 2: Formatar dados numéricos na folha de cálculo do Excel

Para se certificar de que o seu código postal não perde zeros após uma impressão em série, formate a coluna desses códigos como texto.

  1. Abra a folha de cálculo e selecione a coluna que contém os códigos postais.

  2. No separador Base, na caixa Formatar, selecione Texto.

    No separador Base, na caixa Formatar, selecione Texto

Agora pode utilizar estes dados para uma impressão em série.

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×