NÃO (função NÃO)

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Utilize a função NÃO, uma das funções de lógica, quando quiser garantir que um valor não é igual a outro.

Exemplo

Exemplos da função NÃO para inverter argumentos.  Por exemplo: =NÃO(1+1=2)

A função NÃO reverte o valor do seu argumento.

Uma utilização comum da função NÃO consiste em expandir a utilidade das outras funções que executam testes lógicos. Por exemplo, a função SE executa um teste lógico e, em seguida, devolve um valor se o teste devolver VERDADEIRO e outro valor se o teste devolver FALSO. A utilização da função NÃO como argumento teste_lógico da função SE permite testar várias condições diferentes em vez de apenas uma.

Sintaxe

NÃO(lógico)

A sintaxe da função NÃO tem os seguintes argumentos:

  • Lógico    obrigatório. É um valor ou expressão que pode ser avaliado como VERDADEIRO ou FALSO.

Comentários

Se lógico for FALSO, NÃO devolve VERDADEIRO; se lógico for VERDADEIRO, NÃO devolve FALSO.

Exemplos

Eis alguns exemplos gerais da utilização da função NÃO sozinha ou em conjunto com a função SE, E e OU.

Exemplos da função NÃO com funções SE, E ou OU

Fórmula

Descrição

=NÃO(A2>100)

A2 NÃO é maior do que 100

=SE(E(NÃO(A2>1);NÃO(A2<100));A2;"O valor está fora do intervalo")

50 é maior do que 1 (VERDADEIRO) E 50 é menor do que 100 (VERDADEIRO), então NÃO reverte ambos os argumentos para FALSO. E requer que ambos os argumentos sejam VERDADEIROS, então devolve o resultado se for FALSO.

=SE(OU(NÃ0(A3<0);NÃO(A3>50));A3; "O valor está fora do intervalo")

100 não é menor do que 0 (FALSO) e 100 é maior do que 50 (VERDADEIRO), então NÃO reverte os argumentos para VERDADEIRO/FALSO. OU só requer que um argumento seja VERDADEIRO, então devolve o resultado se for VERDADEIRO.

Cálculo de Comissão de Vendas

Eis um cenário bastante comum em que é necessário calcular se os vendedores são elegíveis para um bónus com as fórmulas NÃO, SE e E.

Exemplos de cálculo de bónus de vendas com as funções SE, E e NÃO.  A fórmula na célula E14 é =SE(E(NÃO(B14<$B$7),NÃO(C14<$B$5)),B14*$B$8,0)
  • =SE(E(NÃO(B14<$B$7);NÃO(C14<$B$5));B14*$B$8,0)SE O Total de Vendas NÃO é menor do que o Objetivo de Vendas E as Contas NÃO são menores do que o Objetivo de Conta, multiplicar o Total de Vendas pela % de Comissão, caso contrário, devolver 0.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no UserVoice do Excel.

Tópicos Relacionados

Vídeo: Funções se avançadas
Saiba como utilizar funções aninhadas numa fórmula
função se
função e
função ou
Descrição geral das fórmulas no Excel
Como evitar fórmulas quebradas
Utilizar verificação de erros para detetar erros nas fórmulas
atalhos de teclado no Excel para Windows
atalhos de teclado no Excel 2016 para Mac
Lógica funções (referência)
funções do Excel (por ordem alfabética)
funções do Excel (por categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×