Mover um modelo de formulário publicado numa biblioteca do SharePoint novo

Nota:  Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Neste artigo

Descrição geral

Antes de começar

Obter uma cópia de trabalho do seu modelo de formulário

Passo 1: Publicar o modelo de formulário para a nova biblioteca de documentos

Passo 2: Copiar e voltar a ligar os formulários existentes

Descrição Geral

Depois de a publicar um modelo de formulário para uma biblioteca de documentos para os utilizadores preencherem, poderá ter de deslocar-se de que modelo de formulário para outra biblioteca de documentos. Por exemplo, poderá ter que mover o seu modelo de formulário para um servidor com capacidade de mais, para que mais utilizadores possam preencher formulários ao mesmo tempo. Alguns utilizadores podem ter já preenchido através de formulários baseados no modelo de formulário que foi armazenado na biblioteca de documentos original. Quando mover o seu modelo de formulário para uma nova biblioteca de documentos, irá pretende mover essas formulários existentes, demasiado. Pretende também Certifique-se de que irão funcionar desses formulários existentes na nova biblioteca de documentos, antes de arquivar ou eliminar a biblioteca de documentos antigos.

Sugestão: Antes de mover modelos de formulário publicado para uma nova biblioteca de documentos, crie um plano que inclui a informar os utilizadores que foram movidos respectivos formulários para uma nova biblioteca de documentos. Pretende que os utilizadores utilizem a nova biblioteca de documentos para armazenar novos formulários ou para modificar formulários existentes. O plano também deve incluir um processo para arquivar ou eliminar a biblioteca de documentos original.

Para mover um modelo de formulário e respectivos formulários existentes para uma nova biblioteca de documentos, primeiro tem de publicar a cópia de trabalho do seu modelo de formulário para a nova biblioteca de documentos. A cópia de trabalho é a versão que está armazenada no seu computador ou um programa de controlo de versão, como o Microsoft Visual SourceSafe.

Sugestão: Se não tiver uma cópia de trabalho do modelo de formulário, pode guardar uma cópia do modelo de formulário a partir da biblioteca de documentos original com o seu computador para utilizar como uma cópia de trabalho.

Depois de a publicar a cópia de trabalho para a nova biblioteca de documentos, tem de copiar quaisquer formulários da biblioteca de documentos antiga para a nova biblioteca de documentos e, em seguida, voltar a ligar formulários na nova biblioteca de documentos para o modelo de formulário recentemente publicado.

Se precisa de efetuar as alterações como resultado de mover o modelo de formulário, faça essas alterações antes de publicar o modelo de formulário. Por exemplo, a localização de origens de dados externas que são utilizados pelos formulários baseados neste modelo de formulário também poderá alterar estatístico como resultado da mover o modelo de formulário. Neste caso, precisar de alterar a ligação de dados no modelo de formulário para a nova localização de origens de dados externas antes de publicar o modelo de formulário. Encontre ligações para mais informações sobre como alterar as ligações de dados na secção Consulte também.

Nota: Publicar um modelo de formulário não é o mesmo que guardar um modelo de formulário. Quando publicar um modelo de formulário, o Assistente de publicação adiciona a localização de publicar e processamento de instruções para o modelo de formulário para que os utilizadores podem abrir formulários baseados neste modelo de formulário. Quando guarda um modelo de formulário, esteja a guardar uma cópia do modelo de formulário, tal como o que fazer quando guarda um ficheiro para o seu computador. Deve utilizar sempre o Assistente de publicação quando pretender disponibilizar no modelo de formulário para os utilizadores preencherem.

Início da página

Antes de começar

Antes de mover o modelo de formulário e quaisquer formulários existentes que são baseados no modelo de formulário para uma nova biblioteca de documentos, terá o seguinte procedimento:

  • A cópia de trabalho do modelo de formulário    Esta é uma cópia do modelo de formulário que pretende modificar e, em seguida, voltar a publicar para a nova biblioteca de documentos. A cópia de trabalho pode ser armazenada no seu computador ou um programa de controlo de versão, como Visual SourceSafe.

  • As localizações das novas origens de dados externos    Se a formulários baseados no modelo de formulário utilizam origens de dados externas que foram alterados, terá de novas localizações as origens de dados externas. Verifique se o administrador e os seus utilizadores têm as permissões adequadas para utilizar as origens de dados externos. Se o modelo de formulário utiliza as definições num ficheiro de ligação de dados para ligar à origem de dados externa, certifique-se de que o ficheiro de ligação de dados foi atualizado com a nova localização da origem de dados externa.

  • Os direitos adequados no servidor a executar Windows SharePoint Services 3.0    Terá os direitos adequados no servidor para publicar um modelo de formulário e para copiar todos os formulários existentes a partir da biblioteca de documentos antiga para a nova biblioteca de documentos. Contacte o administrador do servidor para assegurar que têm esses direitos.

Início da página

Obter uma cópia de trabalho do seu modelo de formulário

Se pretende modificar um modelo de formulário que foi publicado para uma biblioteca de documentos ou para uma localização de rede partilhada e não tem uma cópia de trabalho do seu modelo de formulário, pode guardar uma cópia de trabalho do modelo de formulário desde a localização de publicar para o seu computador.

Sugestão: Considere utilizar um programa de controlo de versão, como o Microsoft Visual SourceSafe, para gerir as cópias de trabalho de modelos de formulário.

Guardar uma cópia do modelo de formulário a partir de uma biblioteca de documentos para o seu computador

  1. Num browser, abra a biblioteca de documentos onde o modelo de formulário foi publicado.

  2. No menu Definições, clique em Definições e, em seguida, clique em Definições da biblioteca de formulário.

  3. Em Definições Gerais, clique em Definições avançadas.

  4. Na secção Modelo do documento, clique em Editar modelo.

    O modelo de formulário será aberto no Microsoft Office InfoPath.

  5. Na caixa de diálogo Do Microsoft Office InfoPath, clique em Sim.

  6. No menu Ficheiro, clique em Guardar Como.

  7. Na caixa de diálogo Do Microsoft Office InfoPath, clique em OK.

  8. Na caixa de diálogo Guardar como, navegue para a localização onde pretende guardar uma cópia do modelo de formulário e, em seguida, clique em Guardar.

Guardar uma cópia do modelo de formulário a partir da pasta de rede partilhada com o seu computador

  1. No menu ficheiro, clique em estrutura de um modelo de formulário.

  2. Em Abrir um modelo de formulário, clique No meu computador.

  3. Navegue para a pasta de rede partilhada do modelo de formulário publicado, clique no modelo de formulário e, em seguida, clique em Abrir.

  4. No menu Ficheiro, clique em Guardar Como.

  5. Na caixa de diálogo Do Microsoft Office InfoPath, clique em OK.

  6. Na caixa de diálogo Guardar como, selecione uma localização distinta original publicar a localização onde pretende guardar uma cópia de trabalho do modelo de formulário e, em seguida, clique em Guardar.

Início da página

Passo 1: Publicar o modelo de formulário para a nova biblioteca de documentos

  1. Abra a cópia de trabalho do modelo de formulário no modo de estrutura.

  2. No menu ficheiro, clique em Publicar.

  3. No Assistente de publicação, clique em para SharePoint server com ou sem InfoPath Forms Services e, em seguida, clique em seguinte.

  4. Na caixa Introduza a localização do seu site do SharePoint ou o InfoPath Forms Services, escreva a localização do site do SharePoint que contém a nova biblioteca de documentos que pretende mover o seu modelo de formulário para e, em seguida, clique em seguinte.

  5. Na página seguinte do assistente, clique em Biblioteca de documentos e, em seguida, clique em seguinte.

  6. Clique em criar uma nova biblioteca de documentos e, em seguida, clique em seguinte.

  7. Na página seguinte do assistente, escreva um nome e descrição para a nova biblioteca de documentos e, em seguida, clique em seguinte.

  8. Escolha os campos no modelo de formulário que pretende que apareçam como colunas na vista predefinida da biblioteca de documentos.

    Como?

    1. Clique em Adicionar.

    2. Selecione o campo que pretende adicionar como uma coluna na biblioteca de documentos e, em seguida, efetue um dos seguintes procedimentos:

      • Escreva um nome para a coluna na caixa nome da coluna.

      • Selecione a coluna de site na lista de grupo de colunas de Site, selecione um nome na lista nome da coluna e, em seguida, clique em OK.

        Nota: Se Selecionou um campo de repetição para apresentar dados na biblioteca de documentos, pode definir como pretende apresentar o campo na biblioteca de documentos ao clicar num valor na lista de função. Pode escolher se pretende apresentar o primeiro valor no campo, o último valor no campo ou uma contagem de todas as ocorrências do campo ou se pretende intercalar todos os valores em conjunto.

    3. Clique em OK.

    Encontre ligações para mais informações sobre apresentar os dados nas colunas numa biblioteca de documentos na secção Consulte também.

  9. Clique em Seguinte.

  10. Na página seguinte do assistente, certifique-se de que as informações apresentadas estão corretas e, em seguida, clique em Publicar.

  11. Para abrir a biblioteca de documentos e testar o processo para preencher um formulário que é baseado neste modelo de formulário, selecione a caixa de verificação Abrir esta biblioteca de documentos e, em seguida, clique em Fechar.

    É aberto na biblioteca de documentos num browser. Quando clica em Novo na barra de ferramentas de lista, será aberto um formulário baseado neste modelo de formulário no Microsoft Office InfoPath.

Depois de a publicar o modelo de formulário para uma nova biblioteca de documentos, pode copiar os formulários existentes com baseiam na versão antiga do modelo de formulário a partir da biblioteca de documentos antiga para a nova biblioteca de documentos. Depois de copiar os formulários existentes, pode voltar a ligar os formulários existentes para a nova versão do modelo de formulário. Se não associar os formulários existentes, os utilizadores poderão não conseguir abrir estes formulários existentes.

Início da página

Passo 2: Copiar e voltar a ligar os formulários existentes

Este procedimento pressupõe que ambas as bibliotecas de documentos num servidor que está a ser executado Windows SharePoint Services 3.0.

  1. Abra a biblioteca de documentos antigos num browser.

  2. No menu Ver, clique em Vista do Explorador.

  3. Prima e mantenha premido CTRL, selecione cada formulário que pretende mover e, em seguida, com o botão direito uma das formas.

  4. Na caixa de diálogo Do Internet Explorer, clique em Sim e, em seguida, clique em Copiar no menu de atalho.

  5. Abra a nova biblioteca de documentos.

  6. Em selecionar uma vista, clique em Vista do Explorador.

  7. Botão direito do rato na área em branco na janela da pasta.

  8. Na caixa de diálogo Do Internet Explorer, clique em Sim e, em seguida, clique em Colar no menu de atalho.

  9. No menu Ver, clique em Voltar a ligar documentos.

  10. Na coluna voltar a ligar, selecione a caixa de verificação para cada formulário que pretende ligar para o novo modelo de formulário.

  11. Na barra de ferramentas de lista, clique em Voltar a ligar documentos selecionada.

Depois de voltar a ligar os formulários existentes para o novo modelo de formulário, os seus utilizadores podem alterar os formulários existentes que copiou para a nova biblioteca de documentos ou preencha novos formulários baseados no modelo de formulário recentemente publicado.

Início da página

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×