Insert Julian dates (Functions)

Nota:  Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Uma data Juliana é, por vezes, utilizada para fazer referência a um formato de data, que se trata de uma combinação do ano actual e número de dias desde o início do ano. Por exemplo, 1 de Janeiro de 2007 é representado como 2007001 e 31 de Dezembro de 2007 é representado como 2007365. Tenha em atenção que este formato não se baseia no calendário Juliano.

Existe também uma data juliana normalmente utilizada em astronomia, que é um sistema de datas em série que começa em 1 de Janeiro de 4713 A.C.

Os seguintes procedimentos requerem cortar e colar um exemplo. Este é como:

Como copiar um exemplo

  1. Criar um livro ou folha em branco.

  2. Selecione o exemplo no tópico de Ajuda.

    Nota: Não selecione os cabeçalhos de linha ou coluna.

    Selecionar um exemplo na Ajuda

    Selecionar um exemplo na Ajuda

  3. Prima Ctrl+C.

  4. Na folha, selecione a célula A1 e prima Ctrl+V.

  5. Para alternar entre visualizar os resultados e visualizar as fórmulas que devolvem os resultados, prima Ctrl+Shift+` (acento grave), ou no separador Fórmulas, no grupo Auditoria de fórmulas, clique no botão Mostrar Fórmulas.

Introduzir a data de hoje como uma data Juliana

Para executar esta tarefa, utilize as funções de texto, hojee data .

Exemplo

O exemplo pode ser mais fácil de compreender se o copiar para uma folha em branco.

1

2

3

A

B

Fórmula

Descrição (Resultado)

=TEXTO(HOJE() ;"aa")&TEXTO((HOJE() -DATA.VALOR("1/1/"&TEXTO(HOJE();"aa"))+1);"000")

Data actual no formato Juliano, com um ano com dois dígitos (Varia)

=TEXTO(HOJE() ;"aaaa")&TEXTO((HOJE() -DATA.VALOR("1/1/"&TEXTO(HOJE();"aa"))+1);"000")

Data actual no formato Juliano, com um ano com quatro dígitos (Varia)

Notas: 

  • A data actual utilizada foi obtida a partir do relógio do computador.

  • Nas fórmulas acima, o ano começa a 1 de Janeiro (1/1). Para converter as fórmulas de forma a utilizar uma data de início diferente, edite a parte "1/1/" correspondente à data pretendida.

Converter uma data numa data Juliana

Para executar esta tarefa, utilize as funções de texto e data .

Exemplo

O exemplo pode ser mais fácil de compreender se o copiar para uma folha em branco.

1

2

A

Data

23.06.07

Fórmula

Descrição (Resultado)

=TEXTO(A2;"aa")&TEXTO((A2-DATA.VALOR("1/1/"&TEXTO(A2;"aa"))+1);"000")

A data acima está no formato Juliano, com um ano com dois dígitos (07174)

=TEXTO(A2;"aaaa")&TEXTO((A2-DATA.VALOR("1/1/"&TEXTO(A2;"aa"))+1);"000")

A data acima está no formato Juliano, com um ano com quatro dígitos (2007174)

Nota: Na fórmula acima, o ano começa a 1 de Janeiro (1/1). Para converter as fórmulas de forma a utilizar uma data de início diferente, edite a parte "1/1/" correspondente à data pretendida.

Converter uma data numa data Juliana utilizada em astronomia

Esta formula só funciona com datas posteriores a 3/1/1901 e em livros que utilizem o sistema de data 1900.

Exemplo

O exemplo pode ser mais fácil de compreender se o copiar para uma folha em branco.

1

2

A

Data

23.06.07

Fórmula

Descrição (Resultado)

=A2+2415018,50

A primeira data acima está no formato de data juliana e é utilizada em astronomia (7/28/8619)

Nota: Pode formatar as datas como números. Selecione a célula e no separador Base, no grupo Número, clique na seta e, em seguida, clique em Número.

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×