Importar dados XML

Se criou um Mapa XML anteriormente, pode utilizá-lo para importar dados XML para células que estão mapeadas, mas existem também vários métodos e comandos para importar dados XML sem um Mapa XML.

Se tiver um Mapa XML, faça o seguinte para importar dados XML para células mapeadas:

  1. No Mapa XML, selecione uma das células mapeadas.

  2. Clique em Programador > Importar.

    Se não vir o separador Programador, consulte Mostrar o separador Programador.

  3. Na caixa de diálogo Importar XML, localize e selecione o ficheiro de dados XML (.xml) que pretende importar e clique em Importar.

Outras formas de importar dados XML

Para obter mais informações sobre problemas, consulte Problemas comuns com a importação de dados XML no final deste artigo.

Importar um ficheiro de dados XML como uma tabela XML

  1. Clique em Programador > Importar.

    Se não vir o separador Programador, consulte Mostrar o separador Programador.

  2. Na caixa de diálogo Importar XML, localize e selecione o ficheiro de dados XML (.xml) que pretende importar e clique em Importar.

    Se o ficheiro de dados XML não se referir a um esquema, o Excel infere o esquema a partir do ficheiro de dados XML.

  3. Na caixa de diálogo Importar Dados, efetue um dos seguintes procedimentos:

    1. Selecione Tabela XML numa folha de cálculo existente para importar o conteúdo do ficheiro de dados XML para uma tabela XML na folha de cálculo na localização da célula especificada.

    2. Selecione Tabela XML numa nova folha de cálculo para importar o conteúdo do ficheiro para uma tabela XML numa nova folha de cálculo, a partir da célula A1. O esquema do ficheiro de dados XML é apresentado no painel de tarefas Origem XML.

  4. Se o ficheiro de dados XML não se referir a um esquema, o Excel infere o esquema a partir do ficheiro de dados XML.

  5. Para controlar o comportamento dos dados XML (por exemplo, vínculo, formato e esquema de dados), clique em Propriedades, que apresenta a caixa de diálogo Propriedades do Mapa XML. Por exemplo, os dados existentes num intervalo mapeado serão substituídos ao importar os dados por predefinição, mas pode alterar esta definição.

Importar múltiplos ficheiros de dados XML

  1. Selecione uma célula mapeada para importar múltiplos ficheiros XML para um único conjunto de células mapeadas.

    Se quiser importar múltiplos ficheiros XML para vários conjuntos de células mapeadas, clique numa célula em qualquer parte da folha de cálculo que não esteja mapeada.

  2. Clique em Programador > Importar.

    Se não vir o separador Programador, consulte Mostrar o separador Programador.

  3. Na caixa de diálogo Importar XML, localize e selecione o ficheiro de dados XML (.xml) que pretende importar.

    • Se os ficheiros forem contíguos, prima Shift e clique no primeiro e no último ficheiro da lista. Todos os dados dos ficheiros XML serão importados e acrescentados às células mapeadas.

    • Se os ficheiros não forem contíguos, prima continuamente a tecla Ctrl e clique em cada ficheiro que pretende importar na lista.

  4. Clique em Importar.

    Se tiver selecionado ficheiros não contíguos, é apresentada a caixa de diálogo Importar <nome de ficheiro>.xml. Selecione o Mapa XML correspondente ao ficheiro de dados XML que está a importar para cada ficheiro.

    Para utilizar um único mapa para todos os ficheiros selecionados que ainda não foram importados, selecione Utilizar este Mapa XML para todos os ficheiros selecionados deste esquema.

Importar múltiplos ficheiros de dados XML como dados externos

Para importar múltiplos ficheiros XML que utilizam o mesmo espaço de nomes, mas esquemas XML diferentes, pode utilizar o comando Da Importação de Dados XML. O Excel cria um Mapa XML exclusivo para cada ficheiro de dados XML importado.

Nota: Se estiver a importar múltiplos ficheiros XML que não definem um espaço de nomes, estes ficheiros XML são tratados como se utilizassem o mesmo espaço de nomes.

  1. Se estiver a utilizar o Excel com uma subscrição do Office 365, clique em Dados > Obter Dados > Do Ficheiro > Do XML.

    Se estiver a utilizar o Excel 2016 ou anterior, clique em Dados > De Outras Origens > Da Importação de Dados XML.

  2. Aceda à unidade, pasta ou localização na Internet que tem o ficheiro de dados XML (.xml) que pretende importar.

  3. Selecione o ficheiro e clique em Abrir.

  4. Na caixa de diálogo Importar Dados, efetue um dos seguintes procedimentos:

    • Tabela XML numa folha de cálculo existente    O conteúdo do ficheiro é importado para uma nova tabela XML numa nova folha de cálculo. Se o ficheiro de dados XML não se referir a um esquema, o Excel infere o esquema a partir do ficheiro de dados XML.

    • Folha de cálculo existente    Os dados XML são importados numa tabela bidimensional com linhas e colunas que mostram as etiquetas XML como cabeçalhos de coluna e os dados em linhas abaixo dos cabeçalhos de coluna. O primeiro elemento (nó raiz) é utilizado como um título e é apresentado na localização da célula especificada. As restantes etiquetas são ordenadas alfabeticamente na segunda linha. Neste caso, o Excel não infere um esquema e não pode utilizar um Mapa XML.

    • Nova folha de cálculo    O Excel adiciona uma nova folha de cálculo ao livro e coloca automaticamente os dados XML no canto superior esquerdo da nova folha de cálculo. Se o ficheiro de dados XML não se referir a um esquema, o Excel infere o esquema a partir do ficheiro de dados XML.

  5. Para controlar o comportamento dos dados XML, tais como o vínculo, formato e esquema de dados, clique em Propriedades, que apresenta a caixa de diálogo Propriedades do Mapa XML. Por exemplo, os dados existentes num intervalo mapeado são substituídos ao importar os dados por predefinição, mas pode alterar esta definição.

Abrir um ficheiro de dados XML para importar os dados

  1. Clique em Ficheiro > Abrir.

    Se estiver a utilizar o Excel 2007, clique no Botão do Microsoft Office Imagem de botão do Office > Abrir.

  2. Na caixa de diálogo Abrir, clique na unidade, pasta ou localização da Internet que contém o ficheiro que pretende abrir.  

  3. Selecione o ficheiro e clique em Abrir.

  4. Se for apresentada a caixa de diálogo Importar XML, o ficheiro aberto refere-se a uma ou mais folhas de estilos XSLT (Extensible Stylesheet Language Transformation), pelo que pode clicar numa das seguintes opções:

    • Abrir o ficheiro sem aplicar uma folha de estilos    Os dados XML são importados numa tabela bidimensional com linhas e colunas que mostram as etiquetas XML como cabeçalhos de coluna e os dados em linhas abaixo dos cabeçalhos de coluna. O primeiro elemento (nó raiz) é utilizado como um título e é apresentado na localização da célula especificada. As restantes etiquetas são ordenadas alfabeticamente na segunda linha. Neste caso, o Excel não infere um esquema e não pode utilizar um Mapa XML.

    • Abrir o ficheiro com a seguinte folha de estilos aplicada (selecionar uma)    Selecione a folha de estilos que pretende aplicar e, em seguida, clique em OK. Os dados XML são formatados de acordo com a folha de estilos selecionada.

      Nota: Os dados XML são abertos como sendo só de leitura no Excel para que não guarde acidentalmente o ficheiro de origem no formato de ficheiro Livro do Excel com Permissão para Macros (.xlsm). Neste caso, o Excel não infere um esquema e não pode utilizar um Mapa XML.

  5. Se for apresentada a caixa de diálogo Abrir XML, o ficheiro XML não tem referências de folhas de estilos XSLT. Para abrir o ficheiro, clique numa das seguintes opções:

    • Clique em Como uma tabela XML para criar uma tabela XML num novo livro.

      O conteúdo do ficheiro é importado para a tabela XML. Se o ficheiro de dados XML não se referir a um esquema, o Excel infere o esquema a partir do ficheiro de dados XML.

    • Clique em Como um livro só de leitura.

      Os dados XML são importados numa tabela bidimensional com linhas e colunas que mostram as etiquetas XML como cabeçalhos de coluna e os dados são apresentados em linhas abaixo dos cabeçalhos de coluna. O primeiro elemento (nó raiz) é utilizado como um título e é apresentado na localização da célula especificada. As restantes etiquetas são ordenadas alfabeticamente na segunda linha. Neste caso, o Excel não infere um esquema e não pode utilizar um Mapa XML.

      Os dados XML são abertos como sendo só de leitura no Excel para que não guarde acidentalmente o ficheiro de origem no formato de ficheiro Livro do Excel com Permissão para Macros (.xlsm). Neste caso, o Excel não infere um esquema e não pode utilizar um Mapa XML.

    • Clique em Utilizar o painel de tarefas Origem XML.

      O esquema do ficheiro de dados XML é apresentado no painel de tarefas Origem XML. Em seguida, pode arrastar os elementos do esquema para a folha de cálculo para mapeá-los para a folha de cálculo.

      Se o ficheiro de dados XML não se referir a um esquema, o Excel infere o esquema a partir do ficheiro de dados XML.

Problemas comuns com a importação de dados XML

O Excel apresenta a caixa de diálogo Erro de Importação XML quando não consegue validar os dados de acordo com o Mapa XML. Nesta caixa de diálogo, clique em Detalhes para obter informações adicionais sobre cada erro. A tabela seguinte lista alguns erros de importação comuns:

Erro

O que aconteceu

Falha na validação do esquema

Quando clicou em Validar dados relativamente ao esquema para importar e exportar na caixa de diálogo Propriedades do Mapa XML, os dados foram importados, mas não foram validados relativamente ao Mapa XML especificado.

Alguns dados foram importados como texto

Alguns ou todos os dados importados foram convertidos do respetivo tipo de dados declarado para texto. Para utilizar estes dados num cálculo, terá de convertê-los de texto para números ou datas. Por exemplo, um valor de data convertido para texto não funcionará como pretendido na função ANO até o converter para o tipo de dados Data. O Excel converte dados em texto quando:

  • Os dados estão num formato que o Excel não suporta.

  • Os dados são incompatíveis com a representação interna do Excel do tipo de dados XSD. Para corrigir este problema, verifique cada declaração do tipo de dados para garantir que os dados XML são válidos de acordo com o esquema XML.

Erro de análise XML

O analisador XML não consegue abrir o ficheiro XML especificado. Certifique-se de que o ficheiro XML não tem erros de sintaxe e o XML está bem formado.

Não consegue encontrar um Mapa XML que corresponda aos dados

Este problema pode ocorrer quando seleciona mais do que um ficheiro de dados XML para importar e o Excel não consegue encontrar um Mapa XML correspondente para um dos ficheiros. Para o ficheiro com o nome na barra de título da caixa de diálogo, importe primeiro um esquema adequado e, em seguida, tente importar novamente o ficheiro.

Uma tabela XML não pode ser redimensionada para acomodar dados

Está a tentar adicionar linhas ao importar ou acrescentar dados à tabela XML, mas não existe espaço para a expansão da tabela. Uma tabela XML apenas pode ser expandida da parte inferior para baixo. Por exemplo, pode existir um objeto, como uma imagem ou outra tabela, imediatamente abaixo da tabela XML que impeça a expansão da tabela XML. Ou a expansão da tabela XML ultrapassará o limite do Excel de 1 048 576 linhas. Para corrigir este problema, reorganize as tabelas e os objetos na folha de cálculo para permitir que a tabela XML seja expandida da parte inferior para baixo.

O ficheiro XML especificado não se refere a um esquema

O ficheiro XML que está a tentar abrir não se refere a um esquema XML. Para trabalhar com os dados XML que estão no ficheiro, o Excel precisa de um esquema baseado no conteúdo do ficheiro XML. Se esse esquema for incorreto ou insuficiente, remova-o do livro. Em seguida, crie um ficheiro de esquema XML e edite o ficheiro de dados XML para que este faça referência ao esquema. Para obter mais informações, consulte Mapear elementos XML para células num Mapa XML.

Nota: Não pode exportar o esquema inferido do Excel como um ficheiro de dados de esquema XML separado (.xsd). Embora existam editores de esquemas XML e outros métodos para criar um ficheiro de esquema XML, poderá não ter acesso prático aos mesmos ou saber utilizá-los.

Siga estes passos para remover o esquema criado pelo Excel do livro:

  1. Clique em Programador > Origem.

    Vista de Dados vazia

    Se não vir o separador Programador, consulte Mostrar o separador Programador.

  2. No painel de tarefas Origem XML clique em Mapas XML.

  3. Na caixa de diálogo Mapas XML, clique no Mapa XML criado pelo Excel e clique em Eliminar.

A importação de múltiplos ficheiros XML que utilizam o mesmo espaço de nomes, mas esquemas diferentes, não funciona conforme esperado

Quando trabalha com múltiplos ficheiros de dados XML e esquemas XML, normalmente cria um mapa XML para cada esquema, mapeia os elementos que pretende e, em seguida, importa cada ficheiro de dados XML para o Mapa XML adequado. Através do comando Importar para abrir múltiplos ficheiros XML com o mesmo espaço de nomes, apenas pode utilizar um esquema XML. Quando utiliza este comando para abrir múltiplos ficheiros XML que utilizam o mesmo espaço de nomes mas esquemas diferentes, pode obter resultados inesperados. Por exemplo, os dados podem ser substituídos ou os ficheiros não abrem.

Para importar múltiplos ficheiros XML que utilizem o mesmo espaço de nomes mas que tenham esquemas XML diferentes, experimente utilizar o comando Da Importação de Dados XML (clique em Dados > De Outras Origens). Este comando permite que múltiplos ficheiros XML com o mesmo espaço de nomes utilizem vários esquemas XML. O Excel cria um Mapa XML exclusivo para cada ficheiro de dados XML que pretende importar.

Nota: Se estiver a importar múltiplos ficheiros XML que não definem um espaço de nomes, estes ficheiros XML são tratados como se utilizassem o mesmo espaço de nomes.

Mostrar o separador Programador

Se não vir o separador Programador, faça o seguinte para o apresentar:

  • No Excel 2013 e Excel 2010:

    1. Clique em Ficheiro > Opções.

    2. Clique na categoria Personalizar Friso.

    3. Em Separadores Principais, selecione a caixa Programador e clique em OK.

  • No Excel 2007:

    1. Clique no Botão do Microsoft Office Imagem de botão do Office > Opções do Excel.

    2. Clique na categoria Popular.

    3. Em Opções principais para trabalhar com o Excel, selecione a caixa Mostrar o separador Programador no Friso e clique em OK.

Consulte Também

Descrição geral do XML no Excel

Mapear elementos XML para células num Mapa XML

Exportar dados XML

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×