Função VALORDOCAMPO

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Pode utilizar a função VALORDOCAMPO para obter dados de campos de tipos de dados ligados, como os tipos de dados Ações ou Geografia. Existem métodos mais fáceis de escrever fórmulas que fazem referência a tipos de dados. Por isso, a função VALORDOCAMPO deve ser utilizada principalmente para criar cálculos condicionais com base em tipos de dados ligados.

Nota: 12 de Junho de 2018: Esta função se encontra atualmente uma funcionalidade de beta e só está disponível para uma parte do Office iniciados neste momento. Vamos continuar a otimizar esta funcionalidade ao longo dos próximos meses. Quando estiver pronto, irá disponibilizamos-lo a todos os Office iniciados e subscritores do Office 365.

Detalhes técnicos

Sintaxe

=VALORDOCAMPO(valor; nome_do_campo)

A sintaxe da função VALORDOCAMPO tem os seguintes argumentos:

  • VALOR – o endereço da célula, coluna da tabela ou intervalo com nome que contém um tipo de dado ligado. 

  • nome_do_campo – o nome ou nomes dos campos que pretende extrair do tipo de dados ligados

Descrição

Exemplos

No seguinte exemplo simples, a fórmula =VALORDOCAMPO(A2;"Preço") extrai o campo Preço do tipo de dados de ações da JM Smucker Co.

  Obter um preço das ações da empresa com a fórmula =VALORDOCAMPO(A2;"Preço") .

O exemplo seguinte é um exemplo mais comum da função VALORDOCAMPO. Neste exemplo, estamos a utilizar a função SE.ERRO para verificar se existem erros. Se não existir o nome de uma empresa na célula A2, a fórmula VALORDOCAMPO devolve um erro. Neste caso, queremos que não apresente nada (""). No entanto, se existir o nome de uma empresa, queremos que obtenha o Preço do tipo de dados na célula A2 com =SE.ERRO(VALORDOCAMPO($A2;B$1);"").

Obter um preço das ações da empresa e ignorar os erros com a fórmula =SE.ERRO(VALORDOCAMPO($A2;B$1);"")

Tenha em atenção que a função VALORDOCAMPO lhe permite fazer referência a células de folhas de cálculo para o argumento nome_do_campo. A fórmula acima faz referência à célula B1 para o Preço em vez de introduzir manualmente o "Preço" na fórmula. 

Observações

Se tentar obter dados de um campo de tipo de dados não existente, a função VALORDOCAMPO devolverá o erro #CAMPO!. Por exemplo, poderá ter escrito "Preços", quando o campo de tipo de dados é denominado "Preço". Verifique a sua fórmula para se certificar de que está a utilizar um nome de campo válido. Se quiser apresentar a lista de nomes de campos de um registo, selecione a célula do registo e prima Ctrl+Shift+F2.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no User Voice do Excel.

Consulte também

Tipos de dados geográficos e de ações

Como escrever fórmulas que fazem referência a tipos de dados

Erro #CAMPO!

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×