Fórmulas e funções

Função SE

Função SE

A função SE é uma das funções mais populares no Excel e permite-lhe fazer comparações lógicas entre um valor e o que está à espera. De uma forma resumida, a função SE diz:

  • SE(Algo é Verdadeiro, então fazer algo, caso contrário, fazer outra ação)

Assim, uma instrução SE pode ter dois resultados. O primeiro resultado é se a sua comparação for considerada Verdadeiro, o segundo se a sua comparação for considerada Falso.

Se quiser avançar para o artigo sobre trabalhar com múltiplas instruções SE, consulte: Funções avançadas da função SE – trabalhar com fórmulas aninhadas e evitar falhas.

Utilize a função SE, uma das funções lógicas, para devolver um valor se uma condição for verdadeira e outro valor se for falsa.

Sintaxe

SE(teste_lógico; valor_se_verdadeiro; [valor_se_falso])

Por exemplo:

  • =SE(A2>B2;"Ultrapassou o Orçamento";"OK")

  • =SE(A2=B2;B4-A4;"")

Nome do argumento

Descrição

teste_lógico    (obrigatório)

A condição que pretende testar.

valor_se_verdadeiro    (obrigatório)

O valor que pretende que seja devolvido se o resultado do teste_lógico for VERDADEIRO.

valor_se_falso    (opcional)

O valor que pretende que seja devolvido se o resultado do teste_lógico for FALSO.

Exemplos SE fáceis

A célula D2 contém uma fórmula =SE(C2="Sim";1;2)
  • =SE(C2="Sim";1;2)

No exemplo acima, a célula D2 diz: SE(C2 = Sim, então devolver um 1, caso contrário, devolver um 2)

A célula D2 contém a fórmula =SE(C2=1;"SIM";"NÃO")
  • =SE(C2=1;"Sim";"Não")

Neste exemplo, a fórmula na célula D2 diz: SE(C2 = 1, então devolver Sim, caso contrário, devolver Não)

Como pode ver, a função SE pode ser utilizada para avaliar texto e valores. Também pode ser utilizada para avaliar erros. Não está limitado a verificar apenas se uma coisa é igual a outra e devolver um único resultado, também pode utilizar operadores matemáticos e efetuar cálculos adicionais, consoante os seus critérios. Também pode aninhar múltiplas funções SE de forma a efetuar múltiplas comparações.

Nota: Se utilizar texto nas fórmulas, tem de colocar o texto entre aspas (por exemplo, "Texto"). A única exceção a esta regra é se utilizar VERDADEIRO ou FALSO, que o Excel entenderá automaticamente.

Como começar

A melhor forma de começar a escrever uma instrução SE é pensar sobre o que está a tentar fazer. Que tipo de comparação está a tentar fazer? Muitas vezes, escrever uma instrução SE pode ser tão simples como pensar na lógica na sua cabeça: "o que deve acontecer se a condição for cumprida em comparação com o que deve acontecer se não for o caso?" Terá de se certificar sempre de que os seus passos seguem uma progressão lógica ou a sua fórmula não fará o que acha que devia. Isto é especialmente importante quando criar instruções SE complexas (aninhadas).

Mais exemplos SE

A fórmula na célula D2 é =SE(C2>B2;"Ultrapassou o Orçamento";"Dentro do Orçamento")
  • =SE(C2>B2;"Ultrapassou o Orçamento";"Dentro do Orçamento")

No exemplo acima, a função SE na célula D2 está a dizer que SE(C2 for Maior do que B2, então devolver "Ultrapassou o Orçamento", caso contrário, devolver "Dentro do Orçamento")

A fórmula na célula E2 é =SE(C2>B2;C2-B2;"")
  • =SE(C2>B2;C2-B2;0)

Na ilustração acima, em vez de devolver um resultado de texto, irá devolver um cálculo matemático. Então, a fórmula na célula E2 está a dizer SE(Real for Maior do que o que está Orçamentado, então Subtrair o montante Orçamentado do montante Real, caso contrário, não devolver nada).

A fórmula na Célula F7 é SE(E7="Sim";F5*0,0825;0)
  • =SE(E7="Sim";F5*0,0825;0)

Neste exemplo, a fórmula na célula F7 está a dizer SE(E7 = "Sim", então calcular o Montante Total em F5 * 8,25%, caso contrário, nenhum Imposto sobre Vendas está em atraso e devolver 0)

Melhores Práticas – Constantes

No último exemplo, pode ver "Sim" e a Taxa de Imposto sobre Vendas (0,0825) introduzidos diretamente na fórmula. Normalmente, não é prática recomendada colocar constantes literais (valores que poderão ter de ser alterados ao longo do tempo) diretamente em fórmulas, porque podem ser difíceis de encontrar e alterar no futuro. É muito melhor colocar constantes nas suas próprias células, onde estão à vista e podem ser encontradas e alteradas facilmente. Neste caso, não há problema porque existe apenas uma função SE e a Taxa de Imposto sobre Vendas raramente é alterada. Mesmo que seja alterada, é fácil alterá-la na fórmula.

Operadores de cálculo

Se quiser saber mais sobre os diferentes operadores de cálculo que pode utilizar em fórmulas (< menor que > maior que, = é igual a, <> não é igual a, etc.), consulte o seguinte artigo: Operadores de cálculo e ordem de execução.

Utilizar a função SE para verificar se uma célula está em branco

Por vezes, tem de verificar se uma célula está em branco, geralmente porque não quer que uma fórmula apresente um resultado sem uma entrada.

A fórmula na célula E2 é =SE(D2=1;"Sim";SE(D2=2;"Não";"Talvez"))

Neste caso, estamos a utilizar a função SE com a função É.CÉL.VAZIA:

  • =SE(É.CÉL.VAZIA(D2); "Em Branco";"Não Está em Branco")

Traduzindo: SE(D2 estiver em branco, então devolver "Em Branco", caso contrário, devolver "Não Está em Branco"). Também pode utilizar facilmente a sua própria fórmula para a condição "Não Está em Branco". No exemplo seguinte estamos a utilizar "" em vez de É.CÉL.VAZIA. "" basicamente significa "nada".

Verificar se uma célula está em branco – a fórmula na célula A2 é =SE(É.CÉL.VAZIA(D2); "Em Branco";"Não Está em Branco")
  • =SE(D3="";"Em Branco";"Não Está em Branco")

Esta fórmula indica SE(D3 for nada, então devolver "Em Branco", caso contrário, devolver "Não Está em Branco"). Eis um exemplo de um método muito comum de utilizar "" para impedir uma fórmula de calcular se uma célula dependente estiver em branco:

  • =SE(D3="";"";ASuaFórmula())

    SE(D3 for nada, então devolver nada, caso contrário, calcular a sua fórmula).

Exemplo de SE aninhado

Quando uma função SE simples tem apenas dois resultados (VERDADEIRO ou FALSO), as funções SE aninhadas podem ter de 3 a 64 resultados.

Utilizar "" para verificar a existência de uma célula em branco – a fórmula na célula E3 é =SE(D3="";"Em Branco";"Não Está em Branco")
  • =SE(D2=1;"SIM";SE(D2=2;"Não";"Talvez"))

Na ilustração acima, a fórmula na célula E2 diz: SE(D2 for igual a 1, então devolver "Sim", caso contrário, SE(D2 for igual a 2, então devolver "Não", caso contrário, devolver "Talvez")). Tenha em atenção que existem dois parênteses de fecho no final da fórmula. Esses parênteses são necessários para concluir ambas as funções SE e, se tentar introduzir a fórmula sem os dois parênteses de fecho, o Excel tentará corrigir isso automaticamente.

Tenha em atenção

Ainda que o Excel lhe permita aninhar até 64 funções SE diferentes, não é aconselhável fazê-lo. Porquê?

  • Múltiplas instruções SE exigem muito trabalho para serem criadas corretamente, de forma a garantir que a sua lógica pode ser calculada corretamente ao longo de cada condição até ao fim. Se não aninhar as suas instruções SE corretamente, uma fórmula poderá funcionar 75% das vezes, mas devolver resultados inesperados 25% das vezes. Infelizmente, a probabilidade de o utilizador detetar esses 25% é pequena.

  • Múltiplas instruções SE podem tornar-se muito difíceis de gerir, principalmente quando regressa tempos depois e tenta descobrir o que você, ou pior, outra pessoa, estava a tentar fazer.

  • Múltiplas instruções SE requerem múltiplos parênteses de abertura e de fecho (), o que pode ser difícil de gerir, dependendo da complexidade da sua fórmula.

Problemas comuns

Problema

O que correu mal

0 (zero) numa célula

Não existe um argumento para os argumentos valor_se_verdadeiro ou valor_se_falso Para ver o valor correto devolvido, adicione o argumento de texto aos dois argumentos ou adicione VERDADEIRO ou FALSO ao argumento.

#NOME? na célula

Normalmente, isto significa que essa fórmula está mal escrita.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no User Voice do Excel.

Consulte também

Vídeo: Funções avançadas da função SE

Função SE.S (Office 365, Excel 2016 e posterior)

Funções avançadas da função SE – trabalhar com fórmulas aninhadas e evitar falhas

Vídeos de formação: funções avançadas da função SE

A função CONTAR.SE conta valores com base num único critério

A função CONTAR.SE.S conta valores com base em múltiplos critérios

A função SOMA.SE soma valores com base num único critério

A função SOMA.SE.S soma valores com base em múltiplos critérios

Função E

Função OU

Função PROCV

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Utilizar a verificação de erros para detetar erros nas fórmulas

Funções lógicas

Funções do Excel (por ordem alfabética)

Funções do Excel (por categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×