função OU

Utilize a função OU, uma das funções lógicas, para determinar se alguma das condições num teste são VERDADEIRO.

Exemplo

Exemplos da utilização da função OU.

A função OU devolve VERDADEIRO se qualquer um dos argumentos devolverem VERDADEIRO e devolve FALSO se todos os argumentos devolverem FALSO.

Uma utilização comum para a função OU consiste em expandir a utilidade das outras funções que executam testes lógicos. Por exemplo, a função SE executa um teste lógico e, em seguida, devolve um valor se o teste devolver VERDADEIRO e outro valor se o teste devolver FALSO. A utilização da função OU como argumento teste_lógico da função SE permite testar várias condições diferentes em vez de apenas uma.

Sintaxe

OU(lógico1; [lógico2]; ...)

A sintaxe da função OU tem os seguintes argumentos:

Argumento

Descrição

Lógico1

Obrigatório. A primeira condição que pretende testar pode devolver VERDADEIRO ou FALSO.

Lógico2;...

Opcional. As condições adicionais que pretende testar podem devolver VERDADEIRO ou FALSO, até um máximo de 255 condições.

Comentários

  • Os argumentos têm de ser avaliados como valores lógicos, por exemplo, VERDADEIRO ou FALSO, ou em matrizes ou referências que contenham valores lógicos.

  • Se uma matriz ou um argumento de referência contiver texto ou células vazias, esses valores são ignorados.

  • Se o intervalo especificado não contiver valores lógicos, OU devolve o valor de erro #VALOR!.

  • Pode utilizar uma fórmula de matriz OU para determinar se um valor ocorre numa matriz. Para introduzir uma fórmula de matriz, prima Ctrl+Shift+Enter.

Exemplos

Eis alguns exemplos gerais da utilização da função OU sozinha ou em conjunto com a função SE

Exemplos da utilização da função OU com a função SE.

Fórmula

Descrição

=OU(A2>1;A2<100)

Apresenta VERDADEIRO se a célula A2 for maior do que 1 OU menor do que 100, caso contrário, apresenta FALSO.

=SE(OU(A2>1;A2<100);A3;"O valor está fora do intervalo")

Apresenta o valor na célula A3 se for maior do que 1 OU menor do que 100, caso contrário, apresenta a mensagem "O valor está fora do intervalo".

=SE(OU(A2<0;A2>50);A2;"O valor está fora do intervalo")

Apresenta o valor na célula A2 se for menor do que 0 OU maior do que 50, caso contrário, apresenta uma mensagem.

Cálculo de Comissão de Vendas

Eis um cenário bastante comum em que é necessário calcular se os vendedores são elegíveis para uma comissão com as fórmulas SE e OU.

Exemplo da utilização das funções SE e OU para calcular a comissão de vendas.
  • =SE(OU(B14>=$B$4;C14>=$B$5);B14*$B$6;0)SE O Total de Vendas for maior ou igual (>=) ao Objetivo de Vendas, OU as Contas forem maiores ou iguais (>=) ao Objetivo de Conta, multiplicar o Total de Vendas pela % de Comissão, caso contrário, devolver 0.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no User Voice do Excel.

Tópicos Relacionados

Vídeo: Funções SE avançadas
Saiba como utilizar funções aninhadas numa fórmula
Função SE
Função E
Função NÃO
Descrição geral de fórmulas no Excel
Como evitar fórmulas quebradas
Utilizar a verificação de erros para detetar erros em fórmulas
Atalhos de teclado no Excel 2016 para Windows
Atalhos de teclado no Excel 2016 para Mac
Funções de lógica (referência)
Funções do Excel (por ordem alfabética)
Funções do Excel (por categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×