Exemplos de fórmulas comuns em Listas do SharePoint

Exemplos de fórmulas comuns em Listas do SharePoint

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Utilizar fórmulas em colunas calculadas de uma lista do SharePoint ou biblioteca do SharePoint pode ajudar a calcular algo a partir de colunas existentes, como calcular o imposto sobre vendas num preço. Estas podem ser combinadas para validar dados programaticamente.

Ao introduzir fórmulas, salvo especificação em contrário, não existem espaços entre palavras-chave e operadores. A seguinte lista não é exaustiva. Para ver todas as fórmulas no SharePoint, consulte a lista por ordem alfabética no final deste artigo.

Nota: Os campos calculados só podem operar na sua própria linha, por isso não pode referenciar um valor noutra linha ou noutras colunas contidas numa lista ou biblioteca diferente. Os campos de pesquisa não são suportados numa fórmula e o ID de uma linha recentemente inserida não pode ser utilizado, pois o ID não existe quando a fórmula é processada.

Pode utilizar as seguintes fórmulas para testar a condição de uma declaração e devolver um valor Sim ou Não, para testar um valor alternativo como OK ou Não OK ou para devolver um valor em branco ou um travessão para representar um valor nulo.

Verificar se um número é maior ou menor que outro número

Utilize a função SE para fazer esta comparação.

Coluna1

Coluna2

Fórmula

Descrição (resultado possível)

15000

9000

=[Coluna1]>[Coluna2]

A Coluna1 é maior do que a Coluna2? (Sim)

15000

9000

=SE([Coluna1]<=[Coluna2],"OK","Não OK")

A Coluna1 é menor ou igual à Coluna2? (Não OK)

Devolver um valor lógico após comparar os conteúdos da coluna

Para obter um valor lógico (Sim ou Não) como resultado, utilize as funções E, OU e NÃO.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado possível)

15

9

8

=E([Coluna1]>[Coluna2],[Coluna1]<[Coluna3])

15 é maior do que 9 e menor do que 8? (Não)

15

9

8

=OU([Coluna1]>[Coluna2],[Coluna1]<[Coluna3])

15 é maior do que 9 ou menor do que 8? (Sim)

15

9

8

=NÃO([Coluna1]+[Coluna2]=24)

15 mais 9 não é igual a 24? (Não)

Para obter outro cálculo como resultado ou qualquer outro valor que não seja Sim ou Não, utilize as funções SE, E e OU.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado possível)

15

9

8

=SE([Coluna1]=15,"OK","Não OK")

Se o valor da Coluna1 for igual a 15, é devolvido "OK". (OK)

15

9

8

=SE(E([Coluna1]>[Coluna2],[Coluna1]<[Coluna3]),"OK","Não OK")

Se 15 for maior do que 9 e menor do que 8, é devolvido "OK". (Não OK)

15

9

8

=SE(OU([Coluna1]>[Coluna2],[Coluna1]<[Coluna3]),"OK","Não OK")

Se 15 for maior do que 9 ou menor do que 8, é devolvido "OK". (OK)

Apresentar zeros como espaços em branco ou traços

Para apresentar um zero, efetue um cálculo simples. Para apresentar um valor em branco ou um travessão, utilize a função SE.

Coluna1

Coluna2

Fórmula

Descrição (resultado possível)

10

10

=[Coluna1]-[Coluna2]

Segundo número subtraído pelo primeiro (0)

15

9

=SE([Coluna1]-[Coluna2],"-",[Coluna1]-[Coluna2])

Devolve um traço quando o valor é zero (-)

Ocultar valores de erro em colunas

Para apresentar um traço, #N/D ou Não.Disp., em vez de um valor de erro, utilize a função É.ERRO.

Coluna1

Coluna2

Fórmula

Descrição (resultado possível)

10

0

=[Coluna1]/[Coluna2]

Resulta num erro (#DIV/0)

10

0

=SE(É.ERRO([Coluna1]/[Coluna2]),"ND",[Coluna1]/[Coluna2])

Devolve ND quando o valor é um erro

10

0

=SE(É.ERRO([Coluna1]/[Coluna2]),"-",[Coluna1]/[Coluna2])

Devolve um travessão quando o valor é um erro

Verificar campos em branco

Pode utilizar a fórmula É.CÉL.VAZIA para localizar campos em branco.

Coluna1

Fórmula

Descrição (resultado possível)

"Gomas"

=É.CÉL.VAZIA([Coluna1]

Devolve Sim ou Não quer esteja em branco ou não

"Aço"

=SE(É.CÉL.VAZIA([Coluna1]),"Não OK","OK")

Preenche com as suas escolhas – a primeira se estiver em branco e a segunda se não estiver

Para ver mais funções É, consulte o artigo Funções É.

Pode utilizar as seguintes fórmulas para efetuar cálculos com base em datas e horas, como somar um número de dias, meses ou anos a uma data, calcular a diferença entre duas datas e converter uma hora num valor decimal.

Somar datas

Para somar um número de dias a uma data, utilize o operador de adição (+).

Nota: Quando manipula datas, o tipo devolvido da coluna calculada tem de estar definido como Data e Hora.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

9/6/2007

3

=[Coluna1]+[Coluna2]

Soma 3 dias a 9/6/2007 (12/6/2007)

10/12/2008

54

=[Coluna1]+[Coluna2]

Soma 54 dias a 10/12/2008 (2/2/2009)

Para somar um número de meses a uma data, utilize as funções DATA, ANO, MÊS e DIA.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

9/6/2007

3

=DATA(ANO([Coluna1]),MÊS([Coluna1])+[Coluna2],DIA([Coluna1]))

Soma 3 meses a 9/6/2007 (9/9/2007)

10/12/2008

25

=DATA(ANO([Coluna1]),MÊS([Coluna1])+[Coluna2],DIA([Coluna1]))

Soma 25 meses a 10/12/2008 (10/1/2011)

Para somar um número de anos a uma data, utilize as funções DATA, ANO, MÊS e DIA.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

9/6/2007

3

=DATA(ANO([Coluna1])+[Coluna2],MÊS([Coluna1]),DIA([Coluna1]))

Soma 3 anos a 9/6/2007 (9/6/2010)

10/12/2008

25

=DATA(ANO([Coluna1])+[Coluna2],MÊS([Coluna1]),DIA([Coluna1]))

Soma 25 anos a 10/12/2008 (10/12/2033)

Para somar uma combinação de dias, meses e anos a uma data, utilize as funções DATA, ANO, MÊS e DIA.

Coluna1

Fórmula

Descrição (resultado)

9/6/2007

=DATA(ANO([Coluna1])+3,MÊS([Coluna1])+1,DIA([Coluna1])+5)

Soma 3 anos, 1 mês e 5 dias a 9/6/2007 (14/7/2010)

10/12/2008

=DATA(ANO([Coluna1])+1,MÊS([Coluna1])+7,DIA([Coluna1])+5)

Soma 1 ano, 7 meses e 5 dias a 10/12/2008 (15/7/2010)

Calcular a diferença entre duas datas

Utilize a função DATAD.SE para efetuar este cálculo.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

01-Jan-1995

15-Jun-1999

=DATAD.SE([Coluna1],[Coluna2],"d")

Devolve o número de dias entre as duas datas (1626)

01-Jan-1995

15-Jun-1999

=DATAD.SE([Coluna1],[Coluna2],"am")

Devolve o número de meses entre as datas, ignorando a parte do ano (5)

01-Jan-1995

15-Jun-1999

=DATAD.SE([Coluna1],[Coluna2],"ad")

Devolve o número de dias entre as datas, ignorando a parte do ano (165)

Calcular a diferença entre duas horas

Para apresentar o resultado no formato de tempo padrão (horas:minutos:segundos), utilize o operador de subtração (-) e a função TEXTO. Para este método funcionar, o valor máximo de horas é 24 e o valor máximo de minutos e segundos é 60.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

09/06/2007 10:35

09/06/2007 15:30

=TEXTO([Coluna2]-[Coluna1],"h")

Horas entre duas horas (4)

09/06/2007 10:35

09/06/2007 15:30

=TEXTO([Coluna2]-[Coluna1],"h:mm")

Horas e minutos entre duas horas (4:55)

09/06/2007 10:35

09/06/2007 15:30

=TEXTO([Coluna2]-[Coluna1],"h:mm:ss")

Horas, minutos e segundos entre duas horas (4: 55:00)

Para apresentar o resultado num total baseado numa unidade de tempo total, utilize a função INT, HORA, MINUTO ou SEGUNDO.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

09/06/2007 10:35

10/06/2007 15:30

=INT(([Coluna2]-[Coluna1])*24)

Total de horas entre duas horas (28)

09/06/2007 10:35

10/06/2007 15:30

=INT(([Coluna2]-[Coluna1])*1440)

Total de minutos entre duas horas (1735)

09/06/2007 10:35

10/06/2007 15:30

=INT(([Coluna2]-[Coluna1])*86400)

Total de segundos entre duas horas (104100)

09/06/2007 10:35

10/06/2007 15:30

=HORA([Coluna2]-[Coluna1])

Horas entre duas horas, quando a diferença não excede 24 (4)

09/06/2007 10:35

10/06/2007 15:30

=MINUTO([Coluna2]-[Coluna1])

Minutos entre duas horas, quando a diferença não excede 60 (55)

09/06/2007 10:35

10/06/2007 15:30

=SEGUNDO([Coluna2]-[Coluna1])

Segundos entre duas horas, quando a diferença não excede 60 (0)

Converter horas

Para converter horas do formato de tempo padrão num número decimal, utilize a função INT.

Coluna1

Fórmula

Descrição (resultado)

10:35

=([Coluna1]-INT([Coluna1]))*24

Número de horas desde as 00:00 (10,583333)

12:15

=([Coluna1]-INT([Coluna1]))*24

Número de horas desde as 00:00 (12,25)

Para converter horas de um número decimal para o formato de tempo padrão (horas:minutos:segundos), utilize o operador de divisão e a função TEXTO.

Coluna1

Fórmula

Descrição (resultado)

23:58

=TEXTO(Coluna1/24,"hh:mm:ss")

Horas, minutos e segundos desde as 00:00 (00: 59:55)

2:06

=TEXTO(Coluna1/24,"h:mm")

Horas e minutos desde as 00:00 (0:05)

Insira datas Julianas

Uma data Juliana refere-se a um formato de data que é uma combinação do ano atual e do número de dias desde o início do ano. Por exemplo, 1 de Janeiro de 2007 é representado por 2007001 e 31 de Dezembro de 2007 é representado por 2007365. Este formato não é baseado no calendário Juliano.

Para converter uma data numa data Juliana, utilize as funções TEXTO e DATA.VALOR.

Coluna1

Fórmula

Descrição (resultado)

23/6/2007

=TEXTO([Coluna1],"aa")&TEXTO(([Coluna1]-DATA.VALOR("1/1/"&TEXTO([Coluna1],"aa"))+1),"000")

Data no formato Juliano com um ano com dois dígitos (07174)

23/6/2007

=TEXTO([Coluna1],"aaaa")&TEXTO(([Coluna1]-DATA.VALOR("1/1/"&TEXTO([Column1],"aa"))+1),"000")

Data no formato Juliano com um ano com quatro dígitos (2007174)

Para converter uma data numa data Juliana utilizada em astronomia, utilize a constante 2415018.50. Esta fórmula só funciona para datas posteriores a 1/3/1901 e se estiver a utilizar o sistema de datas de 1900.

Coluna1

Fórmula

Descrição (resultado)

23/6/2007

=[Coluna1]+2415018.50

Data no formato Juliano utilizado em astronomia (2454274.50)

Mostrar datas como o dia da semana

Para converter datas em texto equivalente ao dia da semana, utilize as funções TEXTO e DIA.SEMANA.

Coluna1

Fórmula

Descrição (resultado possível)

19-Fev-2007

=TEXTO(DIA.SEMANA([Coluna1]),"dddd")

Calcula o dia da semana da data e devolve o nome completo do dia (segunda-feira)

3-Jan-2008

=TEXTO(DIA.SEMANA([Coluna1]),"ddd")

Calcula o dia da semana da data e devolve o nome abreviado do dia (qui)

Pode utilizar as seguintes fórmulas para efetuar vários cálculos matemáticos, como somar, subtrair, multiplicar e dividir números, calcular a média ou mediana de números, arredondar um número e contar valores.

Somar números

Para somar números de duas ou mais colunas numa linha, utilize o operador de adição (+) ou a função SOMA.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

6

5

4

=[Coluna1]+[Coluna2]+[Coluna3]

Soma os valores nas primeiras três colunas (15)

6

5

4

=SOMA([Coluna1],[Coluna2],[Coluna3])

Soma os valores nas primeiras três colunas (15)

6

5

4

=SOMA(SE([Coluna1]>[Coluna2],[Coluna1]-[Coluna2],10),[Coluna3])

Se a Coluna1 for maior que a Coluna2, soma a diferença e a Coluna3. Nos outros casos, soma 10 e a Coluna3 (5)

Subtrair números

Para subtrair números de duas ou mais colunas numa linha, utilize o operador de subtração (-) ou a função SOMA com números negativos.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

15000

9000

-8000

=[Coluna1]-[Coluna2]

Subtrai 9000 a 15 000 (6000)

15000

9000

-8000

=SOMA([Coluna1],[Coluna2],[Coluna3])

Soma os números nas primeiras três colunas, incluindo valores negativos (16 000)

Calcular a diferença entre dois números como percentagem

Utilize os operadores de subtração (-) e divisão (/) e a função ABS.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

2342

2500

=([Coluna2]-[Coluna1])/ABS([Coluna1])

Alteração da percentagem (6,75% ou 0,06746)

Multiplicar números

Para multiplicar números de duas ou mais colunas numa linha, utilize o operador de multiplicação (*) ou a função PRODUTO.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

5

2

=[Coluna1]*[Coluna2]

Multiplica os números nas primeiras duas colunas (10)

5

2

=PRODUTO([Coluna1],[Coluna2])

Multiplica os números nas primeiras duas colunas (10)

5

2

=PRODUTO([Coluna1],[Coluna2],2)

Multiplica os números nas primeiras duas colunas e o número 2 (20)

Dividir números

Para dividir números de duas ou mais colunas numa linha, utilize o operador de divisão (/).

Coluna1

Coluna2

Fórmula

Descrição (resultado)

15000

12

=[Coluna1]/[Coluna2]

Divide 15 000 por 12 (1250)

15000

12

=([Coluna1]+10000)/[Coluna2]

Soma 15 000 e 10 000 e, em seguida, divide o total por 12 (2083)

Calcular a média de números

A média também é denominada valor médio. Para calcular a média dos números de duas ou mais colunas numa linha, utilize a função MÉDIA.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

6

5

4

=MÉDIA([Coluna1],[Coluna2],[Coluna3])

Média dos números nas primeiras três colunas (5)

6

5

4

=MÉDIA(SE([Coluna1]>[Coluna2],[Coluna1]-[Coluna2],10),[Coluna3])

Se a Coluna1 for maior que a Coluna2, calcule a média da diferença e da Coluna3. Nos outros casos, calcula a média do valor 10 e Coluna3 (2,5)

Calcular a mediana de números

A mediana é o valor no centro de um intervalo ordenado de números. Utilize a função MEDIANA para calcular a mediana de um grupo de números.

A

B

C

D

E

F

Fórmula

Descrição (resultado)

10

7

9

27

0

4

=MEDIANA(A,B,C,D,E,F)

Mediana dos números nas primeiras 6 colunas (8)

Calcular o número maior ou menor num intervalo

Para calcular o número maior ou menor de duas ou mais colunas numa linha, utilize as funções MÍNIMO e MÁXIMO.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

10

7

9

=MÍNIMO([Coluna1],[Coluna2],[Coluna3])

Menor número (7)

10

7

9

=MÁXIMO([Coluna1],[Coluna2],[Coluna3])

Maior número (10)

Contar valores

Para contar valores numéricos, utilize a funçãoCONTAR.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

Maçã

12/12/2007

=CONTAR([Coluna1],[Coluna2],[Coluna3])

Conta o número de colunas com valores numéricos. Exclui data e hora, texto e valores nulos (0)

12 €

#DIV/0!

1,01

=CONTAR([Coluna1],[Coluna2],[Coluna3])

Conta o número de colunas com valores numéricos, mas exclui valores de erro e lógicos (2)

Aumentar ou diminuir um número por uma percentagem

Utilize o operador de percentagem (%) para efetuar este cálculo.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

23

3%

=[Coluna1]*(1+5%)

Aumenta o número na Coluna1 em 5% (24,15)

23

3%

=[Coluna1]*(1+[Coluna2])

Aumenta o número na Coluna1 pelo valor de percentagem na Coluna2: 3% (23,69)

23

3%

=[Coluna1]*(1-[Coluna2])

Diminui o número na Coluna1 pelo valor de percentagem na Coluna2: 3% (22,31)

Elevar um número a uma potência

Utilize o operador de exponenciação (^) ou a função POTÊNCIA para efetuar este cálculo.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

5

2

=[Coluna1]^[Coluna2]

Calcula cinco ao quadrado (25)

5

3

=POTÊNCIA([Coluna1],[Coluna2])

Calcula cinco ao cubo (125)

Arredondar um número

Para arredondar um número para cima, utilize a função ARRED.PARA.CIMA, ÍMPAR ou PAR.

Coluna1

Fórmula

Descrição (resultado)

20,3

=ARRED.PARA.CIMA([Coluna1],0)

Arredonda 20,3 para cima para o número inteiro mais próximo (21)

-5,9

=ARRED.PARA.CIMA([Coluna1],0)

Arredonda 5,9 para cima para o número inteiro mais próximo (5)

12,5493

=ARRED.PARA.CIMA([Coluna1],2)

Arredonda 12,5493 para cima para a centena mais próxima – duas casas decimais (12,55)

20,3

=PAR([Coluna1])

Arredonda 20,3 para cima para o número par mais próximo (22)

20,3

=ÍMPAR([Coluna1])

Arredonda 20,3 para cima para o número ímpar mais próximo (21)

Para arredondar um número para baixo, utilize a função ARRED.PARA.BAIXO.

Coluna1

Fórmula

Descrição (resultado)

20,3

=ARRED.PARA.BAIXO([Coluna1],0)

Arredonda 20,3 para baixo para o número inteiro mais próximo (20)

-5,9

=ARRED.PARA.BAIXO([Coluna1],0)

Arredonda -5,9 para baixo para o número inteiro mais próximo (-6)

12,5493

=ARRED.PARA.BAIXO([Coluna1],2)

Arredonda 12,5493 para baixo para a centena mais próxima – duas casas decimais (12,54)

Para arredondar um número para o número ou fração mais próxima, utilize a função ARRED.

Coluna1

Fórmula

Descrição (resultado)

20,3

=ARRED([Coluna1],0)

Arredonda 20,3 para baixo porque a parte fracionária é menor que 0,5 (20)

5,9

=ARRED([Coluna1],0)

Arredonda 5,9 para cima porque a parte fracionária é maior que 0,5 (6)

-5,9

=ARRED([Coluna1],0)

Arredonda -5,9 para baixo porque a parte fracionária é menor que -0,5 (-6)

1,25

=ARRED([Coluna1],1)

Arredonda o número para a dezena mais próxima (uma casa decimal). Como a parte a ser arredondada é igual ou maior que 0,05, o número é arredondado para cima (resultado: 1,3)

30,452

=ARRED([Coluna1],2)

Arredonda o número para a centena mais próxima (duas casas decimais). Como a parte a ser arredondada, 0,002, é menor que 0,005, o número é arredondado para baixo (resultado: 30,45)

Para arredondar um número para o algarismo significativo acima de 0, utilize as funções ARRED, ARRED.PARA.CIMA, ARRED.PARA.BAIXO, INT e NÚM.CARAT.

Coluna1

Fórmula

Descrição (resultado)

5492820

=ARRED([Coluna1],3-NÚM.CARAT(INT([Coluna1])))

Arredonda o número para 3 algarismos significativos (5490000)

22230

=ARRED.PARA.BAIXO([Coluna1],3-NÚM.CARAT(INT([Coluna1])))

Arredonda o número para baixo para 3 algarismos significativos (22200)

5492820

=ARRED.PARA.CIMA([Coluna1],5-NÚM.CARAT(INT([Coluna1])))

Arredonda o número para cima até 5 algarismos significativos (5492900)

Pode utilizar as seguintes fórmulas para manipular o texto, por exemplo, combinar ou concatenar os valores de múltiplas colunas, comparar os conteúdos de colunas, remover carateres ou espaços e carateres de repetição.

Alterar as maiúsculas/minúsculas do texto

Para alterar as maiúsculas/minúsculas do texto, utilize a função MAIÚSCULAS, MINÚSCULAS ou INICIAL.MAIÚSCULA.

Coluna1

Fórmula

Descrição (resultado)

mariana Correia

=MAIÚSCULAS([Coluna1])

Altera o texto para maiúsculas (MARIANA CORREIA)

mariana Correia

=MINÚSCULAS([Coluna1])

Altera o texto para minúsculas (mariana correia)

mariana Correia

=INICIAL.MAIÚSCULA([Coluna1])

Altera o texto para iniciais maiúsculas (Mariana Correia)

Combinar nomes e apelidos

Para combinar nomes e apelidos, utilize o operador E comercial (&) ou a função CONCATENAR.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

Diogo

Cunha

=[Coluna1]&[Coluna2]

Combina as duas cadeias (DiogoCunha)

Diogo

Cunha

=[Coluna1]&" "&[Coluna2]

Combina as duas cadeias, separadas por um espaço (Diogo Cunha)

Diogo

Cunha

=[Coluna2]&", "&[Coluna1]

Combina as duas cadeias, separadas por uma vírgula e um espaço (Cunha, Diogo)

Diogo

Cunha

=CONCATENAR([Coluna2], ",", [Coluna1])

Combina as duas cadeias, separadas por uma vírgula (Cunha,Diogo)

Combinar texto e números de colunas diferentes

Para combinar texto e números, utilize a função CONCATENAR, o operador E comercial (&) ou a função TEXTO e o operador E comercial.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

Artur

28

=[Coluna1]&" vendeu "&[Coluna2]&" unidades."

Combina os conteúdos acima numa expressão (Artur vendeu 28 unidades.)

João

40%

=[Coluna1]&" vendeu "&TEXTO([Coluna2],"0%")&" do total de vendas."

Combina os conteúdos acima numa expressão (João vendeu 40% do total de vendas.)

Nota: A função TEXTO acrescenta o valor formatado da Coluna2 em vez do valor subjacente que é 0,4.

Artur

28

=CONCATENATAR([Coluna1]," vendeu ",[Coluna2]," unidades.")

Combina os conteúdos acima numa expressão (Artur vendeu 28 unidades.)

Combinar texto com uma data ou hora

Para combinar texto com uma data ou hora, utilize a função TEXTO e o operador E comercial (&).

Coluna1

Coluna2

Fórmula

Descrição (resultado)

Data de Faturação

5-Jun-2007

="Data da fatura: "&TEXTO([Coluna2], "d-mmm-aaaa")

Combina texto com uma data (Data da fatura: 5-Jun-2007)

Data de Faturação

5-Jun-2007

=[Coluna1]&" "&TEXTO([Coluna2], "dd-mmm-aaaa")

Combina o texto e a data de colunas diferentes numa coluna (Data de Faturação 05-Jun-2007)

Comparar conteúdos de colunas

Para comparar uma coluna com outra coluna ou uma lista de valores, utilize as funções EXATO e OU.

Coluna1

Coluna2

Fórmula

Descrição (resultado possível)

BD122

BD123

=EXATO([Coluna1],[Coluna2])

Compara os conteúdos das primeiras duas colunas (Não)

BD122

BD123

=EXATO([Coluna1],"BD122")

Compara os conteúdos da Coluna1 e a cadeia "BD122" (Sim)

Verificar se o valor de uma coluna ou uma parte da mesma corresponde a texto específico

Para verificar se o valor de uma coluna ou uma parte da mesma corresponde ao texto específico, utilize as funções SE, LOCALIZAR, PROCURAR e É.NÚM.

Coluna1

Fórmula

Descrição (resultado possível)

Correia

=SE([Coluna1]="Correia","OK","Não OK")

Verifica se a Coluna1 é Correia (OK)

Correia

=SE(É.NÚM(LOCALIZAR("v",[Coluna1])),"OK","Não OK")

Verifica se Coluna1 contém a letra v (OK)

BD123

=É.NÚM(LOCALIZAR("BD";[Coluna1]))

Verifica se a Coluna1 contém BD (Sim)

Contar colunas que não estão em branco

Para contar as colunas que não estão em branco, utilize a função CONTAR.VAL.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

Vendas

19

=CONTAR.VAL([Coluna1],[Coluna2])

Conta o número de colunas que não estão em branco (2)

Vendas

19

=CONTAR.VAL([Coluna1],[Coluna2],[Coluna3])

Conta o número de colunas que não estão em branco (2)

Remover carateres do texto

Para remover carateres do texto, utilize as funções NÚM.CARAT, ESQUERDA e DIREITA.

Coluna1

Fórmula

Descrição (resultado)

Vitamina A

=ESQUERDA([Coluna1],NÚM.CARAT([Coluna1])-2)

Devolve 8 (10-2) carateres a partir da esquerda (Vitamina)

Vitamina B1

=DIREITA([Coluna1],NÚM.CARAT([Coluna1])-9)

Devolve 2 (11-9) carateres a partir da direita (B1)

Remover espaços do início e fim de uma coluna

Para remover espaços de uma coluna, utilize a função COMPACTAR.

Coluna1

Fórmula

Descrição (resultado)

 Tudo bem?

=COMPACTAR([Coluna1])

Remove os espaços de início e fim (Tudo bem?)

Repetir um caráter numa coluna

Para repetir um caráter numa coluna, utilize a função REPETIR.

Fórmula

Descrição (resultado)

=REPETIR(".",3)

Repete um ponto final 3 vezes (...)

=REPETIR("-",10)

Repete um travessão 10 vezes (-)

Lista de funções

Eis uma lista das ligações de funções disponíveis para utilizadores do SharePoint. Inclui funções trigonométricas, estatística e financeiras, bem como condicionais, data, matemática e texto.

Função ABS

Função ACOS

Função ACOSH

Função ACOSH

Função E

Função ASEN

Função ASENH

Função ATAN

Função ATAN2

Função MÉDIA

Função MÉDIAA

Função DISTBETA

Função BETA.ACUM.INV

Função DISTR.BINOM

Função ARRED.EXCESSO.

Função CARÁT

Função DIST.CHI

Função SELECIONAR

Função CÓDIGO

Função CONCATENAR

Função INT.CONFIANÇA

Função COS

Função CONTAR

Função CONTAR.VAL

Função CRIT.BINOM

Função DATA

Função DATAD.SE

Função DATA.VALOR

Função DIA

Função DIAS360

Função BDD

Função GRAUS

Função MOEDA

Função PAR

Função EXATO

Função DISTEXPON

Função FATORIAL

Função DISTF

Função LOCALIZAR

Função INVF

Função FISHER

Função FIXA

Função DIST.GAMA

Função INV.GAMA

Função LNGAMA

Função MÉDIA.GEOMÉTRICA

Função MÉDIA.HARMÓNICA

Função HORA

Função DIST.HIPERGEOM

Função SE

Função INT

Função IPGTO

Funções É

Função ESQUERDA

Função NÚM.CARAT

Função LN

Função LOG

Função LOG10

Função INVLOG

Função DIST.NORMALLOG

Função MINÚSCULAS

Função MÁXIMO

Função Me

Função MED

Função SEG.TEXTO

Função MÍNIMO

Função MÍNIMOA

Função MINUTO

Função RESTO

Função MÊS

Função DIST.BIN.NEG

Função DIST.NORM

Função DIST.NORMP

Função INV.NORMP

Função NÃO

Função NPER

Função VAL

Função VAL

Função ÍMPAR

Função OU

Função PGTO

Função POTÊNCIA

Função PPGTO

Função PRODUTO

Função INICIAL.MAIÚSCULA

Função VA

Função RADIANOS

Função SUBSTITUIR

Função REPETIR

Função DIREITA

Função ARRED

Função ARRED.PARA.BAIXO

Função ARRED.PARA.CIMA

Função PROCURAR

Função SEGUNDO

Função SINAL

Função SEN

Função SENH

Função RAIZQ

Função NORMALIZAR

Função DESVPADA

Função DESVPADP

Função DESVPADPA

Função SOMA

Função SOMARQUAD

Função AMORTD

Função TANH

Função DIST.T

Função TEXTO

Função TEMPO

Função INVT

Função HOJE

Função COMPACTAR

Função VERDADEIRO

Função VERDADEIRO

Função MAIÚSCULAS

Função MOEDA.EUA

Função VALOR

Função VAR

Função VARA

Função VARP

Função VARPA

Função DIA.SEMANA

Função WEIBULL

Função ANO

Outros recursos

Se não vir o que está a tentar fazer aqui, consulte o artigo se pode fazê-lo no Excel. Aqui estão algumas outras fontes. Algumas destas podem abranger versões mais antigas, para que podem existir diferenças na interface de utilizador apresentado. Por exemplo, itens no menu Ações do Site no SharePoint 2010 são agora no menu Definições O botão de definições do Office 365 é o que se parece com uma engrenagem e se encontra junto ao seu nome .

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×