Estruturar um modelo de formulário para utilização offline

Nota:  Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Neste artigo

Noções sobre formulários offline

Criar uma ligação de dados a uma base de dados do SQL para utilização offline

Criar uma ligação de dados a uma base de dados do Access para utilização offline

Criar uma ligação de dados para uma biblioteca de documentos do SharePoint para utilização offline

Configurar a disponibilidade de dados

Desativar utilização offline

Noções sobre formulários offline

Poderá ter de estruturar um modelo de formulário do Microsoft Office InfoPath que os utilizadores possam preencher enquanto os respetivos computadores são desligados da rede. Por exemplo, pode estruturar um modelo de formulário que um perito de seguros pode utilizar no campo ao investigar uma afirmação. O modelo de formulário contém ligações de dados secundária que fornece dados ao formulário a partir de uma base de dados externo. O adjuster tem estes dados para poder preencha o formulário. Enquanto ainda no office e ligado à rede, perito de seguros pode criar um formulário baseado neste modelo de formulário e, em seguida, guarde o formulário no seu computador. No campo, o adjuster, em seguida, pode abrir e preencha o formulário sem estar ligado a uma rede. Depois de voltar para o office e voltar a ligar à rede, o adjuster, em seguida, pode submeter o formulário.

Por predefinição, um formulário guardado num computador pode trabalhar sem uma ligação de rede. Quando um utilizador cria um formulário baseado num modelo de formulário, o InfoPath transferências e armazena uma cópia nesse modelo de formulário no computador do utilizador. Sempre que o utilizador abre um formulário com base nesse modelo de formulário, o InfoPath verifica primeiro se existe uma ligação de rede para o computador. Se existir uma ligação de rede, o InfoPath verifica a localização onde o modelo de formulário foi transferido de, para determinar se existe uma versão atualizada do modelo de formulário. Se existir uma versão atualizada, o InfoPath atualiza o modelo de formulário no computador do utilizador. Se não existir uma ligação de rede, o InfoPath utiliza a versão do modelo de formulário que está armazenado no computador do utilizador.

Para estruturar um modelo de formulário para utilização offline, o modelo de formulário deve ser armazenado no computador do utilizador e quaisquer dados que são necessário para concluir o formulário, tais como itens numa caixa de listagem, tem de estar disponível para o utilizador, mesmo se o computador não estiver ligado a ésimo pelo utilizador rede de "e". Os dados dos seguintes controlos são fornecidos a partir de uma ligação de dados secundária a uma origem de dados externos. Estes dados podem ser armazenados no computador do utilizador no modelo de formulário ou numa localização de armazenamento especial denominado a cache.

Quando adiciona uma ligação de dados secundária para um modelo de formulário que consultas os dados de uma origem de dados externos, o InfoPath envia uma consulta para que origem de dados externos. Os resultados da consulta, em seguida, são armazenados no modelo de formulário. Quando o utilizador cria um novo formulário baseado neste modelo de formulário, os dados guardados para o modelo de formulário estão disponíveis para o utilizador.

Quando o formulário utiliza esta ligação de dados secundária para atualizar os conteúdos de uma caixa de listagem ou controlo de caixa de combinação com os dados mais recentes da origem de dados externos, o InfoPath armazena os resultados desta consulta numa localização de armazenamento especial denominada a cache, se o computador ligado a uma rede. O InfoPath utiliza os dados nesta cache para fornecer dados a esses controlos.

Para disponibilizar os dados a partir de uma ligação de dados secundária aos seus utilizadores, mesmo se os respetivos computadores não estiver ligados a uma rede, pode efetuar um ou ambos os seguintes procedimentos:

  • Armazene os dados de origem de dados externa no modelo de formulário.

  • Utilize a ligação de dados secundária quando abre o formulário.

Depois de configurar a ligação de dados secundária para trabalhar enquanto está offline computador do utilizador, também pode configurar o modelo de formulário para obter os dados mais recentes da origem de dados externos. Pode configurar o modelo de formulário para obter os dados mais recentes (ao limitar a disponibilidade dos dados existentes no formulário para um número especificado de dias) e, em seguida, em seguida, adicionar um botão para obter os dados mais recentes.

Armazenar os dados no modelo de formulário

Pode armazenar os dados a partir de uma ligação de dados secundária num modelo de formulário ao selecionar a caixa de verificação Guardar uma cópia dos dados no modelo de formulário no Assistente de ligação de dados ao criar a ligação de dados secundária.

No Assistente de Ligação de Dados, clique nesta caixa de verificação para configurar o modelo de formulário para armazenar dados de uma origem de dados externa no modelo de formulário.

Quando selecionar esta caixa de verificação, o InfoPath utiliza a ligação de dados para recuperar dados de origem de dados externa. Em seguida, armazena estes dados no modelo de formulário. Quando um utilizador cria um formulário ou é aberto um formulário existente baseado no seu modelo de formulário, uma cópia do modelo de formulário, juntamente com os dados armazenados, é transferida para o computador do utilizador. Se o computador do utilizador estiver ligado a uma rede quando é criado o formulário, o InfoPath obtém dados da ligação de dados externos, sempre que o formulário utiliza esta ligação de dados. Se o utilizador não estiver ligado a uma rede quando é criado o formulário, o InfoPath utiliza os dados que estão armazenados no modelo de formulário no computador do utilizador.

Uma vez que os dados foram obtidos no momento em que a ligação de dados foi criada, origem de dados externa poderá ter sido actualizada por hora que um utilizador cria um formulário baseado neste modelo de formulário. Se pretender que os utilizadores recebe os dados mais recentes da origem de dados externa quando criar um novo formulário ou abrir um formulário existente baseado no seu modelo de formulário, deverá estruturar o formulário para utilizar uma ligação de dados secundária quando o formulário abre pela primeira vez.

Utilizar a ligação de dados secundária quando abre o formulário

Se pretender que os utilizadores recebe os dados mais recentes da origem de dados externa, em vez de utilizar os dados armazenados num modelo de formulário, selecione a caixa de verificação obter dados automaticamente quando formulário está aberto no Assistente de ligação de dados quando cria a ligação de dados secundária. Esta caixa de verificação na última página do Assistente de Ligação de Dados configura este modelo de formulário para utilizar esta ligação de dados sempre que o utilizador criar um novo formulário ou abrir um formulário existente.

Quando um utilizador cria um novo formulário enquanto ligado à rede, o InfoPath utiliza esta ligação de dados secundária para obter os dados mais recentes da origem de dados externos. Estes dados são armazenados na cache. Se o utilizador abre um formulário existente guardado no seu computador, o InfoPath verifica se o computador está ligado a uma rede. Se o computador está ligado a uma rede, o InfoPath obtém os dados mais recentes da origem de dados externa ao utilizar esta ligação de dados. Se o utilizador estiver a trabalhar offline, o InfoPath utiliza os dados armazenados na cache ou no modelo de formulário.

Nota de Segurança: Os dados obtidos a partir de uma origem de dados secundária estão armazenados no computador, como texto simples. Se estiver a utilizar uma ligação de dados secundária para obter dados sensíveis a maiúsculas e a partir de uma origem de dados externos, pretende desativar esta funcionalidade para ajudar a proteger os dados de utilização não autorizada caso o computador é roubado ou. Se desativar esta funcionalidade, os dados estará disponíveis apenas se o utilizador está ligado à rede.

Obter os dados mais recentes

Se a origem de dados externa regularmente é atualizada, pode configurar um modelo de formulário para permitir aos utilizadores obter os dados mais recentes através da ligação de dados secundária. Para executar esta tarefa, pode limitar a disponibilidade dos dados que está atualmente armazenados na cache para um número especificado de dias e, em seguida, pode adicionar um botão para obter dados a partir de qualquer origens de dados externos ao utilizar todas as ligações de dados secundária no formulário. Ao fazê-lo Isto ajuda a garantir que os utilizadores estão a trabalhar com os dados mais recentes.

Em alternativa, pode limitar a disponibilidade de dados a partir de uma ligação de dados secundária ao definir uma data de validade quanto tempo que pretende que os dados armazenados no computador de um utilizador. Pode configurar o tempo de vida dos dados armazenados num formulário através da Categoria Offline da caixa de diálogo Opções de Formulário.

Quando utilizar esta opção, o InfoPath torna os dados de todas as ligações de dados secundária disponíveis ao formulário durante o número especificado de dias. Após ter passado esse número de dias, os dados não serão apresentados sob a forma. Em seguida, pode adicionar um botão para o formulário que os utilizadores podem clicar para obter os dados, utilizando uma ligação de dados secundária específicas ou todas as ligações de dados secundária no formulário.

Nota de Segurança: Mesmo se os dados não estão disponíveis para o formulário, os dados permanecem no computador do utilizador após ter passado o número de conjunto de dias. Os dados só serão substituídos quando o sistema operativo utiliza este espaço para armazenar algo.

Início da página

Criar uma ligação de dados a uma base de dados do SQL para utilização offline

Antes de adicionar uma ligação de dados secundária para uma base de dados do Microsoft SQL Server ao seu modelo de formulário, tem as seguintes informações a partir do seu administrador de base de dados.

  • O nome do servidor a localização onde armazenou a base de dados que irá utilizar com este modelo de formulário.

  • O nome da base de dados que irá utilizar com este modelo de formulário.

  • A autenticação de uma ferramenta necessária à base de dados. A base de dados pode utilizar a autenticação do Microsoft Windows ou autenticação do SQL Server para determinar como os utilizadores podem aceder a base de dados.

  • O nome da tabela que contém os dados que pretende enviar para o formulário. Esta é a tabela principal. Se planeia utilizar mais do que uma tabela na base de dados, terá das tabelas de subordinados, os nomes dos outros. Também precisa dos nomes dos campos nas tabelas subordinado que possuam relações para os campos da tabela primária.

  • Se em segurança podem armazenar os resultados da consulta sob a forma para utilização offline.

Depois de receber estas informações, pode utilizar o procedimento seguinte para criar a ligação de dados para uma base de dados do SQL para utilização offline.

  1. No menu Ferramentas, clique em Ligações de dados.

  2. Na caixa de diálogo Ligações de dados, clique em Adicionar.

  3. No Assistente de ligação de dados, clique em criar uma nova ligação para, clique em dados de receção e, em seguida, clique em seguinte.

  4. Na página seguinte do assistente, clique em base de dados (Microsoft SQL Server ou apenas para o Microsoft Office Access) e, em seguida, clique em seguinte.

  5. Na página seguinte do assistente, clique em Selecionar base de dados.

  6. Na caixa de diálogo Selecionar origem de dados, clique em Nova origem.

  7. Na lista de que tipo de origem de dados que pretende ligar a, clique em Microsoft SQL Server e, em seguida, clique em seguinte.

  8. Na caixa nome de servidor, escreva o nome do servidor a localização onde armazenou a base de dados.

  9. Em credenciais de início de sessão, efetue um dos seguintes procedimentos:

    • Se a base de dados determina quem tem acesso ao servidor com base nas credenciais utilizadas numa rede do Microsoft Windows, clique em Utilizar a autenticação do Windows.

    • Se a base de dados determina quem tem acesso no servidor com base em especificado nome de utilizador e palavra-passe que obtém do administrador da base de dados, clique em utilizar os seguintes nome de utilizador e palavra-passe e, em seguida, escreva o nome de utilizador e palavra-passe na nome de utilizador e caixas de palavra-passe.

  10. Clique em Seguinte.

  11. Na página seguinte do assistente, na lista Selecione a base de dados que contém os dados que pretende, clique em base de dados que pretende utilizar, selecione a caixa de verificação ligar a uma tabela específica, clique no nome da tabela primária e, em seguida, clique em seguinte.

  12. Na página seguinte do assistente, na caixa Nome de ficheiro, escreva um nome para o ficheiro que armazena as informações de ligação de dados.

  13. Para guardar estas definições, clique em Concluir.

  14. Adicione outras tabelas que pretende utilizar na ligação de dados de consulta.

    Como?

    1. Clique em Adicionar a tabela.

    2. Na caixa de diálogo Adicionar tabela ou consulta, clique no nome da tabela subordinada e, em seguida, clique em seguinte. Tenta InfoPath definir as relações através da correspondência de nomes de campos em ambas as tabelas. Se não pretende utilizar a relação sugerida, selecione a relação e, em seguida, clique em Remover relação. Para adicionar uma relação, clique em Adicionar relação. Na caixa de diálogo Adicionar relação, clique no nome de cada campo relacionado na coluna respetivos e, em seguida, clique em OK.

    3. Clique em Concluir.

    4. Para adicionar tabelas subordinadas adicionais, repita estes passos.

  15. Clique em Seguinte.

  16. Se pretende que os dados a partir desta ligação de dados secundária para estar disponível mesmo se o computador de um utilizador não estiver ligado a uma rede, selecione a caixa de verificação do arquivo de uma cópia dos dados no modelo de formulário. Quando selecionar esta caixa de verificação, o InfoPath consulta de origem de dados externa e armazena os resultados no modelo de formulário.

    Nota de Segurança: Selecionar esta caixa de verificação armazena os resultados da consulta no modelo de formulário. Uma vez que os dados são armazenados no modelo de formulário, está disponível nos formulários de que os utilizadores preencherem, mesmo se os respetivos computadores não estiver ligados a uma rede. Se está a obter dados sensíveis a partir desta ligação de dados, poderá querer desativar esta funcionalidade para ajudar a proteger os dados, no caso do computador é roubado ou.

  17. Clique em Seguinte.

  18. Na página seguinte do assistente, escreva um nome descritivo para esta ligação de dados secundária. Certifique-se de que as informações na secção de Resumo estão corretas. Para permitir que os utilizadores utilizem esta ligação de dados secundária quando criar um novo formulário ou abrir um formulário existente baseado neste modelo de formulário, selecione a caixa de verificação obter dados automaticamente quando formulário está aberto.

Início da página

Criar uma ligação de dados a uma base de dados do Access para utilização offline

Antes de adicionar uma ligação de dados secundária para uma base de dados do Access ao seu modelo de formulário, tem as seguintes informações a partir do seu administrador de base de dados.

  • O nome e localização da base de dados.

    Nota: Também terá de saber se a base de dados é numa localização de rede que esteja acessível aos seus utilizadores. Se outros utilizadores da rede irão criar formulários baseados neste modelo de formulário, a base de dados têm de estar localizado numa localização de rede que esteja acessível aos seus utilizadores.

  • Se o modelo de formulário será apenas uma consulta a base de dados, terá do nome da tabela que fornece os resultados da consulta enviados para a base de dados. Esta tabela será da tabela primária quando configurar a ligação de dados da consulta.

  • Os nomes das outras tabelas da tabela primária precisem de dados a partir de. Na maioria dos casos, as relações de tabela são já foram estabelecidas na base de dados. Se tem estabelecer relações entre a tabela primária e outra tabela, terá de nomes de campos relacionados em ambas as tabelas.

Depois de receber estas informações, pode utilizar o procedimento seguinte para criar a ligação de dados para uma base de dados do Access para utilização offline.

  1. No menu Ferramentas, clique em Ligações de dados.

  2. Na caixa de diálogo Ligações de dados, clique em Adicionar.

  3. No Assistente de ligação de dados, clique em criar uma nova ligação para, clique em dados de receção e, em seguida, clique em seguinte.

  4. Na página seguinte do assistente, clique em base de dados (Microsoft SQL Server ou apenas para o Microsoft Office Access) e, em seguida, clique em seguinte.

  5. Na página seguinte do assistente, clique em Selecionar base de dados.

  6. Na caixa de diálogo Selecionar origem de dados, navegue para a localização da base de dados.

    Nota: Se a base de dados estiver armazenado numa localização de rede, navegue para o caminho UNC da localização. Não navegue para a localização de rede através de uma unidade de rede mapeada. Se utilizar uma unidade de rede mapeadas, os formulários criados com baseados neste modelo de formulário irão procurar a base de dados a partir de uma unidade de rede mapeada. Se o utilizador não possui uma unidade de rede mapeadas, a forma não irá encontrar a base de dados.

  7. Clique no nome da base de dados e, em seguida, clique em Abrir.

  8. Na caixa de diálogo Selecionar tabela, clique na tabela primária que pretende utilizar e, em seguida, clique em OK.

  9. Na página seguinte do assistente, selecione a caixa de verificação Mostrar colunas da tabela.

    Por predefinição, todos os campos na tabela serão adicionados à origem de dados principal do modelo de formulário.

  10. Em estrutura da origem de dados, desmarque as caixas de verificação para os campos que não pretende incluir na origem de dados principal.

    Adicione outras tabelas ou consultas que pretende utilizar nesta ligação de dados.

    Como?

    1. Clique em Adicionar a tabela.

    2. Na caixa de diálogo Adicionar tabela ou consulta, clique no nome da tabela subordinada e, em seguida, clique em seguinte. Tenta InfoPath definir as relações através da correspondência de nomes de campos em ambas as tabelas. Se não pretende utilizar a relação sugerida, selecione a relação e, em seguida, clique em Remover relação. Para adicionar uma relação, clique em Adicionar relação. Na caixa de diálogo Adicionar relação, clique no nome de cada campo relacionado na coluna respetivos e, em seguida, clique em OK.

    3. Clique em Concluir.

    4. Para adicionar tabelas subordinadas adicionais, repita estes passos.

  11. Clique em Seguinte.

  12. Para tornar os dados a partir desta ligação de dados secundária disponível mesmo se o computador de um utilizador não estiver ligado a uma rede, selecione a caixa de verificação do arquivo de uma cópia dos dados no modelo de formulário. Quando selecionar esta caixa de verificação, o InfoPath consulta origem de dados externa e armazena os resultados da consulta no modelo.

    Nota de Segurança: Selecionar esta caixa de verificação armazena os resultados da consulta no modelo de formulário. Uma vez que os dados são armazenados no modelo de formulário, está disponível nos formulários de que os utilizadores preencherem, mesmo se os respetivos computadores não estiver ligados a uma rede. Se está a obter dados sensíveis a partir desta ligação de dados, poderá querer desativar esta funcionalidade para ajudar a proteger os dados, no caso do computador é roubado ou.

  13. Clique em Seguinte.

  14. Na página seguinte do assistente, escreva um nome descritivo para esta ligação de dados secundária. Certifique-se de que as informações na secção de Resumo estão corretas. Para permitir que os utilizadores utilizem esta ligação de dados secundária quando criar um novo formulário ou abrir um formulário existente baseado neste modelo de formulário, selecione a caixa de verificação obter dados automaticamente quando formulário está aberto.

Início da página

Criar uma ligação de dados para uma biblioteca de documentos do SharePoint para utilização offline

Antes de adicionar uma ligação de dados secundária ao seu modelo de formulário, tem as seguintes informações a partir do seu administrador do site.

  • A localização do site do Microsoft Windows SharePoint Services e as permissões necessárias para aceder à mesma.

  • Verificação de que o site está configurado para que os utilizadores possam aceder a dados a partir da biblioteca de documentos ou lista.

  • Verificação que pode armazenar os dados a partir da biblioteca de documentos ou lista em computadores dos seus utilizadores para utilização offline.

Depois de receber estas informações, pode utilizar o procedimento seguinte para criar a ligação de dados para uma base de dados do Access para utilização offline.

  1. No menu Ferramentas, clique em Ligações de dados.

  2. Na caixa de diálogo Ligações de dados, clique em Adicionar.

  3. No Assistente de ligação de dados, clique em criar uma nova ligação para, clique em dados de receção e, em seguida, clique em seguinte.

  4. Na página seguinte do assistente, clique em lista ou biblioteca do SharePoint e, em seguida, clique em seguinte.

  5. Na página seguinte do assistente, escreva o URL do site do SharePoint com a lista ou biblioteca de documentos e, em seguida, clique em seguinte.

  6. Na página seguinte do assistente, na lista Selecione uma lista ou biblioteca, clique na lista ou biblioteca que pretende utilizar e, em seguida, clique em seguinte.

  7. Na página seguinte do assistente, selecione as caixas de verificação junto dos campos que irão fornecer dados ao modelo de formulário. Se o modelo de formulário será publicado à biblioteca de documentos, e formulários baseados neste modelo de formulário para obter os metadados sobre o formulário, selecione a caixa de verificação incluir dados para o formulário activo apenas.

  8. Clique em Seguinte.

  9. Para tornar os dados a partir desta ligação de dados secundária disponível mesmo se o computador de um utilizador não estiver ligado a uma rede, selecione a caixa de verificação do arquivo de uma cópia dos dados no modelo de formulário. Quando selecionar esta caixa de verificação, o InfoPath consultas origem de dados externa e armazena os resultados da consulta no modelo de formulário.

    Nota de Segurança: Selecionar esta caixa de verificação armazena os resultados da consulta no modelo de formulário. Uma vez que os dados são armazenados no modelo de formulário, está disponível nos formulários de que os utilizadores preencherem, mesmo se os respetivos computadores não estiver ligados a uma rede. Se está a obter dados sensíveis a partir desta ligação de dados, poderá querer desativar esta funcionalidade para ajudar a proteger os dados, no caso do computador é roubado ou.

  10. Clique em Seguinte.

  11. Na página seguinte do assistente, escreva um nome descritivo para esta ligação de dados secundária e, em seguida, verifique se as informações na secção de Resumo estão corretas.

  12. Para permitir que os utilizadores utilizem esta ligação de dados secundária quando criar um novo formulário ou abrir um formulário existente baseado neste modelo de formulário, selecione a caixa de verificação obter dados automaticamente quando formulário está aberto.

Início da página

Configurar a disponibilidade de dados

Se a sua origem de dados externos regularmente é atualizada com os novos dados, pode configurar o modelo de formulário para disponibilizar quaisquer dados em cache. Estes dados estão disponíveis para formulários baseados neste modelo de formulário para um número limitado de dias que corresponde à agenda de atualização de origem de dados externa. Ao limitar o número de dias que os dados estão disponíveis para formulários baseados neste modelo de formulário, pode exigir que os utilizadores atualizar os dados de origem de dados externa regularmente.

Para atualizar os dados, pode adicionar um botão ao seu modelo de formulário que os utilizadores podem clicar para atualizar os dados de todas as ligações de dados secundária utilizadas no modelo de formulário.

Nota: Se utilizar um botão para atualizar a ligação de dados, informe os utilizadores para clique neste botão apenas se estiver ligados a uma rede.

Especificar o número de dias dados em cache não estão disponíveis

Esta definição aplica-se para todas as ligações de dados secundária no modelo de formulário.

  1. No menu Ferramentas, clique em Opções de formulário.

  2. Na lista categoria, na caixa de diálogo Opções de formulário, clique em Offline.

  3. Em Offline, selecione a caixa de verificação armazenar os dados devolvidos de consultas para que possam ser utilizado no modo Offline.

  4. Clique em consultas armazenado expirarem após este número de dias.

  5. Na lista, selecione o número de dias que pretende que os dados em cache ficar disponível para o formulário.

Adicionar um botão para atualizar a ligação de dados

  1. Se o modelo de formulário tem múltiplas vistas, clique em nome da vista, no menu Ver para ir para a vista com o controlo onde pretende apresentar os dados de origem de dados secundária.

  2. Se o painel de tarefas Controlos não estiver visível, clique em Mais Controlos no menu Inserir ou prima ALT+I, C

  3. Arraste um controlo de botão para o modelo de formulário.

  4. Faça duplo clique no controlo de botão que acabou de adicionar ao modelo de formulário.

  5. Clique no separador Geral.

  6. Na lista de ação, clique em Atualizar.

  7. Na caixa etiqueta, escreva o nome que pretende que apareçam no botão.

  8. Clique em Definições.

  9. Na caixa de diálogo Atualizar, efetue um dos seguintes procedimentos:

    • Para configurar o botão para obter os dados mais recentes através desta ligação de dados, clique numa origem de dados secundária.

    • Para configurar o botão para obter os dados mais recentes através de todas as ligações de dados secundária, clique em todas as origens de dados secundária.

  10. Na lista Escolher a origem de dados secundária, clique em origem de dados secundária que está associada a ligação de dados da consulta.

  11. Clique em OK para fechar todas as caixas de diálogo Abrir.

  12. Para testar as suas alterações, clique em Pré-visualizar na barra de ferramentas Padrão ou prima CTRL+SHIFT+B.

Início da página

Desativar utilização offline

Em alguns casos, vai querer estruturar um modelo de formulário para permitir apenas aos utilizadores preencher um formulário quando estão ligados a uma rede. Por exemplo, se o modelo de formulário tem uma ligação de dados de origem de dados externa que contenha dados confidenciais, poderá querer configurar o modelo de formulário para permitir que os formulários preenchido num estado ligado apenas. Ao configurar o modelo de formulário desta forma, pode ajudar a proteger os dados no caso do computador é roubado ou, porque os dados não está a ser armazenados no computador do utilizador.

Para configurar o modelo de formulário para permitir que utilizadores preencha o formulário, apenas se o seu computador está ligado a uma rede, conclua os passos seguintes.

  1. No menu Ferramentas, clique em Opções de formulário.

  2. Na lista categoria, na caixa de diálogo Opções de formulário, clique em Offline.

  3. Em Offline, desmarque a caixa de verificação Permitir que os utilizadores preencherem este formulário se dados não estiver disponíveis.

Início da página

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×