Elementos modelo da Interface do Windows XP

Nota:  Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Utilize o modelo Interface do Utilizador do Windows XP para criar modelos de interfaces do utilizador com formas concebidas de acordo com as directrizes do Microsoft Windows XP. As formas incluem os elementos frequentemente utilizados nas interfaces como, por exemplo, um formulário em branco para a base de uma janela de aplicação, páginas de assistente, barra de ferramentas, formas de menu e formas de controlo.

Pode utilizar estas formas para efetuar tudo a partir de um modelo de uma janela de aplicação complexo ou caixa de diálogo com separadores a uma caixa de mensagem simples ou botão único.

O que pretende fazer?

Criar uma única caixa de diálogo

Criar uma caixa de diálogo com separadores

Criar uma janela de aplicação

Criar menus e barras de ferramentas

Criar uma caixa de diálogo única

  1. A partir de Janelas e Caixas de Diálogo, arraste uma forma Formulário em Branco para a página de desenho.

  2. Com a forma seleccionada, escreva um título para a caixa de diálogo.

  3. Arraste uma forma Botões das Janelas para a extremidade direita da barra de título e seleccione o tipo de botão. Normalmente, existe um botão Ajuda e um botão Fechar, dispostos da esquerda para a direita.

  4. Adicione botões de comando, como OK, Cancelar e Aplicar, ao canto inferior direito da forma Formulário em Branco.

    como

    1. A partir de Controlos Comuns, arraste formas de Botão de comando para a extremidade inferior direita da forma Formulário em Branco.

    2. Seleccione cada botão e escreva o nome do controlo.

  5. Arraste os controlos adequados para a forma Formulário em Branco. Clique com o botão direito do rato nas formas para escolher as opções, conforme apropriado.

    Para obter ajuda sobre uma forma de controlo específica, clique com o botão direito do rato na forma e clique em Ajuda.

    Se utilizar a ferramenta Texto para criar o seu próprio texto na forma Formulário em Branco, formate o texto como Tahoma 8 pt.

  6. Agrupe comandos em grupos lógicos.

  7. Arraste as formas Caixa de grupo e Linha de grupo para a forma Formulário em Branco para separar visualmente os grupos.

    Utilize Guias para alinhar os controlos.

    A caixa de diálogo Imprimir, no menu Ficheiro, é um excelente exemplo de uma caixa de diálogo com muitos dos elementos mais comuns.

Início da página

Criar uma caixa de diálogo com separadores

  1. A partir de Janelas e Caixas de Diálogo, arraste uma forma Formulário em Branco para a página de desenho.

  2. Com a forma seleccionada, escreva um título para a caixa de diálogo.

  3. Arraste uma forma Botões das Janelas para a extremidade direita da barra de título e seleccione o tipo de botão. Normalmente, existe um botão Ajuda e um botão Fechar dispostos da esquerda para a direita.

  4. Adicione botões de comando, como OK, Cancelar e Aplicar, ao canto inferior direito da forma Formulário em Branco.

    como

    1. A partir de Controlos Comuns, arraste formas de Botão de comando para a extremidade inferior direita da forma Formulário em Branco.

    2. Seleccione cada botão e escreva o nome do controlo.

  5. Arraste uma forma Controlo separador (corpo) para a forma Formulário em Branco e ajuste o tamanho ao interior do formulário, deixando espaço para os separadores.

  6. Arraste uma forma Controlo separador (separadores) e cole a mesma à parte superior da forma Controlo separador (corpo).

  7. Com a forma Controlo separador (separadores) seleccionada, escreva um nome para o separador.

  8. Repita os passos 6 e 7 para cada separador, colando os separadores uns aos outros, bem como à forma Controlo separador (corpo).

  9. Clique com o botão direito do rato no separador que pretende mostrar como separador da frente, clique em Separador em Primeiro Plano e defina os outros separadores como Separador em Segundo Plano.

  10. Arraste os controlos adequados para a forma Formulário em Branco. Clique com o botão direito do rato nas formas para escolher as opções, conforme apropriado.

    Para obter ajuda sobre uma forma de controlo específica, clique com o botão direito do rato na forma e clique em Ajuda.

    Se utilizar a ferramenta Texto para criar o seu próprio texto na forma Formulário em Branco, formate o texto como Tahoma 8 pt.

  11. Agrupe comandos em grupos lógicos.

  12. Arraste as formas Caixa de grupo e Linha de grupo para a forma Formulário em Branco para separar visualmente os grupos.

    Utilize Guias para alinhar os controlos.

    A caixa de diálogo Configurar Página, no menu Ficheiro, é um excelente exemplo de uma caixa de diálogo com muitos dos elementos mais comuns.

Início da página

Criar uma janela de aplicação

  1. A partir de Janelas e Caixas de Diálogo, arraste uma forma Formulário em Branco para a página de desenho.

  2. Com a forma seleccionada, escreva um título para a janela de aplicação.

  3. Para adicionar um ícone ao lado esquerdo do texto na barra de título, clique com o botão direito do rato na forma Formulário em Branco e seleccione a caixa de verificação Espaço para Ícone.

  4. Arraste uma forma Botões das Janelas para a extremidade direita da barra de título e seleccione o tipo de botão. Normalmente, existem três botões: um botão Minimizar , um botão Maximizar ou Restaurar e um botão Fechar dispostos da esquerda para a direita.

  5. A partir de Barras de Ferramentas e Menus, arraste uma forma Barra de menus para a forma Formulário em Branco, cole a mesma à parte inferior da barra de título e, em seguida, adicione itens de menu.

    como

    1. Arraste uma forma Item de menu de nível superior para a página e cole a mesma à extremidade esquerda da Barra de menus.

      Pode colocar um ícone à esquerda do primeiro item de menu.

    2. Com a forma seleccionada, escreva um nome. Se o item de menu tiver um atalho de teclado, sublinhe a letra adequada.

    3. Repita os passos 1 e 2 conforme necessário.

      Para obter ajuda sobre uma forma, clique com o botão direito do rato na mesma e clique em Ajuda.

      Para ocultar a ligação pontos Imagem do ponto de ligação - X azul , no menu Ver, clique em Pontos de ligação.

      Os itens numa coluna devem todos ter a largura do item mais largo.

    Para mostrar os pontos de controlo na extremidade esquerda da barra de menus, clique com o botão direito do rato na forma e desmarque a caixa de verificação Bloquear Barra de Menus.

  6. A partir de Barras de Ferramentas e Menus, arraste uma forma Barra de Ferramentas para a forma Formulário em Branco, cole a mesma à parte inferior da barra de menus e, em seguida, adicione botões da barra de ferramentas.

    como

    1. Arraste uma das formas Botões da barra de ferramentas para a página e cole a mesma à extremidade esquerda da forma Barra de Ferramentas.

    2. Na caixa de diálogo Dados da Forma, escolha o tipo de botão pretendido. Se posteriormente pretender alterar o botão, clique com o botão direito do rato na forma e clique em Definir Tipo de Botão para reabrir a caixa de diálogo Dados da Forma.

    3. Arraste para fora mais formas Botões da barra de ferramentas e Separador de botão, conforme necessário, e cole-as umas às outras.

      Para obter ajuda sobre uma forma, clique com o botão direito do rato na mesma e clique em Ajuda.

      Para ocultar a ligação pontos Imagem do ponto de ligação - X azul , no menu Ver, clique em Pontos de ligação.

    Para mostrar os pontos de controlo na extremidade esquerda da barra de ferramentas, clique com o botão direito do rato na forma e desmarque a caixa de verificação Bloquear Barra de Ferramentas.

  7. A partir de Controlos Comuns arraste barras de deslocamento vertical e horizontal, conforme necessário, para as extremidades direita e inferior da forma Formulário em Branco.

  8. Clique com o botão direito do rato nas barras de deslocamento e escolha Definir Tamanho de Miniatura para indicar até onde é possível deslocar a janela.

    Para indicar que apenas uma pequena parte do documento está visível, diminua o tamanho da miniatura. Para indicar que grande parte do documento está visível, aumente o tamanho da miniatura.

  9. Arraste uma forma Barra de estado para a extremidade inferior da janela de aplicação e formate correctamente.

    como

    1. Arraste uma forma linha divisória de barra de estado para a página e colá-la para controlo alça Imagem da alça de controlo - losango amarelo a forma de barra de estado .

      As alças de controlo fornecem um local para colar uma forma Linha divisória de barra de estado a uma Barra de estado ou a outra forma Linha divisória de barra de estado.

      Se não conseguir visualizar uma forma Linha divisória de barra de estado depois de a colar a uma forma Barra de estado, seleccione a forma Barra de estado e, no menu Forma, aponte para Ordem e, em seguida, clique em Enviar Atrás.

    2. Arraste uma forma Redimensionamento de Janela para a extremidade direita da barra de estado para indicar que actualmente a janela é redimensionável.

Início da página

Criar menus e barras de ferramentas

Pode utilizar as formas do Windows XP para criar menus básicos, menus pendentes e barras de ferramentas.

Criar um menu

  1. A partir de Barras de Ferramentas e Menus, arraste uma forma Barra de menus para a página de desenho. Para mostrar os pontos de controlo na extremidade esquerda da barra de menus, clique com o botão direito do rato na forma e desmarque a caixa de verificação Bloquear Barra de Menus.

  2. Arraste para fora uma forma Item de menu de nível superior e cole a mesma à extremidade esquerda da Barra de menus.

    Sugestão: Poderá pretender colocar um ícone à esquerda do primeiro item de menu.

  3. Com a forma seleccionada, escreva um nome. Se o item de menu tiver um atalho de teclado, sublinhe a letra adequada.

  4. Repita os passos 2 e 3 conforme necessário.

    Para obter ajuda sobre uma forma, clique com o botão direito do rato na mesma e clique em Ajuda.

    Para ocultar a ligação pontos Imagem do ponto de ligação - X azul , no menu Ver, clique em Pontos de ligação.

    Os itens numa coluna devem todos ter a largura do item mais largo.

Criar um menu pendente

  1. Arraste uma forma Item de menu de nível superior para a página de desenho.

  2. Com a forma seleccionada, escreva um nome. Se o item de menu tiver um atalho de teclado, sublinhe a letra adequada.

  3. Arraste uma forma Item de menu pendente, cole a mesma à parte inferior de Item de menu de nível superior e escreva um nome.

  4. Repita o passo 3 para todos os itens de menu pendente existentes na coluna.

  5. Redimensione todos as formas Item de Menu Pendente para a largura do item mais largo.

  6. Clique com o botão direito do rato em cada forma Item de Menu Pendente, clique em Propriedades do Item de Menu e seleccione as opções apropriadas.

    Para obter ajuda sobre uma forma, clique com o botão direito do rato na mesma e clique em Ajuda.

    Para ocultar a ligação pontos Imagem do ponto de ligação - X azul , no menu Ver, clique em Pontos de ligação.

Criar uma barra de ferramentas

  1. A partir de Barras de Ferramentas e Menus, arraste uma forma Barra de Ferramentas para a página de desenho. Para mostrar os pontos de controlo na extremidade esquerda da barra de ferramentas, clique com o botão direito do rato na forma e desmarque a caixa de verificação Bloquear Barra de Ferramentas.

  2. Arraste uma forma Botão da barra de ferramentas e cole-a à extremidade esquerda da forma Barra de ferramentas.

  3. Na caixa de diálogo Dados da Forma, escolha o tipo de botão que pretende. Se posteriormente pretender alterar o botão, clique com o botão direito do rato na forma e clique em Definir Tipo de Botão para reabrir a caixa de diálogo Dados da Forma.

  4. Arraste mais formas Botão da barra de ferramentas e Separador de botão, conforme necessário, e cole as mesmas umas às outras.

    Para obter ajuda sobre uma forma, clique com o botão direito do rato na mesma e clique em Ajuda.

    Para ocultar a ligação pontos Imagem do ponto de ligação - X azul , no menu Ver, clique em Pontos de ligação.

Início da página

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×